Comments

RedRob-CandlelightProdctns wrote on 9/1/2022, 5:13 PM

Identified two VST bugs in Vegas 20:

  1. Selective-Paste AudioFX does not paste audio-effect if it is a VST2 plug-in. Paste event-effect works correctly, replacing the existing audio FX with the pasted one(s).

    To reproduce:
    a. Event 1 has Vegas Volume envelope on it. Event 2 has Izotope Spectral Noise Reduction (VST2)
    b. Select audio event 2, right-click, choose "Copy"
    c. Select audio event 1, right-click, choose "Paste Event Attributes". The volume effect is gone and it now has the noise reduction effect on it. UNDO [the paste]
    d. Select audio event 1, right-click, choose "Selectively Paste Event Attributes", check "Audio Event Effects" (or all if you prefer). Nothing will be replaced -- the volume effect is still there.
     
  2. VST3 Problem: After installing Vegas 20, I now have two copies of my Izotope plug-ins, a VST2 version and VST3 version. The VST2 version seems to work. The VST3 version does not allow me to select the "Learn" button -- when I press it, it automatically un-presses.
Erkki wrote on 9/3/2022, 4:25 AM

Project description:
    2h hour lesson recorded single camera setup 
    - 4 speakers, clip count <20

    - one video track 
    - one powerpoint image (slides as png images) track 
    - 2 audio track (stereo as dual mono) 
    - lower thirds track 

    - minor track adjustment to audio
    - no color grading or related video effects applied

    - 1920 x 1080 25p  Sony Ex1 35Mbit/s VBR 4:2:0 8-bit.  SDR 8-bit project 
    - 4K display SDR mode

    - total editing time less than 4 hours 

Computer setup:
    - Windows 10, 32 GB RAM, NVidia 1050Ti, SSD for video project and data 

Vegas:
    - version 20.0 (Build 139)
    - live save mode on. 

Observations during works:

    Crash #1: During edit, applying new still image length and pressed apply. 
    - posted crash report. 
    - did not crash second time when applying same after restart. 
    - could not reproduce

    Crash #2: Fast forwarding video track (scrub) 
    - posted crash report. 
    - could not reproduce


Findings:
Settings are not saved before exiting program. If user has changed settings and application crashes, previous settings are "restored". 

Sometimes when adding new image from project media and started playback, preview window update (mode preview/auto) does not start. Switching application (alt+tab) to another and then back cures the issue. 

Adjusting clip end fading with mouse not always possible (no mouse cursor adjustment indicator). 

Summary:
Pretty good. Far more better than Vegas 19 initial release a year ago when doing something like above resulted many crashes.

david-b7658 wrote on 9/3/2022, 5:16 AM

I'm experiencing general slowdown when using V20 and I've also experienced more crashes in comparison to V19. Using a 3900x with a 3800ti, 64gb Ram (Win11)
Going to stick with V19 for now until things improved. It's a shame too, being a 365 subscriber.

with my system similar to yours (amd 3900x rtx 2070super 64g of ram, but on win 10) also for me the same thing ...
using xavc files (fullhd -50 mega bitrate -sony a7iii / a7s3)
i am forced to enable legacy avc decoding (as in vegas 19) to avoid continuous crashes.
Also known that v20 opens various instances of "Microsoft Edge WebView2"
can anyone explain it?

RogerS wrote on 9/3/2022, 7:29 AM

@david-b7658 I found with 19, build 550 was stable for me. 636 may be as well (don't have time to test every build so reverted to 550), but I had issues with Sony UHD XAVC S and 643. 20 is even less stable for me.

WebView2 should be for Hub but why it is loading multiple times is a mystery.

MyChain wrote on 9/6/2022, 4:03 AM

Close Caption should be improved and developed to be modern and easy to use.

Thanks

Anthony-Keane wrote on 9/6/2022, 11:33 AM

Have been customising the columns in the Project Media tab. However I cannot get rid of these two columns - Stream Chase and UMID. Can anyone else confirm this?

Vincent-Mesman wrote on 9/7/2022, 6:48 AM

I love Vegas Pro but don't see room for an upgrade in my situation yet. I would like to give a few suggestions for the development team to appeal to an even larger target group: improve the workflow for 3D animation and stop-motion animation.

- DSLR frame(-by-frame) capture
- motion planning with ad hoc sketched overlays, during frame capture
- onion skinning, during frame capture
- audio reference, during frame capture
- preview of captured image sequence, during frame capture
- more storyboard features (I love this concept)
- options to handle missing frames in image sequences
- drag-n-drop image sequences, default fps

For such animation/stop-motion functionality, I would now have to install other software that overlaps in functionality with a lot of features in Vegas Pro.

fr0sty wrote on 9/7/2022, 4:12 PM

Close Caption should be improved and developed to be modern and easy to use.

Thanks

@MyChain it is something that they are interesting in implementing (CEA 708 CC natively), as soon as they can, but it is unclear when that will be.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

Gardo wrote on 9/11/2022, 1:23 PM

Identified two VST bugs in Vegas 20:

  1. Selective-Paste AudioFX does not paste audio-effect if it is a VST2 plug-in. Paste event-effect works correctly, replacing the existing audio FX with the pasted one(s).

    To reproduce:
    a. Event 1 has Vegas Volume envelope on it. Event 2 has Izotope Spectral Noise Reduction (VST2)
    b. Select audio event 2, right-click, choose "Copy"
    c. Select audio event 1, right-click, choose "Paste Event Attributes". The volume effect is gone and it now has the noise reduction effect on it. UNDO [the paste]
    d. Select audio event 1, right-click, choose "Selectively Paste Event Attributes", check "Audio Event Effects" (or all if you prefer). Nothing will be replaced -- the volume effect is still there.
     
  2. VST3 Problem: After installing Vegas 20, I now have two copies of my Izotope plug-ins, a VST2 version and VST3 version. The VST2 version seems to work. The VST3 version does not allow me to select the "Learn" button -- when I press it, it automatically un-presses.

I have a bug number 1 as well. (I haven't checked bug number 2.)

I have another audio problem in Vegas 20 that may be related to bug 1. It's a problem I did not have in 19 or earlier versions:

I'm editing one video with audio (recorded with a single camcorder) and adding to it a musical soundtrack. At times I'm fading down the original audio while letting the music play on. So sometimes I have two audio tracks, sometimes only one, as I've unlinked the original audio from the original video for certain clips and simply deleted the original audio. When preview playback hits that transition, audio levels go into the red with a big pop/thump and there's no sound at all. When I render the project, the same pop/thump occurs and the audio goes dead.

I was getting weird audio glitches on ordinary dissolves using the original audio/video, but that seemed to go away once I copied audio settings (not selective attributes, as that didn't work, but all event attributes) onto every clip in the original sound. When that original sound drops away, however, I get the big pop/thump. Usually. It's not always consistent or consistently at the same place.

That the straight dissolves stopped throwing audio glitches once the audio event attributes were consistent on the original audio makes me think something may be up with the plugins, as in bug 1.

Mark-Linenbroker wrote on 9/11/2022, 6:00 PM

I've been using Vegas Pro since version 16 and version 20 is the most stable of any previous upgrades or builds. No crashes in many hours of use. Nice no longer reminding myself to hit the <Save> button every few edits.

Windows 11; GPU Nvidia GTX 1070

Most often edit GoPro files 1920x1080. Videos may have up to 9 tracks.

General
Complete name                            : D:\Produce\Backrow.mp4
Format                                   : MPEG-4
Format profile                           : Base Media / Version 2
Codec ID                                 : mp42 (isom/mp42)
File size                                : 153 MiB
Duration                                 : 1 min 47 s
Overall bit rate mode                    : Variable
Overall bit rate                         : 12.0 Mb/s
Encoded date                             : UTC 2022-06-06 00:37:55
Tagged date                              : UTC 2022-06-06 00:37:55

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main@L4@High
Codec ID                                 : hvc1
Codec ID/Info                            : High Efficiency Video Coding
Duration                                 : 1 min 47 s
Bit rate                                 : 11.8 Mb/s
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 29.970 (30000/1001) FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Bits/(Pixel*Frame)                       : 0.190
Stream size                              : 151 MiB (98%)
Language                                 : English
Encoded date                             : UTC 2022-06-06 00:38:00
Tagged date                              : UTC 2022-06-06 00:38:00
Color range                              : Limited
Codec configuration box                  : hvcC

Audio
ID                                       : 2
Format                                   : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Codec ID                                 : mp4a-40-2
Duration                                 : 1 min 47 s
Bit rate mode                            : Variable
Bit rate                                 : 192 kb/s
Maximum bit rate                         : 448 kb/s
Channel(s)                               : 2 channels
Channel layout                           : L R
Sampling rate                            : 48.0 kHz
Frame rate                               : 46.875 FPS (1024 SPF)
Compression mode                         : Lossy
Stream size                              : 2.42 MiB (2%)
Language                                 : English
Encoded date                             : UTC 2022-06-06 00:38:00
Tagged date                              : UTC 2022-06-06 00:38:00
 

 

fr0sty wrote on 9/11/2022, 8:00 PM

I've been using Vegas Pro since version 16 and version 20 is the most stable of any previous upgrades or builds. No crashes in many hours of use. Nice no longer reminding myself to hit the <Save> button every few edits.

It only gets better from here. I recently heard an announcement about the development team that is very, very encouraging regarding the future of VEGAS Pro, its stability/performance, and how the team is now much better equipped to implement the many things they've been wanting to do for a while now, and we're told this change is only the beginning. There's also some really cool stuff being tested that users have been asking for a very long time now... though that is as much as I am at liberty to say.

VEGAS has an exciting year ahead of it.

Last changed by fr0sty on 9/11/2022, 8:01 PM, changed a total of 1 times.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

walter-i. wrote on 9/12/2022, 1:09 AM

Nice no longer reminding myself to hit the <Save> button every few edits.

I'm also happy that the software is developing so well - but the manual saving would actually not be necessary - with the customized settings in the menu Extras / Advanced Save

mofobo wrote on 9/12/2022, 9:05 AM

Just booting up Vegas 20 today made my whole GPU crash and I was presented with black screens. After waiting around 30 seconds I got an error message saying a GPU accelerated program caused the issue and I should check drivers. All drivers are up to date (NVIDIA Studio 516.94). Using a 3080ti / 3900x / 64gb Ram. OS, Program, projects and sources are all on SSDs.

I'm currently considering cancelling my 365 subscription and seeking a refund because I simply can't use Vegas 20 without some sort of issue. It is generally very slow when I first run the program, it will then fix itself after a few minutes, but as soon as I try to use the menu (File / Edit / Insert etc) it becomes sluggish again (to the point I have to wait it out to save the project and restart V20).

I didn't have a single issue with V19 but 20 has been a nightmare for me to use personally. It's a shame too because I do enjoy using Vegas a lot. It might be best for me to just buy V19 outright at this point.

fr0sty wrote on 9/12/2022, 9:09 AM

I'm using a 3090 without issue (Driver 516.94), and several on the beta team are using 3080's without issue, so it's not likely anything wrong with VEGAS. Your driver may be corrupt, or your card may be damaged. I'd recommend uninstalling your driver using a display driver uninstaller that completely removes all traces of the driver, and re-installing it. If not that, it could be an OS issue.

Last changed by fr0sty on 9/12/2022, 9:11 AM, changed a total of 2 times.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

pierre-k wrote on 9/12/2022, 10:05 AM

I added it to my top post and will add it here as well:

Too high demands on Dram memory during editing.

For large projects with lots of Ful HD MXF, the Dram limit reaches 16GB. Vegas becomes unusable and cuts drastically. In VP 19, Dram stays in the range of 11-13GB and can be used without problems.

gabgilson wrote on 9/13/2022, 1:25 AM

I've had no luck with V20 - new projects and imported v19 projects crash before I can start any editing. I also had no joy with v19 643. I've stuck with v19 636 which is the most stable version of v19 I've ever had. I use 10 bit xavcs files from a Sony a7siii with proxies. Set up is windows 11, AMD5900x and 6700x GPU + 64gb RAM.

Can anyone suggest a top 3 things to try when I next have time? In v19 636 I don't have 'enable legacy avc' selected, so I don't see why I'd need to select it for for v20 but I could try it if I can hold off the crashes for long enough. I have updated to the latest GPU driver (and it's very stable on v19 636) so I don't think it's that.

Excited to get the benefits of v20 at some point, but at least I can work normally on v19 636 for now.

Thanks for any suggestions.

j-v wrote on 9/13/2022, 4:24 AM

@gabgilson
Better to make your own post if there are questions

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 21H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti, Intel HD graphics 630
Laptop  :Asus EVO37T, W11 home version 21H2, CPU i7-10875H, 16 GB RAM, Intel UHD Graphics + NVIDIA GeForce RTX 2070. VP 19, 20 and VMS PL 17 are installed, all latest builds, Nvidia GPU driver version 517.40 Studiodriver and Intel GPU
driver 31.0.101.2111
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEM CELL DONOR !!!

Older Dutch tutorials of 3POINT and me: https://vimeo.com/vegasvideoforum

mofobo wrote on 9/13/2022, 4:23 PM

I'm using a 3090 without issue (Driver 516.94), and several on the beta team are using 3080's without issue, so it's not likely anything wrong with VEGAS. Your driver may be corrupt, or your card may be damaged. I'd recommend uninstalling your driver using a display driver uninstaller that completely removes all traces of the driver, and re-installing it. If not that, it could be an OS issue.

I'll give the display driver uninstaller a shot.
Something I did notice however, saving and completely rebooting the progam helps (for a while). It seems like using any dropdown menus instantly makes it slow and pretty unusable though. First boot of the day is always slow too. Seems strange that V19 is still running perfectly but V20 has this issue (on my system anyway).
 

todd-b wrote on 9/13/2022, 6:08 PM
 

For large projects with lots of Ful HD MXF, the Dram limit reaches 16GB. Vegas becomes unusable and cuts drastically. In VP 19, Dram stays in the range of 11-13GB and can be used without problems.

@pierre-k You did not have same problem with V19 643?

I think that was VP20 in sheeps clothing with features turned off.

Peter-Baker wrote on 9/14/2022, 11:35 AM

I have bought Vegas Post. I can't open Vegas Effects material in Vegas Pro 20 as the filetype is not recognised by the programme. Vegas Post files open fine in Vegas Pro 19. Additionally the Vegas Post software items are dependent on having a copy of Vegas Pro 19 installed in order for the programmes to run. Any idea when these issues will be fixed so we can import native Vegas Effects material into Vegas Pro 20?

fr0sty wrote on 9/14/2022, 12:03 PM

Did you install the updated version of Vegas Effects for Vegas Pro 20? If you still have Vegas Effects for Vegas 19 installed, it will not work in 20.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

Komaryt wrote on 9/15/2022, 4:10 AM

After 2 finished weddings in V20 and starting problems with this software I can say something.

It's much faster than V17 and everything works fine. HSL Curves are perfect for me and I don't need to use DaVinci now to edit my LUTs but there are 3 things that I personally dont really like:

1. No ColorGrading in Video FX. I would like to have control on manually dragging LUTs for clips. I know that in ColorGrading tab I can choose to apply this on each clip but when I have +50media clips in 4 minutes mini-clip it is really pain in ass to change everything manually in each Media FX. I know that I can make other tracks for clips and apply ColorGrading for Track FX but I don't like many tracks.

2. Adding rendered footage into timeline after render is completed - I couldn't find option to turn it off. Is that possible to turn it off? Because when render is complete I need to wait few more minutes until clip will add into timeline and when I am making pre-render clips to add it into AAE and I have 8 media clips to render it takes ages to wait for them

3. Occasionally I have black screens in rendered footage. Sometimes it is at start of movie, sometimes it is in middle of movie. In 60-90minutes movies it is hard to see it and I need to render it again. On timeline everything is alright but it happened after rendering.

walter-i. wrote on 9/15/2022, 5:32 AM

3. Occasionally I have black screens in rendered footage. Sometimes it is at start of movie, sometimes it is in middle of movie. In 60-90minutes movies it is hard to see it and I need to render it again. On timeline everything is alright but it happened after rendering.

@Komaryt
There are a few threads on black frames - have you used the forum search?

m3lquixd wrote on 9/15/2022, 8:48 AM

Magix has highlighted the templates for vertical videos, but they don't improve the freedom of adjusting the interface layout. For example, putting the preview on the right to make better use of the screen.