VP19 B550 Render is slow

alifftudm95 wrote on 4/12/2022, 2:20 AM

Normal export & batch rendering are equally slow. Averaging 3FPS. Usually I can get 18-20FPS average.

Project settings is 1080p 25FPS.

Render Template Magix AVC 1080p 25FPS NVENC.

GPU acceleration is enabled.

My computer specs can be seen on my signature.

Clip Media Info:

General
Complete name                            : F:\TAKBIR TAKAFUL 2022\ARTWORK\CAM 1\PRIVATE\M4ROOT\CLIP\C5407.MP4
Format                                   : XAVC
Codec ID                                 : XAVC (XAVC/mp42/iso2)
File size                                : 1.19 GiB
Duration                                 : 49 s 440 ms
Overall bit rate mode                    : Variable
Overall bit rate                         : 206 Mb/s
Encoded date                             : UTC 2022-04-09 02:26:27
Tagged date                              : UTC 2022-04-09 02:26:27

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High 4:2:2@L5.2
Format settings                          : CABAC / 2 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 2 frames
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 49 s 440 ms
Bit rate mode                            : Variable
Bit rate                                 : 200 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 50.000 FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:2
Bit depth                                : 10 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.482
Stream size                              : 1.15 GiB (97%)
Encoded date                             : UTC 2022-04-09 02:26:27
Tagged date                              : UTC 2022-04-09 02:26:27
Color range                              : Full
Codec configuration box                  : avcC

Audio
ID                                       : 2
Format                                   : PCM
Format settings                          : Big / Signed
Codec ID                                 : twos
Duration                                 : 49 s 440 ms
Bit rate mode                            : Constant
Bit rate                                 : 1 536 kb/s
Channel(s)                               : 2 channels
Sampling rate                            : 48.0 kHz
Bit depth                                : 16 bits
Stream size                              : 9.05 MiB (1%)
Encoded date                             : UTC 2022-04-09 02:26:27
Tagged date                              : UTC 2022-04-09 02:26:27

Other
Type                                     : meta
Duration                                 : 49 s 440 ms

Comments

alifftudm95 wrote on 4/12/2022, 3:43 AM

Is it possible to share clips of the same format?

Will share and tag you later, file is pretty big

PC DEKSTOP

CPU: Ryzen 9 5900x

GPU: RTX2060 6GB

RAM: 64GB 3200MHZ

Storage:

C DRIVE NVME M.2 1TB SSD GEN 4

D DRIVE NVME M.2 2TB SSD GEN 4

E DRIVE SATA SSD 2TB

F DRIVE SATA SSD 2TB

G DRIVE HDD 1TB

Monitor: BenQ PD2700U 4K HDR

 

 

 

todd-b wrote on 4/12/2022, 4:09 AM

@alifftudm95 Reminder you can use Shutter encoder or similar to reduce the file size by"Cut without re-encoding" to either create a mock project for testing purposes or upload a single file if you have diagnosed the file to be the problem without any relationship to project parameters

3POINT wrote on 4/12/2022, 6:26 AM

@ aliff Since you're changing framerate from 2160p50 to 1080p25, make sure that in your project settings resampling is disabled or not set to optical flow (which will cause tremendous slow rendering).

alifftudm95 wrote on 4/12/2022, 9:39 AM

@lan-mLMC https://drive.google.com/drive/folders/1F3Rg1xsXGaj4xp82Eak5TOkcxOcslyAL?usp=sharing

PC DEKSTOP

CPU: Ryzen 9 5900x

GPU: RTX2060 6GB

RAM: 64GB 3200MHZ

Storage:

C DRIVE NVME M.2 1TB SSD GEN 4

D DRIVE NVME M.2 2TB SSD GEN 4

E DRIVE SATA SSD 2TB

F DRIVE SATA SSD 2TB

G DRIVE HDD 1TB

Monitor: BenQ PD2700U 4K HDR

 

 

 

john_dennis wrote on 4/12/2022, 10:20 AM

@alifftudm95

I experienced a similar result with that media.

My main system:
Motherboard: Asus X99-AII
CPU: Intel i7-6850K
GPU: Sapphire Radeon RX480-8GB
RAM: Corsair Dominator (4 x 4 GB) DDR4 2400
Disk O/S & Programs: Intel SSD 750 (400 GB)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: Corsair Hydro series H115i
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Crystal Sound 3 on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 190943
Camera: Sony RX10 Model IV

https://www.youtube.com/user/thedennischannel

alifftudm95 wrote on 4/12/2022, 10:20 AM

@ aliff Since you're changing framerate from 2160p50 to 1080p25, make sure that in your project settings resampling is disabled or not set to optical flow (which will cause tremendous slow rendering).

I always disable resampling

PC DEKSTOP

CPU: Ryzen 9 5900x

GPU: RTX2060 6GB

RAM: 64GB 3200MHZ

Storage:

C DRIVE NVME M.2 1TB SSD GEN 4

D DRIVE NVME M.2 2TB SSD GEN 4

E DRIVE SATA SSD 2TB

F DRIVE SATA SSD 2TB

G DRIVE HDD 1TB

Monitor: BenQ PD2700U 4K HDR

 

 

 

alifftudm95 wrote on 4/12/2022, 10:22 AM

Beside slow rendering, the project in general is very sluggish. Delay and sometimes froze for solid 5 sec.

 

 

PC DEKSTOP

CPU: Ryzen 9 5900x

GPU: RTX2060 6GB

RAM: 64GB 3200MHZ

Storage:

C DRIVE NVME M.2 1TB SSD GEN 4

D DRIVE NVME M.2 2TB SSD GEN 4

E DRIVE SATA SSD 2TB

F DRIVE SATA SSD 2TB

G DRIVE HDD 1TB

Monitor: BenQ PD2700U 4K HDR

 

 

 

alifftudm95 wrote on 4/12/2022, 10:22 AM

@alifftudm95

I experienced a similar result with that media.

Hmm I wonder why?

PC DEKSTOP

CPU: Ryzen 9 5900x

GPU: RTX2060 6GB

RAM: 64GB 3200MHZ

Storage:

C DRIVE NVME M.2 1TB SSD GEN 4

D DRIVE NVME M.2 2TB SSD GEN 4

E DRIVE SATA SSD 2TB

F DRIVE SATA SSD 2TB

G DRIVE HDD 1TB

Monitor: BenQ PD2700U 4K HDR

 

 

 

john_dennis wrote on 4/12/2022, 10:28 AM

@alifftudm95

It doesn't appear to benefit from GPU decode or encode and doesn't make very good use of the CPU, either. At least on my older RX480 and CPU with no on-die video processing.

My main system:
Motherboard: Asus X99-AII
CPU: Intel i7-6850K
GPU: Sapphire Radeon RX480-8GB
RAM: Corsair Dominator (4 x 4 GB) DDR4 2400
Disk O/S & Programs: Intel SSD 750 (400 GB)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: Corsair Hydro series H115i
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Crystal Sound 3 on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 190943
Camera: Sony RX10 Model IV

https://www.youtube.com/user/thedennischannel

john_dennis wrote on 4/12/2022, 10:35 AM

The timeline performance on my machine I so bad, I think I would find a machine that I'm not using and convert to MagicYUV RGB or ProRes before I even started the project.

My main system:
Motherboard: Asus X99-AII
CPU: Intel i7-6850K
GPU: Sapphire Radeon RX480-8GB
RAM: Corsair Dominator (4 x 4 GB) DDR4 2400
Disk O/S & Programs: Intel SSD 750 (400 GB)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: Corsair Hydro series H115i
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Crystal Sound 3 on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 190943
Camera: Sony RX10 Model IV

https://www.youtube.com/user/thedennischannel

Yelandkeil wrote on 4/12/2022, 10:47 AM

The actual property of the shared clip is 10bit422HEVC.

It's a de/encode bottleneck in VEGASpro as @todd-b reported many times, barely dependent on hardware from yesterday or today.

Transcode to e.g. ProRes seems the only way to solve the problem currently.

ASUS TUF Gaming B550plus Bios2803: 
*Thermaltake TOUGHPOWER GF1 850W 
*ADATA XPG GAMMIX S11PRO 512GB4sys + 2TB4data 
*G.SKILL F4-3200C16Q-64GFX 
*AMD Ryzen9 5950x + LiquidFreezer II-240 
*XFX Speedster-MERC319雇佣兵-RX6900XT + AdrenalinEdition 22.5.1 (WHQL) 
DPort: 2xSamsung-LU28R55 10bit4k60Hz 300cd/m²HDR10 
ALC1200+Realtek 6.0.9360.1 Analog: ROCCAT Kave 5.1Headset/Mic 

ALC1200-TOSLINK: Samsung HW-Q60T 5.1 Soundbar?
USB Input: IK Multimedia iRigKeys MIDI24 
USB Device: Ultron CardReader/Writer 

Windowspro 10.0.19044.1865 
DirectX 12_2 Ultimate, Direct3D11Package installed 
OpenGL 4.6.14800 Compatibility Profile Context Version 22.5.1 30.0.15021.11005

Vegaspro19 + Handbrake/XMediaRecode + DVDArchi7 
Acidpro10 + SoundForgpro14.0.0.65 + SpectraLayerspro7 

K-LitecodecPack1662 (MPC Video Renderer for HDR10-Videoplayback) 

3POINT wrote on 4/12/2022, 10:52 AM

Than provided Media info seems not correct, 10bit422XAVC!

john_dennis wrote on 4/12/2022, 10:58 AM

Mediainfo of the file that I downloaded:

General
Complete name                            : C:\Users\John\Downloads\C8761.MP4
Format                                   : XAVC
Codec ID                                 : XAVC (XAVC/mp42/iso2/nras)
File size                                : 1.28 GiB
Duration                                 : 52 s 320 ms
Overall bit rate                         : 210 Mb/s
Encoded date                             : UTC 2022-04-09 03:44:29
Tagged date                              : UTC 2022-04-09 03:44:29

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Format Range@L5.1@High
Codec ID                                 : hvc1
Codec ID/Info                            : High Efficiency Video Coding
Duration                                 : 52 s 320 ms
Bit rate                                 : 200 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 50.000 FPS
Color space                              : YUV
Chroma subsampling                       : 4:2:2
Bit depth                                : 10 bits
Bits/(Pixel*Frame)                       : 0.482
Stream size                              : 1.22 GiB (95%)
Encoded date                             : UTC 2022-04-09 03:44:29
Tagged date                              : UTC 2022-04-09 03:44:29
Color range                              : Full
Codec configuration box                  : hvcC

Audio
ID                                       : 2
Format                                   : PCM
Format settings                          : Big / Signed
Codec ID                                 : twos
Duration                                 : 52 s 320 ms
Bit rate mode                            : Constant
Bit rate                                 : 1 536 kb/s
Channel(s)                               : 2 channels
Sampling rate                            : 48.0 kHz
Bit depth                                : 16 bits
Stream size                              : 9.58 MiB (1%)
Encoded date                             : UTC 2022-04-09 03:44:29
Tagged date                              : UTC 2022-04-09 03:44:29

Other
Type                                     : meta
Duration                                 : 52 s 320 ms

 

My main system:
Motherboard: Asus X99-AII
CPU: Intel i7-6850K
GPU: Sapphire Radeon RX480-8GB
RAM: Corsair Dominator (4 x 4 GB) DDR4 2400
Disk O/S & Programs: Intel SSD 750 (400 GB)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: Corsair Hydro series H115i
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Crystal Sound 3 on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 190943
Camera: Sony RX10 Model IV

https://www.youtube.com/user/thedennischannel

Yelandkeil wrote on 4/12/2022, 11:10 AM

Also, the big/signed PCM could occur problems.

Tips:

ASUS TUF Gaming B550plus Bios2803: 
*Thermaltake TOUGHPOWER GF1 850W 
*ADATA XPG GAMMIX S11PRO 512GB4sys + 2TB4data 
*G.SKILL F4-3200C16Q-64GFX 
*AMD Ryzen9 5950x + LiquidFreezer II-240 
*XFX Speedster-MERC319雇佣兵-RX6900XT + AdrenalinEdition 22.5.1 (WHQL) 
DPort: 2xSamsung-LU28R55 10bit4k60Hz 300cd/m²HDR10 
ALC1200+Realtek 6.0.9360.1 Analog: ROCCAT Kave 5.1Headset/Mic 

ALC1200-TOSLINK: Samsung HW-Q60T 5.1 Soundbar?
USB Input: IK Multimedia iRigKeys MIDI24 
USB Device: Ultron CardReader/Writer 

Windowspro 10.0.19044.1865 
DirectX 12_2 Ultimate, Direct3D11Package installed 
OpenGL 4.6.14800 Compatibility Profile Context Version 22.5.1 30.0.15021.11005

Vegaspro19 + Handbrake/XMediaRecode + DVDArchi7 
Acidpro10 + SoundForgpro14.0.0.65 + SpectraLayerspro7 

K-LitecodecPack1662 (MPC Video Renderer for HDR10-Videoplayback) 

Former user wrote on 4/12/2022, 11:13 AM

Yep playback of that file pretty much non existent, just a static image on screen.

Render 5.37mins

alifftudm95 wrote on 4/12/2022, 11:27 AM

Also, the big/signed PCM could occur problems.

Tips:

I dont have the luxury to transcode all of this 200+GB file to ProRes that will create 400-500GB of file.

PC DEKSTOP

CPU: Ryzen 9 5900x

GPU: RTX2060 6GB

RAM: 64GB 3200MHZ

Storage:

C DRIVE NVME M.2 1TB SSD GEN 4

D DRIVE NVME M.2 2TB SSD GEN 4

E DRIVE SATA SSD 2TB

F DRIVE SATA SSD 2TB

G DRIVE HDD 1TB

Monitor: BenQ PD2700U 4K HDR

 

 

 

alifftudm95 wrote on 4/12/2022, 11:31 AM

So what is the solution to improve the playback & render speed? Beside transcoding.

PC DEKSTOP

CPU: Ryzen 9 5900x

GPU: RTX2060 6GB

RAM: 64GB 3200MHZ

Storage:

C DRIVE NVME M.2 1TB SSD GEN 4

D DRIVE NVME M.2 2TB SSD GEN 4

E DRIVE SATA SSD 2TB

F DRIVE SATA SSD 2TB

G DRIVE HDD 1TB

Monitor: BenQ PD2700U 4K HDR

 

 

 

alifftudm95 wrote on 4/12/2022, 11:42 AM

The actual property of the shared clip is 10bit422HEVC.

It's a de/encode bottleneck in VEGASpro as @todd-b reported many times, barely dependent on hardware from yesterday or today.

Transcode to e.g. ProRes seems the only way to solve the problem currently.

If you don't mind, can you explain bout the bottleneck thingy ?

I've seen a forum post someone mentioning about current hardware (GPU if im not wrong), are not capable yet to decode latest codec from Sony or something, debayer, 10bit something I cant remember.

Last changed by alifftudm95 on 4/12/2022, 11:43 AM, changed a total of 1 times.

PC DEKSTOP

CPU: Ryzen 9 5900x

GPU: RTX2060 6GB

RAM: 64GB 3200MHZ

Storage:

C DRIVE NVME M.2 1TB SSD GEN 4

D DRIVE NVME M.2 2TB SSD GEN 4

E DRIVE SATA SSD 2TB

F DRIVE SATA SSD 2TB

G DRIVE HDD 1TB

Monitor: BenQ PD2700U 4K HDR

 

 

 

alifftudm95 wrote on 4/12/2022, 11:56 AM

After double checking on main project, I realize it's a mixture of H264 and H265!

H264 is CAM 1

HEVC is CAM 2

Even tho H264 clip render faster (I test the render and get result of 15-18fps average), the playback performance

is still poor, but not as bad as HEVC clip. I've upload 2nd sample clip on the same drive link:

https://drive.google.com/drive/folders/1F3Rg1xsXGaj4xp82Eak5TOkcxOcslyAL?usp=sharing

 

PC DEKSTOP

CPU: Ryzen 9 5900x

GPU: RTX2060 6GB

RAM: 64GB 3200MHZ

Storage:

C DRIVE NVME M.2 1TB SSD GEN 4

D DRIVE NVME M.2 2TB SSD GEN 4

E DRIVE SATA SSD 2TB

F DRIVE SATA SSD 2TB

G DRIVE HDD 1TB

Monitor: BenQ PD2700U 4K HDR

 

 

 

Yelandkeil wrote on 4/12/2022, 12:07 PM

There are 2 codecs, the modern one so4compoundplug.dll and the legacy one mxhevcplug.dll, responsible for AVC/XAVC/HEVC.

In the past there was a blacklist to filter certain formats/sourcematerials using this or that codec to achieve max performance. I don't know where the blacklist was/is.

With my Signature I can handle almost every kind material except this one: 10bit422HEVC.

Last changed by Yelandkeil on 4/12/2022, 12:10 PM, changed a total of 1 times.

ASUS TUF Gaming B550plus Bios2803: 
*Thermaltake TOUGHPOWER GF1 850W 
*ADATA XPG GAMMIX S11PRO 512GB4sys + 2TB4data 
*G.SKILL F4-3200C16Q-64GFX 
*AMD Ryzen9 5950x + LiquidFreezer II-240 
*XFX Speedster-MERC319雇佣兵-RX6900XT + AdrenalinEdition 22.5.1 (WHQL) 
DPort: 2xSamsung-LU28R55 10bit4k60Hz 300cd/m²HDR10 
ALC1200+Realtek 6.0.9360.1 Analog: ROCCAT Kave 5.1Headset/Mic 

ALC1200-TOSLINK: Samsung HW-Q60T 5.1 Soundbar?
USB Input: IK Multimedia iRigKeys MIDI24 
USB Device: Ultron CardReader/Writer 

Windowspro 10.0.19044.1865 
DirectX 12_2 Ultimate, Direct3D11Package installed 
OpenGL 4.6.14800 Compatibility Profile Context Version 22.5.1 30.0.15021.11005

Vegaspro19 + Handbrake/XMediaRecode + DVDArchi7 
Acidpro10 + SoundForgpro14.0.0.65 + SpectraLayerspro7 

K-LitecodecPack1662 (MPC Video Renderer for HDR10-Videoplayback) 

john_dennis wrote on 4/12/2022, 12:15 PM

@alifftudm95

Please state which camera(s) and/or outboard recorder(s) created these files.

My main system:
Motherboard: Asus X99-AII
CPU: Intel i7-6850K
GPU: Sapphire Radeon RX480-8GB
RAM: Corsair Dominator (4 x 4 GB) DDR4 2400
Disk O/S & Programs: Intel SSD 750 (400 GB)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: Corsair Hydro series H115i
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Crystal Sound 3 on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 190943
Camera: Sony RX10 Model IV

https://www.youtube.com/user/thedennischannel

alifftudm95 wrote on 4/12/2022, 12:17 PM

@alifftudm95

Please state which camera(s) and/or outboard recorder(s) created these files.

Sony A7Siii

PC DEKSTOP

CPU: Ryzen 9 5900x

GPU: RTX2060 6GB

RAM: 64GB 3200MHZ

Storage:

C DRIVE NVME M.2 1TB SSD GEN 4

D DRIVE NVME M.2 2TB SSD GEN 4

E DRIVE SATA SSD 2TB

F DRIVE SATA SSD 2TB

G DRIVE HDD 1TB

Monitor: BenQ PD2700U 4K HDR