Decklink Mini Monitor 4K with Vegas: Soft image?

njdocmaker wrote on 9/30/2020, 3:01 PM

I've decided to take the advice of the wisemen and monitor through a Blackmagic Decklink Mini Monitor 4K card for my color grading display, which is a Benq SW240, calibrated with DisplayCal.

The Decklink card works with Vegas 17, and the color and gamma seem about the same as when monitored through the HDMI output on my graphics card. But there's a problem:

I noticed pretty quickly that the image coming from the Decklink looks slightly softer and less crisp than the image from the graphics card. It's subtle but unmistakable. A closer inspection shows that straight lines (like the edges of a building for example) are slightly pixelated, while through the graphics card those lines are sharp and clean.

I've tried changing a bunch of different settings both within Vegas and withini Blackmagic Desktop Video Setup, but nothing helped.

Anyone have any experience with this or good ideas? I realize it could be something wrong between Vegas and the Decklink card, but it could also be something wrong between the Decklink and the monitor.



Musicvid wrote on 9/30/2020, 3:57 PM

Are you comparing the sharpness on your BenQ with your standard monitor? If so, chances are your standard monitor is oversharpened at factory settings.

To check, look at some black text on a blue background. If you see any visible piping (white fringe) around the text, back off your Sharpen control until it just goes away. Then compare.

fr0sty wrote on 9/30/2020, 5:35 PM

What preview quality are you sending to the card?



AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Radeon VII

Windows 10


ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

njdocmaker wrote on 9/30/2020, 6:00 PM

I'm sending "Best" quality. Just to clarify, the BenQ looks great when plugged into the computers graphics card via HDMI. If I pull the HDMI cable out of the graphics card and plug it into the Decklink, then the image on the BenQ is soft and slightly blurry. Kind of reminds me of this:

fred-w wrote on 9/30/2020, 7:02 PM

What are your settings? I have an older (not 4k) Decklink Mini Monitor... I always use 1080i60 fps for my Decklink Desktop settings, but my monitor won't accept the range of input frequencies that yours most probably does, so I'm more or less stuck with that.

Mine is crisp. No such problems. You're outputting 4k resolution to a lower resolution monitor, that might have something to do with it. Have you tried downgrading the output to 1080p (or 1080i )?

What are your Vegas Project settings, FPS (frames per second) and resolution, interlaced or progressive?

njdocmaker wrote on 9/30/2020, 7:30 PM

My project is 1920x1080p, 23.98 fps. (And the footage is the same.)

One thought that crossed my mind is that the monitor resolution itself is 1920x1200, so maybe it's having problems scaling through the Decklink that for some reason it doesn't have through the graphics card.

Overall, I'm wondering if it's worth the hassle to keep trying to troubleshoot. The one reassuring part of all this is that the colors and gamma through the graphics card seem to be very close to the Decklink, so that makes me feel not so worried about using External Monitoring through the graphics card.



Musicvid wrote on 9/30/2020, 7:46 PM

The fact that you have and know how to use DisplayCal is probably the reason they are close. Out of curiosity, what colorimeter are you using?

njdocmaker wrote on 9/30/2020, 7:53 PM

I've been using a Colormunki Display, which is apparently no different than the i1Display Pro, just slower. My results got noticeably better once I figured out the right colorimeter correction in Displaycal to use for my specific monitor.

fred-w wrote on 9/30/2020, 8:59 PM

Yes. I had looked up your monitor before replying, and the non 16:9 layout brought scaling immediately to mind as an issue. Vegas has a check box for simulating output device dimensions on your Video tab in Preferences.

Also, these come in handy: