Comments

JackW wrote on 5/12/2019, 12:36 AM

You should be able to download the font and install it on your computer. Vegas will find it from among the loaded fonts whenever you select it from the list.

Grazie wrote on 5/12/2019, 12:41 AM

@JackW I’m not sure @ron-p is asking for this?

@ron-p Are you wanting another DEFAULT Font to appear in your Text Event?

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

ron-p wrote on 5/12/2019, 10:22 AM

@JackW I’m not sure @ron-p is asking for this?

@ron-p Are you wanting another DEFAULT Font to appear in your Text Event?


I am wondering if I can set Vegas Pro to always use Impact as the default font. Its on my computer but when I start Vegas the default font is Verdana. Can I set Vegas up to use Impact as the default font when Vegas Pro 16 starts?

ron-p wrote on 5/12/2019, 12:22 PM

@JackW I’m not sure @ron-p is asking for this?

@ron-p Are you wanting another DEFAULT Font to appear in your Text Event?

I found out how to do it, you need to change the default font in Windows., but the problem is every time you type it will be in your new default font. So I guess I will just leave it alone. Thanks for everyone's input.

Dot wrote on 5/12/2019, 6:45 PM

You can create a generated text with the font you want and load that each time you want new text.

ron-p wrote on 5/12/2019, 7:11 PM

You can create a generated text with the font you want and load that each time you want new text.


How do you do that? I use Impact all the time in Vegas Pro 16. I would love to set it up to use that font each time I open Vegas.

Musicvid wrote on 5/12/2019, 7:24 PM

Can't you make a project with the font you want and save that as a .veg to use as a template?

Marco. wrote on 5/12/2019, 7:35 PM

In the folder

C:\Program Files\VEGAS\VEGAS Pro 16.0\OFX Video Plug-Ins\TitlesAndText.ofx.bundle\Contents\Resources\

look for the appropriate XML file and replace

"OfxParamPropDefault>{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fcharset0 Verdana;"

against

"OfxParamPropDefault>{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fcharset0 Impact;"

ron-p wrote on 5/12/2019, 7:39 PM

In the folder

C:\Program Files\VEGAS\VEGAS Pro 16.0\OFX Video Plug-Ins\TitlesAndText.ofx.bundle\Contents\Resources\

look for the appropriate XML file and replace

"OfxParamPropDefault>{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fcharset0 Verdana;"

against

"OfxParamPropDefault>{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fcharset0 Impact;"


Thats what I was looking for, thank you VERY much!!!!

Grazie wrote on 5/12/2019, 11:29 PM

@Marco. - That’s a right, real stunning piece of IT knowledge, just there! Your understanding of this stuff leaves me far away in the dust. 😃

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

Marco. wrote on 5/13/2019, 2:58 AM

😄
I only tend to guess and then try out. And in the cases my guess and try turns to be wrong, I tend to be quiet. This then appears as if I would have known in the cases it works. Good recipe? 😎

Grazie wrote on 5/13/2019, 4:53 AM

Good recipe? 😎

AKA Hannibal Lecter, “and a nice chianti

 

 

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

Marco. wrote on 5/13/2019, 5:16 AM

🍷

ron-p wrote on 5/13/2019, 9:24 PM

In the folder

C:\Program Files\VEGAS\VEGAS Pro 16.0\OFX Video Plug-Ins\TitlesAndText.ofx.bundle\Contents\Resources\

look for the appropriate XML file and replace

"OfxParamPropDefault>{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fcharset0 Verdana;"

against

"OfxParamPropDefault>{\rtf1\ansi\ansicpg1252\deff0{\fonttbl{\f0\fnil\fcharset0 Impact;"

I have been trying to save this and can not. Even if I delete the file Vegas still starts up with Verdana as the default font. I don't know what I am doing wrong. Any advice? Were you able to change it successfully?

 

Dexcon wrote on 5/13/2019, 10:00 PM

@ron-p … if you can't save the change because Windows won't let you, it's probably a permissions issue.

Right click the XML file and select Properties; then select the Security tab at the top of the Properties dialogue box. In the Group or User Names, you should see 2 lines names Administrators and Users. When you highlight each of these, the Allow listing for Full Control and Modify in the Permissions for Users box below are most likely not checked. To get them checked, click the Edit selection in between the 2 boxes and check Allow for both Full Control and Modify, and then hit OK. Do this for both Administrators and Users (there may be even more names related to administrator and users, depending on how your computer is configured Windows-wise). Close all the boxes with OK, and you should then be able to change the font name and save the revised XML file.

ron-p wrote on 5/13/2019, 10:25 PM

@ron-p … if you can't save the change because Windows won't let you, it's probably a permissions issue.

Right click the XML file and select Properties; then select the Security tab at the top of the Properties dialogue box. In the Group or User Names, you should see 2 lines names Administrators and Users. When you highlight each of these, the Allow listing for Full Control and Modify in the Permissions for Users box below are most likely not checked. To get them checked, click the Edit selection in between the 2 boxes and check Allow for both Full Control and Modify, and then hit OK. Do this for both Administrators and Users (there may be even more names related to administrator and users, depending on how your computer is configured Windows-wise). Close all the boxes with OK, and you should then be able to change the font name and save the revised XML file.


I deleted the file and it still started with Verdana. There is something else storing the font.

Dot wrote on 5/13/2019, 10:36 PM

Are you using Titles and Text, Legacy, or Pro Type titler?

ron-p wrote on 5/13/2019, 10:45 PM

Are you using Titles and Text, Legacy, or Pro Type titler?


Text Media. Right click on a video track and selected that. Not Pro type.

Dexcon wrote on 5/13/2019, 10:47 PM

I deleted the file and it still started with Verdana.

Following Marco's suggestion, deletion shouldn't be necessary. All that needs doing is to edit the appropriate XML file to change the font name, and then save the edited XML file - no name change is necessary as it should save with the same name.

Also, check to see that you are editing the appropriate XML file. If your Vegas Pro is set to English, then the Titles AndText.xml file is the one to change; however, if you are using another language, then one of the other XML files would be the appropriate XML file to edit.

Are you using Titles and Text, Legacy, or Pro Type titler?

Following Marco's approach, I have changed the default font to Arial, and Arial now appears by default for all three titling options.

 

ron-p wrote on 5/13/2019, 10:59 PM

I deleted the file and it still started with Verdana.

Following Marco's suggestion, deletion shouldn't be necessary. All that needs doing is to edit the appropriate XML file to change the font name, and then save the edited XML file - no name change is necessary as it should save with the same name.

Also, check to see that you are editing the appropriate XML file. If your Vegas Pro is set to English, then the Titles AndText.xml file is the one to change; however, if you are using another language, then one of the other XML files would be the appropriate XML file to edit.

Are you using Titles and Text, Legacy, or Pro Type titler?

Following Marco's approach, I have changed the default font to Arial, and Arial now appears by default for all three titling options.

 


Too late here will try again tomorrow, thanks.

ron-p wrote on 5/13/2019, 11:34 PM

@ron-p … if you can't save the change because Windows won't let you, it's probably a permissions issue.

Right click the XML file and select Properties; then select the Security tab at the top of the Properties dialogue box. In the Group or User Names, you should see 2 lines names Administrators and Users. When you highlight each of these, the Allow listing for Full Control and Modify in the Permissions for Users box below are most likely not checked. To get them checked, click the Edit selection in between the 2 boxes and check Allow for both Full Control and Modify, and then hit OK. Do this for both Administrators and Users (there may be even more names related to administrator and users, depending on how your computer is configured Windows-wise). Close all the boxes with OK, and you should then be able to change the font name and save the revised XML file.

I went by your instructions and it worked. I was clicking on the one that said ES for English. Thank you.

3POINT wrote on 5/14/2019, 8:09 AM

Alternatively you can make own preset(s) with your favorite font(s) and delete the (never used) default presets, (delete in C/Program Files/Vegas/Vegas Pro xx.x/OFX Video Plugins/TitlesAndText.ofx.bundle/Contents/ the Presets folder).

Last changed by 3POINT on 5/14/2019, 8:26 AM, changed a total of 1 times.

3POINT, Theo Houben, Vegasuser since version 5

Recware: DJI Osmo Pocket, GoproHero7Black, PanasonicFZ300/HCX909, Sony PXW-X160.

Software:VegasPro16/VegasMovieStudio16/PowerDirector16

Hardware:i7 4770, 16GB, GTX650ti, 1920x1200 display

Playware:Philips 55PFL7108