How to get better Playback performance in the Video Preview window

Julius_ wrote on 6/24/2021, 2:30 PM

Hi,

I'm trying to get better playback in the Video Preview Window. When I am editing and playing thru the timeline, the Video Preview window struggles to play (no f/x added). I have to drop down to DRAFT quality at half to get it to play. (1080p footage 60fps,xavc) What do I need to change? My system is a few years old:

My system is an i7-6800 Processor    Intel(R) Core(TM) i7-6800K CPU @ 3.40GHz, 3401 Mhz, 6 Core(s), 12 Logical Processor(s)

Motherboard: X99A RAIDER (MS-7885)
Win 10 Pro
32GB Ram

Vegas 18 Pro build 527

GPU acceleration is set to: Optimal -Advance Micro Devices

Dynamic Ram:2000 (available 31644)
Rendering Threads: 32

 

Video Card: AMD Radeon R9 390 (drivers updated):

GPU - AMD Radeon (TM) R9 390 Series - Primary/Discrete
VRAM - 8192 MB - GDDR5 1500 MHz
Graphics Card Manufacturer - Powered by AMD
Graphics Chipset - AMD Radeon (TM) R9 390 Series
Device ID - 67B1
Vendor ID - 1002
SubSystem ID - 04ED
SubSystem Vendor ID - 1043
Revision ID - 80
Bus Type - PCI Express 3.0
Current Bus Settings - PCI Express 3.0 x16
BIOS Version - 015.049.000.004
BIOS Part Number - 115-C671GPI-200
BIOS Date - 2015/08/06 23:21
Usable Memory Size - 8192 MB
Memory Type - GDDR5
Memory Clock - 1500 MHz
Core Clock - 1050 MHz
Total Memory Bandwidth - 384 GByte/s
Memory Bit Rate - 6.00 Gbps
2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/CurrentControlSet/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0000
OpenGL® API Version - 4.6
OpenCL™ API Version - 2.0

 

Sony video files I normally use (MediaInfo):

Format :XAVC
Codec ID :XAVC (XAVC/mp42/iso2)
File size :88.0 MiB
Duration :14 s 14 ms
Overall bit rate mode :Variable
Overall bit rate :52.7 Mb/s
Encoded date :UTC 2021-06-12 14:24:33
Tagged date :UTC 2021-06-12 14:24:33

Video

ID :1
Format :AVC
Format/Info :Advanced Video Codec
Format profile :High@L4.2
Format settings :CABAC / 2 Ref Frames
Format settings, CABAC :Yes
Format settings, RefFrames :2 frames
Format settings, GOP :M=1, N=15
Codec ID :avc1
Codec ID/Info :Advanced Video Coding
Duration :14 s 14 ms
Bit rate mode :Variable
Bit rate :50.0 Mb/s
Maximum bit rate :60.0 Mb/s
Width :1 920 pixels
Height :1 080 pixels
Display aspect ratio :16:9
Frame rate mode :Constant
Frame rate :59.940 (60000/1001) FPS
Standard :NTSC
Color space :YUV
Chroma subsampling :4:2:0
Bit depth :8 bits
Scan type :Progressive
Bits/(Pixel*Frame) :0.403
Stream size :83.6 MiB (95%)
Encoded date :UTC 2021-06-12 14:24:33
Tagged date :UTC 2021-06-12 14:24:33
Color range :Limited
Color primaries :BT.709
Transfer characteristics :IEC 61966-2-4
Matrix coefficients :BT.709

 

Thanks for any tips!!

 

 

Comments

j-v wrote on 6/24/2021, 2:52 PM

Do a total reset following this precisly and after that do not change a setting in Preferences/Video and Preferences/File I/O. Let those at their defaults

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 23H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti with driver
555.85 Studiodriver and Intel HD graphics 630 with driver 31.0.101.2127
Laptop  :Asus ROG Str G712L, W11 home version 23H2, CPU i7-10875H, 16 GB RAM, NVIDIA GeForce RTX 2070 with Studiodriver 555.99 and Intel UHD Graphics 630 with driver 31.0.101.2127
Vegas software: VP 10 to 21 and VMS(pl) 10,12 to 17.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEM CELL DONOR!!! (because it saved my life in 2016)

 

Julius_ wrote on 6/24/2021, 2:55 PM

Do a total reset following this precisly and after that do not change a setting in Preferences/Video and Preferences/File I/O. Let those at their defaults

Yes I did that too, it helps a bit, but the issue returns quickly.

Julius_ wrote on 6/24/2021, 3:13 PM

For fun, I clear the cache again....very little difference...the video playback in the timeline is very slow..at DRAFT!

j-v wrote on 6/24/2021, 3:17 PM

Show here screenshots of Preferences/Video and Preferences File I/O

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 23H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti with driver
555.85 Studiodriver and Intel HD graphics 630 with driver 31.0.101.2127
Laptop  :Asus ROG Str G712L, W11 home version 23H2, CPU i7-10875H, 16 GB RAM, NVIDIA GeForce RTX 2070 with Studiodriver 555.99 and Intel UHD Graphics 630 with driver 31.0.101.2127
Vegas software: VP 10 to 21 and VMS(pl) 10,12 to 17.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEM CELL DONOR!!! (because it saved my life in 2016)

 

Julius_ wrote on 6/24/2021, 3:20 PM

This is what I have now..

Julius_ wrote on 6/24/2021, 3:28 PM

Here's a video...look at the DRAFT setting I have and the FRAME count and how it struggles when I press play.

 

j-v wrote on 6/24/2021, 3:35 PM

Thanks, all normal.
The only tip I can give left is to change in Video the amount of used Ram to o when you not use Shift+B on a part of the timeline. Sometimes it has helped with this kind of problems.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 23H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti with driver
555.85 Studiodriver and Intel HD graphics 630 with driver 31.0.101.2127
Laptop  :Asus ROG Str G712L, W11 home version 23H2, CPU i7-10875H, 16 GB RAM, NVIDIA GeForce RTX 2070 with Studiodriver 555.99 and Intel UHD Graphics 630 with driver 31.0.101.2127
Vegas software: VP 10 to 21 and VMS(pl) 10,12 to 17.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEM CELL DONOR!!! (because it saved my life in 2016)

 

Marco. wrote on 6/24/2021, 3:39 PM

If your source video is 60 fps why do you set your project properties to 29,97 fps? If you gain for best playback performance, your project properties should match your source properties. Also ensure in the project properties resampling is turned off for the "Resample mode".

Julius_ wrote on 6/24/2021, 3:44 PM

It comes in at 60, and set my project to 30 because I get butter smooth slow motion at 30%

Resampling is turned off

BTW: If my source (60) is set to my project (60). I still have the problem

Last changed by Julius_ on 6/24/2021, 3:46 PM, changed a total of 2 times.

i7-6800 (Intel 3.40GHz, 6 cores)

Windows 10 PRO (up to date)

32GB Ram

MB: x99A Raider, MS-7885 (MSI)

SDD+HDD

AMD Radeon R9 390

Vegas user since V5

Realtek audio

 

Marco. wrote on 6/24/2021, 3:46 PM

Project properties should not affect slow motion processing but it directly affects your preview performance, though if resampling is turned off it shouldn't matter.

Marco. wrote on 6/24/2021, 3:49 PM

Could you share your project file (without media)?

Btw – your source is not 60 fps, it is 59,94 fps. That's a big difference when we talk about matched parameters and performance issues.

Julius_ wrote on 6/24/2021, 4:03 PM

Could you share your project file (without media)?

https://mega.nz/file/4p8TRIgZ#vem72yOzSLKs-KCkzdnUdLSuQy2udhu-SxctDXYqDbQ

Just IGNORE all media when opening.

Marco. wrote on 6/24/2021, 4:13 PM

Strange, except of a few areas where you used slomos and transition fx I cannot find anything which could cause such a performance slow down. If you hadn't turned off resampling, I'd say the frame rate mismatch is it. But with resampling turned off this cannot be the cause.

Are you sure there aren't any hidden Media FX (not Event FX) applied to the clips? These ones cannot be shown in the project without media files, so I can't look for them.

EdiTools wrote on 6/24/2021, 4:17 PM

@Julius_

1.Go to Options/Preferences. In Video set Dynamic Ram Preview Max. to "0" and in GPU acceleration of video processing set "OFF"

2.Right click mouse button in Vegas icon on Desktop/choose open file location/search FileIO Plug-Ins folder and rename the folder so4compoundplug to so4compoundplug.OFF/ Open Vegas and see if that solves.

This can be undone anytime you want.

Marco. wrote on 6/24/2021, 4:17 PM

Is the performance poor for the whole project from the first second on? Or does the performance drop start after project timecode 00:51:02:01?

Julius_ wrote on 6/24/2021, 4:22 PM

Strange, except of a few areas where you used slomos and transition fx I cannot find anything which could cause such a performance slow down. If you hadn't turned off resampling, I'd say the frame rate mismatch is it. But with resampling turned off this cannot be the cause.

Are you sure there aren't any hidden Media FX (not Event FX) applied to the clips? These ones cannot be shown in the project without media files, so I can't look for them.

I don't have any FX, I put 3-4 clips in slow motion, but the playback isn't even in those clips.

I did put the project to 59.95 and still lags.

No hidden effects.

It's only a few crossfades that I have..not many.

Thanks

Julius_ wrote on 6/24/2021, 4:23 PM

Is the performance poor for the whole project from the first second on? Or does the performance drop start after project timecode 00:51:02:01?

It's pretty much poor the minute the project is loaded...I can place the playhead anywhere and it struggles everywhere.

Julius_ wrote on 6/24/2021, 4:28 PM

@Julius_

1.Go to Options/Preferences. In Video set Dynamic Ram Preview Max. to "0" and in GPU acceleration of video processing set "OFF"

2.Right click mouse button in Vegas icon on Desktop/choose open file location/search FileIO Plug-Ins folder and rename the folder so4compoundplug to so4compoundplug.OFF/ Open Vegas and see if that solves.

This can be undone anytime you want.

This is interesting..It works!

Even with 59.95 in BEST FULL!

With GPU off :( I wont be able to render AMD VCE)...and can't use SHFT-B for dynamic ram..maybe my card is old?

 

THANK YOU!

Last changed by Julius_ on 6/24/2021, 4:30 PM, changed a total of 2 times.

i7-6800 (Intel 3.40GHz, 6 cores)

Windows 10 PRO (up to date)

32GB Ram

MB: x99A Raider, MS-7885 (MSI)

SDD+HDD

AMD Radeon R9 390

Vegas user since V5

Realtek audio

 

Musicvid wrote on 6/24/2021, 5:07 PM

I don't have any FX, I put 3-4 clips in slow motion, but the playback isn't even in those clips.

If you have a slow motion effect, it may never preview smoothly without prerendering.

That's exactly what we mean by realtime processing, which uses huge amounts of resources, and even with the best systems available will not always be able to keep up.

Prerender.  

EdiTools wrote on 6/25/2021, 3:07 PM

With GPU off :( I wont be able to render AMD VCE)...and can't use SHFT-B for dynamic ram..maybe my card is old?

@Julius_

Just enable GPU acceleration only at render time and Dynamic Ram Preview (Shift+B) only on the parts you find necessary. I've been working this way for years and I've never had any problems.

fred-w wrote on 6/29/2021, 1:28 AM

@Julius_

1.Go to Options/Preferences. In Video set Dynamic Ram Preview Max. to "0" and in GPU acceleration of video processing set "OFF"

2.Right click mouse button in Vegas icon on Desktop/choose open file location/search FileIO Plug-Ins folder and rename the folder so4compoundplug to so4compoundplug.OFF/ Open Vegas and see if that solves.

This can be undone anytime you want.

This is interesting..It works!

Even with 59.95 in BEST FULL!

With GPU off :( I wont be able to render AMD VCE)...and can't use SHFT-B for dynamic ram..maybe my card is old?

 

THANK YOU!

If you are following this advice formula, and are thus setting Ram Preview to "0" - well, effectively, you then would have "0" resources allocated towards the "preview." So, of course, it wouldn't work, at all. That is normal. I don't think, (of course, I'm guessing) RAM Preview allocation is hurting you, looks like the GPU is not one that Vegas likes, so with keeping the GPU "off" go ahead and try allocating up to 10GB for RAM preview, won't hurt anything to try, and you might still have the playback that you now are enjoying.

Some have recommended the "one third total RAM" allocation, especially if you've got a fair amount, and you do. YMMV, but really, unless your build has some idiosyncrasies, you should be fine with a healthy RAM preview allocation.