Magix Vegas 18 fails to render 4K - 2160p NVENC

Cobra wrote on 3/2/2021, 11:54 AM


I get this when I try to render. It fails. I have set Dynamic RAM to 0. Didn't help

I render this to my high end laptop AMD 4800h/RTX2060/16GB RAM

Why VEGAS is so poorly performing??
I also noticed that after exceeding the 4 minutes of editing (having heavy effects and edit) the editing experience is TERRIBLE

Latest VEGAS 18 434
Windows 10 Enterprise LTSC 1809
 

Comments

walter-i. wrote on 3/2/2021, 1:13 PM

Then you should first tell us the project settings, the rendering settings and the media info - otherwise we can only turn the large glass ball.
Here is a collection of what else could be helpful and interesting:

https://www.vegascreativesoftware.info/de/forum/important-information-required-to-help-you--110457/

 

Cobra wrote on 3/2/2021, 1:56 PM

Project Settings

Render Settings


File Properties

Most are MP4 4K from Sony A6600

some are MOV files from Adobe AE

Plenty of MP3, PNG, JPG and some simple AVC 1080p videos


I tried both MAGIX AVC & HEVC

 

walter-i. wrote on 3/2/2021, 2:43 PM

Please present the media information of the files that you have listed above, as described here in the article:
https://www.vegascreativesoftware.info/us/forum/faq-how-to-post-mediainfo-and-vegas-pro-file-properties--104561/

And please also take a screenshot of:
Options > Preferences > Video und
Options > Preferences > File I / O

You updated the graphics card drivers with Vegas Pro 18: Help> Check for Driver Updates?
Please enter the driver numbers here or a screenshot of the result

Is there a specific reason you're not updating your Windows - your version is from 2018.

 

frmax wrote on 3/2/2021, 4:58 PM

Walter, it´s LTSC, long term version, 10 years support, 1809 is the latest version.

The LTSC versions are actually only used for special situations, Microsoft also points out that some applications will not work properly.
So it comes into consideration as a source of error.

I9900K, RTX 2080, 32GB RAM, 512Mb M2, 1TB SSD, VEGAS Pro 14-20 (Post), Magix ProX, HitfilmPro
AMD 5900, RTX 3090 TI, 64GB RAM, 1 TB M2 SSD, 4 TB HD, VP 21 Post

Monitor LG 32UN880; Camera Sony FDR-AX53; Photo Canon EOS, Samsung S22 Ultra

RogerS wrote on 3/2/2021, 7:17 PM

Project and render settings seem fine. You are on the Studio driver?

File I O tab would be helpful, as Walter said.

I also edit a6600 files with NVIDIA and performance is good.

What are the Fx you applied​? Not all play back in real-time.​​​​​​

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with latest driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (latest available driver), dual internal SSD (256GB; 1TB), Windows 10 64 bit

VEGAS Pro 19.651
VEGAS Pro 20.411
VEGAS Pro 21.208

Try the
VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7

fr0sty wrote on 3/2/2021, 8:49 PM

Also, without knowing your hardware specs, we don't know if you're just simply overloading your system with more than it is actually capable of.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Geforce RTX 3090

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

Cobra wrote on 3/3/2021, 2:10 AM

Trust me the LTSC Windows version is amazing.

Doesnt have all the bloatware the 20H2 has. (No Windows Store, Xbox gaming bars, etc.) it runs much smoother even on my desktop. You have to try it out.

I check marked the AVC.

NVIDIA Drivers are the latest.

I managed to render the file setting the GPU acceleration to NONE (which sucks). That shows its a Vegas software problem.

I think all the addons I have make VEGAS even slower. (Borris FX, Sapphire & Universe)

I have the latest GAMING driver 461.72 - I will try the Studio driver too.

I love VEGAS but, I will give Da Vinci Resolve a try today to check the performance differences. The only problem for me is the learning curve AGAIN.

RogerS wrote on 3/3/2021, 2:50 AM

Try the Studio Driver first and redo your tests.

Then uncheck legacy AVC and HEVC. Put hardware decoding back to Auto.

See if it renders. If not, try disabling the plugins and try again. If it is a plugin causing the issue let Magix know.

Setting GPU acceleration to none isn't a big deal- just disables some preview acceleration (might be having issues with one of your plugins). Decoding and encoding via GPU still work with this unchecked.

For Resolve, the free version lacks hardware decoding or encoding so don't expect great performance.

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with latest driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (latest available driver), dual internal SSD (256GB; 1TB), Windows 10 64 bit

VEGAS Pro 19.651
VEGAS Pro 20.411
VEGAS Pro 21.208

Try the
VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7

Musicvid wrote on 3/5/2021, 12:38 PM

The file properties you posted fall short of what was asked for, however they may provide a clue as to one cause of your crashes:

Until we see the MediaInfo and Vegas file properties, the introduction of MOV w/Alpha is one thing that could be held suspect. KwikProxy in Happy Otter Scripts is a nifty way to handle it.

https://www.vegascreativesoftware.info/us/forum/faq-how-to-post-mediainfo-and-vegas-pro-file-properties--104561/

Also, running a render with GPU turned off (using a software encoder) could be tried. NVENC doesn't support Alpha channel afaik.