Rendering 2160p footage to NTSC widescreen (MPEG2) has tiny black bars

anoymous1234567890 wrote on 10/13/2019, 6:46 AM

I have had this problem for a while, including with VP17 and movie studio platinum 15 but here's the issue:

 

When I have 4k (3840x2160) footage and render it to 720x480i widescreen, for DVD use, I have these tiny black bars on the side:

But when I render the same file to 1920x1080 and THEN to 720x480 widescreen, I get no black bars:

(white everywhere)

For me to go directly from 4k to 720x480i widescreen I have to enable "stretch video to fill output frame size" option.

Now I don't really want to have it be distorted with that option but I also really don't want to have to render to 1920x1080p, first, and then to 720x480i.

Is there anything I can do to go directly from 4k to 720x480i widescreen, without that stretch option?

Comments

Dexcon wrote on 10/13/2019, 7:06 AM

It might have something to do with the difference in aspect ratios. 3840 x 2160 has a ratio of 1.77:1 whereas 720:480 has a ratio closer to 1.5:1.

I can't explain why 1920x1080 results without bars in 720x480, but is it the result in the 1920x1080 process somehow stretching horizontally ever so slightly without your input?

With your end aspect ratio using a vertical image of 480, you would need a horizontal pixel ratio of approaching 850.

anoymous1234567890 wrote on 10/13/2019, 7:18 AM

I can't explain why 1920x1080 results without bars in 720x480, but is it the result in the 1920x1080 process somehow stretching horizontally ever so slightly without your input?

No it's not and I have the stretch option disabled.

The weird thing is that 3840x2160 and 1920x1080 are both the same exact aspect ratio of 16:9 (1.777...).

But why does 1920x1080 behave better with this?

Musicvid wrote on 10/13/2019, 7:28 AM

Possibly because different encoders are being used?

Anyway, the "Adjust Source Media ..." option in your Project is supposed to take care of this.

anoymous1234567890 wrote on 10/13/2019, 7:46 AM

Possibly because different encoders are being used?

Anyway, the "Adjust Source Media ..." option in your Project is supposed to take care of this.


I tested this with a PNG image file at 3840x2160. This also happens with video of the same resolution with the same encoders and the video project was adjusted to source media, as always.

Dexcon wrote on 10/13/2019, 7:55 AM

@anoymous1234567890 … just as a test only, try reframing a small section of your original 4K timeline project via Track Motion to reframe to 1.5:1 and then render that small section to 720x480. If the black bars still appear, then that will more likely focus the problem to the rendering process.

anoymous1234567890 wrote on 10/13/2019, 8:28 AM

@anoymous1234567890 … just as a test only, try reframing a small section of your original 4K timeline project via Track Motion to reframe to 1.5:1 and then render that small section to 720x480. If the black bars still appear, then that will more likely focus the problem to the rendering process.

I have no idea what that means.

I can crop to 1500x1000 inside the frame but I have to check the box to stretch to fill frame in the render settings, still, and that is part of the problem to begin with. It just renders only that part with the rest being black, still being 3840x2160.

Former user wrote on 10/13/2019, 8:31 AM

You are already distorting the image in order to create the 720x480 product. Using the "stretch video..." causes no additional harm. I don't know why it works correctly when going from 1080i because on all of my 1080i videos, I have to use the "stretch video..." option to avoid the black bars. I think musicvid is most correct in that one of your encoders is causing the difference.

anoymous1234567890 wrote on 10/13/2019, 8:48 AM

I think musicvid is most correct in that one of your encoders is causing the difference.

How do I use a different one? I'm using the DVD Architect NTSC MPEG2 widescreen and I don't see an option to change from NV Encoder or something, in render options. This happens not only with my footage, but with a plain white PNG image as well.

Former user wrote on 10/13/2019, 9:43 AM

kplo wrote on 10/13/2019, 11:12 AM

Try unchecking the "Maintain aspect ratio" box when rendering. That seems to work for me...stretches it out just enough when I was editing a lot of DV footage..

anoymous1234567890 wrote on 10/13/2019, 11:13 AM

That is the solution to the problem for 3840x2160 but I don't need to do that for 1920x1080. I put that in the OP post.

My question is why can't I not have it stretch to fill the frame coming from 3840x2160? That's literally my OP post.

anoymous1234567890 wrote on 10/13/2019, 11:14 AM

Try unchecking the "Maintain aspect ratio" box when rendering. That seems to work for me...stretches it out just enough when I was editing a lot of DV footage..

I'm trying to do this without stretching anything. It does fine from 1920x1080 without stretching but I want to avoid recompressing.

Former user wrote on 10/13/2019, 11:21 AM

I think you are concerned about a non-existent problem. Stretching to fill does not impact quality at all. It only makes the rendered file fill the screen.

anoymous1234567890 wrote on 10/13/2019, 11:24 AM

I think you are concerned about a non-existent problem. Stretching to fill does not impact quality at all. It only makes the rendered file fill the screen.

Yes that is very true but what is causing this forced stretching, only with 3840x2160? And I am also forced to recompress my whole project to 1920x1080 and then to the DVD format, to not get any stretching.

I would rather not have the 5%~ stretching in my projects for my clients.

Former user wrote on 10/13/2019, 11:57 AM

Think about it. You are taking a project that has 8,294,400 pixels per frame and I assume from a high quality acquisition format and converting it to 345,600 pixels per frame in a highly compressed format.. Then you are taking that 720 x 480 video, horizontally compressed, and actually stretching it horizontally to display at 16 x 9 aspect. Is it really going to make much difference in quality if a few pixels are added to make the picture fill the whole 720 x 480 frame? Remember at that point pixels are added, it is not stretched. It is stretched during display. Your clients are getting the short end by watching your HD video at SD size, not by the minimal adding of pixels to fill the frame. Skip the interim render and go straight to 720 x 480 stretched to fill.

Musicvid wrote on 10/13/2019, 1:35 PM

Please be clear, thin black bars is the expected behavior going from 16:9 to NTSC Anamorphic. A better question is, why "isn't" this happening with 1080p?

Again, the "Adjust Source Media..." switch exists in Properties for that very reason. You can just leave it as a default - doesn't affect nonanamorphic.

OldSmoke wrote on 10/15/2019, 5:29 AM

Try rendering to 704x480 without stretching, it’s a legal DVD format too.

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15&16.

System Spec.:
Motherboard: ASUS X299 Prime-A

Ram: G.Skill 4x8GB DDR4 2666 XMP

CPU: i7-9800x @ 4.6GHz (custom water cooling system)
GPU: 1x AMD Vega Pro Frontier Edition (water cooled)
Hard drives: System Samsung 970Pro NVME, AV-Projects 1TB (4x Intel P7600 512GB VROC), 4x 2.5" Hotswap bays, 1x 3.5" Hotswap Bay, 1x LG BluRay Burner

PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM (2560x1440)