(RESOLVED) Bad crossfades that cause Vegas 452 to freeze

Paul-Fierlinger wrote on 7/18/2020, 9:05 AM

I am suddenly experiencing problems with my cross dissolves in build 452. As the cursor passes over the crossover section the screen imagery flickers badly a few times before the picture on that layer just turns black. I have titles on the layer above which aren't effected. At this point I can't bring the cursor to a stop and after awhile the entire GUI gets a milky sheen while still playing. At some point the playback freezes and I have to use Ctrl, Alt, Delete to close Vegas.

I thought one of the events might be corrupted but that isn't the case (I re-rendered the events which changed nothing). The squirrel seems to be in the cross fades themselves but this baffles me because they all have been working well (I use Automatic Crossfades). I don't have Quantize to Frames activated. I can't think of anything else that would have caused this; it just started to happen when I last returned to Vegas after working on my animation software as I do back and forth dozens of times every day.

I also tried working on another project and all is OK there, so this doesn't seem to be caused by Vegas itself but something strange happens to all my crossfades in this one project. When I throw the events apart all plays well. Once I recreate a crossfade everything goes haywire with the picture as described above.

Any suggestions?

Addendum: I tried restarting my computer to no avail and BTW the same behavior is happening on all my backups and secondary saves, which is really, really strange.

One more thought: Recently I switched my NVIDIA GTX 1660 card from its Game setting to Studio.

RESOLVED: Recently I raised my Dynamic RAM max to 1/3 of my Max available 31676 as suggested in an NVIDIA YouTube in one of these threads. Back to 200 and all is well.

Comments

Musicvid wrote on 7/18/2020, 9:14 AM

after awhile the entire GUI gets a milky sheen while still playing. At some point the playback freezes and I have to use Ctrl, Alt, Delete to close Vegas.

......

Any suggestions?

Yes.

  1. Update your graphics drivers to the latest -if they are Nvidia, use the Studio driver, not the gaming driver.
  2. If that does not fix it, disable "GPU Acceleration of Video Processing." and provide all of the necessary information requested here.
  3. https://www.vegascreativesoftware.info/us/forum/important-information-required-to-help-you--110457/
Paul-Fierlinger wrote on 7/18/2020, 9:55 AM

Thanks, Mvid.

If you will go back to my thread you will see that I figured out the problem before I found your kind reply. I feel sort of proud that I fixed it in the same area you are suggesting here. So the milky sheen was the giveaway for you?

 

Musicvid wrote on 7/18/2020, 10:20 PM

Yep, it's kind of a ringer.

Musicvid wrote on 7/19/2020, 10:25 AM

It makes sense that sequestering so much ram would have the same effect, both are related to buffer underflow, I suspect. I have limited ram, and can't use preview acceleration at all. Congratulations on methodical troubleshooting!

I'll add your findings, including freeing up or adding more physical ram to my list of suggestions for the "Pale Screen of Misery" bug.

@frosty

Paul-Fierlinger wrote on 7/19/2020, 3:04 PM

Interesting. Ever since i reset my RAM allocation back to 200 my computer has lost its spirit and stumbles on tasks that it never had trouble with before. It's small stuff, yet a nuisance at times. Perhaps I could raise it to something less impressive such as 500 RAM or so?

j-v wrote on 7/19/2020, 3:21 PM

Do you use the option Dynamic RAM Preview often?

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.38 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Paul-Fierlinger wrote on 7/19/2020, 4:58 PM

I've been toying with it if that's what you mean. It has a lot to do with my work flow. I start my animations by first assembling a sound track in Vegas, then I make rough drawings setting up the entire film, about one drawing per scene, which I bring into Vegas where I create the first rough edit, making decisions of the films flow by stretching each drawing to the estimated length of the scene.

Next in Vegas I make increment copies of the broken up sound track (broken into scenes) and bring those individual small tracks into TVP. There I make a more detailed rough series of drawings per scene, which I take back to Vegas. When all that is done I can play a sort of slide show of how the story is turning out and from now on this is how I work back and forth, adding more drawings, changing lengths of scenes etc. and adding color.

This means I am each time adding complexity of motion and weight to the project. That's when I might play around with the dynamic RAM. There's a difference between a 30 minute film and a 10 minute one or just a 30 sec commercial.

My events are AVIs and my sound tracks are wav graphs. My format is 1080p and the events are all non compressed.

Does this answer your question?

And BTW, now that I have raised the size of my dynamic RAM from 200 to 500 my previews are once more smooth. I always use Best (FULL); I couldn't tolerate watching anything less. I create a number of crossfades both in sound and video. That's about the extent of plugins I use.

j-v wrote on 7/19/2020, 5:14 PM

Does this answer your question?

No, I was asking for the D R Preview option of the menu Tools ( shift-B)

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.38 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Paul-Fierlinger wrote on 7/19/2020, 5:23 PM

Sorry, my technical knowledge of video editing is tightly limited to the work I described above. I have no idea how to use this Preview Option. Would you mind explaining? It might be something I should learn.

Paul-Fierlinger wrote on 7/19/2020, 8:02 PM

Here is an almost completed pencil test of our current WIP. It also happens to show my computer setup:

https://vimeo.com/fierlingers/download/439837428/d130e9af30

Paul-Fierlinger wrote on 7/19/2020, 8:53 PM

@j-v

I checked out Dynamic Preview in Help and must say I have never come across a need for something like this. I have though on occasions used Prerender which I find very useful.

michael-harrison wrote on 7/19/2020, 9:22 PM

I found when playing around with some Boris Sapphire fx that using a ram setting of 1024 resulted in a test project playing back smoothly vs 1 frame every second. Sapphire, on my machine, is cpu bound and needs more ram. If I'm not using Sapphire, I can usually leave the ram setting at 0

System 1:

Processor        Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz, 3192 Mhz, 6 Core(s), 12 Logical Processor(s)

BaseBoard Product        ROG STRIX Z390-E GAMING

Installed Physical Memory (RAM)        32.0 GB

Adapter Description        NVIDIA GeForce GTX 1660

Driver Version        Studio <the latest stable>

Resolution        1920 x 1080 x 60 hertz

Video Memory 6G GDDR5

 

System 2:

Lenovo Yoga 720

Core i7-7700 2.8Ghz quad core, 8 logical

16G ram

Intel HD 630 gpu

Nvidia GTX 1050 gpu

j-v wrote on 7/20/2020, 2:24 AM

@j-v

I checked out Dynamic Preview in Help and must say I have never come across a need for something like this. I have though on occasions used Prerender which I find very useful.

Because the setting for RAM preview you were resetting( "i reset my RAM allocation back to 200") is mostly used for the Dynamicc RAM Preview, you never use, it's not important which amount is choosen. But be carefull, the amount choosen is not anymore available for other tasks.

 

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.38 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Paul-Fierlinger wrote on 7/20/2020, 3:38 AM

AH ... now I understand. Maybe this should be explained on the spot; or is this something most users already know?

So I just turned it to 0 now and all my pans stuttered badly, turned it back to 200 and that fixed it. Perhaps having my playback set to Best(full) uses Dynamic RAM for Preview after all, or perhaps it does in cases of hand drawn animation because I animate in 2s like everyone else in the hand drawn world, yet if the stuttering appears during camera moves over a still background that can't be the explanation.