Vegas Movie Studio 17.0 (204) Crashes just looking at M2TS Files

Cory-Kihlstrom wrote on 4/18/2021, 6:27 PM

I use the add media function and select a M2TS file in the file dialog box, The application immediately crashes. "Movie Studio Platinum has stopped working" Some sort of "unmanaged exception" in the Kernelbase.dll

I am able to load the file in DVD Architect.

I have updated Windows.

I have updated my Video Drivers

I have reloaded Movie Studio, removed old versions.

Any ideas?

Comments

BigGator wrote on 4/18/2021, 6:51 PM

There's some discussion on MTS files on the Vegas Pro side, but it seems to be affecting VMS as well. I just hit it tonight - dead in the water trying to edit some camera footage.

Musicvid wrote on 4/18/2021, 11:21 PM

See if this thread provides a possible solution for your problem. We're seeing a lot of this . . .

https://www.vegascreativesoftware.info/us/forum/vegas-pro-17-crashes-when-loading-mts--128572/#ca799527

Cory-Kihlstrom wrote on 4/19/2021, 2:36 AM

Sounds like Microsoft closed a loop hole being used for MTS files. Not sure anything can be done will a patch comes out.

Musicvid wrote on 4/19/2021, 7:20 AM

I did some testing last night, and if the suspicion is correct, it may apply to all transport streams -- MTS, M2T, M2TS, even VOB is giving problems.

Cory-Kihlstrom wrote on 4/19/2021, 9:38 AM

On the bright side, I was able to give a heads up at work to software developers about the issue.

I guess we will need to wait for a patch to come out either for VMS or from Microsoft.

Musicvid wrote on 4/19/2021, 11:49 AM

Uninstalling KB5001330 is working for some users.

BigGator wrote on 4/20/2021, 8:40 AM

That KB uninstall didn't work on my laptop.. will try on my workstation at home when I get a few. This is pretty bad - as I've got about 5 hours of footage from this weekend that needs to be edited. No bueno.

BigGator wrote on 4/20/2021, 8:47 AM

Since this is obviously a widespread problem (and not just with a Windows update - as other programs in Windows can open the files just fine). Is Vegas aware and is there an open ticket of some sort?

VEGASDerek wrote on 4/20/2021, 9:19 AM

As I have stated in a number of other threads, we are aware of it and have a fix that is currently being tested. We are working to release the fix as soon as possible.

Cory-Kihlstrom wrote on 4/20/2021, 9:36 AM

As I have stated in a number of other threads, we are aware of it and have a fix that is currently being tested. We are working to release the fix as soon as possible.

Thank you.

Jamie-Vegas wrote on 4/20/2021, 9:49 AM

I'm having this issue as well. Pretty sure it has to do with a recent windows update. Not sure if this helps at all - the windows version I'm having issues with is:

Windows 10 Home

Version: 20H2

Installed: 3/13/2021

OS Build: 19042.928

My other Windows 10 computer has no issues.

Windows 10 Home

Version: 1903

Installed: 8/10/2019

OS Build: 18362.719

Granddadmd wrote on 4/20/2021, 10:40 AM

Hello.

Read the call,

now I use 50HZ/Pal system, in VMS17 Platium M2Ts does work on Windows 10 version 20H2

Is the problem not 60 Hz / NTSC

See my video

Greeting

Granddad

j-v wrote on 4/20/2021, 12:40 PM

The difference in VMS 17 is between mts files with stereo sound (no problem) or mts files with surround sound (problem)

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W11 home version 21H2, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti, Intel HD graphics 630
Laptop  :Asus EVO37T, W10 home version 21H2, CPU i7-10875H, 16 GB RAM, Intel UHD Graphics + NVIDIA GeForce RTX 2070. VP 17,18,19 and VMS PL 17 are installed, all latest builds, both Nvidia GPU's have driver version 472.47 Studiodriver. both Intel GPU's have
driver:  30.0.9864
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

BigGator wrote on 4/20/2021, 12:49 PM

mine are stereo, not surround

BigGator wrote on 4/20/2021, 7:26 PM

Edit: I looked, and my camera somehow switched to multichannel - so they ARE 6 channel files.

The KB delete worked on my workstation, but not my laptop

bill_webster wrote on 11/18/2021, 2:27 PM

Is it possible to burn a 4k rendered video to a 4k uhd disc using Studio 17 Platinum or will I have to use DVD Architect. When using the make movie option in Studio 17 it only gives the option to burn blu ray HD 1080 and no 4k option.

EricLNZ wrote on 11/18/2021, 2:58 PM

As far as I'm aware you cannot burn 4K with either VMS or DVDA. The only way to play 4K from a disk is to simply copy the files over as a Data Disc. Most players will recognise it and give you a list of playable videos. But obviously you don't get the menus, navigation etc that you do with an authored video disc.