Vegas Pro 18 32bit Full Range Render Errors

_Mark_ wrote on 8/6/2020, 2:37 AM

First time actually came to rendering in the new Vegas Pro 18. Rendering using 32bit full range there is an issue. The firs time I went to render it did render, but the preview screen was flashing between black and the video image, this was also rendered into the video itself.

So, went to re-render and it just wouldn't and came up with an error message. I've uploaded a video to show this. Setting ram preview to zero had no effect on this, same issue. I always 32bit full range as I always get odd banding artifacts using 8 bit. Full range always gives me the best quality.

The only way to fix this was to turn off GPU acceleration. (my spec are in my sig)

Windows 10 Pro x64
ASUS TUF B450-PRO GAMING
ASUS VP28U 4K Monitor
AMD Ryzen 7 2700 8 Core
32GB DDR4 3200MHZ
NVIDIA GeForce GTX 1650 (Latest Studio Drivers)

Audio Interface: Zoom UAC 8
Camera: Sony FDR-AX100E
Audio: Sony PCM-D100

 

Comments

fr0sty wrote on 8/6/2020, 2:46 AM

There has been much debate around here about whether there's any benefit at all from using 32 bit on 8 bit projects, so far nobody has been able to show any improvement that I've seen, and you end up spending way more time rendering it. I'd be interested in seeing a screencap of these artifacts you mention.

As for your problem, click "Help" at the top of VEGAS, then use the new driver update utility to update your GPU's drivers. That should resolve your issue.

Systems:

Desktop

AMD Ryzen 7 1800x 8 core 16 thread at stock speed

64GB 3000mhz DDR4

Radeon VII

Windows 10

Laptop:

ASUS Zenbook Pro Duo 32GB (9980HK CPU, RTX 2060 GPU, dual 4K touch screens, main one OLED HDR)

_Mark_ wrote on 8/6/2020, 2:52 AM

Thanks for your reply, drivers are fine and all up to date (Studio Driver)

There is a difference for me, as I said above I get odd banding artifacts in 8 bit, really noticeable in darker areas, hence why I use 32bit full range, always have done. Version 17 renders fine though. Turning off GPU acceleration fixes it, but not much use if a plugin needs it.

Edit: scrap previous edits, same issue still exits, first rendered with flashing preview screen, second render same error message.

Last changed by _Mark_ on 8/6/2020, 3:15 AM, changed a total of 3 times.

Windows 10 Pro x64
ASUS TUF B450-PRO GAMING
ASUS VP28U 4K Monitor
AMD Ryzen 7 2700 8 Core
32GB DDR4 3200MHZ
NVIDIA GeForce GTX 1650 (Latest Studio Drivers)

Audio Interface: Zoom UAC 8
Camera: Sony FDR-AX100E
Audio: Sony PCM-D100

 

Marco. wrote on 8/6/2020, 3:30 AM

The banding will be back once you render to 8 bit in the end.

_Mark_ wrote on 8/6/2020, 3:57 AM

The banding will be back once you render to 8 bit in the end.

Yep, 8 bit full range in VP18 is better than legacy as in VP17

8bit screen shot VP17 added vignette to show it more easily

32bit screen shot VP17 added vignette to show it more easily

Windows 10 Pro x64
ASUS TUF B450-PRO GAMING
ASUS VP28U 4K Monitor
AMD Ryzen 7 2700 8 Core
32GB DDR4 3200MHZ
NVIDIA GeForce GTX 1650 (Latest Studio Drivers)

Audio Interface: Zoom UAC 8
Camera: Sony FDR-AX100E
Audio: Sony PCM-D100

 

adis-a3097 wrote on 8/6/2020, 7:27 AM

I also see a level mismatch there. :)

Musicvid wrote on 8/6/2020, 8:47 AM

Rendering 32 bit float projects as 8 bit output adds shadow noise and banding, it doesn't reduce it.

https://www.vegascreativesoftware.info/us/forum/hdr-to-8-bit-vegas-grading-tip-reclaiming-the-shadows--117747/

It's true in any downconversion from 32 float space to 8 bit output, and theoretically worse when conducted in a nonlinear (gamma-weighted) environment. Here is a visual example using just eight- and ten- bit encoders straight through an 8 bit pipe, no other internal processing.

What you are seeing as "less" banding is actually rounding noise from converting the 10 bit frequency domain to 8 bit spatial domain, which can give the appearance of smoothing ("thickening") the banding edges. It's still just noise, not better signal. The tradeoff, of course, is the added shadow noise you see in both examples I gave, not to mention insufferable render times.

Bottom line: If you want less banding, shoot and render 10 bit.

 

 

 

_Mark_ wrote on 8/8/2020, 3:48 AM

Just an update on the OP. I ended up uninstalling v17 & v18 then reinstalling v18 and so far haven't noticed any major issues rendering at 32 bit. (clip length just over an hour with GPU acceleration back on) Maybe a conflict with v17? although shouldn't be as it`s in a separate installation folder? but just a thought, shared registry entries?

RE: Banding. I think the issue was for me that in VP17 using 8bit render to render an 8bit video made it look worse because of the banding, that`s why I used 32bit full range float. In VP18 now we have the 8bit full colour option this shouldn't be an issue, haven't done an major tests or comparisons, but from what I can see with the naked eye its a lot better.

Last changed by _Mark_ on 8/8/2020, 4:23 AM, changed a total of 1 times.

Windows 10 Pro x64
ASUS TUF B450-PRO GAMING
ASUS VP28U 4K Monitor
AMD Ryzen 7 2700 8 Core
32GB DDR4 3200MHZ
NVIDIA GeForce GTX 1650 (Latest Studio Drivers)

Audio Interface: Zoom UAC 8
Camera: Sony FDR-AX100E
Audio: Sony PCM-D100