Video with 360° picures (preview ok, render horrible!)

DeTomasi wrote on 2/12/2019, 1:10 PM

Hi, Im editing a video with 360° pictures where I use the tinyplanet plugin to make them planar and make some camera movements!
I my preview window, all is fine, but when render the video part is ok, the 360° picture come blurred and low res.
How can I render this? This is the final render and this is the preview
My project is at 4k and the render is set to 720p

Comments

Marco. wrote on 2/12/2019, 1:51 PM

Are you sure the Tiny Planet FX is meant to be used this way?

Are your source photos 360° dual fisheye?

What is your workflow?

Did you set your project to the 360° mode?

DeTomasi wrote on 2/12/2019, 7:01 PM

 

 

Are you sure the Tiny Planet FX is meant to be used this way?

Don't know but work's :)

Are your source photos 360° dual fisheye?

I used 360 panoramic stitched photos.

What is your workflow?

Did you set your project to the 360° mode?

Working at normal 4k, not VR.

 

Marco. wrote on 2/13/2019, 3:44 AM

If your photos are already stiched without fisheye abberation then why don't you use Pan/Crop to zoom and move. This would prevent loss of resolution.

Musicvid wrote on 2/13/2019, 5:09 AM

My project is at 4k and the render is set to 720p

Why so low? Have you tried a 4k render, or am I missing a limitation?

DeTomasi wrote on 2/13/2019, 7:14 AM

Yep, 4k render well...

1080 does not too

This is the picture I used!

Marco. wrote on 2/13/2019, 1:49 PM

Please check your render quality setting. It should be set to "Best".

DeTomasi wrote on 2/13/2019, 1:53 PM

Will test now!

Doesn´t work.... same problem

Looks good only if render at 4k, but the problem is only at the picture all other media works fine.

Try yourself with that photo

Marco. wrote on 2/13/2019, 4:31 PM

Another try: In the FX window try switching the order of the Tiny Planet FX and Pan/Crop so Pan/Crop is last in the chain.

Musicvid wrote on 2/13/2019, 10:22 PM

The only market for 8k now is vr360. There must be a reason for that, even if yours may not be so demanding.

MagixPascal wrote on 2/14/2019, 1:43 PM

@DeTomasi Hi. The tiny planet effect is the correct way to go.

The preview window is using this effect in the 360° mode. Please deactivate the 360° preview and add the tiny planet effect to your image/video. Use 4 as the value for z and rotate the sphere with the longitude and latitude. It should look like the 360° preview. Finally render your with a high resolution and please to not use a 360° template (because your video is transformed by tiny planet and planar).

DeTomasi wrote on 2/14/2019, 2:16 PM

@DeTomasi Hi. The tiny planet effect is the correct way to go.

The preview window is using this effect in the 360° mode. Please deactivate the 360° preview and add the tiny planet effect to your image/video. Use 4 as the value for z and rotate the sphere with the longitude and latitude. It should look like the 360° preview. Finally render your with a high resolution and please to not use a 360° template (because your video is transformed by tiny planet and planar).

Look at my project settings and effect settings

DeTomasi wrote on 2/14/2019, 2:26 PM

Look how ugly are the image from the pictures compared with the drone footage

 

Marco. wrote on 2/14/2019, 2:31 PM

Did you try changing the order of Pan/Crop and Tiny Planet?

DeTomasi wrote on 2/14/2019, 2:33 PM

Did you try changing the order of Pan/Crop and Tiny Planet?

Yes, same results!

Marco. wrote on 2/14/2019, 2:38 PM

Strange, I tested this yesterday and there was a huge difference. I'll re-check later.

DeTomasi wrote on 2/14/2019, 2:42 PM

Ill do too because I didnt used the pan/crop

 

Marco. wrote on 2/14/2019, 4:24 PM

It is not about using Pan/Crop. It is only about changing the signal workflow.

Marco. wrote on 2/14/2019, 4:34 PM

I checked a second time now and I have same result:

If I leave Pan/Crop before Tiny Planet the rendered 1280x720 looks as ugly as your own result. But when I switch Pan/Crop after Tiny Planet the final render looks fine.

@MagixPascal
Is this a bug?

MagixPascal wrote on 2/15/2019, 5:07 AM

I am not really able to follow you both but I see a small resolution mismatch. Your input has got a resolution of 3840x1920 (2:1) and your rendering output is using 1280x720 (1,777:1)... and between you are using a (tiny planet) transformation which increase this mismatch.

 

Is this a help for you?

Marco. wrote on 2/15/2019, 5:56 AM

@MagixPascal

Try setting the project properties to 1280x720 while using this 3840x1920 photo. Then switch the signal process from Pan/Crop -> Tiny Planet to Tiny Planet -> Pan/Crop.

There is a huge quality difference, it is even more than the difference between SD and full HD. And the same difference would appear when rendering this one to 1280x720.

The quality difference would not surprise me if it would happen vice versa. You can't repro this quality difference when rendering or previewing 3840x1920. It appears when using 1280x720.

DeTomasi wrote on 2/15/2019, 12:49 PM

if I change the order I cant make the camera movement

DeTomasi wrote on 2/15/2019, 12:57 PM

the only solution I find to do that is set to 4k, render at 4k then convert to lower resolution after that...

Marco. wrote on 2/15/2019, 1:10 PM

"if I change the order I cant make the camera movement"

Why not? Setting Pan/Crop after Tiny Planet does not affect the function of Tiny Planet.

Another option is to use Tiny Planet as Media FX instead of Event FX (because this also switches the signal processing).

Marco. wrote on 2/15/2019, 1:32 PM

@MagixPascal

See the quality difference:

Pan/Crop before a doubled Smart Zoom FX (which is default)

Pan/Crop after a doubled Smart Zoom FX

I just wanted to check if other resizing tools shows same issue and make it very clear (so I doubled the FX, same happens with Tiny Planet).