VP17 - Colors get altered whenever I use a plugin

Ivan187 wrote on 9/14/2019, 2:28 PM

Vegas Pro 17 contains a major pet peeve of mine. Whenever I use any video FX plugins, the colors get altered when they're not supposed to. It only happens on third-party OFX plugins, but under the video FX tab you'll be able to see each preset showing the eye picture in the wrong color, even with the default Vegas plugins.

Once I insert a rather simple third-party plugin like BCC Fast Flipper and turn it on (a plugin that is never meant to change colors), this happens:

Yeah, as you can tell, the colors of the picture are not the same. Is there a way to make Vegas 17 not do this? I have at least seven OFX plugin families installed and none of them had this behavior in Vegas 14, 15 and 16.

Comments

LongIslanderrr wrote on 9/14/2019, 3:08 PM

In Preferences . Make sure transform is off, Video is set to 32bit full range, and 2.22

Ivan187 wrote on 9/14/2019, 3:20 PM

In Preferences . Make sure transform is off, Video is set to 32bit full range, and 2.22

I can't find those options within Preferences

j-v wrote on 9/14/2019, 4:10 PM

I think @LongIslanderrr means in projectproperties.😉

met vriendelijke groet
Jan

Camera : Pan X900, GoPro Hero7 Hero Black, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10, i7 7900 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home, version 1903 build 18.362,295 CPU i7 7700HQ, 16 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 15,16,17 and VMS PL 15,16 are installed
Both Nvidia GPU's have driver version 431.86 Studio Drivers
TV      :LG 4K 55EG960V

Dutch video tutorials for beginners

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Ivan187 wrote on 9/14/2019, 4:42 PM

Well, I tried every option under the sun, but nothing. None of the color changes match with the original picture...not even 32-bit full range + 2.222 composing gamma + View transform off.

fr0sty wrote on 9/14/2019, 4:43 PM

If you're using 8 bit source material, just use 8 bit mode.

Ivan187 wrote on 9/14/2019, 4:50 PM

If you're using 8 bit source material, just use 8 bit mode.

I don't use 8-bit source material :/

Musicvid wrote on 9/14/2019, 5:30 PM

Well, what do you use?

https://www.vegascreativesoftware.info/us/forum/faq-how-to-post-mediainfo-and-vegas-pro-file-properties--104561/

Musicvid wrote on 9/14/2019, 5:33 PM

It looks suspiciously like the Windows update screen bug. Is this only in Vegas, or in VLC, etc.?

Ivan187 wrote on 9/27/2019, 8:28 PM

Apologies for the late reply, but this issue has been fixed as of build 321. Thanks for all the answers. :)