AVC/XAVC-S issues in VP15/16? Try disabling so4compoundplug.dll!

Comments

Wuster wrote on 11/21/2018, 8:10 AM

I was running Vegas 15 Build 316, and had the same sluggish response problems with mp4s taken on an iPhone X. If I disabled the So4 options, one essential video file would not load. I just updated to Vegas 15 Build 416 and on a whim I tried disabling the "Use So4 audio reader for Intermediate/HEVC" and leaving everything else enabled as shown in the screenshot.

That solved my problem!

This is observable, repeatable behaviour that the so4compound developers should be all over.

The only problem now is I have a memory leak error that crashes my computer whenever I open an HEVC file! If I disable the HEVC decoder by renaming the mxhevcplug.dll, the memory leaks go away. Vegas shows around 1-2GB commit and rises slowly in the background. With HEVC enabled, Vegas shows around 25GB commit and rises rapidly!

PanTutaj wrote on 12/21/2018, 1:43 PM

I had some issues with rendering, it was stopping on 24% and rendering black screen, same on preview. Everything changed when I have disabled so4compoundplug.dll. Thank you!

SheroxGG wrote on 5/31/2019, 1:56 PM

When I type so4 nothing appear, can someone help? Thanks!

Chief24 wrote on 5/31/2019, 3:13 PM

It's highly unlikely. You went to the very end of the thread/post, and forgot to read everything in between. Guess what? The answer lies within.

Self Build: MSI TRX40 Pro WiFi w/3960X (be Quiet! Dark Rock Pro TR4) @ stock; 128GB Team Group 3200 Mhz; OS/Apps - Inland Premium PCI-e 4.0x4 2TB, Documents/Extras - Inland Premium PCI-e 4.0x4 2TB; XFX AMD Radeon VII; Samsung 32 Inch UHD 3840x2160; Windows 10 Pro 64-Bit (21H2 19044.1466); (2) Intel 660p 2TB/(2) PNY 3040 4TB PCI-e on Asus Quad M.2x16; (2) WD RED 4TB;

VEGAS Pro 19 Edit (458)/VEGAS Pro 18 Edit (527); DVD Architect 7.0 (100);

Sound Forge Audio Studio 15; ACID Music Studio 11; SonicFire Pro 6.4.3 (with Vegas Pro/Movie Studio Plug-in); Creative SoundBlaster Zx sound card; Magix Xara Photo & Graphics Designer Pro 18

Canon EOS R6/EOS 80D; GoPro Hero 5+ & 6 Black & (2) 7 Black & (2) 9 Black & 10 Black; Sony FDR AX-53 & AX-33 HandyCams;

SheroxGG wrote on 5/31/2019, 4:13 PM

It's highly unlikely. You went to the very end of the thread/post, and forgot to read everything in between. Guess what? The answer lies within.

Hello Chief, thanks for the help, I am not a native speaker so maybe I miss understanded something, I read the post once again and cant find a solution. I understand that you want me to put more effort looking for it, but I cant find it, maybe the answer is between words that I dont know. Thanks and sorry.

AVsupport wrote on 6/1/2019, 3:46 AM

post #1 from Nick: hold shift key while opening prefs to get the 'internal' (developer) tab activated..

my current Win10/64 system (latest drivers, water cooled) :

Intel Coffee Lake i5 Hexacore (unlocked, but not overclocked) 4.0 GHz on Z370 chipset board,

32GB (4x8GB Corsair Dual Channel DDR4-2133) XMP-3000 RAM,

Intel 600series 512GB M.2 SSD system drive running Win10/64 home automatic driver updates,

Crucial BX500 1TB EDIT 3D NAND SATA 2.5-inch SSD

2x 4TB 7200RPM NAS HGST data drive,

Intel HD630 iGPU - currently disabled in Bios,

nVidia GTX1060 6GB, always on latest [creator] drivers. nVidia HW acceleration enabled.

main screen 4K/50p 1ms scaled @175%, second screen 1920x1080/50p 1ms.

SheroxGG wrote on 6/1/2019, 3:55 AM

Ohh, I see, I knew the shift part was important. I understood it wrong so I was pressing shift all the time because I didnt know when to press it. ill try it again! Thanks!

don-giani wrote on 1/5/2020, 7:16 AM

Hey guys.

Moved to Magix Vegas Pro 16 from 13 and the audio wasn't sync with the video. After a few google hits, I was able to find a quick and easy solution : disable the so4 compound reader for AVC by turning the value to 'FALSE' instead of 'TRUE. That instantly solved my problem.

After rendering my video, I discovered a lot of frame loss happening quite randomly. I tried a lot of tweaks to solve the issue but none of them worked. I suddenly decided to enable back the so4 compound reader for AVC and guess what? No frame loss issues anymore. The video is smooth and is the same as the original now. The audio isn't sync with the video though. That's still a massive problem.

If anyone could help here, I would be so thankful for that.

SPECS: AMD Ryzen 5 2600x6, Nvidia Geforce GTX 1060 6GB RAM, 16GB RAM, Windows 10, Vegas 16.

I used Nvidia Geforce Experience (Shadowplay) to capture the footage. 1920x1080, 60 FPS. (The true fps value is 60,003 after disabling the so4 compound reader and 60,002 before the removal)

DETAILS: I tried to set all the different fps values in both the Project and Media settings. Still have the fps issues in the rendering video.

I also tried to rename my original file from .mp4 to .dif to solve the video/audio sync. It works but I still have the fps issues in the rendering video.

Musicvid wrote on 1/5/2020, 8:35 AM

Feel free to start your own thread with a description of your problem and the important information in Section C here: https://www.vegascreativesoftware.info/us/forum/important-information-required-to-help-you--110457/

Shadowplay footage is a known separate issue.

 

AvixzTheNub wrote on 8/2/2020, 8:31 PM

i cant find the so4 compund thingy dude help

set wrote on 8/2/2020, 11:18 PM

i cant find the so4 compund thingy dude help

Vegas Pro version?

sakendrick wrote on 10/13/2020, 11:05 AM

am I correct that in 18 it is under File I/O and you have to enable the top two check boxes to disable So4?

RogerS wrote on 10/13/2020, 6:32 PM

This is an old thread before 18. In 18 check enable AVC legacy decoding. HEVC is a different plugin.

Alexander-Ehrath wrote on 11/22/2020, 4:25 PM

Anyone ever got this working? When I leave AVC legacy unchecked, it loads my project fine but crashes when rendering. When I check the AVC legacy box, it says "An error occurred opening the media file." This is ridiculous. I wasted so many hours finding work arounds that do not work after hours of trying. For the money we pay, you'd think a Magix coder could dedicate some time to do a deeper dive to fix these issues once and for all!

set wrote on 11/22/2020, 4:31 PM

 it loads my project fine but crashes when rendering.

Is it error when selecting File>Render as... without ever seeing the Render dialog box?

I had this issue lately several times, and the workaround when starting Vegas Pro, is to start with blank project first, just insert any media generator, then File>Render as...

The Render dialog box should appear. Now after doing this, open the project you are working on, then do File>Render as...

It works for me when working with DJI Osmo Pocket MP4 medias.

lenard wrote on 11/22/2020, 4:41 PM

They look to Not be updating the legacy method of decoding video, which is more stable, but only updating the So4 decoder, so the further into the evolution of VegasPro, the more unstable and crashing it will get.

Alexander-Ehrath wrote on 11/23/2020, 2:30 PM

Ok, so it has to do with HEVC encoding. I was able to render as AVC/NVENC fine, but HEVC/NVENC as well as HEVC/QSV both fail every time! When I enable AVC legacy rendering in the file i/o options, it refuses to load some of the content into the project with "Internal Error" message. Not very helpful error message :) and makes legacy rendering useless for me. So workaround: Forget about HEVC rendering to ever work, and use AVC rendering instead. Hopefully MAGIX is reading this and will fix it soon. I feel we should get half our money back as only half the features seem to work :)

lenard wrote on 11/23/2020, 4:57 PM

It's extremely annoying. If you have something like even a ryzen 3600 CPU , legacy decoder is very useable for many projects. You no longer have GPU hardware decoding, but have enough cpu where it doesn't matter (AVC decoding, not HEVC), but that that never worked properly on Vegas and timeline scrubbing and playing across edit points would creates lag. As the average computer grows stronger in case of 4K AVC we don't actually need hardware decoding, we need stability and so legacy should be able to decode all codecs that so4 can until so4 is fixed or replaced

 

AVsupport wrote on 11/23/2020, 5:16 PM

HEVC is the way forward, no doubt, this should be a priority.

my current Win10/64 system (latest drivers, water cooled) :

Intel Coffee Lake i5 Hexacore (unlocked, but not overclocked) 4.0 GHz on Z370 chipset board,

32GB (4x8GB Corsair Dual Channel DDR4-2133) XMP-3000 RAM,

Intel 600series 512GB M.2 SSD system drive running Win10/64 home automatic driver updates,

Crucial BX500 1TB EDIT 3D NAND SATA 2.5-inch SSD

2x 4TB 7200RPM NAS HGST data drive,

Intel HD630 iGPU - currently disabled in Bios,

nVidia GTX1060 6GB, always on latest [creator] drivers. nVidia HW acceleration enabled.

main screen 4K/50p 1ms scaled @175%, second screen 1920x1080/50p 1ms.

johan-tasche wrote on 9/7/2021, 6:45 AM

I was helped tremendously by NickHopes guidelines on switching-off So4Compounplug.dll. Thank you so much Nick! I have a nice set of (small) self made legacy AVC files being the core of the (huge!) problem.

Being it not possible to disable So4Compounplug.dll on VP18, I found out that VP18 for all AVC files with .mts extension correctly decodes AVC files using the legacy compoundplug.dll. That mechanism also worked fine for my AVC .mp4 files after changing the file-extensions simply to .mts!

So, just changing the extention helped me out of my problem. => That might be helpful for a few of you.

Now reading this thread again, I learned that in VP18 (and VP19!) just enabling legacy decoding (Options => Preferences => File I/O) allows compoundplug.dll once again to do the correct decoding (also for .mp4). Thank you!

So, two solutions for the problem.

RogerS wrote on 9/7/2021, 7:02 AM

I was helped tremendously by NickHopes guidelines on switching-off So4Compounplug.dll. Thank you so much Nick! I have a nice set of (small) self made legacy AVC files being the core of the (huge!) problem.

Being it not possible to disable So4Compounplug.dll on VP18, I found out that VP18 for all AVC files with .mts extension correctly decodes AVC files using the legacy compoundplug.dll. That mechanism also worked fine for my AVC .mp4 files after changing the file-extensions simply to .mts!

So, just changing the extention helped me out of my problem. => That might be helpful for a few of you.

Now reading this thread again, I learned that in VP18 (and VP19!) just enabling legacy decoding (Options => Preferences => File I/O) allows compoundplug.dll once again to do the correct decoding (also for .mp4). Thank you!

So, two solutions for the problem.

For AVC in VP 18 you just go to preferences file i/o and check "enable legacy AVC"- no need to go to internal prefs anymore. The other one- legacy HEVC is a different decoder. The legacy decoders aren't generally needed anymore and have their own issues, lack of support for newer file types being the biggest one.