AVC/XAVC-S issues in VP15/16? Try disabling so4compoundplug.dll!

Comments

Wuster wrote on 11/21/2018, 8:10 AM

I was running Vegas 15 Build 316, and had the same sluggish response problems with mp4s taken on an iPhone X. If I disabled the So4 options, one essential video file would not load. I just updated to Vegas 15 Build 416 and on a whim I tried disabling the "Use So4 audio reader for Intermediate/HEVC" and leaving everything else enabled as shown in the screenshot.

That solved my problem!

This is observable, repeatable behaviour that the so4compound developers should be all over.

The only problem now is I have a memory leak error that crashes my computer whenever I open an HEVC file! If I disable the HEVC decoder by renaming the mxhevcplug.dll, the memory leaks go away. Vegas shows around 1-2GB commit and rises slowly in the background. With HEVC enabled, Vegas shows around 25GB commit and rises rapidly!

PanTutaj wrote on 12/21/2018, 1:43 PM

I had some issues with rendering, it was stopping on 24% and rendering black screen, same on preview. Everything changed when I have disabled so4compoundplug.dll. Thank you!

SheroxGG wrote on 5/31/2019, 1:56 PM

When I type so4 nothing appear, can someone help? Thanks!

Chief24 wrote on 5/31/2019, 3:13 PM

It's highly unlikely. You went to the very end of the thread/post, and forgot to read everything in between. Guess what? The answer lies within.

Self Build: MSI X399 Gaming Pro Carbon AC/1950X @ stock; 64GB Corsair 2666 Mhz; OS-Intel 750 800GB, Project Media-Samsung 960 EVO 1TB & 970 EVO 1TB; (2) Samsung 850 EVO 500GB SSD for various (Magix Xara Photo & Graphics Designer Pro 16), Render, Other Assets; Sapphire AMD Radeon VII; (2) Samsung 28 Inch UHD 3840x2160; Windows 10 Pro 64-Bit (1809); (2) Intel 660p 2TB PCI-e on Asus Quad M.2x16; Magix Vegas Pro 15 Suite (416), Magix Movie Studio Platinum 15 Suite (157); Canon EOS 80D; GoPro Hero 5+ & 6 Black & 7 Black; Sony FDR AX-53 HandyCam; Sound Forge Studio 12.6; Creative SoundBlaster Zx sound card; Magix Music Maker Premium 2019

SheroxGG wrote on 5/31/2019, 4:13 PM

It's highly unlikely. You went to the very end of the thread/post, and forgot to read everything in between. Guess what? The answer lies within.

Hello Chief, thanks for the help, I am not a native speaker so maybe I miss understanded something, I read the post once again and cant find a solution. I understand that you want me to put more effort looking for it, but I cant find it, maybe the answer is between words that I dont know. Thanks and sorry.

AVsupport wrote on 6/1/2019, 3:46 AM

post #1 from Nick: hold shift key while opening prefs to get the 'internal' (developer) tab activated..

my current Win10/64 system (latest drivers, water cooled) :

Intel Coffee Lake i5 Hexacore (unlocked, but not overclocked) 4.0 GHz on Z370 chipset board,

16GB (2x8GB Corsair Dual Channel DDR4-2133) XMP-3000 RAM,

Intel 600series 512GB M.2 SSD system drive running Win10/64 home automatic driver updates,

4TB 7200RPM NAS HGST data drive,

Intel HD630 iGPU - currently disabled in Bios,

nVidia GTX1060 6GB, always on latest [creator] drivers. nVidia HW acceleration enabled.

main screen 4K/50p 1ms scaled @175%, second screen 1920x1080/50p 1ms.

SheroxGG wrote on 6/1/2019, 3:55 AM

Ohh, I see, I knew the shift part was important. I understood it wrong so I was pressing shift all the time because I didnt know when to press it. ill try it again! Thanks!