Blurry output when rendering MTS to MP4

Klaas-Wijchman wrote on 4/1/2020, 7:21 AM

Blurry output when rendering MTS to MP4

Windows 10, Movie Studio 16 Platinum

Nvidia GeForce RTX 2070 Super, Nvidia Studio driver version 26.21.14.4219.

Input: Panasonic MTS file, looks very sharp on screen, no blurry parts, 1920x1080x25fps

 

Problem:

When I render this file as-is, so even without any editing changes in MS16, the resulting MP4 file is blurry, especially in moving parts.

However, when I first convert said MTS file into MP4 using Handbrake, and use this MP4 file to render in MS16, then the resulting MP4 file looks as good as the original MTS file, no blurs at all.

 

What I already tried:

I read https://www.vegascreativesoftware.info/us/forum/faq-why-does-my-rendered-video-look-bad-troubleshooting-quality--103361/ and ‘played around’ with those suggestions.

In MS16, in Options - Preferences - Video I defined GPU acceleration to use the Nvidia card.

I used rendering formats MAGIX AVC/AAC MP4 and also Sony AVC/MVC and used the pre-defined template Internet HD 1080p 25fps (NVIDIA NVENC), but also the one without NVIDIA (that is for the MAGIX format, for Sony I used the 1920x1080 template).

Also tried various other templates, just to see whether they would result in better output.

I made many tests with various different settings in those templates, both with and without the GPU acceleration, but I haven’t found a combination of settings where the direct MTS to MP4 rendering gets a good quality output.

Resume:

MTS --> MP4 (MS16) is blurry

MTS --> MP4 (Handbrake) --> MP4 (MS16) is perfect

Any thoughts ?

Thanks !!

 

File Properties:

General

  Name: 00121.MTS

  Folder: E:\FOTOS\Test

  Type: MPEG-2 Transport Stream

  Size: 83,66 MB (85.665.792 bytes)

  Created: Mittwoch, 1. April 2020, 11:19:20

  Modified: Dienstag, 21. Januar 2020, 15:41:43

  Accessed: Mittwoch, 1. April 2020, 11:19:21

  Attributes: Archive

 

Streams

  Video: 00:00:40,360, 25,000 fps interlaced, 1920x1080x12, AVC

  Audio: 00:00:40,360, 48.000 Hz; Stereo, Dolby AC-3

 

ACID information

  ACID chunk: no

  Stretch chunk: no

  Stretch list: no

  Stretch info2: no

  Beat markers: no

  Detected beats: no

 

Other metadata

  Regions/markers: no

  Command markers: no

 

Media manager

  Media tags: no

 

Plug-In

  Name: compoundplug.dll

  Folder: Q:\MyPrograms\Video\Vegas Movie Studio 16\FileIO Plug-Ins\compoundplug

  Format: MPEG-2 Transport Stream

  Version: Version 16.0 (Build 175)

  Company: MAGIX Computer Products Intl. Co.

MediaInfo:

Comments

j-v wrote on 4/1/2020, 9:05 AM

Cannot try the same as you do, because my MTS files from my Panasonic are all since years FHD 50p and yours are probably 25i. I tried with mine many times and do not see any blurry.

However, when I first convert said MTS file into MP4 using Handbrake, and use this MP4 file to render in MS16, then the resulting MP4 file looks as good as the original MTS file, no blurs at all

Converted to interlace or progressive?

Last changed by j-v on 4/1/2020, 9:25 AM, changed a total of 1 times.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 16,17 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 451.48 Studio Driver, desktop the Studio DHC driver
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Musicvid wrote on 4/1/2020, 9:28 AM

Handbrake will not output interlaced video.

@Klaas-Wijchman Thanks for posting your input file properties. If you will do the same for one of your rendered files that is blurry, we may be able to clear this up.

Your Project Properties would be helpful too.

Klaas-Wijchman wrote on 4/2/2020, 5:45 AM

@ j-v and Musicvid, thank you for your quick reply.

The interlace/progressive remark by j-v made me do some more tests and now I have a good result, but nevertheless I’m not satisfied....

When I use the MAGIX AVC/AAC MP4 Format and the ‘Internet HD 1080p 25fps (NVIDIA NVENC)’ template without changes I get the blurry output I mentioned before. This template has the default setting for Field order as ‘None (progressive scan)’.

When I change this Field order either to ‘Upper field first’ or ‘Lower field first’

I get the following error message.

I then used the above mentioned template and changed Encode mode from ‘NV Encoder’ into Mainconcept AVC’ and used the default Field order. This gave the same blurry output.

However, when I changed the Field order into Upper field first or Lower field first, then the rendering created an almost perfect output. I say ‘almost’ because in some places some colored shadows were visible, especially when you stopped the video, but when watching it, this was almost neglectable.

In my first sentence I wrote that I still was not satisfied. Well, instead of using the Mainconcept ACC Encoder, I’d rather use the NV Encoder, because it is a lot faster, but in this case it creates an error, so I hope the specialists can look into the above shown error message and find a solution.

 

@Musicvid

You asked for the following info of the blurry video, although maybe it is not necessary anymore to look into this, due to above findings, but here it is:

MediaInfo:

 

Project Properties:

 

General

  Name: 00121.MTS

  Folder: E:\FOTOS\Klaas-Panasonic-TZ101\20200124

  Type: MPEG-2 Transport Stream

  Size: 83,66 MB (85.665.792 bytes)

  Created: Mittwoch, 4. März 2020, 20:07:21

  Modified: Dienstag, 21. Januar 2020, 15:41:43

  Accessed: Mittwoch, 4. März 2020, 20:07:22

  Attributes: Archive

 

Streams

  Video: 00:00:40,360, 25,000 fps interlaced, 1920x1080x12, AVC

  Audio: 00:00:40,360, 48.000 Hz; Stereo, Dolby AC-3

 

ACID information

  ACID chunk: no

  Stretch chunk: no

  Stretch list: no

  Stretch info2: no

  Beat markers: no

  Detected beats: no

 

Other metadata

  Regions/markers: no

  Command markers: no

 

Media manager

  Media tags: no

 

Plug-In

  Name: compoundplug.dll

  Folder: Q:\MyPrograms\Video\Vegas Movie Studio 16\FileIO Plug-Ins\compoundplug

  Format: MPEG-2 Transport Stream

  Version: Version 16.0 (Build 175)

  Company: MAGIX Computer Products Intl. Co.

 

Thank you very much !!

 

 

EricLNZ wrote on 4/2/2020, 6:00 AM

Your source files are interlaced so check which deinterlacing method is being used in your Project Properties.

The default "Blend Fields" can give blurring. Alter it to "Interpolate fields".

 

j-v wrote on 4/2/2020, 7:18 AM

@Klaas-Wijchman

Made with my Panasonic the same kind of footage you had.
No problems with me, but to get much better footage and thus also better renderresults change your camera setting to make 50p in stead of 50i, like I did from te beginning with that cam in 2012.
Look to my way of working with it without problems

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 16,17 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 451.48 Studio Driver, desktop the Studio DHC driver
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Klaas-Wijchman wrote on 4/2/2020, 11:17 AM

@EricNLZ, ThankU for replying so quickly.

I checked input and render settings, both Upper field first.

I changed 'Blend Fields' as you suggested, but still the same errormessage.

@j-v: Thanks for your test with 'my' same settings and the video.

As far as I can see, I have exactly the same settings in both input and template settings, but still the errormessage pops up.

Of course I then followed your advise and changed the video settings in my camera, made a noninteresting video, copied it to the PC, rendered it with the same settings you showed, and surprise: everything worked fine, no errors, and perfect output.

All in all: Thank you all very much for your suggestions and advise.

A really GREAT Forum (especially the people behind it :-) )

 

3POINT wrote on 4/2/2020, 1:58 PM

@Klaas-Wijchman

Of course you should record, like j-v explained, in the best format you camera can, which ist 1080p50, means FHD (1920x1080) with 50 progressive frames.

For the recordings you have already made in 1080i50, means FHD (1920x1080) with 50 interleaved frames, you have several options. Depending on where your movie should be showed/played you can/should render to 1080i50 or have to render to 1080p25.

For playing on a home (U)HDTV with an USB port, the best is to render to 1080i50.

For playing on Devices or Internet you have to render to 1080p25.

Mp4 is an often used container for playing on devices or Internet (therefor all those render templates are named Internet.....) and are progressive rendering templates.

Converting 1080i50 to 1080p25 is called deinterlacing and can be done in several ways, with less or more quality loss. Unfortunately the deinterlacing methods VMS16 offers (Blend and Interpolate) are not the best, like you discovered yourself, the output gets blurry. Also the deinterlacing method of Handbrake is very well, as you also discovered.

To give you further advice which render templates or render options you should/can use for getting the best result of your 1080i50 recordings, we need to know where you want to play your renders TV or internet?

By the way, the Dutch Vegas Forum is accepting again new members, here you can find also a lot of information about rendering, in Dutch language of course

Klaas-Wijchman wrote on 4/2/2020, 3:12 PM

Thank you 3POINT !.

Yes, the first thing I did was change the setting in the camera, and a first test confirms that it's now much better.

I didn't make 1080i50 videos yet, so that was my fault, but it also means that I don't have to re-render them

Most of the time I want to play them on my own website, in a diary I called Diarium, so that especially my children and grandchildren can look at memories of their holidays or playing in the snow or whatever.

I only had these blurry issues when my old Windows7 PC broke down (it had Vegas 10 Platinum) and I bought a new one with the NVIDIA GeForce 2070 RTX 2070 super and Windows10 and Vegas 16, and I finally came to render videos made with my 'photo' camera and not a dedicated Hi-8 video camera. I still have to digitize most of those tapes though...

Only occasionally we watch them on TV.

BTW, just noticed that the file where it all started with, and which I finally rendered with the Mainconcept coder, looks very good in IE Edge, but still (in another kind) blurry in Firefox 74.0 !!

Haven't been able to check other browsers yet.

You can check for yourself on www.wijchman.com, then choose Diarium, go to January 21, look at the year 2020 and click on the pink link. Around 0:22 and onwards it is very visible, especially when you stop the video.

Do this only on a normal or larger screen, not on a SmartPhone !

Thanks for the info about the Dutch Vegas Forum. Last week I checked and there was still no possibility to register, but if there is now, then I'll certainly do that.

Thank you !!

 

FayFen wrote on 4/2/2020, 11:31 PM

I watched the clip, All videos over the internet should be progressive.

 

3POINT wrote on 4/3/2020, 4:40 AM

I can't see no issues in IE.

Klaas-Wijchman wrote on 4/3/2020, 8:14 AM

@FayFen, yes, thanks, working on it now to get that done.

@3POINT, that's right, in IE it all looks ok, it's Firefox where there are problems, but as I just told FayFen, I'm trying to convert it from (still) interlaced to progressive. Almost done there I think.

Thanks !

3POINT wrote on 4/3/2020, 8:53 AM

Probably the easiest way to get good/better results is to render your 1080i50 (AVCHD) edited project with the Make Movie wizard in VMS to AVCHD. The result is a 1080i50 (AVCHD) .mts file.

Use this file for archiving (can be also played on your TV) and as input for Handbrake to make an Internet compatible deinterlaced mp4 file for upload to your site. Use the built-in Fast 1030p30 preset. If necessary you can also sharpen a little in Handbrake to get a even more crispier result.

Despite the double rendering of this workflow, the final result is of a better quality, than rendering and deinterlacing with VMS using the MP4 creating internet videos rendering option.

Last changed by 3POINT on 4/3/2020, 8:58 AM, changed a total of 1 times.

3POINT, Theo Houben, Vegasuser since version 5 and co-founder of the Dutch Vegasforum https://www.vegas-videoforum.nl/index.php

Recware: DJI Osmo Pocket, GoproHero7Black, PanasonicFZ300/HCX909, Sony PXW-X160.

Software:VegasPro17/VegasMovieStudio17/PowerDirector18

Hardware:i7 4770, 16GB, GTX650ti, 1920x1200 display

Playware:Samsung Qled QE65Q6FN, Philips 55PFL7108

Klaas-Wijchman wrote on 4/3/2020, 12:27 PM

OK, thank you, I'll give it a try and will come back with the results.

Thanks !!

Musicvid wrote on 4/3/2020, 1:36 PM

As far as deinterlacing MTS and blurring are concerned, you may be happier with the Decomb included with Handbrake. I am.

[Revised]

3POINT wrote on 4/3/2020, 1:38 PM

On the other hand, I'm wondering that your new PC with a brandnew NVIDIA GeForce 2070 RTX 2070 videocard suffers from errors when rendering with NVIDIA NVENC support. The same error message I encounter also sometimes when rendering NVIDIA NVENC with my old GTX650ti.

3POINT wrote on 4/3/2020, 1:40 PM

As far as deinterlacing and blurring are concerned, you may be happier with the QTGMC included with Happy Otter Scripts. I am.


 

@Musicvid, this is the VMS forum. HOS works only in Vegas Pro!

Last changed by 3POINT on 4/3/2020, 1:40 PM, changed a total of 1 times.

3POINT, Theo Houben, Vegasuser since version 5 and co-founder of the Dutch Vegasforum https://www.vegas-videoforum.nl/index.php

Recware: DJI Osmo Pocket, GoproHero7Black, PanasonicFZ300/HCX909, Sony PXW-X160.

Software:VegasPro17/VegasMovieStudio17/PowerDirector18

Hardware:i7 4770, 16GB, GTX650ti, 1920x1200 display

Playware:Samsung Qled QE65Q6FN, Philips 55PFL7108

Musicvid wrote on 4/3/2020, 1:44 PM

@Musicvid, this is the VMS forum. HOS works only in Vegas Pro!

Sorry, wrong forum! I'll leave the comparisons up, and switch my suggestion to Handbrake, which is just as good.

No question that software deinterlacers are sharper. Here's a quick edge comparison of those:

3POINT wrote on 4/3/2020, 2:21 PM

Nice picture Musicvid, good to compare the difference in quality between Vegas interpolate (blend is even worse) and HB deinterlacers.

Musicvid wrote on 4/3/2020, 7:37 PM

Don't know if you've seen this, download the link and throw it on your big screen.

https://www.vegascreativesoftware.info/us/proxy/fdf600d9634d9a0e7201/?link=https%3A//drive.google.com/file/d/1zB_oEF0KCwV0RT3kfhbv-grIiaBzrKlK/view%3Fusp%3Dsharing

Klaas-Wijchman wrote on 4/4/2020, 7:16 AM

@Musicvid: very nice comparison ! Thanks for the decomb info as well.

@3POINT, thanks again for your input and by, with the help of HandBrake I now have a progressive file on my website which looks very good in both Firefox as well as IE.

Regarding "The same error message I encounter also sometimes when rendering NVIDIA NVENC with my old GTX650ti." asks the question: which part of the whole process is at fault, is it MVS or a driver or the part of the card that wasn't changed between GTX650ti and RTX2070 or something else.... Who can or will find out ?

ThankUall !!

3POINT wrote on 4/4/2020, 9:32 AM

Sometimes this error pops up when you manipulate the built in render templates with illegal settings. After such an error it's best to restart your pc.

@Klaas-Wijchman do you get also this error with the standard 1080p25 nvenc rendertemplate?

Klaas-Wijchman wrote on 4/4/2020, 12:10 PM

Not with the standard 1080p nvenc, but only when in that standard template I change the Field order from 'none (progressive scan)' to 'Upper field first' (also error when I change to 'Lower field first'.

But I now know that this is a problem area, so for the time being I won't try it again :-)

Thanks

3POINT wrote on 4/4/2020, 1:26 PM

Upper field should be no problem. When you change a template, save it first before you use it.

But nevermind, since you only need a progressive video, you can use the 1080p25 template and compare the render with the Handbrake render.

Musicvid wrote on 4/4/2020, 7:17 PM

with the help of HandBrake I now have a progressive file on my website which looks very good in both Firefox as well as IE.

I been consistently impressed. For my viewing, Decomb, EEDI2, and QTGMC are all very serviceable.