Image Sequence Aspect Ratio

cbrillow wrote on 10/14/2020, 11:02 AM


I'm an old Vegas forum member who's not done much video work for nearly 10 years, and haven't upgraded past Vegas Pro 12, nor have I visited the Magix forums much since the acquisition. But I still use Vegas occasionally for hobby work.

I'm helping out with the restoration of some video that was sourced from a professional telecine of 16mm film. To accomplish this, I've been provided some avi clips containing 1440x1080x24 motion jpegs, with a PAR of 1, which translates to 4:3 display aspect ratio. My project setting have been set to reflect these parameters and the image looks correct in the preview window.

To do the cleanup work, I take individual frames into an image editing program, then save the altered frame file with the same name, which Vegas recognizes automagically in the timeline. (Cool!)

In order to break out the frames, I have used the Vegas 'Render Image sequence', and saving as jpegs to a new folder, which gives me an individual file for each frame.

Here's my problem: The files Vegas is writing are 1920x1080, not 1440x1080. There doesn't seem to be a way of instructing Vegas to write the resolution that I want during the render.

I'd appreciate any suggestions. I'm guessing this isn't an area that's significantly changed in later versions of Vegas, so maybe I'm doing something wrong?


john_dennis wrote on 10/14/2020, 11:06 AM


I recently stumbled on to this oddity in Vegas Pro.

It should be an easy fix.

Musicvid wrote on 10/14/2020, 11:46 AM

Yeah, it was a strange choice for the developers.

Happy Otter Scripts will give you the correct aspect and there is a free trial.

Nice to see your name here again!

cbrillow wrote on 10/14/2020, 12:01 PM

Thank you, John, for your quick response to my question. I've gone down the rabbit hole to the thread you referenced, and am trying to relate the information to my situation.

Gotta admit that I'm not fully comprehending all the branches in that thread, but several of the suggestions and explanations are within my grasp, especially the references to Vegas' incorrect assumption that 1440 x 1080 files must have a 1.3333 PAR.

And most of the posts in that thread are referring to what Vegas is sensing upon import of stills. In my case, I'm importing an avi file, which Vegas thinks is 1.3333, and stretches it in the preview window. I change the PAR to 1 (square) in Properties pane, and the preview image shrinks to the proper aspect ratio.

But I need the image sequence files for cleanup, and, no matter what I do, Vegas writes a 1920 x 1080 jpeg or tiff, which translates into a windowboxed image.


cbrillow wrote on 10/14/2020, 12:03 PM

Yeah, it was a strange choice for the developers.

Happy Otter Scripts will give you the correct aspect and there is a free trial.

Nice to see your name here again!

Thanks, Musicvid! I remember you well from the 'old days'.... 😀

john_dennis wrote on 10/14/2020, 12:10 PM

Set Project Settings to 1440x1080?

cbrillow wrote on 10/14/2020, 12:37 PM

Tried various combinations of that, including the ever-popular 'Set project properties to first media imported to timeline'. When I do that, it detects as 1440 x 1080, 1.3333 PAR, and the preview window shows a stretched image. If I set the PAR to 1.0/square in Properties -- the image in the preview window appears correct.

I say 'appears correct', because it changes a 4:3 image. But it appears letterboxed because the preview window still looks like 16:9.


STOP THE PRESSES! I just wrote out a few frames as an image sequence after unchecking the Project Properties box that says: Adjust source media to better match project or render settings. This produced an image file that correctly is identified as 1440 x 1080, rather than 1920 x 1080. Guess I'll try to import those back into Vegas and see what happens.



Musicvid wrote on 10/15/2020, 10:39 AM

Sharp as ever, I see!

Thanks for posting a possible solution for this really strange behavior.

john_dennis wrote on 10/15/2020, 1:13 PM


"Adjust source media to better match project or render settings." is an evil switch to those who know what they want. In my previous post I should have advised you to set PAR to 1.0.

cbrillow wrote on 10/15/2020, 2:30 PM

Sharp as ever, I see!

Thanks for posting a possible solution for this really strange behavior.

What a nice thing to say! Of course, it shouldn't be assumed that I was ever that sharp to begin with. But it's comforting to know that I don't come across as being any dumber, either.... 😉

I'm just a flickering CFL compared to some of the bright halogen bulbs like you, who populate this forum!

cbrillow wrote on 10/15/2020, 2:37 PM

Thanks to everyone who contributed comments or suggestions. I'm pleased to report that I stumbled across the right combination of things to do to things work out.

The first part was getting the image sequence written out correctly. Then I had to bring the individual image files back onto the timeline. Of course, Vegas once again assumed that the PAR should be 1.3333 when they were imported. Fortunately, I was able to select all 586 files in the media bin and change it to 1.0 or square pixels, all with a single click.

Seemed to work out well! Here's a sample of what I was working on, if anyone's interested.

Musicvid wrote on 10/15/2020, 3:38 PM

And if Vegas had recognized that their is 4:3 1440x1080p media in our constellation, all of that would have been unnecessary. Instead, they chose a soccermom "solution" in search of a problem. This trend bothers me, suggest saving these features for Movie Studio.