Preview & render colours different to original file.

WelshJester wrote on 2/5/2019, 11:59 AM

I have a VOB file that i made from a DVD of mine, after i import to Vegas i notice that the colour looks kinda washed out in the preview window, same with a game video i have. In VLC the original VOB has better blacks etc.

What I've tried is changing the project to 32bit, view transform off. This seems to give the same colour as the original VOB file even when rendered out. If i keep 8bit settings and render using x264 and xvid they both render looking washed out, there are a few built in options that render 8bit looking normal like Sony AVC/MVC. The other thing I've noticed people say is to use the filter: studio RGB to computer RGB. I did that with the project set to 8bit and it looks normal even rendered to x264. The thing is though I've also seen people say to disable that filter before rendering.

What's correct? If the original has good blacks in VLC then surely rendering it out as an .avi or .mp4 with the same looking colours is best, and not the default way Vegas seems to handle it looking washed out in most export options?

Comments

Musicvid wrote on 2/5/2019, 12:09 PM

The RGB preview in Vegas is not a player. Your .vob will render right if you do nothing.

FAQ #24, but read them all.

https://www.vegascreativesoftware.info/us/forum/vegas-pro-faqs-and-troubleshooting-guides--104787/

WelshJester wrote on 2/5/2019, 2:10 PM

The problem is that it looks washed out in the Vegas preview as well as a file rendered out of Vegas if i render to xvid or x264, i don't need to alter anything for that to happen, just import the video and then export.

I can only get colours like the original VOB if i do what i mentioned in my first post, only then it looks like the original VOB in VLC. If i do nothing as you suggest, it just looks a bit too bright overall and not good blacks like it shows in VLC with the original file.

Musicvid wrote on 2/5/2019, 2:49 PM

Did you get the .vob from a DVD that you and your friend made yourselves?

The information in the link I gave is 100% bulletproof. If it isn't working as Nick described, there is something you haven't shared with us yet. Your source DVD, the .vob and the rendered file should all look the same in VLC. The Vegas preview should not look the same, unless you are to add a temporary Computer RGB filter to the preview.

Needed for any further assistance -- complete MediaInfo and Vegas properties, Also an original uploaded sample (not on YouTube.)

https://www.vegascreativesoftware.info/us/forum/important-information-required-to-help-you--110457/

In order to do this right, you must maintain 8 bit pipeline levels door to door. 32 bit pixel format is not for leveling the preview or output.

Start from scratch, and maintain the defaults, then we can talk.

 

 

 

WelshJester wrote on 2/6/2019, 1:09 AM

Hmm, well there is somebody else that had pretty much the same issue, here's a link https://forums.adobe.com/thread/2371459 and quote below

"Sony VEGAS

In Sony Vegas, whatever happens, I render in the format - Sony AVC/MVC.

If I need another format, then the color wash out appears and I add the LEVEL plug-in with the preset: Studio RGB in computer RGB."

To show you what I'm seeing, here are 2 renders i made, one of a game file and the .vob file from a DVD film. The left shows the originals, the right shows after rendering in .avi with .x264. I'm pretty sure settings are all default in Vegas.

https://ibb.co/myFtLMf

https://ibb.co/kSWYmZH

Musicvid wrote on 2/6/2019, 3:10 AM

With all respect, AVI is a different Color Space (RGB 0-255). Your images are correct, and yet your conclusion is upside-down. Quite normal, really.

Since AVI is rarely used for either acquisition or delivery these days, it "can" be considered a red herring in this decade.

Before you can undertake any of this, you should know your source levels, regardless of how they are flagged. In fact, it's the most important thing in commercial post-production. Note once more that the video pipeline (pixel format) must be set to 8-bit, and dynamic contrast on your graphics must be turned off.

https://www.vegascreativesoftware.info/us/forum/plea-to-new-users-please-do-not-set-32-bit-pixel-format--114750/

I calculate that a million monkeys will get it wrong 97% of the time.

https://www.vegascreativesoftware.info/us/forum/pc-to-tv-levels-a-comedy-of-errors--107325/

Nick's FAQ is one with which I agree 100%, having begun this research in 2010. Yes, we are pretty sure of our advice. Here is the full 2011 archive of our inquiry, upside-down thinking and all, should you want to try reinventing the wheel. 🙃🙃

http://jazzythedog.com/testing/DNxHD/HD-Guide.aspx

We eagerly await the arrival of your complete source properties and pristine source sample, which you can smart-render directly from your .vob. If it's from a homespun DVD (you didn't answer) the.vob source levels "may" be noncompliant, as well.

WelshJester wrote on 2/6/2019, 12:34 PM

Hi Musicvid,

I'm still quite confused. Are you saying when it looks washed out to me that it's supposed to look that way? How are you seeing those images that i linked to? Which looks better, left or right? If the right image looks better then i don't understand it since the left ones are the original files. The right ones rendered from Vegas look a bit washed out to me and the blacks aren't completely black.. but you said the images look correct, they can't both be correct though if one of them differs from the original? 😃 Unless you mean they look correct in how they were rendered from Vegas?

I just want my videos to look as they should do for viewing on YouTube etc.. You don't recommend rendering in .avi? I thought x264 was quite well used for compression. So if i want it rendered from Vegas to look like the original file i have to use either the levels filter, 32 bit, or render to .mp4 which seems to basically be the only format that will export the video looking the same as the original, without altering anything else 😕. Something seems off to me about that, unless that's just the way it is.

The .vob file screenshot of VLC is of a retail DVD disc i ripped it from quite a while ago. The game in the other screenshot was recorded using OBS.

I've now set dynamic range back to 16-235 in the NV control panel. To be honest I'm not seeing any visual difference between the 2 settings there in VLC, it does appear to change in Windows Media Player, as well as Films & TV though. VLC is showing deep blacks no matter what i set the dynamic range to.. Hmm, could the problem be VLC? But then, that would mean the other players are showing the right colours & brightness with the 16-235 dynamic range? They look washed out though much like the Vegas preview, even the original .vob. I can't make sense of this.

This particular .vob file from the DVD is only 22 megabytes since it's not very long, do you just want me to upload that and post the link? Or do you need me to get a mediainfo screenshot as well?

Musicvid wrote on 2/6/2019, 1:28 PM

"Washed out" isn't an editing term; in fact you and the poster you linked used it to mean exactly the opposite things -- does it mean flat or contrasty to you?

Yes, in order for your B.T. 709 (YUV not RGB) render to look and play like the original.

Your native Vegas preview must look like this

This is not a design flaw, it is a feature professionals use to evaluate full source levels instead of previewing a clipped output. You are entirely welcome to love it or hate it, but working with it becomes second nature after a while.

You could temporarily add a Computer RGB filter to preview playback levels, the pitfall being most people would forget to remove it before rendering and then go off on their peers for having suggested such a ridiculous thing. In newer versions, there is a preference to normalize the preview, but I'm kind of old school and haven't explored it yet.

First, determine your source levels. If the source looks like the first histogram above after editing, add the Studio RGB filter before rendering, which will make the output correct and the preview look flat, as in the second image.

If the native Vegas preview image already looks like the second histogram, you need do nothing; player levels should be correct once rendered.

( However, "if" you were rendering to RGB AVI, you might actually need a Computer RGB filter to correct the flat output to 0-255.)

Now, let's turn it upside-down one more time. My preferred method is to edit until the preview looks exactly the way I want to deliver and view my movie, then slap a Studio RGB filter on the output buss just prior to rendering, knowing that VLC will do it's job correctly. This method also strictly confirms the output, making it legal for the most stringent interpretation of ATSC Broadcast rules, such as at PBS.

I truly appreciate your willingness to wrap your brain around this; it's been the downfall of better editors than me, I can tell that you are getting it, but please don't lose any sleep over it, because most people are really quite nongivashitical about the whole thing.

This particular .vob file from the DVD is only 22 megabytes since it's not very long, do you just want me to upload that and post the link? Or do you need me to get a mediainfo screenshot as well?

Yes, 22MB is fine. I didn't want to deal with a 2GB download. Put your representative pristine source on a trusted fileshare, along with posting Medainfo here. If you can do that, I can tell you exactly how to level this particular source, and you will be well on your way to making your next project the best it can be.

If you want x264, as I also prefer, use Happy Otter or Handbrake to make an MP4;

x264vfw AVI is the worst possible option for you. It's a useless kludge, comparatively speaking.

I've now set dynamic range back to 16-235 in the NV control panel

No, I thought it should be set at PC levels 0-255. There really shouldn't be such an option, because it raises the chance of user mistakes, exponentially.

And keep the questions coming -- they are good ones!

Musicvid wrote on 2/6/2019, 2:11 PM

To answer all of your questions about your internal graphics and player settings, we use a grayscale like this to compare and match levels from door-to-door. Feel free to use it, because I can't be at your computer.

JN_ wrote on 2/6/2019, 5:11 PM

“My preferred method is to edit until the preview looks exactly the way I want to deliver and view my movie, then slap a Studio RGB filter on the output buss just prior to rendering, knowing that VLC will do it's job correctly. This method also strictly confirms the output, making it legal for the most stringent ATSC Broadcast rules, such as at PBS.”

I used to do it the other way, with a fair chance of forgetting to remove the Computer RGB, of course I could still forget to apply the Studio RGB. All joking aside, going forward, i’m going to use this, visually more attractive option, thanks Musicvid.

Last changed by JN_ on 2/6/2019, 5:13 PM, changed a total of 1 times.

 

Desktop and Laptop basic specs ...

Both run Win 10 ...

Running latest ver. of Vegas Pro with latest updates.

VP13 B453 also.

Vegaseur and Pluraleyes installed on both ...

Quicktime 7.79.80.95

PC ...

i9 9900K, Intel Graphics 630. Nov 2018.

Mem. 32gb DDR4 Nov. '18.

Graphics card .. Nvidia Rtx 2080 Ti

Nvidia Graphics driver 25.21.14.1967

Intel Graphics driver 26.20.100.6709

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..16GB DDR4 

Graphics card .. Nvidia GTX 1070, driver is 4.1967

Musicvid wrote on 2/6/2019, 6:19 PM

Thank you, JN_

I don't necessarily warm up when I'm told, "My way is the best way for you," and yet I see myself slipping in that same direction sometimes. Glad you can use it.

The way that works and is familiar to you, is of course the best one.

The one gotcha of my method is to avoid stacking corrections that cancel each other out, which if ridiculously serious enough, can reduce bit depth, not a desirable outcome, except for possible artistic purposes.

https://www.vegascreativesoftware.info/us/forum/posteruzation-in-vegas--111932/

GJeffrey wrote on 2/6/2019, 8:05 PM

I suggest that you use this vegas extension.

You will be able to see in the viewer what you will see on your player.

Musicvid wrote on 2/6/2019, 10:34 PM

I understand the extensions are very good.

I am pretty stuck in my old school ways.

matthias-krutz wrote on 2/7/2019, 2:08 AM

I have been using this SeMW Extensions for a long time and am very satisfied with it. It fixes two basic problems in Vegas that lead to misunderstandings.
The Preview Device Preferences "Adjust levels from studio RGB to computer RGB" only change the External Preview, not the internal preview window.
And the Vector Scopes Settings "Studio RGB (16 to 235)" changes the video scope and waveform, but not the histogram.

With the SeMW extension it is also possible to edit visually correctly without an external monitor and the analysis is more logical. I could do that with a level FX on video output, but I'd always have to remember to disable the FX before rendering. I think this simple functionality should be an integral part of Vegas.

WelshJester wrote on 2/8/2019, 5:32 AM

Ok, so I've made sure to set and keep my dynamic range to full 0-255 in the Nvidia settings, i also have no clue why it's not set to this by default if it should be.

Right, my main issue is that the video rendered from Vegas is still looking too bright/too much contrast. As soon as i render to anything but .mp4, that happens. Exactly like the guy said in the link i posted. .wmv is too bright, .avi with x264 is too bright. I only get a good looking image like the original if i export to .mp4. I even tried exporting from the free version of lightworks in .avi h264 and it looks like the original.

It's as if Vegas does not like anything but the .mp4 export options. Otherwise it renders out looking like the preview, too bright. EDIT: let me rephrase that, pal sd yuv .avi actually does render right. But even uncompressed .avi has too much contrast.

Here's a link to the .vob file https://ufile.io/p3rus

Here's the mediainfo of the .vob file https://ibb.co/ZgdGpYs

Musicvid wrote on 2/8/2019, 9:13 AM

After searching the internet, your Nvidia default may be 16-235. Sorry to have misled you, I don't own one, and the nomenclature may have changed since I had a desktop at my old job. Setting it back may help your problem with avi renders. Also, double check your Project to be sure your pixel format is set at 8-bit.

Your .vob is quite happy living in YUV color space, as was intended. Since your Levels already fit nicely between 16-235, no additional correction is necessary nor desirable when rendering to mp4, the whole range of mpeg-2 codecs, and just about everything else except AVI and WMV, the two main RGB codecs on your system.

It is my strongest recommendation that you avoid those two container formats entirely unless you have a special need you have not told us about. AVI and WMV are not streaming formats, and their quality is quite bad compared to file size,

You obviously got some outdated advice. Like from a decade ago.

When you actually have source that fills the 0-255 space,either correctly or incorrectly (in the case of cellphone video), you must apply the "Computer to Studio RGB Levels Filter" to the output, except if you will be rendering to WMV or AVI, the two main RGB codecs on your system.

Remember, with all the controls available to you, there are 31 ways to get it wrong, and one way to get it right. You may have unknown, or redundant settings lurking about, so you may have to play a bit.

Confused yet? I would worry if you weren't.. The cure for this is to read this article, then laugh out loud. Repeat as necessary.

https://www.vegascreativesoftware.info/us/forum/pc-to-tv-levels-a-comedy-of-errors--107325/

I may be of limited usefulness going forward, so I'll defer to the advice of others to help with more up-to-date advice about your hardware tweaks, Best of luck.

 

Kinvermark wrote on 2/8/2019, 9:36 AM

Ah yes, the never ending levels issue. Vegas handles this fine as do all the other NLE's I've ever used, but the forums (all of them) have lots of posts from users complaining that their export is too contrasty or too washed out - That just means you got your levels messed up.

I think this gets way to complicated and can be simplified:

1) Set your waveform scope to video levels (16-235)

2) Set your external preview monitor as @matthias-krutz has suggested

The Preview Device Preferences "Adjust levels from studio RGB to computer RGB" only change the External Preview, not the internal preview window.

3) Colour correct/grade your footage, stills, etc. so they look good and have proper waveform levels (0-100). Noting of course that only true black objects in the image should be at zero and only true white at 100. Don't add levels changes afterwards to try to compensate for something - that's where you start chasing your tail.

 

Musicvid wrote on 2/8/2019, 10:10 AM

And truly the best way to learn any of this is to make LOTS of mistakes. At least I did.

OldSmoke wrote on 2/8/2019, 12:18 PM

I thought stills should be treated differently from video as they usually have a different (RGB) color space?

Proud owner of Sony Vegas Pro 7, 8, 9, 10, 11, 12 & 13 and now Magix VP15.

System Spec.:
Motherboard: Intel DX79SR
Ram: G.Skill 8x4GB DDR3 2133 (running at 1600 and lower latency)
CPU: 3930K @ 4.3GHz (custom water cooling system)
GPU: 1x ASUS Fury-X
Hard drives: 4x 2GB WD Red in RAID 5 (with Hot Spare), 2x Crucial 256GB SSD in RAID 0 (mulitcam project drive), 1x Samsung 850 Pro 256GB SSD (System), 1x Crucial 64GB SSD (temp files and swap file), 1x 3.5" Hotswap Bay, 1x LG BluRay Burner
PSU: Corsair 1200W
Monitor: 2x Dell Ultrasharp U2713HM, 1x Sony HDTV 32" preview monitor

Musicvid wrote on 2/8/2019, 5:43 PM

I'm trying my best to dissuade the OP from rendering to any RGB format.

WelshJester wrote on 2/9/2019, 6:56 AM

Oh i am still confused, maybe more so than before i posted here.

So i should set and keep the dynamic range to limited 16-235? I've done this, but now only VLC is showing what looks like the more accurate image for the .vob. My other media players play it looking too bright now.

Just to make sure i have now also double checked on the uncompressed .avi, it looks accurate in VLC and not in my other media players. Windows Media Player plays it looking like it has placed a bright film over the whole video. Same with my game footage.

The x264 .avi render looks too bright in any player, Vegas dislikes it for some reason. I'm not sure if it's the codec or if it's Vegas at fault there.

What can i make of this? Only VLC is showing the videos correctly and most other video players are junk? Even YouTube seems to show the right colours for these files. Also Vegas doesn't seem to like .wmv or x264 as it renders them out too bright in any player. It doesn't matter about  .wmv but I'd still like to know why this happens with x264.

So i guess it's best to stick with .mp4 and use VLC if i want to view them properly.

WelshJester wrote on 2/9/2019, 7:05 AM

To make things a bit more confusing, i noticed that taking a snapshot through Vegas also shows a brighter image when viewed in a photo editing program. Though imported back to Vegas and then exported and viewed through VLC it looks like it should with the rest of the video.

Quite confusing.

Kinvermark wrote on 2/9/2019, 7:41 AM

I thought stills should be treated differently from video as they usually have a different (RGB) color space?

Yes and No. :)

Here's the thing. While the photo levels will indeed be 0-255, you don't know whether any particular photo is over exposed, under exposed, high key, low key, etc. So, if you setup monitor and scopes for 16-235 AND correct/ grade to suit, then all will be good. Applying a computer-to-studio levels fx to all your stills could be part of this correction, but doesn't have to be.

 

Musicvid wrote on 2/9/2019, 9:04 AM

This is so hard not being at your computer. Can you dump and reload your graphics drivers and utilities so they are at the default, whatever that may be?

Then everything else you do, make it look about the same range in the scopes and preview. Your .vob is already there: flat and TV Shirley range. Your well-exposed stills will be in PC (RGB) range, so put them on their own track and apply Computer to Studio RGB at the track level. Now they should look like your vob -- flat in the native Vegas preview, correct in a player. Sounding familiar?

Now, please do not render to any AVI or WMV. Please do render to an MP4 AVC codec. Now play and compare only in VLC, not the Vegas timeline. This is sooooo important. If you have AVI or WMV in your project, they must be treated exactly the same as your stills. On their own track, with the Computer to Studio filter.

There are several ways to set your preview to be not flat, but correct like the player, as long as you don't affect the render levels, which will look right in VLC.

If you make a simple project that includes representative media from each source, save with the trimmed media (that's a checkbox), and zip the new folder, how big will it be?

Really, you need to visually study the relationship between the scopes and the preview, and recognize the RGB stuff (AVI, WMV, Stills) when they show up. If all of your timeline assets are RGB, then simply apply the Computer to Studio RGB filter to the output.

Kinvermark and I approach this a little differently, but we both have trained eyes that are locked on to results (flat native preview, correct player levels), not a blind set of directions from the hopefuls like us.

Just study the Shirleys.

https://www.vegascreativesoftware.info/us/forum/pc-to-tv-levels-a-comedy-of-errors--107325/

-- Native Vegas preview -- TV Shirley

-- Corrected Vegas preview -- PC Shirley

-- VLC (player) -- PC Shirley

-- Clipped Shirley -- Something's wrong, fix it first.

-- Overcorrected Shirley -- Overthinker alert!

Remember, your properly calibrated monitor, video scopes and your own eyes are all youve got, Make them work together and the results will be less wrong.

I can tell from your last three posts that there is a hardware setting that is still too hot. Setting every conceivable module back to their defaults should clean it up.

In my signature is a grayscale you are welcome to use. It gives you separate PC and TV ramps. To use them correctly, you need to tune in on the endpoints and be very aware of clipping in the blacks and whites when it occurs. If you throw it in an image viewer like Irfanview, not Vegas, and the levels are too hot, your hardware settings are screwed up. Fix that first.

Sometimes having too many cooks in the kitchen is a good thing -- it forces you to trust your own instincts, in self-defense if nothing else. Sounds like Kinvermark is making the best connection with you, but realize that no matter how you approach it, we are guiding you to exactly the same place -- no disagreement whatsoever.

Now put some stuff together and show us your mistakes, because verbal descriptions can be deceiving, as we've discovered. You are almost there.

Native Vegas preview

Correct Player levels

Hardware screwup

Preview Flat, Play Correct. Sleep on it.

 

WelshJester wrote on 2/10/2019, 2:32 PM

Just to be clear, if i take a snapshot at any point in that .vob file in Vegas, and then view the snapshot in the Windows photo viewer or photo editor like paint.net, it looks like the preview in Vegas - still quite bright as i can tell.

Then if i put that snapshot on the timeline in Vegas along with that .vob file, it still matches the same brightness. So it seems to be consistent even if i export an .mp4, in Media Player the whole video still looks too bright, but it still looks right in VLC.

It doesn't help with the players not being consistent in brightness at all. It's somewhat confusing that snapshots have the same brightness as the Vegas preview as well, that is if VLC is showing the output video correctly, which it seems to be.