Skipping every time moving onto a new clip

343idiots wrote on 10/13/2020, 1:47 AM

I reinstalled sony vegas 14.0
I have a GTX 1070. Good CPU to match it.

Now, when I am playing the simplest clip, and it moves onto the next video it will almost always skip. It's extremely noticeable in short clips <1 second long. You'll hear the audio of the opening of each clip, but the preview window'll show no video for 80% of it on short ones. So when you have many sequences of short clips, basically.. it's a mess.

I am running vegas on C:\ because it's installed there and the clips are stored on an NVME elsewhere. I have tried matching project settings and other regular solutions. I have not changed any unusual settings either.

 

In a post below, I realize that this may have something to do with the file encoding or file extension?

Comments

andyrpsmith wrote on 10/13/2020, 6:12 AM

Although you have a 1070 check with task manager (GPU) to see if V14 is using it when playing back the timeline. V14, V15 & V16 do not with my 1080Ti ie check for activity in the video decode box

Musicvid wrote on 10/13/2020, 7:28 AM

Import your media to your desktop; don't edit over a remote drive.

343idiots wrote on 10/13/2020, 6:41 PM

Wait it's not a remote drive. It's still connected in my computer, or did I misunderstand you?

Well the issue I'm concerned about is a lack of space on my C:\ but I can try that. The thing is that I used to do just this and it was fine in my previous setup?

RogerS wrote on 10/13/2020, 8:06 PM

It sounds like both your c: drive and drive where the media lives are both high speed drives? If so, that doesn't sound like the cause.

Does reducing preview quality help at all (preview/full)?

Musicvid wrote on 10/13/2020, 8:35 PM

It was your "elsewhere" that led me to believe it was remote.

343idiots wrote on 10/13/2020, 11:15 PM

It sounds like both your c: drive and drive where the media lives are both high speed drives? If so, that doesn't sound like the cause.

Does reducing preview quality help at all (preview/full)?

Yep, they are NVME's

Well, higher preview quality can make it worse, but not get rid of the problem. I've tried quarter, or basically van gough resolution and it still does not make for a smooth preview.

RogerS wrote on 10/13/2020, 11:43 PM

What kind of media are these? Do you have that issue with all types of videos you deal with? If the problem is just with some, consider transcoding to an easier to edit intermediate format.

I'm limited in how much I can help as I never used VP 14. I had 12 and have 15-18 installed here.

343idiots wrote on 10/15/2020, 4:08 PM

Oh. I just realized it may have to do with the files I'm using and however they may be encoded. I don't fully understand it but here's what I know. Before, everything I used was clipped with NVIDIA shadowplay. They are MP4 files but I don't know what encoding.https://ibb.co/YDJ7HrY
The recent ones are.. also MP4? Weird, but here's the info. https://ibb.co/Sy2QKRJ

I could've sworn they were mkv. Oh they actually start as mkv from OBS studio, and they are encoded in "NVIDIA NVENC H.264 (new)". And then they are cut down to size with Avidemux, which while saving the new files as Mp4's, I have set to alter very little of the original file. Maybe that doesn't change some of the way it's encoded?

Hopefully these are some more helpful clues to everyone.

Musicvid wrote on 10/15/2020, 7:50 PM

everything I used was clipped with NVIDIA shadowplay

Shadowplay footage is fraught with problems in Vegas. Always has been; search.

Here are the recommended OBS settings for Vegas. If you use my "best practice" settings at the end, be sure to install UT codecs on your system. Don't use AviDemux, it does not close GOPs at the cut points and cause jumps!. Leave the files whole, or trim and mux them in VideoRedo. For best quality, use a software encoder, not NVENC. Best of luck.

https://www.vegascreativesoftware.info/us/forum/faq-what-obs-studio-settings-work-well-with-vegas-pro--109925/#ca762521

lenard-p wrote on 10/15/2020, 9:41 PM

 

I could've sworn they were mkv. Oh they actually start as mkv from OBS studio, and they are encoded in "NVIDIA NVENC H.264 (new)". And then they are cut down to size with Avidemux, which while saving the new files as Mp4's, I have set to alter very little of the original file. Maybe that doesn't change some of the way it's encoded?

Hopefully these are some more helpful clues to everyone.

You want to keep the obs save as .mkv because it resists corruption very well in event of a crash of some sort, but there is an option to auto remux to mp4 when you end recording.You can also use obs to manually remux mkv files at a later date. See if removing avimux out of equatation fixes or does nothing

I have found using obs mkv files are more prone to vegas malfunctions if you import directly so certainly should be remuxed to mp4.... actually in vp14 I don't think you can import mkv, so that's not relevant

lenard-p wrote on 10/16/2020, 8:45 AM

Incidently I was able to replicate your problem using a 1080P60 AVC. The reduction in frame rate corresponds to overloading of Nvidia GPU decoder each time it reads beginning of a new clip. CPU and GPU processing are very low. It seems like a Vegas fault. If I understand it correctly, Vegas is trying to dump a huge amount of new decoded frames into vegas so that it can start timeline rendering as soon as possible into a video cache to aid with timeline playback, but it's not working here, at least now around edit points

 

 

343idiots wrote on 10/17/2020, 1:18 AM

Thanks all. I will try those solutions out.

But um, what is the UT codec? I'm not understanding why I will need it, if it does not seem to be required by OBS or any other program. Or how I will use it.

lenard-p wrote on 10/17/2020, 1:52 AM

It is the lossless recording mode in OBS, it uses a ridiculous amount of hard drive. you go to settings , recording output, make sure you're in simple mode, rather than advanced, and click on lossless quality, the following warning shows up. I think you need to download a codec to playback in vegas

It is much less compressed than AVC, so you wouldn't see lags in vegas as it's easier to decode, but you could see lags due to it's enormously high bitratre

RogerS wrote on 10/17/2020, 8:08 AM

@343idiots You need it because you are having issues editing the other formats you are using in OBS. It outputs a UT file, you then edit said file in Vegas and you output a smaller compressed file without glitches, errors and crashes. MusicVID gave good advice above that's worth testing out.

Musicvid wrote on 10/17/2020, 10:29 AM

Lenard, you're showing a message for beginners in Simple Mode regarding NVENC, which I didn't mention, and is never lossless! And you're using it as a reason to talk down a completely different recommendation, one you obviously know little about.

Kindly confine your comments to the facts at hand, and practice doing so going forward. This is growing weary.

These are the facts:

  • UT is a state of the art lossless codec that works in OBS in Advanced mode. You must also install it as a system codec in order to be used in Vegas. https://www.videohelp.com/software/Ut-Video-Codec-Suite
  • Because it is lossless, UT is easiest on a viable system, and produces the highest possible quality output from OBS.
  • The files are large because it is lossless intraframe, not lossy interframe, which slows down your capture! Of course it is not used for delivery! It is an intermediate to Vegas to make a normal AVC delivery file, or whatever you wish.
  • If the OP wants a small, lossy, medium quality capture using x264, that is in the very first post of the link I provided. Read and follow that if my advice bothers you.
  • Anyone using a hardware codec for screen capture has lower expectations and a different agenda than I am addressing. Sorry if that wasn't obviously clear to you.
  • Lossless quality and best capture frame rate, which many of us demand from screen captures, comes at the expensive of larger files. Small, compressed files, which you seem to expect, come at the expense of lower quality, artifacts, and slower capture rates.

Please make a note of it.

lenard-p wrote on 10/17/2020, 11:46 AM

Lenard, you're showing a message for beginners in Simple Mode regarding NVENC, which I didn't mention, and is never lossless! And you're using it as a reason to talk down a completely different recommendation, one you obviously know little about.

Kindly confine your comments to the facts at hand, and practice doing so going forward. This is growing weary.

These are the facts:

The lossless quality option that I show in Simple mode (rather than advanced) is the UT codec, there is no need to install anything, it comes with OBS. Try it and see. The NVENC you see at top is what I use for streaming. it is not the recording option. You are likely confused due to it being the simple mode menu which most tech people never look at.

Musicvid wrote on 10/17/2020, 2:50 PM

The lossless quality option that I show in Simple mode (rather than advanced) is the UT codec,

I'll give you that. I hadn't explored the option in simple mode and I'm glad to know it's there. Thank you.

 there is no need to install anything, it comes with OBS. Try it and see. 

That is 100% incorrect, if you plan to open the UT files in Vegas, as I stated twice in the context of this discussion. OBS installs UT as a Local, not a System VFW Codec that would be seen and utilized by Vegas. Try this: Uninstall the UT system codec from the Control Panel, record to it in OBS (which still works), and then attempt to open it it in Vegas. You'll see.

it uses a ridiculous amount of hard drive.

Why don't you go back to my first linked post, copy and paste the very last statements here (Pros and Cons), so we'll at least know you've read it. It has always been there for others, who do have brains, to read and make their own informed choices.

This is the last time I will address your cross-statements directly. It goes against my personal posting ethic, although I stray from time to time. I must say I have had to bite my tongue while reading your posts many, many times leading up to this direct reply. Going forward, you can be a bigger help to the community by confining your comments to the question at hand, posting information in place of adjectives, rather than editorializing on others' responses. It's annoying, and might be mistaken for attention-seeking.