Unable to read timecode from Canon 5D Mark iv

patrick-n wrote on 9/27/2018, 10:25 PM

I know this has to be out there but I can't find an answer. I have a Canon 5D Mark IV that creates .MOV files. When I import them into Vegas Pro 16 project media panel and display there details, the start time of the timecode is always 00.00.00.24 for .MOV files and 28 for MP4 files. I have the camera set to "Free run" the timecode . I also have a Sony NX30 Camcorder that creates .MTS files and it is also set to "Free run". Vegas Pro 16 displays the start and end time of those files perfectly.

Not being able to find an answer, I plugged those same files into Adobe Premiere CC and had just the opposite problem! It read and displayed the .MOV files start and stop times perfectly, but the .mts files start times from the Sony Camcorder always started at 00.00.00.00 . However, I did find some workaround after a long search which stated that to get Premier Pro to display .mts files timecode correctly, the entire folder that the video files were created in needed to be copied over to your computer. I thought that was crazy until I tried it and it worked! So I solved it for Premiere but I do 99% of my work in Vegas and am desperate for an answer. Can someone please help?

Comments

NickHope wrote on 9/27/2018, 10:37 PM

Can you share one or more short files that illustrate this problem (e.g. on Dropbox, Google Drive, OneDrive, mega.nz, wetransfer.com or mediafire.com)? For others to test, and to link the developers to.

Musicvid wrote on 9/28/2018, 3:41 AM

Might try trimming a couple of frames from the very beginning of the file, save as mp4. Videoredo is best for this.

patrick-n wrote on 9/28/2018, 4:39 AM

Okay, here is a link to two short files I have on my cameras. One from the Canon and one from the Sony. They do have similar timecodes.

https://www.dropbox.com/sh/i6g7xajt0o40rw2/AACvJFCJ7Azt6C5SrbDxQUNAa?dl=0

Ok, Musicvid, I tried that but don't have Videoredo, so I don't think it worked since I think my software rendered the file I took the frames off and therefore ruined the original timecode on the file.

To both of you, I did add screenshots of Vegas and Premiere of my problem. File 1594.mov and 1594_FC.mp4 are just in there to show you what happened to the file when I tried to take some frames out.
Files 00004.mts and 1596.Mov are two files that are on there to show you my problem. 00004.mts displays correctly in Vegas, but 1596.Mov does not. 1596.Mov displays correctly in Premiere but 00004.mts does not. However, after that weird workaround you will see that when I imported the 00004.mts file in the second time it does display correctly. They say that some timecode info is stored in the files folder and that is why you have to copy the whole files folder to your computer when taking it from your camera.

Musicvid could you please see if you could trim a few frames from the .mov file and let me know if that works from the file I shared with you in the above link? That way I don't have to buy the software if I don't need to. I would be so grateful!

Anyway, Thank you two so much. I will wait for a reply.

patrick-n wrote on 9/30/2018, 9:14 AM

Did anyone find a solution to my problem? I can't believe no one has had this problem. I'm new to timecodes, so maybe it is just something simple I'm missing? I have Pluraleyes and have used that very successfully, but just think timecodes would be just so much simpler and also I don't have to be able to hear the same audio in the event to sync up my multicams. Can someone please help?

Former user wrote on 9/30/2018, 9:22 AM

Vegas Version 12 reads the timecode of both files with no problem. Ihave QT installed so that could be the difference. Maybe whatever 16 uses for MOV files does not see TC.

 

Marco. wrote on 9/30/2018, 11:14 AM

Re-Wrapping to MP4 solves the TC problem here for VP16. I used the Vegasaur Smart Trim tool for re-wrapping (which uses ffmpeg internally).

Musicvid wrote on 9/30/2018, 11:49 AM

Videoredo has a free trial, but my suggestion is a Longshot. Usually only happens with slaved tape.

patrick-n wrote on 9/30/2018, 2:11 PM

Ok Thanks everyone. I'm going to try these things and I will let you know as soon as I find out.

Former user wrote on 9/30/2018, 3:54 PM

John Dennis, do you have QT installed?

Marco. wrote on 9/30/2018, 4:12 PM

The Quicktime timecode works in Vegas Pro versions before 15 where not so4compound reader is used. But it looks like re-wrapping to MP4 helped for version 15 and 16.

patrick-n wrote on 9/30/2018, 4:13 PM

Thank you Marco! That worked great! I don't know why I have to do that but I guess it isnt to much of a work around. To John_dennis and david-tu; Would installing QT (Does that stand for Quicktime?) also be an answer for this to work without having to Re-wrap like Marco's solution did? Let me know. Thanks again Marco.

Marco. wrote on 9/30/2018, 4:23 PM

You maybe would not even need to install Quicktime but just disable "Enable So4 Compound Reader for AVC/M2TS" in internal preferences. But this would break the proper timecode reading for other types of video like the re-wrapped MP4.

patrick-n wrote on 9/30/2018, 7:26 PM

Ok, Thank you, thank you, thank you! I'm so happy I can now get my 5d mark iv to sync up and work with my 2 sony camcorders! I did want you all to know though after playing around I found I can keep my .MOV extension and not have to re-wrap to MP4. Don't get me wrong, I did have to use Vegasaur Smart Trim tool for re-wrapping, but I just told it to re-wrap to .MOV and that also worked like a charm! Also the 5D does write files in MP4, but that had the same timecode read problem as the .MOV files. But that too could be rewrapped from MP4 to MP4 or MP4 to MOV and it would correct the problem either way. I don't own the Vegasaur add on yet but I will get it for this very handy purpose, and I'm sure there are other things I will like that it can do. Do you have any favorite things you like about it that it can do? Again Thank you all for your time and Marco for the solution I'm going to use.

Marco. wrote on 10/1/2018, 3:01 AM

Vegasaur is my favorite workflow tool so I like to also use it for some FFmpeg based processes and you'd probably benefit in several ways from using this tool.

But if it is only for remuxing the MP4 and MOV files you can also use FFmpeg itself and just a small script. If you have FFmpeg installed all you need to do is save this script as "*.bat", then drag and drop the files you'd need to remux onto the script.

@echo off
:next
if "%~1"=="" goto done
set output=%~dpn1_new%~x1
ffmpeg.exe -i "%~1" -c:a copy -c:v copy "%output%"
shift
goto next
:done
exit

 

patrick-n wrote on 10/1/2018, 3:38 PM

Whoa!!! That is awesome! Now that IS the solution! I wasn't sure if I was going to be able to handle installing the FFmpeg correctly, but found a little help by some searching and named my file remuxvideofiles.bat. Then I just put that file in the directory that I have my video files that need to be remuxed and did what you said and dropped them onto the .bat file. Did its thing, and I loaded the *_new.MP4 or *_new.MOV files into Vegas Pro 16 and they read perfectly! Very quick and easy! Thank you again Marco, and this time for saving me 100 bucks.