User interface totally change - completely lost.

GTDavis wrote on 7/4/2020, 7:26 PM

I have been using Vegas Platinum for many years, and thought I had gotten pretty good at it. Recently I "upgraded" to Version 17 and ....holy cow, NOTHING looks the same. I cannot even get started. No track window, no transport control....I can't find a single control I recognize. I suspect there might be some new default mode. Is there some way to go back to the old interface?

Comments

Musicvid wrote on 7/4/2020, 8:04 PM

You didn't say "which" version you had previously but yes, the interface has changed a lot since the brand change.

As with brand new users, the Interactive Tutorials and What's This button already in your program are the place to start learning your way around. And after you've got that, there are many ways to extend your knowledge.

https://www.vegascreativesoftware.info/us/forum/movie-studio-beginner-s-tutorial--103312/

https://www.vegascreativesoftware.info/us/forum/new-users-consult-the-tutorials-first-please--118014/

Steve Grisetti wrote on 7/4/2020, 8:27 PM

Or even my free 8-part Basic Training tutorial series.

GTDavis wrote on 7/4/2020, 8:44 PM

OK, I was in power user mode, but I found something that resets the screen to what I am used to (last version I used was 14). It is View->Window Layouts->Default Layout. That shows something reasonably close to past versions. Once in a while when I click something, the screen freaks out and all these windows disappear (timeline, preview, etc.). But I can always get back to normal by selecting "Default Layout".

Anyway, thanks for responses.