Happy Otter Scripts for Vegas Pro

Comments

john_dennis wrote on 7/8/2019, 3:24 AM

" 'RenderEvents' won't work for me at all. It just doesn't function. But what I was trying to do with RenderEvents is to Render project Regions with names, using MagicYUV CODEC in AVI containers, and I have found that I can do that with 'RenderPlus.' "

Did you select all tracks on the timeline? I found that using Render Events with the Region radio button selected that it will render black video for the unselected tracks, but render the selected tracks properly. Release 1.0.2.59

IAM4UK wrote on 7/8/2019, 9:23 AM

@IAM4UK

...

Regarding "RenderEvents". To render to MagicYUV in an avi container, you must select "Vegas" as the render option. You must first create your MagicYUV template inside of Vegas. Once the template is created, exit Vegas and then restart for the template to be shown. This should work. ...

That did work; thanks. Please see the other reply from @john_dennis -- it's true that using RenderEvents with "Region" selected causes black video unless all the referenced Tracks are selected in the timeline.

IAM4UK wrote on 7/8/2019, 9:25 AM

" 'RenderEvents' won't work for me at all. It just doesn't function. But what I was trying to do with RenderEvents is to Render project Regions with names, using MagicYUV CODEC in AVI containers, and I have found that I can do that with 'RenderPlus.' "

Did you select all tracks on the timeline? I found that using Render Events with the Region radio button selected that it will render black video for the unselected tracks, but render the selected tracks properly. Release 1.0.2.59


Confirmed. Once I followed @wwaag instruction about making a Vegas render template for MagicYUV, then I was able to use RenderEvents as described, and I discovered the BlackVideo phenomenon you mentioned. Selecting all tracks before engaging the RenderEvents script cured that. Thanks.

Musicvid wrote on 7/8/2019, 10:18 AM

HOS Bug Alert--Vegas Crash after FrameServer Starts

I've had a number of users report that Vegas crashes right after the frameserver starts (which I have reproduced using 1.0.2.59). Thanks to some detective work by John Dennis, the problem stems from the introduction of a new build of the FrameServer. It occurs whenever the older FrameServer versions attempt to "check for updates". The issue affects not only HOS, but anyone using the previous version for use in such scripts as Vegas2Handbrake, For non-HOS users, simply download and install the new FrameServer version. For HOS users, I've kluged a workaround which blocks the FrameServer from checkng for updates in the app that links Vegas to the encoder. It can be downloaded at. https://www.dropbox.com/s/rxtne1htpxp73gc/fs2enc.exe?dl=0 The file should be copied into the following folder "C:\Program Files\HappyOtterScripts".  Be advised that this "fix" may or may not work for your specific installation.


The new FrameServer version will be incorporated into the next HOS build.

 

The fix isn't working on a new Windows 10 installation of VP14. Will try again when the next beta is released.

wwaag wrote on 7/8/2019, 10:29 AM

@Musicvid

Sorry that it's not working. Some have reported that it works OK, others not. There is also a fix by John Dennis that involves blocking the DMFS website altogether that works for him. As stated, Satish is aware of the problem and is working on a fix. Hopefully, this can be sorted out soon since DMFS is a key component in HOS.

Musicvid wrote on 7/8/2019, 10:44 AM

I'm in no hurry. Very happy with the product, but no burning deadlines.

Working fine on Windows 7/

IAM4UK wrote on 7/8/2019, 1:38 PM

The fix isn't working on a new Windows 10 installation of VP14. Will try again when the next beta is released.

The "fix" didn't work for me, but then I went to the website for FrameServer and downloaded/installed Version 3...that worked.

Musicvid wrote on 7/9/2019, 8:00 AM

@Musicvid

Sorry that it's not working. Some have reported that it works OK, others not. There is also a fix by John Dennis that involves blocking the DMFS website altogether that works for him. As stated, Satish is aware of the problem and is working on a fix. Hopefully, this can be sorted out soon since DMFS is a key component in HOS.


@wwaag

Does the HOS installer turn on

Preferences->Video->GPU Acceleration of video processing

by default? I can't be sure that was it, but on my new machine (Windows 10, 7th Gen Intel}, checking that option causes the VP14 early termination problem with several of my Magix renderers, not just Frameserver. But Intel HEVC encoder works fine with it set either way.

wwaag wrote on 7/9/2019, 10:07 AM

@Musicvid

Does the HOS installer turn on

Preferences->Video->GPU Acceleration of video processing

by default?

No. HOS doesn't change any Vegas Preferences settings.

 

Musicvid wrote on 7/9/2019, 10:44 AM

Ok thanks. I wasn't sure.

IAM4UK wrote on 7/9/2019, 6:07 PM

@wwaag Now that I have followed your instructions on how to use RenderEvents properly, I have experimented with it and have a feature request:
I put "raw video" from two different types of camera sources on a Vegas Pro 16 timeline, with each camera getting its own Track, and the clips added to the appropriate Tracks. I add Regions and name them for the general content I want to use when I edit the actual project. I want to use Vegas LUT to standardize both cameras' clips to Rec.709 during the render of these Regions, and I have LUT for those specific cameras and their colorspace settings (e.g. Panasonic Cinelike_D, FilmicPro LogV2...) for that purpose. I tried adding the LUT to the Tracks (easy), and rendered with RenderEvents, checking Keep videoFX. The LUT added as TrackFX did not get included in those renders. I then tried it by individually adding LUT to each clip; that worked.
If it is possible to add "What to keep..." "TrackFX" to RenderEvents, that would be very useful. Regardless, your scripts are very, very valuable...Thanks!

wwaag wrote on 7/9/2019, 7:39 PM

@IAM4UK

You can already do this. You must tick "Same Track" and then select the track to be rendered. If you then tick "All Tracks" all video tracks will be included in the render.

wwaag wrote on 7/16/2019, 1:14 PM

New version 1.0.2.60 released with added features, and bug fixes. Change log may be found here. https://tools4vegas.com/wp-content/uploads/HappyOtter-Change-Log.pdf

The major change is the integration of the new DebugMode FrameServer build 3.0 into HOS. Other changes include:

o    AudioTrim—added track render option plus options to bypass event gain, envelopes, and pan settings

o    VideoSmartTrim—support for subclips added

o    RenderEvents—added checks to insure that video exists in the selected tracks for region and project renders

To download the new version, Launch Help and click on Check Now.

Comments are welcome.

Grazie wrote on 7/17/2019, 2:17 AM

@wwaag - Great stuff Wayne! - Where can I get the FREEWARE version of MagicYUV, necessary to Import into Vegas?

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

skeeter123 wrote on 7/17/2019, 4:05 AM

Pardon my ignorance, but what is the update procedure? Run the .exe and go through all the steps again? Or? ?

(Seriously loving these scripts, BTW!)

Cheers!

rraud wrote on 7/17/2019, 10:14 AM

- Great stuff Wayne! - Where can I get the FREEWARE version of MagicYUV, necessary to Import into Vegas?

https://www.magicyuv.com. At the bottom of the page are the download links @Grazie

I don't recall if the MagicYUV files need to be in a HOS folder or in the default install Program Files (x86)

Grazie wrote on 7/17/2019, 10:23 AM

https://www.magicyuv.com. At the bottom of the page are the download links @Grazie

@rraud - Hi! Yeah I did do that at 8:00am this morning and got this, and no further:

Then I came here. Any ideas?

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

wwaag wrote on 7/17/2019, 10:38 AM

@Grazie

Just enter 0 and another screen will appear where you enter email address. You should then be able to download the setup file.

@skeeter123

Just run the new setup file.

@rraud

The default install location is C:\Program Files (x86)\MagicYUV. There is nothing in HOS.

Grazie wrote on 7/17/2019, 10:53 AM

@wwaag - Hi Wayne. Which of these should I go with?

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

rraud wrote on 7/17/2019, 10:56 AM

Here is a MagicYUV download link from videohelp.com . Yeah, the MagicYUV site is confusing, as Wayne stated they want an amount figure, even if it is 0.

https://www.videohelp.com/download/MagicYUV_v1.2_win-rev2.exe

wwaag wrote on 7/17/2019, 10:56 AM

I'd say "both".

Grazie wrote on 7/17/2019, 11:07 AM

@wwaag - I'd say "thank you", and I will, THANK YOU! 😀

Grazie

PC 7 64-bit 16gb * Intel® Core™i7-2600k Quad Core 3.40GHz * 2GB NVIDIA GEFORCE GTX 560 Ti

PC 10 64-bit 64gb * Intel® Core™i9 - 3.3GHz * 40Gb NVIDIA  GeForce RTX 2070

Cameras: Canon XF300 + PowerShot SX60HS Bridge

Musicvid wrote on 7/17/2019, 11:31 AM

UT and Magic are so close in all aspects -- I'm going to hold off installing Magic at least for a while.

@wwaag

Pleased to report success with the new beta -- will post separately about VP9 compatibility in Import Assist.

[EDIT] VP9 / MKV 2160 p60 is now importing and converting. Great work!