Happy Otter Scripts for Vegas Pro

Comments

Jep wrote on 12/26/2018, 3:46 PM

@Jep

"Can I ask what script RenderPlus uses when set to the Default Template?"

Most HOS tools involving FFmpeg, Avisynth, and VirtualDub are command line driven. You can always see the actual command lines that are being used. For RenderPlus, such information can be found at "C:\ProgramData\HappyOtterScripts\Magix Vegas Pro\RenderPlus". RenderPlus.avs gives the Avisynth script while renderCommandLine.bat is the actual FFmpeg command line. Each tool will have its own folder in which scripts can be found. Particularly useful is the file LastRenderLogFile.txt for diagnosing crashes due to scripting errors.

Uploading sample footage would be best. Time delay is no problem since I am away from my main development machine for this week.

Hi wwaag,

First - apologies for the delay in replying, my PC went belly-up and I've spent most of the last week fixing it. Finally had to reinstall my OS and all my other software.

Thanks for your detailed explanation of the technicalities behind HOS. A bit above my paygrade I'm afraid.

Finally, I'm attaching two very short clips. They're very short with no audio, but enough to show you the results I get using the Change Frame Rate script. Their titles are self explanitory. The first being the original footage and the second is output via HOS in Vegas 13 Pro using the Change Frame Rate script. Also I disabled resample before using HOS to increase frame rate.

If you place one on a track above the other and toggle the top track on an off you'll see what I'm talking about.

Thanks for your time.

P.S. I'm not sure if you can download those clips. If I should be posting them a different way please let me know.

wwaag wrote on 12/26/2018, 5:03 PM

Hi Jep,

Thanks for the uploads. Somewhere, you have definitely applied a Computer RGB to Studio RGB Fx (or PC to TV in Avisynth language)--most likely in the Avisynth script that you are using. Here is your original clip.

Notice in the scopes window, the waveform extends from 0 to 100. Here's your rendered clip.

Notice how the range of the waveform is reduced, which accounts for your "washed out" look.

Using Render Plus, here are the settings.

Just change the frame rate to 30 and render. Tick "Add to Timeline" and the rendered file will be added to a new Track. Here are the results.

The waveform is now at full range and the same as your original clip as shown.

You will also note that your rendered clip has an additional frame. If you were using the Vegas 2 Handbrake script, that would explain it. If you need help with the actual script you were using, upload an exact copy and also indicate which tool you were using--Render Plus or AviDub. The best thing is to copy the converted script which can be found in either the AviDub (AviDub.avs) or RenderPlus (RenderPlus.avs) folder. Hope this helps.

wwaag

Musicvid wrote on 12/26/2018, 5:24 PM

A little confusion with importing MKV using Render Plus.

Dialog says use the folder option, but there is no .mkv file type to be selected.

I can drag and drop one MKV to the window, but only one.

These MKVs consist of 4k VP9 obtained from Youtube.

Win7 64

wwaag wrote on 12/26/2018, 5:33 PM

Hi Musicvid,

You cannot import MKV files directly into Render+. You must first import the file to the timeline using ImportAssist, where you can either rewrap or transcode your file into an MP4 or MOV container. I have not tried any VP9 footage, so I have no idea whether it will work or not. Could you provide a link to one of your YT files so that I could so some testing. I have made quite a few changes to ImportAssist (direct AC3 import plus numerous bug fixes including inability to import certain video files including MKVs using the Add Files or Add Folder buttons) since the last release which I hope to get out sometime this year (LOL).

wwaag

Jep wrote on 12/27/2018, 12:29 PM

Hi Jep,

Thanks for the uploads. Somewhere, you have definitely applied a Computer RGB to Studio RGB Fx (or PC to TV in Avisynth language)--most likely in the Avisynth script that you are using. Here is your original clip.

Notice in the scopes window, the waveform extends from 0 to 100. Here's your rendered clip.

Notice how the range of the waveform is reduced, which accounts for your "washed out" look.

Using Render Plus, here are the settings.

Just change the frame rate to 30 and render. Tick "Add to Timeline" and the rendered file will be added to a new Track. Here are the results.

The waveform is now at full range and the same as your original clip as shown.

You will also note that your rendered clip has an additional frame. If you were using the Vegas 2 Handbrake script, that would explain it. If you need help with the actual script you were using, upload an exact copy and also indicate which tool you were using--Render Plus or AviDub. The best thing is to copy the converted script which can be found in either the AviDub (AviDub.avs) or RenderPlus (RenderPlus.avs) folder. Hope this helps.

wwaag

Thanks again for the quick reply Wayne.

First, I was using Render Plus with one of the Custom scripts installed with HOS. Here is what my selections looked like

The exact path of the script is: C:\ProgramData\HappyOtterScripts\AvisynthScripts\Change Frame Rate.avs. The text from the script is as follows:

# SetFilterMTMode is set by mtmodes.avsi in your AviSynth plugins folder. See http://avisynth.nl/index.php/AviSynth%2B#Help_filling_MT_modes
# Requires jm_fps.avsi and its dependencies in your AviSynth plugins folder
# Explanation of this script is at https://forum.doom9.org/showthread.php?p=1800439#post1800439

SetMemoryMax(1024) #Adjust for your system if necessary
AviSource("C:\ProgramData\HappyOtterScripts\Magix Vegas Pro\AviDub\fs.avi").KillAudio().ConvertToYV12()

# Uncomment line corresponding to your desired output frame rate
#jm_fps(25)
#jm_fps(23.976)
#jm_fps(24)
#jm_fps(29.97)
#jm_fps(30)
#jm_fps(50)
jm_fps(59.94)
#jm_fps(60)

Prefetch(4) #Adjust for your system if necessary

The only change made to that script was to uncomment the line jm_fps(59.94) to double the frame rate from 29.97. That script requires jm_fps.avsi in the AviSynth plugins folder. The exact text from the script is as follows:

# Motion Protected FPS converter script by johnmeyer from Doom9
# Slightly modified interface by manolito
# Requires MVTools V2 and RemoveGrain
# Also needs fftw3.dll in the System32 or SysWOW64 folder

function jm_fps(clip source, float "fps")
{
fps = default(fps, 29.970)
fps_num = int(fps * 1000)
fps_den = 1000

prefiltered = RemoveGrain(source, 22)
super = MSuper(source, hpad = 16, vpad = 16, levels = 1) # one level is enough for MRecalculate
superfilt = MSuper(prefiltered, hpad = 16, vpad = 16) # all levels for MAnalyse
backward = MAnalyse(superfilt, isb = true, blksize = 16, overlap = 4, search = 3, dct = 0)
forward = MAnalyse(superfilt, isb = false, blksize = 16, overlap = 4, search = 3, dct = 0)
forward_re = MRecalculate(super, forward, blksize = 8, overlap = 2, thSAD = 100)
backward_re = MRecalculate(super, backward, blksize = 8, overlap = 2, thSAD = 100)
out = MFlowFps(source, super, backward_re, forward_re, num = fps_num, den = fps_den, blend = false, ml = 200, mask = 2)

return out
}

I haven't made any changes to that script. However I checked the first four lines of the script and I don't seem to have MVTools V2 or RemoveGrain (line 3), and I checked my System32 and SysWOW64 folders and couldn't find fftw3.dll (line 4). Perhaps it's those missing requirements causing the problem. I'm not sure how to go about installing them if it is the case.

Thanks again for your quick response.

Jep wrote on 12/27/2018, 12:32 PM

One other question if I may. I would like to get Send2HandBrake running properly again. That requires a normal install of Avisynth. Having already installed HOS will I screw it up if I now install a separate version of Avisynth?

wwaag wrote on 12/27/2018, 4:07 PM

Hi Jep,

Question. Why did you choose to use a custom script when the RenderPlus GUI supports frame rate changes and also correctly sets levels? The underlying script is the same. If you use a custom script, then you have to correctly set these levels yourself inside the Avisynth script.

In any case, just change ConvertToYV12() to ConvertToYV12(interlaced=false,matrix="PC.709"). This tells Avisynth to maintain PC levels with HD color coefficients.

"Perhaps it's those missing requirements causing the problem." No. All of the required plug-ins can be found in "C:\Program Files\HappyOtterScripts\AvisynthRepository\AVSPLUS_x86\plugins".

Regarding the Vegas 2 Handbrake script, it should work with the version of Avisynth+ that is already installed. If you were to install a regular version of Avisynth such as 2.58 or 2.6MT, then HOS would not work at all since it requires Avisynth+.

 

 

Joelson-Forte wrote on 12/27/2018, 5:02 PM

Installing HappyOtter is simple, but installing Send2HandBracke is a bit more complex because it involves several steps.

HappyOtter and Send2HandBracke use elements in common such as Debug Mode FrameServer and the Avysynth +

I also had problems with Send2Handbracke when installing HappyOtter Script, but I realized that for Vegas2HandBrake and HappyOtter Script to work correctly together it is necessary to know the correct order of installation.

You must always install HappyOtter Script first as it automatically installs the Debug Mode FrameServer and Avysynth + which will also be used by Send2Handbracke. Only after that should you start the installation of the other components of Send2Handbracke:

1.Pismo File Mount Audit Package.exe
2.frameserve_scripts in the directory C:\Program Files\VEGAS\Vegas Pro XX.0\Script Menu
3.Frameserver.x64 in the directory C:\Program Files\VEGAS\Vegas Pro XX.0

But if you have HOS you no longer need Send2Handbracke, because in the Render Plus Encoder Settings of HOS in Video Options there are several options superior to Send2HandBracke options.

Marco. wrote on 12/27/2018, 5:09 PM

Why would you use Vegas2HandBrake if HOS is available? I think HOS is superior all over.

Adi-W wrote on 12/27/2018, 6:58 PM

I just installed HappyOtter Script and have some problem with the script "Open Audio Editor" as it doesnot ask me (as it should ?) in the first run to select my Audio Editor. So it is the window "Waves render templates" that open but, while I can make selection in it, the OK button doesnot respond and it is no more possible to going back to Vegas. The only way to go out of that is to right-click on the Vegas icon on the taskbar and select "Close All Window". Then, only the "Waves render templates" window closes and Vegas become functionnal again. I have tried to reset the "Open Audio Editor" script but withtout any change.

Ok, the problem is more complicated than that. The window for selecting audio editor finaly appeared, I select my wave editor Soundforge 10, click OK and then I am getting the error message that "the wave render template could not be found". Click OK, and then after that, if I tried again the script I am back at the begining of the problem I described with the "Waves render templates" window not responding.

wwaag wrote on 12/27/2018, 7:32 PM

It sounds as if your wave templates are not set up correctly.

First, go to this folder "C:\ProgramData\HappyOtterScripts". There should be a file named "WaveTemplates.txt". If it exists, delete the file.

Second, open Vegas and select "AudioTrim", which is the first tool. It really doesn't matter which is selected. Then save the project. The following should then appear:

For English versions, the forms are filled out correctly. For non-English you must select the render templates from the drop-down menus for mono, stereo, and 5.1. You cannot enter OK until, you have selected the templates. That is probably what was happening when you first attempted to install the software.

Once saved, go back to the above folder and make sure that the file "WaveTemplates.txt" exists and contains the correct template. If OK, then the open audio editor should work.

Hope this helps.

 

 

Adi-W wrote on 12/27/2018, 11:04 PM

Thanks wwaag, that solved the problem and the audio editor is opening. Now I have a lot more functions to explore...!

tripleflip18 wrote on 12/30/2018, 12:24 PM

Hi very very useful addition to vegas for me and my workflow... But using Proxy assist im getting an error clicking build "Oops! The following error has occurred: Attempted to perform and unauthorized operation. Can you share of a way around the problem, thank you!

If somehow this thing worked for Resolve I would switch to resolve... any chance of that?

Joelson-Forte wrote on 12/30/2018, 12:47 PM

@tripleflip18 

This is a bug that occurs with HOS in windows 10. The developer is working on a solution to this problem. For now an alternative solution is to start Vegas as an administrator. Do this that will work correctly.

tripleflip18 wrote on 12/30/2018, 12:55 PM

@tripleflip18 

This is a bug that occurs with HOS in windows 10. The developer is working on a solution to this problem. For now an alternative solution is to start Vegas as an administrator. Do this that will work correctly.

BIG THANKS!!! works! Do you know if there is any negative side running vegas as admin? i remember few years ago i had to do it for some reason but it caused some other issues....

Joelson-Forte wrote on 12/30/2018, 1:11 PM

@tripleflip18 

BIG THANKS!!! works! Do you know if there is any negative side running vegas as admin? i remember few years ago i had to do it for some reason but it caused some other issues....

I'm not sure about this information. But here I work without problems.

tripleflip18 wrote on 12/30/2018, 1:58 PM

just bumped into another problem, smartvideotrim renders audio off by a bit...... anyone know of a fix? Thank you

BruceUSA wrote on 12/30/2018, 2:05 PM

I just decided to play with this really nice app but I am at a lost here and I am missing something here. I try to play with slow motion but unable to find the correct page for it. I click on the the OtterinforBar and click R+ a screen come up but I don't see anywhere to change the playback framerate in slow motion. Can you some please do a quick tutorial on how please.

Eagle Six wrote on 12/30/2018, 2:40 PM

@Bruce, go back to the tools4vegas where you downloaded Happy Otter and scroll down to various tutorials including slow motion.

System Specs......
Corsair Obsidian Series 450D ATX Mid Tower
Asus X99-A II LGA 2011-v3, Intel X99 SATA 6 Gb/s USB 3.1/3.0 ATX Intel Motherboard
Intel Core i7-6800K 15M Broadwell-E, 6 core 3.4 GHz LGA 2011-v3 (overclocked 20%)
64GB Corsair Vengeance LPX DDR4 3200
Corsair Hydro Series H110i GTX 280mm Extreme Performance Liquid CPU Cooler
MSI Radeon R9 390 DirectX 12 8GB Video Card
Corsair RMx Series RM750X 740W 80 Plus Gold power pack
Samsung 970 EVO NVMe M.2 boot drive
Corsair Neutron XT 2.5 480GB SATA III SSD - video work drive
Western Digitial 1TB 7200 RPM SATA - video work drive
Western Digital Black 6TB 7200 RPM SATA 6Bb/s 128MB Cache 3.5 data drive

Bluray Disc burner drive
2x 1080p monitors
Microsoft Window 10 Pro
DaVinci Resolve Studio 16 pb2
SVP13, MVP15, MVP16, SMSP13, MVMS15, MVMSP15, MVMSP16

wwaag wrote on 12/30/2018, 3:41 PM

@tripleflip18

"just bumped into another problem, smartvideotrim renders audio off by a bit...... anyone know of a fix? Thank you"

That's the reason for inclusion of an audio offset control. Some formats can be trimmed without any need for adjusting offset while others cannot. In such cases, you can easily determine the required offset in Vegas by comparing the original audio track against the trimmed audio track.

First, you will need to find a very distinct waveform event such as a click. Change the time format to time or seconds and under Options, Disable Quantize to Frames. Then set the beginning of a loop region (enter I) to the location of waveform event for one track and then go the the same waveform event on the other audio track and set the end region (Enter O). You can then read the length of the loop region (located on the lower right of the Vegas window) which corresponds to the amount of audio delay. Enter that value back in SmartVideoTrim and try again.

One other thing. Once you've finished, don't forget to re-enable Quantize to Frames under Options and change your time format back to your preference.

BruceUSA wrote on 12/30/2018, 4:18 PM

@BruceUSA

This should get your started...

John_dennis. Thank you so much. I knew I was missing a step somewhere. I did click on advance but I did not realized there is another click to get to the page where I want. Again Thank you.

Musicvid wrote on 12/30/2018, 4:54 PM

Hi Musicvid,

You cannot import MKV files directly into Render+. You must first import the file to the timeline using ImportAssist, where you can either rewrap or transcode your file into an MP4 or MOV container. I have not tried any VP9 footage, so I have no idea whether it will work or not. Could you provide a link to one of your YT files so that I could so some testing. I have made quite a few changes to ImportAssist (direct AC3 import plus numerous bug fixes including inability to import certain video files including MKVs using the Add Files or Add Folder buttons) since the last release which I hope to get out sometime this year (LOL).

wwaag

Woops I meant Import Assist.

Win 7 64 OS

Link to Youtube MKV / VP9 sample here:

https://drive.google.com/file/d/1bQ3IbJEQKkWWYMv8Gh-SBuHB2QGBBtMW/view?usp=sharing

Let me know if you have trouble downloading the MKV.

It's a great extension and I will be spending a lot of time learning its capabilities.

wwaag wrote on 12/30/2018, 5:04 PM

@Musicvid

The problem you described with adding files has now been fixed in 1.0.2.50. I was able to find a vp9 file, but I'll take a look at that one as well. Thanks.