Happy Otter Scripts for Vegas Pro

Comments

wwaag wrote on 2/18/2020, 11:54 AM

New version 1.0.2.69 released. Change log may be found here. https://tools4vegas.com/wp-content/uploads/HappyOtter-Change-Log.pdf

  • New Tool
    • ExternalApps—launches external applications including those requiring a media file as an argument such as photo and audio editors.  Launch ColorCop and VirtualDub are now included within this tool.

  • New Features

    • AudioTrim

      • Now shares the same saved Vegas audio templates as RenderPlus

      • Added after render options to Open Folder, and Play Med

    • FileInfo—added MediaInfo as the default file info tool

    • FrameFixer

      • New frames now saved in a sub-folder of the media file folder

      • Added FrameFixer media bin where new frames are added

    • ImportAssist—added VirtualDub render templates for direct import of Webm files with alpha

    • Preferences—provides for selected launch of either ThemeDesigner or ToolFileSetup

  • Bug Fixes

    • ImportAssist--Folder import only worked for still images and not video files—fixed

    • RenderPlus

      • Crash when opening EncoderSettings dialog—fixed

      • Long program audio (>4gb) support using wave 64 and fdk-aac now working correctly

    • GPU encoding check results only worked correctly in RenderPlus--now fixed in all tools

    • Lots of minor bug fixes and update to help files

Please advise of any further issues.

Musicvid wrote on 2/20/2020, 10:35 AM

Long program audio (>4gb) support using wave 64 and fdk-aac now working correctly

Yes it is, and a ticket to freedom for long-form producers. Thanks Wayne!

MikeLV wrote on 2/26/2020, 4:48 PM

@wwaag I think I found a bug in RenderPlus, see video below. In the avisynth settings, when you click on the Double option under frame rate, it goes to same. But all the other drop down options are selectable. I'm using 1.02.68 and just noticed there's a newer version, so not sure if the new version fixes that; I'll check..

Update: Current version does not correct the issue cited in the video.

MikeLV wrote on 2/26/2020, 6:30 PM

That check box only works if you are using deinterlacing though.

wwaag wrote on 2/26/2020, 6:34 PM

Works OK here. I can select any of the frame rates without deinterlacing.

MikeLV wrote on 2/26/2020, 6:41 PM

No, my issue was not with regard to the deinterlacing. I was addressing john's post.

Just the frame rate. When I click on double, it goes to same, as shown in the video.

wwaag wrote on 2/26/2020, 6:52 PM

Here's a recording.

MikeLV wrote on 2/26/2020, 7:04 PM

@wwaag, except you didn't click double, which is the one that doesn't work (for me anyways)

john_dennis wrote on 2/26/2020, 7:15 PM

I see the behavior.

I'm not sure what to make of it.

wwaag wrote on 2/26/2020, 7:52 PM

OK. Now I understand what you mean. That's by design. It shows Double ONLY when you set the Deinterlacing to Double. You cannot "double" the frame rate by selecting that item from the list.

MikeLV wrote on 2/27/2020, 4:02 PM

Ok, thanks just wanted to make sure it wasn't a bug.

New problem, I just did an encode using VCE. According to the Render Progress window, it shows 43456 of 43511 Frames Processed, 100%. But I got the stop dialog box, directing me to this log file:

2020/02/27  13:47:49  --VCEEnc (x64) 5.01 (r382) by rigaya, Dec 24 2019 13:55:36 (VC 1924/Win/avx2)
2020/02/27  13:47:49  --OS Version     Windows 10 x64 (18363)
2020/02/27  13:47:49  --CPU:           Intel Core i7-2600K @ 3.40GHz [TB: 4.43GHz] (4C/8T)
2020/02/27  13:47:49  --GPU:           Radeon RX 590, AMF Runtime 1.4.16 / SDK 1.4.14
2020/02/27  13:47:49  --Input Info:    Avisynth+ 2.60(yv12)->nv12 [AVX], 1920x1080, 30000/1001 fps
2020/02/27  13:47:50  --Vpp Filters    copyHtoD
2020/02/27  13:47:50  --Output:        H.264/AVC  High @ Level 4
2020/02/27  13:47:50  --               1920x1080p 0:0 29.970fps (30000/1001fps)
2020/02/27  13:47:50  --               avwriter: h264 => mp4
2020/02/27  13:47:50  --Quality:       slow
2020/02/27  13:47:50  --CQP:           I:21, P:21
2020/02/27  13:47:50  --VBV Bufsize:   31250 kbps
2020/02/27  13:47:50  --Bframes:       0 frames
2020/02/27  13:47:50  --Ref frames:    2 frames
2020/02/27  13:47:50  --LTR frames:    0 frames
2020/02/27  13:47:50  --Motion Est:    Q-pel
2020/02/27  13:47:50  --Slices:        1
2020/02/27  13:47:50  --GOP Len:       300 frames
2020/02/27  13:47:50  --Others:        deblock hrd 
2020/02/27  14:01:26  --                                                                               
2020/02/27  14:01:26  --encoded 43511 frames, 53.31 fps, 20746.50 kbps, 3590.60 MB
2020/02/27  14:01:26  --encode time 0:13:36, CPULoad: 7.4
2020/02/27  14:01:26  --frame type IDR   146
2020/02/27  14:01:26  --frame type I     146,  total size    44.10 MB
2020/02/27  14:01:26  --frame type P   43365,  total size  3546.50 MB

Any idea what went wrong?

wwaag wrote on 2/27/2020, 4:10 PM

That log file indicates that the video processing was successful. After processing the video, it copies the video and adds the audio in FFmpeg to produce the final file. Just got your crash report so I will take a look. Thanks for adding an email to that report.

wwaag wrote on 2/29/2020, 4:53 PM

New version 1.0.2.70 released. Change log may be found here. https://tools4vegas.com/wp-content/uploads/HappyOtter-Change-Log.pdf

New Versions of VirtualDub2, Nvencc64, Qsvencc64, Vceencc64**

  • New Features
    • Added 422 x264 rendering support to RenderEvents and AviDub
    • SmartVideoTrim
      • Option added to select bit rate when aac recoding is necessary
      • For PCM audio in MP4 files, option to use older FFmpeg which copies PCM or newer version which demands the audio be recoded to AAC.  Newer version used for other file types.
  • Bug Fixes

o    ImportAssist-- Newly created x264 templates not being immediately shown—fixed
o    ProxyAssist-- Selected encoder template in EncoderSettings not updated to main dialog—fixed
o    AudioTrim-- Selection of AAC renderer crashed Vegas—fixed
o    RenderEvents--GPU assisted renders not working—fixed
o    Preferences—crashed Vegas on some systems when running ToolFileSetup—fixed
o    SmartVideoTrim—option to add audio from different source not working correctly—fixed

** For AMD Radeon Users: The newest version of VCEEncC64 that supports VCE rendering, cannot be used in Win7.  To continue using Win7, you must go to the folder “C:\Program Files\HappyOtterScripts” and delete the file “VCEEncC64.exe”.  Then rename “VCEEncC64_Win7.exe” to “VCEEncC64.exe”.

 

NickHope wrote on 3/4/2020, 2:21 AM

Thanks for the update wwaag. I'm getting "can't connect to server" error at the moment.

wwaag wrote on 3/4/2020, 10:11 AM

Received a notice a couple of weeks ago about a facility upgrade which may have accounted for the problem. I just tried to re-download the latest version and it worked OK. Here was the original message:

"On Wednesday, March 4, starting from 01:01AM CST, we will perform an infrastructure upgrade and migrate your account(s) from server us126.siteground.us to a new server with the latest hardware in our new Google facility in Iowa."

Let me know if it still persists.

 

 

LBro wrote on 3/9/2020, 4:42 AM

Hi, I am working on getting the audio up to higher specifications. I think one way to do this would be to use aac-nero. Upon selecting that choice in HOS, I get a warning dialog box that I must place file 'neroAacEnc.exe' into the "Tools" directory. Ok - So I located a "Tools" directory on the Root of C and placed the proper file into it. The same issue remains when trying to invoke the aac-nero option. I guess I need to know what the typical path to the "Tools" directory is supposed to be?

Thanks,

LB

LBro wrote on 3/9/2020, 4:48 AM

Hi again,

WWaaq - You helped me a while back to get audio from 16 bit max in a mp4 file to 24 bit. Your methode used a ".mov" wrapper and some other steps. I have searched until I am blue in the face and cannot find your comments on this or mine, here or at the CC forum. I also tried Mr. Google and found nothing. It is as if it went incognito. At any rate if you remember that, can you point me to it or repeat what you said? I know you did a short tutorial video on it too...

Thanks,

LB

LBro wrote on 3/9/2020, 4:51 AM

I see you have a new version of HOS out. It lasts till the end of March. At one point you gave some information on the direction HOS might take. That was a few months ago. Since time has passed, do you now have a better vision for this tool? I would be happy to pay a reasonable amount for HOS and look forward to some kind of more permanent release!

LB

wwaag wrote on 3/9/2020, 11:24 AM

@LBro

The location for the Nero executable "neroAacEnc.exe" is "C:\Program Files\HappyOtterScripts".

I vaguely recall such a question, but don't remember exactly what was said or when. The best thing is to pose once again exactly what you are trying to accomplish.

I am hoping to have the first release build available by 1 April. At that time, a user could also have a 30 day trial. Licenses should also be available for $79 US.

Musicvid wrote on 3/9/2020, 1:28 PM

@LBro

Audio for streaming video distribution is 16 bit 48kHz. Anything else would be reserved for BluRay or one's hobby interest.

Nero AAC hasn't been developed in many years. FDK can be found precompiled or I could send you a one time link.

LBro wrote on 3/9/2020, 3:28 PM

@LBro

Audio for streaming video distribution is 16 bit 48kHz. Anything else would be reserved for BluRay or one's hobby interest.

Nero AAC hasn't been developed in many years. FDK can be found precompiled or I could send you a one time link.

Hi,

Yes I saw the last date on the update for Nero. Please do send the link for DDR.

Thanks

LB

LBro wrote on 3/9/2020, 3:36 PM

@LBro

The location for the Nero executable "neroAacEnc.exe" is "C:\Program Files\HappyOtterScripts".

I vaguely recall such a question, but don't remember exactly what was said or when. The best thing is to pose once again exactly what you are trying to accomplish.

I am hoping to have the first release build available by 1 April. At that time, a user could also have a 30 day trial. Licenses should also be available for $79 US.

Thanks on the location, release date and price! All sounds good!

The audio specs I am looking for are:

44.1Hz

24 bit or 32 bit float if that is what it takes to bump up that on the next line below.

320 Bit Rate or up to that amount, everything I have tried only gives a bit rate of 256 max.

Mov wrapper using whatever encoder you think is best.

Thanks much and thanks for the long hours on HOS.

LB

MikeLV wrote on 3/13/2020, 1:58 PM

@wwaag, not sure if it's anything related to HOS, but I was in R+, and I had just clicked on the Resizer icon in the avisynth settings and I got this crash:

Problem Description
   Application Name:    VEGAS Pro
   Application Version: Version 17.0 (Build 387)
   Problem:             Unmanaged Exception (0xe0434352)
   Fault Module:        C:\Windows\System32\KERNELBASE.dll
   Fault Address:       0x00007FF8B7EBA859
   Fault Offset:        0x000000000003A859

Fault Process Details
   Process Path:        C:\Program Files\VEGAS\VEGAS Pro 17.0\vegas170.exe
   Process Version:     Version 17.0 (Build 387)
   Process Description: VEGAS Pro
   Process Image Date:  2020-02-16 (Sun Feb 16) 22:15:06