PeterDuke wrote on 11/8/2015, 1:08 AM
I have Vegas 8 to 13 installed under Win 7 before upgrading to 10. All appear to work and are registered, except Vegas 8 which hangs during start up while Initializing DirectX plugins.

I haven't tried installing Vegas in Win 10.
PeterDuke wrote on 11/8/2015, 1:21 AM
In the cause of science (and THF) I uninstalled Vegas Pro 10 and reinstalled it. The registration happened smoothly.
TheHappyFriar wrote on 11/8/2015, 5:56 AM
Strange. I'll just wait until tomorrow to chat with support. Thanks for checking for me. (it didn't work on the win 7 64-bit or Win 10 64-bit machines).
Former user wrote on 11/8/2015, 8:01 AM
Try using the option to register from another computer. It will send you an email with the registration file. This worked for me once when I couldn't register the normal way.
TheHappyFriar wrote on 11/8/2015, 8:54 PM
Just tried that. It asks for my e-mail, I enter it, then it says I'm registering Vegas 10 Pro & shows my SN, click next (or whatever) and it takes me to the web registration page & says there is an error.
Former user wrote on 11/8/2015, 8:55 PM
Cookies? Browser settings?
TheHappyFriar wrote on 11/8/2015, 9:16 PM
Got a new hard drive, brand new Win 10 install.

EDIT: also gave the same error on a Win 7 machine last week too.
PeterDuke wrote on 11/8/2015, 11:15 PM
Have you exceeded your quota of registrations? If so, talking/chatting/emailing SCS is the only solution.
TheHappyFriar wrote on 11/9/2015, 5:52 AM
I might of. Does it give a generic error message if you did?
vkmast wrote on 11/9/2015, 6:04 AM
From this thread:
"The server was unable to complete the registration as requested. [-41]"
"That code means "too many activations"."
Chienworks wrote on 11/9/2015, 6:38 AM
Just this past week they've changed it to "Too many activations".
rs170a wrote on 11/9/2015, 7:25 AM
Stephen, my experience is that Live Chat ( Monday - Thursday: 09:00 AM - 04:30 PM CST; Friday: 10:00 AM - 04:30 PM CST ) is the easiest solution.

TheHappyFriar wrote on 11/9/2015, 8:24 AM
Just waiting for chat support to open up.

Thanks for the previous thread: nondescript error message. Like I said in the other thread, they should change the error message. :)
TheHappyFriar wrote on 11/9/2015, 9:03 AM
9:03am CST. All fixed with chat.