Chroma key frustrations - green screen issues

dragonblade wrote on 5/6/2016, 6:02 AM
Ive been doing a fair amount of green screen work with Sony Movie Studio Platinum 12 lately. So far everything has been fine until my latest project. I have two video tracks (one on top of the other.) These are the green screen subject track and a background track. After I adjust the green screen settings in the chroma keyer dialogue box, everything looks good. All is normal when I play the two tracks together on the timeline.

However, when I am rendering the video, I can see a brief appearance of the green background every now and then in the footage. And when I play the completed video, I get this annoying flickering effect from the green showing through at random moments - and it's happening a lot within the clip. In other words, there are many instances where only the green screen track is visible (no background track) during the rendering and the finished video - if that makes any sense. And like I mentioned before, these issues are not visible when the project is played on the timeline.

I never had these problems with the previous green screen projects I did. The only difference with this one is I'm shifting the tracks quite a considerable distance in relation to each other after I adjust the chroma key settings (high threshold and low threshold.) I have to do this shuffling of the tracks back and forth because there is an element of timing in this video. An action occurs in the green screen subject track and this must coincide with another action that is visible in the background track. And I can't move the tracks into the proper position before I adjust the low / high thresholds because I need to see both tracks together (subject in the green screen track showing through the background track) in order to play around with the timing.

Is there anything I can do to stop this green flickering that I keep getting in the finished video?


musicvid10 wrote on 5/6/2016, 6:13 AM
Turn off GPU in Vegas.
dragonblade wrote on 5/6/2016, 10:28 AM
I'm not familiar with GPU. Ive done a google search but couldn't find out what it means exactly. Seems to be connected to the running of the software....I think. How would I turn it off?
musicvid10 wrote on 5/6/2016, 1:02 PM
Type the words 'turn off GPU' into a Search of this Forum.
Read first few posts and you will have your answer in no time at all!

After following the instructions, post back if the problem persists, along with complete media, project, and render properties, along with a link to a short file that has the problem.
vkmast wrote on 5/6/2016, 2:45 PM
Search also GPU in the SCS Support Knowledgebase section for general info.
"In current versions of Movie Studio and Vegas, go to Options -> Preferences -> Video (tab) and turn GPU acceleration of video processing OFF. Close and restart the application to apply the change."
dragonblade wrote on 5/6/2016, 10:55 PM
Vkmast, I followed your instructions but I see that the 'GPU acceleration of video processing' is already to set to Off.
dragonblade wrote on 5/7/2016, 2:13 AM
I solved the problem. And it looks like I was right with my original theory - it's the shifting of the tracks (after doing the green screen adjustments) that causes the problem. So what I had to do was start entirely from scratch with a new project, utilising the same footage. I took note of the start and end points of the individual clips when I trimmed them in the trimmer, then brought them on to the timeline as separate tracks and adjusted the green screen settings. I then moved one track back and forth to get the timing right (for the actions that occur in the two tracks.) When I was happy with the timing, I took note of the frame positions for both tracks (first and last frames) on the timeline and recorded the info into a word document along with the trimmer cut positions.

I then started a new project, opened the same clips in the trimmer and made sure that they were cut at exactly the same positions as in the previous project. I then brought them into the timeline and positioned them exactly the same as last time (according to the first and last frame numbers that I had recorded.) The very last step was the adjustment of the green screen settings (low and high threshold.) So basically a reversed order of doing things. When I rendered the video, the end result was perfect - no more problems.

Yes, it was a lot of extra work but it was the only way that I could figure out how to do this without the green showing through at random intervals, creating that annoying green flicker. From my previous experiences with green screen in Sony Movie Studio, if you move one or two tracks by a very small amount after adjusting the chroma key settings, this causes no issue. If you move a track a considerable distance in relation to the other track, this creates a problem. It might be invisible when you play the tracks together on the timeline but it will be evident during the rendering and the finished video.
dragonblade wrote on 5/23/2016, 6:33 PM
It certainly took a while but I got there in the end. The finished video can be seen here:

mike_in_ky wrote on 5/24/2016, 8:02 AM