DVD drive not recognised

Charles-Lewry wrote on 12/14/2019, 11:33 AM

I have recently upgraded from Windows 7 to Windows 10. Previously I have been using DVD Architect Studio 5.0 with no problems. Now, when I run the burn process in the device: drop down 'ISO image writer' is the only option. Other programmes can see the DVD drive e.g. Cyberlink 'Power 2 Go' disc burning.

Have tried uninstalling and reinstalling the DVD driver. I have now bought DVD Architect Studio 7.0 and that does the same thing.

 

Comments

vkmast wrote on 12/14/2019, 11:46 AM

@Charles-Lewry have you tried toggling Options / Preferences / Burning > Use legacy disc drivers?

Charles-Lewry wrote on 12/14/2019, 1:35 PM

Thank You, that seemed to work!

 

Charles-Lewry wrote on 12/14/2019, 1:42 PM

Just for reference, that option is only available on DVD Architect Studio 7.0 not 5.0

 

vkmast wrote on 12/14/2019, 2:59 PM

Yes, at least not in the early builds. Not sure if it was added in the later updates (#15x). Not sure either if "Skip drive database..." (in General Prefs.) would help.

Last changed by vkmast on 12/14/2019, 3:00 PM, changed a total of 1 times.

A volunteer forum moderator as of 11/27/2017. I don't work for VEGAS Creative Software.

Time Zone (FI) EET (UTC+2), EEST (UTC+3) as of 03/29/2020