Font styles missing from font

Ed-Lyons wrote on 9/25/2019, 2:16 PM

In VMSS16 in text and titles (I don't see legacy text anymore) the font list shows Montserrat Regular (free, open licensed TTF from Google fonts), but no other weights like Thin, Light, Semi-bold, Black, etc... They are installed correctly and work in all my other programs. VMSS is the only one not working. I NEED these other weights NOW for my current project. It seems like this bug was reported years ago and still not fixed. Is there a work around? Is there a timeline to fix it?


Marco. wrote on 9/25/2019, 2:23 PM

The workaround is to use a different titler in Movie Studio just like (Legacy) Text.

Ed-Lyons wrote on 9/25/2019, 2:33 PM

VMSS16 does not have (Legacy) Text any more. It looks like they dropped it after v15. I have NewBlue Titler Pro Express, but only see fancy options I cannot customize. I sometimes have a screen full of text (like a powerpoint slide) and need to mix and match styles. Importing all text as PNG or SVG will be a royal pain!

vkmast wrote on 9/25/2019, 2:40 PM

Please read here.


Ed-Lyons wrote on 9/25/2019, 3:12 PM

FANTASTIC! Thank you! Legacy will supply most or all of my needs for this type of text requirement. While I was waiting for replies, I remembered an old ttf editor I have (TypeTool 2) and started making new font files from the old ones. I renamed Montserrat Black to MontBlack inside the file, installed it, restarted VMSS and then it showed up in text and titles. I tried the same thing with MontRegular, but it showed up only in legacy. Sigh.

Ed-Lyons wrote on 9/25/2019, 4:22 PM

I did some more work on this problem. Now all my missing fonts are showing up. (I'm worried they will remove legacy text and then I might need to rework if I need to re-render.) INSIDE the font file I 1) changed all instances of OldName to NewName, 2) changed weight to regular, 3) changed version number for good measure. The idea is that windows and apps must recognize the new font as entirely unrelated to the old font. Different apps look at different parts of the info inside the file. Just copying the old font file to a new renamed file is not enough. Hope this helps!

tags: missing fonts, missing font styles, missing font weights, font disappeared, font does not show

PS. The correct font and weight shows up in text and titles, but an arbitrary weight is rendered. Sigh. Still working on this.