License Expired and Crashing Constantly

JM_Wigand wrote on 10/13/2015, 5:35 PM
I was finishing up a project and it kept crashing again and again. In my frustration of being unable to complete it I kept reloading, renaming the file, etc. to try and bypass Vegas idiotic crashing which was probably just because there were too many elements to the movie and Vegas is overly sensitive to that.
I decided to re-install it. Now I can't get into Vegas at all. An error message pops up saying:
Your product license has expired.
Expiration date: 10/11/2015
OK

No other options like: Enter product key or renew license. Just screwed. I bought this copy of Sony Vegas Movie Studio HD 9.0C USED. I had no idea there was some licensing going on, nor that it would render the program completely useless with no means of fixing the problem.

What do I do?

Comments

Former users wrote on 10/13/2015, 6:13 PM
Contact Sony Customer service.

I have never heard of a license expiring so it sounds like you might have bought a hacked version. Someone can sell their Vegas license, but it comes with a serial number and should be transferred thru Sony.
Chienworks wrote on 10/13/2015, 6:21 PM
I'm wondering if that expiration message is coming from something other than Vegas.
TreeTops wrote on 10/14/2015, 10:26 AM
He bought version 9 used. That's too old for todays videos. Getting a version that 5 years old is beyond me.
ChaserChick87 wrote on 7/10/2016, 9:19 PM
I am having the same problem.

Only mine HAD been working with absolutely NO problem, whatsoever. Until I got a virus on my computer.

Long story short, i wiped my laptop, reinstalled everything and got everything situated.

Then i reinstalled Movie Studio HD 9.

Same thing happened to me - product license expired (same date, even).

Mine was also used. I didnt buy mine, though. A friend of mine sent it to me as a gift for Christmas. He had bought it for himself a while ago, it ended up not working for what he needed it for and sent it to me.

He told me hed send it to me in August. Well, life happened and he didnt get it sent out until December, right around Christmastime (23ish, i believe)

I LOVE taking video of storms and turning them into time lapses in post-production, adding music and so on and so fourth.

This is exclusively a hobby for me, i do it because i love doing it. I also have never had any "formal" training, everything i know has been self-taught.

...wow, kinda got sidetracked for a little bit. Sorry. Lol.

Anyway, when i got the software, the license was still in his name. I was not aware of this, so after i wiped my computer (it was horribly slow and would constantly say "not responding" to almost everything i was doing), I reinstalled it.

Well, something happened, and i wasnt able to use it anymore. My friend suggested i transfer the license from him to me. I was unaware you could even do that.

Talked to Customer Support twice, first time was before i was aware i could transfer the license (the guy i talked to was i, i thought, just a tad rude.

The second time i talked to this VERY nice lady. I told her my problem, gave her some information, she did her thing. She told me that when she was done transferring the license over, she said she had increased the number of times you could install the software before it wouldnt let you install it anymore. Said she increased the amount to where she said i wouldnt have that problem again.

It worked fine after that.

Until the last time i wiped my computer. I even reinstalled all the drivers i had been missing after i wiped my laptop (12 of them), thinking that would fix the problem. Nope.

That is where i ran into the error message.

BTW, i KNOW this is an older version of the software, i am currently downloading a trial of Movie Studio 13 Platinum. I will probably upgrade sometime after that.

PS...I am VERY sorry this is so long.

Larry Clifford wrote on 7/11/2016, 8:43 AM
ChaserChick87,

You stated that you like taking videos of storms. Do you have any available to the public for viewing? I think they would be interesting.

Thank you,
Larry
Chienworks wrote on 7/11/2016, 9:15 AM
I still think it's something else going on though. Vegas licenses don't expire, ever. I could install Vegas 2 from the license i had 15 years ago and be up and running.

You may run out of available activations if you've reinstalled and reactivated too many times, but a simple call to customer service clears that up. And, the message you get is either "error -41" or "activation limit exceeded." You should *never* see a message about the license expiring, at least not from sonycreatiesoftware programs. Their licenses are perpetual.
UKharrie wrote on 7/18/2016, 8:52 AM
Whilst it may be policy to be perpetual ( thanks Sony), the messages are part of Windows Routines . . . so a small error somewhere may be bringing up this message which has no meaning to the viewer.User.

That it is crashing may also point to some errors . . .or conflict with new hardware, etc....even if that hardware is working correctly . . . it may have inadvertently put a spoke in the wheel, as it were.

Maybe get yr dealer to give the PC a good flushing - or a new HDD is cheap enough and gives you some years of peace.
jerochk wrote on 7/22/2016, 3:28 PM
Okay, so I thought I'd jump in here since I too am having the same issue. However, I am not too tech savvy in that I wouldn't know what else would be causing this..

Just a bit of background on my problems with the program:
If memory serves me well, I bought this program at a Best Buy - and I'm going to say that I'm 90% sure about that since there is a price sticker on the box. And no I did not buy this recently - maybe 2009 or '10.
Only a few days ago did I decide I wanted to make a new project/video (I'm into making fan videos of shows and such).
I fixed all the initial issues I was having such as wrong file type, etc. My next issue was figuring out how to get the playback to render properly. I found about the whole Shift-B rendering thing, to play back sections, which was working marvelously but was short lived.
I was having problem after problem with the playback and then I started having problems with it "not responding".
I would get it to work by messing around with a preference here, a property there, but as of yesterday nothing seems to be getting it to play back for me. I click to a certain point on the timeline and bam!, not responding.

So, about the license expiration. I first saw this when I tried to install it on my friend's computer since his has way more memory and such. It said the same thing, same date. October something 2015.

No biggie, I still had it on my computer - however, my last resort (or at least what I thought was) with getting it to work was to uninstall and reinstall the program on my own computer.
Annnnnnd expired.

Now I have nothing. Can't get it to reinstall.

Apologies for the long post, but wanted to give a bit of detail ...
My thing is, I wouldn't know what else that could be causing this. And as far as my program being a hacked one, I don't see how that would possible as I'm fairly certain I bought this in store.

I'm kind of desperate right now for finding a solution because I don't have a lot of money to throw around and buy a new program or HDD or whatever else.

Any help is GREATLY appreciated!!
-Jen
hmlake wrote on 7/22/2016, 4:25 PM
Hello, I was able to get past this license expired message on Sony Vegas Movie Studio HD 9.0 by temporarily setting the time back on my computer to 2014. Good luck.
jerochk wrote on 7/22/2016, 6:41 PM
Oh really?? Not sure why I hadn't thought of that haha Okay, I'll give that a go - thanks so much!
Then I'll have to see if that fixes my other problems - to be continued!

EDIT:
Okay so I was able to reinstall the program by setting my date back.
However, the "not responding" problem continues - so I guess reinstalling it didn't fix that :(

First time I tried to open my project, after a few seconds, it gave me an error message. This is what the details said:
Vegas Movie Studio HD 9.0
Version 9.0c (Build 30)
Exception 0xC0000005 (access violation) WRITE:0xFE000010 IP:0x77E19F83
In Module 'ntdll.dll' at Address 0x77DD0000 + 0x49F83
Thread: VideoRender ID=0x151C Stack=0x1321F000-0x13220000
Registers:
EAX=fe000010 CS=0023 EIP=77e19f83 EFLGS=00010286
EBX=fe00000c SS=002b ESP=1321fc60 EBP=1321fc64
ECX=fe00000c DS=002b ESI=13eb7608 FS=0053
EDX=00244000 ES=002b EDI=fe000000 GS=002b
Bytes at CS:EIP:
77E19F83: F0 0F BA 30 00 73 14 8B ...0.s..
77E19F8B: 42 24 89 41 0C 33 C0 C7 BA.3..
Stack Dump:
1321FC60: FE000000 7FFF0000 + 7E010000
1321FC64: 13EB7608 13810000 + 6A7608
1321FC68: 006B655F 00400000 + 2B655F (VegasMovieStudioHD90.exe)
1321FC6C: FE00000C 7FFF0000 + 7E01000C
1321FC70: 00000026
1321FC74: 13EB7608 13810000 + 6A7608
1321FC78: 00000006
1321FC7C: 006B5973 00400000 + 2B5973 (VegasMovieStudioHD90.exe)
1321FC80: 13EB7608 13810000 + 6A7608
1321FC84: 0EAFB1D0 0E7B0000 + 34B1D0
1321FC88: 0059D086 00400000 + 19D086 (VegasMovieStudioHD90.exe)
1321FC8C: 00000000
1321FC90: 00000000
1321FC94: 00000000
1321FC98: FFFFFFFF
1321FC9C: FFFFFFFF
> 1321FCB4: 0059D2C3 00400000 + 19D2C3 (VegasMovieStudioHD90.exe)
1321FCB8: 97010CF2 7FFF0000 + 17020CF2
1321FCBC: 13EB7608 13810000 + 6A7608
1321FCC0: 00000001
1321FCC4: 0EAFB1D0 0E7B0000 + 34B1D0
> 1321FCD0: 77D0E6E0 77CF0000 + 1E6E0 (KERNEL32.DLL)
> 1321FCDC: 77D0E758 77CF0000 + 1E758 (KERNEL32.DLL)
> 1321FCEC: 635E7344 635D0000 + 17344 (MSVCR80.dll)
> 1321FD4C: 77E46DDC 77DD0000 + 76DDC (ntdll.dll)
> 1321FD50: 750D9EB0 75020000 + B9EB0 (KERNELBASE.dll)
> 1321FD60: 005A02CD 00400000 + 1A02CD (VegasMovieStudioHD90.exe)
1321FD64: 97010CF2 7FFF0000 + 17020CF2
1321FD68: 13EB7608 13810000 + 6A7608
1321FD6C: 00000001
1321FD70: 0EAFB1D0 0E7B0000 + 34B1D0
> 1321FD8C: 005A0B65 00400000 + 1A0B65 (VegasMovieStudioHD90.exe)
- - -
1321FFF0: 00000000
1321FFF4: 005A1E90 00400000 + 1A1E90 (VegasMovieStudioHD90.exe)
1321FFF8: 0EAFB1D0 0E7B0000 + 34B1D0
1321FFFC: 00000000



What does that mean??
I tried opening it again, and it didn't give me any message but just stopped responding.
MSmart wrote on 7/23/2016, 10:54 PM
@jerochk,

Does this happen for all projects or just a specific one. If just one, it could be corrupt and nothing you can do about it.
jerochk wrote on 7/24/2016, 10:25 PM
Just the one, that I know of :(
Do you think if I try to redo the project, maybe using a different video file, that it might work?

Thanks for replying, by the way. :)
vkmast wrote on 7/25/2016, 7:14 AM
jerochk, you could try these steps.
Find the backup project with the extension of .vf.bak in the same folder. Copy it to a new name .vf and see if that opens.
If you think it might be the media, copy the .vf file to a new folder and open it. If the project is not corrupt, it should prompt you for the missing media. If the project won't open, the project file is probably corrupt.
jerochk wrote on 7/25/2016, 4:51 PM
I'm sorry if I'm being a complete doofus about this...

Okay, so I tried your first suggested step, didn't open correctly.
I tried to move all the media files to a new folder with a new name - I opened the project, it prompted me to search for missing media, which I did (except for one cause I forgot what I had renamed it) but it still didn't play through. Tried this once more but still nothing.
The project opens, it just then stops responding.

And this ^ is from my second attempt at this project.
I started from scratch last night and it was working fine. The only time it stopped responding was when I clicked the "project media" tab - for whatever reason...
So then today, I was working on it again, and all was well until I accidentally clicked that same tab. Then it stopped responding and it's been messed up since... I could tell it was all messed up because the thumbnails of the video clips in the timeline changed to just the initial screenshot that the thumbnails have in my folder. (This is when I tried your suggestions)

Anyway...If this is just a lost cause, let me know and I'll stop. Seems like this program just does not want to work with me any longer. Might be time for an upgrade. :/

I appreciate all the help, though, I really do!!
vkmast wrote on 7/25/2016, 5:11 PM
jerochk, you might try the trial of MS Platinum 13. It's still available to download from this site and the upgrade price in the SCS Online Store seems reasonable. May be available from there only for a few days now though due to the MAGIX acquisition of most of the SCS software.
jerochk wrote on 7/25/2016, 5:30 PM
Okay, thank you, I'll give that a go :)
ChrisRedfield wrote on 8/24/2016, 9:00 AM

The registration wouldn't work because it kept saying that the registration code had expired last year.Then after researching this error message,I read that you had to change the pc date and time to year or two back.Then I had to enter the additional authentication code,then lastly I had to change the date and time to the current date and time and then try to reregister the software and then it worked,with no problems.