Sony Movie Studio Platinum 12 stopped rendering giving Error msg.

Eli-Cohen wrote on 12/19/2020, 11:29 AM

For the past week or so Every time I want to RENDER the program crashes.
What happen is that I made a mistake by disabling "Write cache on device " in windows device manger.
The system then did NOT reboot and needed "Startup repair"
and since then the program does not render to HDD.
I Did reset settings by CTRL+SHIFT+LAUNCH
I did remove the program and reinstalling it 2 or 3 times.
and yet no render.

My system: MB: Z87
CPU: I7-4770

Windows 7 Pro.

As contacting Sony they sent me here: The MAGIX Software support team has taken over support for all VEGAS and Movie Studio products. To receive support for your VEGAS Movie Studio Platinum 12 software, you will need to contact their support team directly.


vkmast wrote on 12/19/2020, 11:51 AM

Were you able to clear the cache when resetting?

VEGAS Support link above your post.

Eli-Cohen wrote on 12/19/2020, 11:57 AM


YES I did.

And I did again just now and same error.

vkmast wrote on 12/19/2020, 12:19 PM

You could try proceeding from the link in this comment from Nick H.

Randy-Dreammaker wrote on 1/1/2021, 3:09 PM

Changes to Windows 10 have a new security feature that needs bypassed for V12 of Movie Vegas/Studio. This might fix your issue too. I use 12 on a similar PC. After not getting any useful help here in the forums or support, I did a video to document the issue and how I resolved it. This fixed my rendering crashes and install issues

Eli-Cohen wrote on 1/3/2021, 1:33 AM


I am using Windows7 so it's not really the solution

I tried to bypass firewall and Anti virus but still no help...

I get the same Error while rendering ONLY to HDD.

Rendering and burning DVD does WORK!

Eli-Cohen wrote on 3/9/2023, 6:50 AM

Rendering on VASST Render Assistant DO WORK! only "Make Movie" gives this Error.