Speeding up playback performance VP17 vs VP18

hambonio wrote on 8/4/2020, 3:11 PM

I now have a fresh Windows 10 Pro installation (2004).

The only software I have installed is VP18 and VP17.

For scrubbing footage: Typically with VP17 and VP14, I have been able to increase playback speed to 4x while still displaying max FPS, and with 7x playback speed with displaying ~18-22 FPS playback. I usually have my displays set to Best:Half for scrubbing.

With VP18, the frame-rate drastically starts dropping once I start going above 2.5x speed. Once I hit 4x speed it drops to 1-2 FPS, and 7x speed is less than 1 FPS playback. I tried setting the playback quality as low as Preview:Quarter with not much help.

I noticed this first with my basic install of VP18, so I also installed VP17 to make sure I wasn't going crazy. It still works like butter in VP17 at higher speeds, even at Best:Full it is almost full frame-rate.

I did try the tips in the video here: and maybe it seems to help just a touch, but I think it is my wishful imagination. It is still nowhere near the playback speeds of VP17 that had none of those options changed after a fresh install (I did change most of those options as well in VP17 after watching).

I also had the exact clip solo loaded into each version, basically setting up the same project but loaded on their own, and can switch between each version loaded at the same time and see a huge difference. No effects added, just simple bare 4K footage from my a7sii.

 

I now have tried both of the newest drivers for my Radeon VII - The normal and Enterprise versions - and the result is the same.

 

VP18 build 284 - VP17 Build 452

Radeon VII

3x Dell Ultrasharp U2718Q 27" 4K UHD Monitors

Ryzen 9 3900x,

Crosshair VIII Hero, X570 Motherboard

64GB RAM

 

Any other tips?

Comments

VEGASHeman wrote on 8/6/2020, 7:58 AM

I assume the footage from your A7SII is in XAVC-S format? If not, could you post the MediaInfo properties of the clip. Are you using the default settings for both VP17 and VP18? The main change is the addition of hardware decoding auto-selector, and from your description, it sounds like somehow the software decoder is being used for VP18. Once I get the above information from you, we can try to narrow this down further - you should not really see the kind of performance degradation you are experiencing.

hambonio wrote on 8/6/2020, 9:16 AM

Yes, they are XAVCS-4K 60M (I have not tried the 100M files yet)

I am also experiencing the same issues on my secondary PC with an AMD RX480 GPU and i7-5960 CPU. I can pass along the rest of that system as well if needed. My main system I have in my profile (Radeon VII GPU with R9 3900x CPU).

RogerS wrote on 8/6/2020, 9:25 AM

You need to paste in full media info.

VEGASHeman wrote on 8/6/2020, 9:28 AM

Can you report the decoder used for this clip in both VP17 and VP18, by doing the following:

1. Add clip to timeline

2. Right click on the video event for the clip, and select "Properties" from the context menu

3. Select the "General" tab with SHIFT key pressed; this should bring up some additional entries, including "Streams (Debug)". Please note down the "Codec name", and provide that to us.
 

As you see similar behavior for your secondary i7 PC too, please do the same for both VP17 and VP18 on that too.

On your primary AMD CPU, the default decoder (indicated by "Auto") should be the AMD UVD/VCN, but on the secondary system, it should be Intel QSV.

VEGASHeman wrote on 8/6/2020, 9:28 AM

This is what the debug entry should look like:

VEGASHeman wrote on 8/6/2020, 9:31 AM

@RogerS: Yes, that is normally always helpful, but in this case as the footage is from the SonyA7SII, and is a well known format (XAVC-S), extra info is not needed at this time.

hambonio wrote on 8/6/2020, 10:32 AM

Here is what I have on My i7-PC

I have included part to my system info in the screenshots below to verify I am using an Intel CPU.

In VP18 it IS in fact showing up as 'AMD UVD AVEDecoder'

In VP17 it is showing up as 'MainConcept Professional AVC Decoder'

 

I will check my main PC shortly

 

These are 2 separate projects opened as new with the same clip dragged in. So no transferring from one version to the other.

hambonio wrote on 8/6/2020, 10:33 AM

Sorry here are the screenshots From the Intel CPU PC:

hambonio wrote on 8/6/2020, 11:17 AM

Here are screenshots from my AMD CPU PC:

VP18 with no options selected: - it says 'AMD UVD AVC Decoder'

VP18 with "Enable legacy AVC decoding" - the codec is blank

VP17 with no options selected - it says 'MainConcept Professional AVC Decoder'

VP17 with "Enable Hardware Decoding for supported formats" - it says the same 'MainConcept Professional AVC Decoder'

 

I also noticed on the AMD CPU PC the files and projects load with "Legacy 8-bit (video levels)", but on the Intel CPU PC the files and projects load with "8-bit (full range)". Neither of those options seen to affect playback performance.

VEGASHeman wrote on 8/6/2020, 12:06 PM

Thank you for the information.

As you noted, VEGAS is in fact using the hardware decoder for VP18 ("AMD UVD AVC Decoder"), because of the auto-detection feature introduced, but for VP17 it is using the software decoder ("MainConcept Professional AVC Decoder") - because the default option, "Intel QSV" is not available, and for this file, you are getting better performance out of the software decoder (probably because of the extra cores).

Your Intel processor on the secondary PC does not support QSV (as it is one of the Extreme editions), so the default decoder used there is also the AMD one, and hence you get similar behavior.

Could you switch the "Hardware Decoder To Use" to "Off" in VP18, and see if you see the same performance as VP17, for this file?

hambonio wrote on 8/6/2020, 12:17 PM

Thanks for following up, where is the "Hardware Decoder to Use" option?

vkmast wrote on 8/6/2020, 12:28 PM

Options > Preferences > File I/O

john_dennis wrote on 8/6/2020, 12:33 PM

@VEGASHeman

Here's a data point for your amusement...

Vegas 18-284 AMD UVD AVC Decoder

Vegas 18-284  MainConcept Professional AVC Decoder

VEGASHeman wrote on 8/6/2020, 12:47 PM

Thanks, @john_dennis. What kind of AMD GPU do you have?

We were aware of issues with HEVC decoding with the older generation of AMD GPUs, but this indicates that even certain AVC files may be a problem. Could both you and @hambonio share the files, to allow us to take a closer look at what is going on?

john_dennis wrote on 8/6/2020, 12:52 PM

@VEGASHeman

Card type RX480-8GB is shown on the Task Manager / GPU 0 and in my profile. I'll gladly run the OP @hambonio files if needed.

hambonio wrote on 8/6/2020, 12:57 PM

When I turned that option to OFF and had to clear all check boxes above, the 4x speed now gets up to 7-8 fps playback, and it does note that it is now  'MainConcept Professional AVC Decoder' as it showed in VP17, but still not buttery smooth at 4x playback like VP17. It is an improvement.

As far as a file goes, I can send another smaller file from the same day or camera (I believe all my shorter clips from that day were captured at 30p, but most other clips I capture of those cameras are 24p)? That particular file is 4.93 GB. And how to share it?

john_dennis wrote on 8/6/2020, 12:59 PM

@hambonio

dropbox.com, onedrive, etc. and share the link. Or, I can shoot XAVC-S UHD-23.976p at 60Mbps, but not on an A7S.

hambonio wrote on 8/6/2020, 1:01 PM

Okay let me find a smaller/other file from that camera with less private audio on it.

hambonio wrote on 8/6/2020, 1:32 PM

https://www.dropbox.com/s/w13fdk4rnv72h6y/a7s2%20Emily%20and%20Ross%20%28108%29.zip?dl=0

My secondary PC is the same gpu as yours RX480 8GB.

My main PC is Radeon VII.

 

Oddly, while I was waiting for the dropbox file to upload, I did experiment with some proxies (I have not felt the need to use these in years). The RX480 seems to handle them fairly well, the Radeon VII 16GB RAM not so smooth. But that was just observation here while testing. I would rather not deal with proxies period.

john_dennis wrote on 8/6/2020, 3:03 PM

@VEGASHeman

I used the files provided by @hambonio and ran all tests at Best / Full on Vegas 17-452 and 18-284. The system from my profile fell down between 2.5 and 3.0 playback rate.

17 Mainconcept

17 AMD UVD

18 Mainconcept

18 AMD UVD

lenard-p wrote on 8/6/2020, 7:50 PM

Would people be able to try this XAVC file. for me using 10 series nvidia gpu and nvidia decode it crashes vegas. If it loads with your setup I'd like to hear about it

https://drive.google.com/file/d/1F5wvEt0RBYysCLbe_IjoHFIQS3u7LkWy/view?usp=sharing

lenard-p wrote on 8/6/2020, 10:49 PM

The permissions were incorrect for this file. if you tried to download it before, please try again

RogerS wrote on 8/6/2020, 11:59 PM

Nope, doesn't work. Vegas hangs. This is a7sIII, HEVC 4K60- 10 bit?

The rest of Tony's video files are here:
https://drive.google.com/drive/folders/1_T0-fPMhneSxlyUmW0yfdNpi_5DCNN51

lenard-p wrote on 8/7/2020, 12:09 AM

The a7sIII XAVC HEVC files do not load in VP because Vegas doesn't like HEVC with pcm audio. So I thought a work around that doesn't require much resources is simply to change the audio to AAC, and leave the video alone. So that download link is to modified version with AAC audio.

Vegas may have good reason to not play non standardised videos, as it may help with stability. It won't play the default XAVC-S HEVC file because it's non standard as far as it knows (VP18 does not know about a7sIII files) and XDCAM-S HEVC with AAC audio is ofcourse non standard, but Davinci Resolves plays back both versions and it is one of the worst editors as far as demanding 'legal' codecs