Unwanted Looping

Bambino wrote on 7/9/2016, 7:00 AM
Suddenly, whenever I double click on a picture on the timeline in Sony Vegas I create a loop for that picture. I don't know what I have done to bring this about. I have tried using the Edit menu --> Switches and turning off the tick beside 'Loop' but it makes no difference - the next time I double click, the picture is looped and the tick has reinserted itself on the Switch submenu. Can anyone tell me what has caused this and how I can make things return to normal?

Comments

Former users wrote on 7/9/2016, 8:40 AM
What do you want it to do when you double click?
Bambino wrote on 7/9/2016, 8:57 AM
I want to select the area above it (exactly) so that any text frame or generated media i insert will be positioned precisely above the picture.
Eagle Six wrote on 7/9/2016, 11:46 AM
Hi Bambino,

Generated media will position starting at the cursor position. The video below the text track doesn't have to be selected. Position the cursor on the text track and then double click on the media you wish to insert. Does this help, or am I missing something?


Best Regards.......George

System Specs......
Corsair Obsidian Series 450D ATX Mid Tower
Asus X99-A II LGA 2011-v3, Intel X99 SATA 6 Gb/s USB 3.1/3.0 ATX Intel Motherboard
Intel Core i7-6800K 15M Broadwell-E, 6 core 3.4 GHz LGA 2011-v3 (overclocked 20%)
64GB Corsair Vengeance LPX DDR4 3200
Corsair Hydro Series H110i GTX 280mm Extreme Performance Liquid CPU Cooler
MSI Radeon R9 390 DirectX 12 8GB Video Card
Corsair RMx Series RM750X 740W 80 Plus Gold power pack
Samsung 970 EVO NVMe M.2 boot drive
Corsair Neutron XT 2.5 480GB SATA III SSD - video work drive
Western Digitial 1TB 7200 RPM SATA - video work drive
Western Digital Black 6TB 7200 RPM SATA 6Bb/s 128MB Cache 3.5 data drive

Bluray Disc burner drive
2x 1080p monitors
Microsoft Window 10 Pro
DaVinci Resolve Studio 16 pb2
SVP13, MVP15, MVP16, SMSP13, MVMS15, MVMSP15, MVMSP16

Bambino wrote on 7/9/2016, 3:14 PM
Thanks for that, George. But I am still puzzled. I used to be able to double-click without creating a loop. Now when I do it the loop is created. What can I have done to alter the status quo?!
Eagle Six wrote on 7/9/2016, 6:12 PM
Hi Bambino,

Are you using Movie Studio or Vegas Pro, and what version? Have you ever gone to 'Options', then held down the 'Shift' key when you left clicked on 'Preferences'? This would produce an additional tab on the 'Preferences' display called 'Internal'. I don't think there is anything in there that allows you to change how your mouse works.

Vegas Pro has an option to change the keyboard key assignments. Although I don't think it will allow you to change the left mouse button, it may. Movie Studio doesn't have that option that I'm aware of.

I have Movie Studio 12 and 13 platinum, Vegas Pro 13 and the trial version of Vegas Pro 12. They all by default assign a loop region to an even that I double left click on, just as yours is doing. So that puzzles me, how your version didn't use to work like that! Hopefully someone else will jump in hear to explain.


Best Regards.......George

System Specs......
Corsair Obsidian Series 450D ATX Mid Tower
Asus X99-A II LGA 2011-v3, Intel X99 SATA 6 Gb/s USB 3.1/3.0 ATX Intel Motherboard
Intel Core i7-6800K 15M Broadwell-E, 6 core 3.4 GHz LGA 2011-v3 (overclocked 20%)
64GB Corsair Vengeance LPX DDR4 3200
Corsair Hydro Series H110i GTX 280mm Extreme Performance Liquid CPU Cooler
MSI Radeon R9 390 DirectX 12 8GB Video Card
Corsair RMx Series RM750X 740W 80 Plus Gold power pack
Samsung 970 EVO NVMe M.2 boot drive
Corsair Neutron XT 2.5 480GB SATA III SSD - video work drive
Western Digitial 1TB 7200 RPM SATA - video work drive
Western Digital Black 6TB 7200 RPM SATA 6Bb/s 128MB Cache 3.5 data drive

Bluray Disc burner drive
2x 1080p monitors
Microsoft Window 10 Pro
DaVinci Resolve Studio 16 pb2
SVP13, MVP15, MVP16, SMSP13, MVMS15, MVMSP15, MVMSP16

vkmast wrote on 7/10/2016, 2:17 AM
As Eagle Six points out, double-clicking assigns a loop region here. He gives correct advice in his two posts above.

Note that up to v.11 Vegas Movie Studio Platinum had the "Collapse loop region when no time selection is present" option in Options > Preferences > Editing. It made the loops disappear every time you clicked anywhere. That option was removed for Movie Studio Platinum 12.0 "due to a decision made by the developers." (It's still in Vegas Pro though.)

Note too that you can press the "i" and "o" keys and this collapses the loop region to a simple point and effectively disables it.
I don't remember seeing a way to return the yellow flags to the start without dragging.
Remember that the selection only loops when you have "Loop Playback" enabled. It's the circular arrow button (KB shortcut is "q") in Transport Controls. So if you don't want looping, keep it disabled. If your loop region is selected/highlighted, it's still played though.

Note three Deleting a loop region.

Bambino wrote on 7/10/2016, 3:19 AM
Thanks George and vkmast for that information. I am using Vegas Movie Studio 10. I see I posted a question on looping some time ago - sorry about that, I'd quite forgotten.

I didn't realise the use of the i and o keys, and that is making my life a lot easier - much better than dragging to get rid of the loop. Back to my project, with much appreciation for your help.
Chienworks wrote on 7/11/2016, 9:10 AM
I've found that about 99% of the time, if not more, looping doesn't really matter, especially if you have loop playback turned off. Some folks find the visual of the highlighted section objectionable, but if you learn ti ignore it, it pretty much is ignorable. It really doesn't affect you in anything else you're trying to do.