Effects window is cropped.

Neelie wrote on 6/20/2020, 8:27 AM

Using effects like pinch/punch have this weird little window crop after the second time using it. I don't know what I did last time I used it. It was completely normal. I tried resetting the computer and it still didn't work. Even uninstalled and installed Vegas Pro 15 again, but still no dice. I'm sure I'm on the latest version (not sure which one though but it's the latest)

 

My Specs (if this helps)

OS: Windows 10 Professional

GPU: NIVDIA GEFORCE RTX 2070 SUPER

 

Hopefully I get a response and fix for this soon.

Comments

Dexcon wrote on 6/20/2020, 8:34 AM

I don't have VP15 installed any more, but check Options/Preferences/Display to make sure that 'Use High DPI scaling' is nor selected. Also, if you are using a 4K monitor, that High DPI setting may need to be on, or your Windows display setting may need to be adjusted to to 125% or other.

I vaguely recall that there may have been a display problem like this back in the earlier days of Vegas Pro.

Neelie wrote on 6/20/2020, 12:04 PM

I don't have VP15 installed any more, but check Options/Preferences/Display to make sure that 'Use High DPI scaling' is nor selected. Also, if you are using a 4K monitor, that High DPI setting may need to be on, or your Windows display setting may need to be adjusted to to 125% or other.

I vaguely recall that there may have been a display problem like this back in the earlier days of Vegas Pro.

So I tried what you said, by finding the High DPI settings in the program's properties tab under compatibility. I have an FHD monitor (not 4K or UHD) and it still didn't work. The DPI scaling feature wasn't even selected. I also tried changing the display settings to 125% and everything looked larger and a bit fuzzier than before, regardless it still didn't work.

vkmast wrote on 6/20/2020, 12:26 PM

Try and search "serif" and/or "serife" on this forum for possible solutions.

michael-harrison wrote on 6/20/2020, 12:26 PM

It's a font issue...

 

"OK.  I got it working.  For any who see this problem...  It appears the "true type" sans serif font is the only one in the base windows installation.  My guess is that this font needed is an older style, non-true type font.  I just googled "MS Sans Serif 8,10,12,14,18,24" and downloaded the font file from a website.  Then double click the .fon file in windows and it will show you samples and have a button in the window to "install".

 

From <http://www.vegascreativesoftware.info/us/forum/solved-my-ui-is-very-messed-up--102907/> "

System 1:

Processor        Intel(R) Core(TM) i7-8700 CPU @ 3.20GHz, 3192 Mhz, 6 Core(s), 12 Logical Processor(s)

BaseBoard Product        ROG STRIX Z390-E GAMING

Installed Physical Memory (RAM)        32.0 GB

Adapter Description        NVIDIA GeForce GTX 1660

Driver Version        Studio <the latest stable>

Resolution        1920 x 1080 x 60 hertz

Video Memory 6G GDDR5

 

System 2:

Lenovo Yoga 720

Core i7-7700 2.8Ghz quad core, 8 logical

16G ram

Intel HD 630 gpu

Nvidia GTX 1050 gpu

vkmast wrote on 6/20/2020, 12:45 PM

https://www.vegascreativesoftware.info/us/forum/solved-my-ui-is-very-messed-up--102907/ is indeed one of the many threads on the subject.

Neelie wrote on 6/20/2020, 2:28 PM

Followed the above, didn't work still, even after trying to clear the cache by pressing CTRL + SHIFT upon loading Vegas Pro. https://prnt.sc/t3g8fe

vkmast wrote on 6/20/2020, 2:52 PM

What exactly did you try besides resetting? Did you check any of the threads in the link above?

Neelie wrote on 6/20/2020, 3:05 PM

What exactly did you try besides resetting? Did you check any of the threads in the link above?

Okay, so.. I looked up "MS Sans Serif 8,10,12,14,18,24" and downloaded and installed sserife.fon, Win+R and typed regedit, went to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts and changed the value of "MS Sans Serif 8,10,12,14,18,24" that was already there (SSERIFE.FON) to SSERIFER.FON. Restarted my computer, even hard resetted. Cleared the cache with CTRL+SHIFT upon Vegas Pro 15 and checked to see if it worked.

 

Surprisingly, it.. didn't.

vkmast wrote on 6/20/2020, 3:40 PM

Thanks. If this thread does not give you any more clues to the solution, contact Support. The link is in my second comment in that thread.

Neelie wrote on 6/20/2020, 8:44 PM

Thanks. If this thread does not give you any more clues to the solution, contact Support. The link is in my second comment in that thread.

So I guess that was the problem after all, I had the same problem he had. Glad it works now.

wwaag wrote on 6/20/2020, 8:50 PM

Just tried it on my system in V15 and it works without issue using both FHD and UHD monitors with dpi ranging from 125 to 300. Incidentally, there is no High-dpi setting in V15. That wasn't introduced until V16 as "experimental". Its clearly a scaling issue since the font inside is so much larger.

Just changed the scale to 150% using FHD monitor and the results look very much the same.

Make sure that the display scale is set to 100% in display settings.

vkmast wrote on 6/21/2020, 1:01 AM

The first reports of this issue I've seen were from around 2012.

fifonik wrote on 6/21/2020, 10:26 PM

Recently I noticed that I also have the issue. This does not bother me as I thought only some kind of outdated plugins affected (that I did not use).

However, when I read this thread I tried to fix the issue.

- .fon font was correctly installed in my W10 Pro 1909 and mentioned in registry. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts\MS Sans Serif 8,10,12,14,18,24 = SSERIFER.FON (I tried to reinstall font with no success)

- My display resolution is 1920*1200 and DPI scale -- 100%. No custom DPI scale specified for VP

- Starting VP with CTRL + SHIFT pressed did not help (Resetting cache? I did not know about this)

 

The solution in my case was to un-tick the UTF8 checkbox (as per this post) and restart windows (Settings | Time & Language | Language | Administrative language settings | Change system locale... | Beta: Use Unicode UTF-8 for worldwide language support).

Last changed by fifonik on 6/21/2020, 10:29 PM, changed a total of 1 times.

Camcorder: Panasonic X920

Desktop: MB: MSI B450M MORTAR TITANIUM, CPU: AMD Ryzen 3700X (not OC), RAM: G'Skill 16 GB DDR4@3200 (not OC), Graphics card: MSI RX580 8GB (factory OC), SSD: Samsung 970 Evo+ NVMe 500MB (OS), HDDs: Seagate & Toshiba 2TB, OS: Windows 10 Pro 1909

NLE: Vegas Pro [Edit] 11, 12, 13, 15, 17