How to trim an overlapping event? (Solved: use Trim-to-Fit.)

gary-o wrote on 6/23/2020, 9:47 PM

If I copy/insert an event that overlaps the next event, I usually want to trim the end of the new event to match up with the start of the existing event.

But when I move the cursor to the end of the new event, it doesn't change to the trim tool. Is this a bug? Or am I missing something? Is there a preference setting that I need to change perhaps?

The workaround I use is to expand the track, trim the event and then collapse the track again. It's a bit irritating (especially as Num5 for expanding/collapsing a track doesn't work on a laptop keyboard. That might be another bug or oversight, but the workaround for that is to define a different key combination for that in customize keyboard.)

 

Comments

wwaag wrote on 6/23/2020, 10:08 PM

Unless I'm missing something, you simply click the end of pasted/inserted event and drag back to the start of the existing event. Here's a demo.

gary-o wrote on 6/23/2020, 10:29 PM

Oh, that's exactly what DOESN'T happen when I do the same thing! The cursor arrow doesn't change to the trim tool when I hover of the right edge of the event.

(It changes to the trim tool if I hover over the left edge of the event underneath.)

I'll contact technical support, it must be a weird bug or configuration error...

Thanks

fifonik wrote on 6/23/2020, 11:07 PM

Another way to do this -- use "trim to the end" command using Alt + ] shortcut.

Camcorder: Panasonic X920

Desktop: MB: MSI B450M MORTAR TITANIUM, CPU: AMD Ryzen 3700X (not OC), RAM: G'Skill 16 GB DDR4@3200 (not OC), Graphics card: MSI RX580 8GB (factory OC), SSD: Samsung 970 Evo+ NVMe 500MB (OS), HDDs: Seagate & Toshiba 2TB, OS: Windows 10 Pro 1909

NLE: Vegas Pro [Edit] 11, 12, 13, 15, 17

gary-o wrote on 6/23/2020, 11:42 PM

That little aqua colored triangle on the right tells me that is where the edge of event is, not where you are pointing.

Yeah, that's the starting edge of the following event. The event I just inserted seems to be underneath the next event and hovering over the right edge doesn't allow me to trim it (as in wwaags video above)...

gary-o wrote on 6/23/2020, 11:48 PM

Another way to do this -- use "trim to the end" command using Alt + ] shortcut.

That's not working either - it leaves a gap between the end of the "trimmed-to-end" event and the start of the next event. (But at least it then allows me to drag the edge to meet up with the next event... so it's a useful workaround, thanks.)

wwaag wrote on 6/24/2020, 12:34 AM

Just found the problem. Under Options you must select Automatic Crossfades. If not selected, I get the same layout as your initial screen grab. Turn on Automatic Crossfades and it works as shown in the demo.

gary-o wrote on 6/24/2020, 12:54 AM

Just found the problem. Turn on Automatic Crossfades and it works as shown in the demo.

Thanks, I don't know if it was designed that way - but I would have thought, automatic crossfades or not, one should still be able to grab the edge of an event and trim or extend it. :)

Yellandkeil wrote on 6/24/2020, 3:09 AM

You are able to do it: Expand Track Layers. This has been discussed so crazily just before sometime under PEOPLE who have trouble reading (Vegaspro manual).

vkmast wrote on 6/24/2020, 3:17 AM

Yes. And please note the difference, (from the FAQ): 28. Why is my video track split between "A" & "B" tracks?
If a red square bracket appears at the end of one of your video events then you are in Expanded Edit Mode. To exit expanded edit mode, do one of the following:

Choose "Edit" > "Select" > "Exit Expanded Edit Mode" / Press 5 on the numeric keypad / Double-click the event edge / Press Esc on your keyboard

If no red square bracket appears then your track layers are simply expanded. To "unexpand" them, right click on the track header (the area to the left of the track) > uncheck "Expand Track Layers".

Yellandkeil wrote on 6/24/2020, 3:27 AM

And the Expanded Edit Mode is a treasure hunt for hard transitions:

fifonik wrote on 6/24/2020, 5:54 AM

Another way to do this -- use "trim to the end" command using Alt + ] shortcut.

That's not working either - it leaves a gap between the end of the "trimmed-to-end" event and the start of the next event. (But at least it then allows me to drag the edge to meet up with the next event... so it's a useful workaround, thanks.)

Press Ctrl + L before Alt + ] to toggle Auto-Ripple.

Camcorder: Panasonic X920

Desktop: MB: MSI B450M MORTAR TITANIUM, CPU: AMD Ryzen 3700X (not OC), RAM: G'Skill 16 GB DDR4@3200 (not OC), Graphics card: MSI RX580 8GB (factory OC), SSD: Samsung 970 Evo+ NVMe 500MB (OS), HDDs: Seagate & Toshiba 2TB, OS: Windows 10 Pro 1909

NLE: Vegas Pro [Edit] 11, 12, 13, 15, 17

gary-o wrote on 6/24/2020, 8:19 AM

Another way to do this -- use "trim to the end" command using Alt + ] shortcut.

That's not working either - it leaves a gap between the end of the "trimmed-to-end" event and the start of the next event. (But at least it then allows me to drag the edge to meet up with the next event... so it's a useful workaround, thanks.)

Press Ctrl + L before Alt + ] to toggle Auto-Ripple.

Err... no. I particularly DON'T want the entire track to ripple out of sync with the other events. I want to slip in an event to fill a gap, and trim the event so that it fits exactly into the gap... :)

So far, wwaag's solution seems to be the best one - I don't know why it doesn't work when auto crossfades are switched off.

gary-o wrote on 6/24/2020, 8:24 AM

 

You are able to do it: Expand Track Layers. This has been discussed so crazily just before sometime under PEOPLE who have trouble reading (Vegaspro manual).

Thanks, but you didn't read my post either I see LOL. I particularly want to avoid have to expand the track layers because it's several actions instead of just one. I have nearly 10,000 of these edits to do for my project, so every second wasted (actually around 5 seconds in total) in faffing about with clicking things on or off and then switching back to a previous view, etc. will add maybe a week or two to the project!

 

So far, wwaag's solution seems to be the best one. Simple and does exactly what I want.

vkmast wrote on 6/24/2020, 8:41 AM

Are you actually referring to "Expand Track Layers" or "Expanded Edit Mode"? Remember this thread?

gary-o wrote on 6/24/2020, 10:16 AM

Are you actually referring to "Expand Track Layers" or "Expanded Edit Mode"? Remember this thread?

Sorry, vkmast. I haven't figured out the distinction yet... :o To me they seem exactly the same thing. When the track is expanded, I see two "half-tracks" (?) with a kind of X between them. The only difference might be that the Video Preview switches to two images side by side in Expanded Edit Mode. I probably don't want that. If the track is expanded then I just see the events alternate between the two half-tracks with the transitions in the in-between "sandwich" track.

It would be SO much easier just to be able to select the right edge of the event and drag it into place, which I'm now doing easily enough with auto crossfades switched on. (I think the crossfades revert to none when I drag the edge of the event to be adjacent to the following event).

vkmast wrote on 6/24/2020, 10:20 AM

They are not the same thing.

Please see https://vegas-magazine.com/organizing-your-vegas-pro-workspace-2/

Technique Twelve: Expand track layers

But I guess you want a different workflow, so never mind.

gary-o wrote on 6/24/2020, 10:26 AM

If you are simply trying to fill a gap or add a scene to cover a specific length, use a 3 point edit. Mark IN and OUT on your timeline of where you want to place the scene. You might need to hit SHIFT-Q to select the marked area. Select the track you want to add the scene to. Mark an IN in the trimmer where you want the scene to begin and then click the ICON below the trimmer window that indicates ADD to TIMELINE or click key "A". Then no need to trim to make the scene fit.

Hi Dot - so sorry, but I don't understand a word of it. I tried what you suggested. Clicked on the start of the gap on the timeline. Entered a marker (M) - I saw a yellow 3 on the top of the timeline. Then I clicked on the end of the gap and inserted an end marker (M) - I saw a yellow 8 on the top. Then I pressed Shift-Q and somehow I ended up in the Video Preview window. I had previously copied the event I wanted and pressed A but nothing happened. So I clicked on the start of the gap where I wanted to insert the event. And then the track went haywire and several events were overwritten (I think, coz I quickly undid everything and went back to my brute-force way of doing it... select event, copy or drag it to the start of the gap, trim the end of the event to the end of the gap.

It would be wonderful to have all events automatically trim themselves up to the start of the next event (if overlong) as you position them, but so far I haven't found the most efficient solution to this. :o

Yellandkeil wrote on 6/24/2020, 10:39 AM

@gary-o, just noticed that as I posted, my apology. What you described in the last is called Punch-In or something like that, with one condition: its right edge must be shorter than the ground event. But what annoys you with 2 tracks?

It would be wonderful to have all events automatically trim themselves up to the start of the next event (if overlong) as you position them, but so far I haven't found the most efficient solution to this. :o

Turn on this one --

 

gary-o wrote on 6/24/2020, 11:00 AM

Turn on auto-ripple

 

Dear Yell&Keil, thank you but no. I'm still researching this. I do not want auto-ripple. I need the events to stay exactly where they are and insert an overlong event into the gap between two events. I deliberately switched off auto-crossfades also because I just wanted the inserted event to stop at the left edge of the following event (not crossfade into it).

But that's when all the trouble started. I couldn't then drag the final edge of the inserted event back to snap with the starting edge of the following event.

I would have thought this is a fairly common editing activity and it kind of seems obvious to me to have an option that allows you to insert an event into a gap and for the event to automatically fit into the gap, with the end bit lopped off so as not to overlap with the following clip.

As for the two tracks, 1) it's unnecessary clutter because I'm not fiddling about with transitions - just lots of simple trims to sync to an audio track; and 2) I don't have enough space on the monitor to double-up on the tracks in the timeline, and I try to avoid having to scroll up and down to see if there's an event hidden somewhere out of view.

Frankly, unless there's a particular reason for this (non-) action, I suspect it's probably a bug. I may have misunderstood what the purpose of disabling auto-crossfades is. Or perhaps this is something I need to add as a feature-request. It's a really useful (and obvious) requirement. Anyone doing sync work will be doing what I want to do as a matter of routine.

gary-o wrote on 6/24/2020, 11:07 AM

They are not the same thing. Technique Twelve: Expand track layers

Thanks again. I'm really trying hard to get my head around this. I may have the terminology wrong, but I know this technique very well. In fact, I think this (A/B editing approach?) was the only way of working way back in ancient history.

I've really learnt to appreciate the Vegas approach of hiding the transitions and stringing out all the events on a single track. If I want to tweak the transitions then, yes, this is a very useful mode of working. But currently, I'm just laying out lots of events in sequence and trimming them to size to sync with an audiotrack. It's almost the most simple form of editing imaginable (like cutting film). It should be easy-peasy! :)

wwaag wrote on 6/24/2020, 12:46 PM

@gary-o

Just threw together a very simple script, Trim To Fit, that may be the solution to your problem given that there is no native option in Vegas to "easily" paste/insert and then trim so there is no overlap with the next event. Here's a demo.

The best way to use the script would be to assign a keyboard shortcut so that you could Paste the event and then run the script which will trim to fit. Note that it works on "selected" events, which automatically occurs when you Paste.

Let me know if there are problems.

It can be freely downloaded in the HappyOtterScripts Free Tool library at https://tools4vegas.com/library/

walter-i. wrote on 6/24/2020, 2:58 PM

@wwaag
You are a "miracle healer" 🙂🙂🙂

Camcorder: Pana HDC SD909, Sony FDR-AX53
Hardware: CPU i9-9900KS 4GHz, 32 GB Ram, GTX 1660 SUPER, ASUS TUF Z390-PLUS Gaming, SSD 970 EVO Plus 500GB M.2, SSD 860 EVO Series 1TB, Toshiba 3TB SATA, WIN 10 Pro
NLE: Vegas Pro11-15+17, Heroglyph4, RespeedR

gary-o wrote on 6/25/2020, 1:36 AM

@gary-o

Just threw together a very simple script, Trim To Fit,

It can be freely downloaded in the HappyOtterScripts Free Tool library at https://tools4vegas.com/library/

Wow, thank you so much. Problem solved! I'm seriously looking at your HappyOtter collection. Seems reasonably-priced too for all the many useful shortcuts you've created so far.