problem with reverb VST

Diego_C. wrote on 8/8/2019, 6:40 AM

I use Vegas since the time of vegas audio / vegas video just to edit stereo or multitrack audio of classical music.
I never had the need to applay any effect.
Now I'm trying to applay a VST reverb.
When I applay it on the single tracks, there are no problems.
When I apply to a bus or to the master bus, there are lot of glitch problems.
I tried different reverb plugin, both 64 and 32 version, but the problem is not solved.
I tried bot Vegas 14 and the new Vegas 17, but the problem is not solved.
I tried different audio interfaces, both asio and without asio, but not solved.
This happens on 3 different PC.
The curious thing is that if I work on a single stereo track, the plugin is ok applied to the track, but with glitchies applied to the main bus.

Any suggestion or solution?
Thanks,

Diego

 

Comments

rraud wrote on 8/8/2019, 2:51 PM

- Which reverb plug-in are you using?
- Are glitches present after rendering?
- Do other reverbs and FX plug-ins in general cause glitches as well? Some plug-ins use lots of CPU resources and can cause glitches in preview.

 You may want to try using the 'Assignable Fx' mode? it is very much like an effects send/return set-up on a hardware mixing console, where the amount of reverb can be added to the desired tracks.. Right-click in the "Mixer" window and select 'Insert Assignable FX" The tracks' pan fader doubles as a pre or post 'Send' .. the 'Return' fader will be in the mixer window with plug-in's UI. Generally, in a send/return configuration, reverbs are set to 100% 'wet'.

Diego_C. wrote on 8/9/2019, 3:12 AM

Thanks rraud, with your techinque is slightly better, even if sometimes I hear glitches.
But if I use a plugin like ozone 8, for example, is a total disaster.
Applaying ozone to the single tracks (11 tracks) is perfect, but I want to use it on the main out.
Anyway, glitches are non present in rendered file, but is almost impossible to choose the right parameters without a clean monitoring.
Even with the siplest reverb (SIR 2), both 32 and 64 there are glitches.
Glitches are there also with Lexicon MPX reverb and with Liquidsonic reverberate.
I have a last generation pc (processor is at 10% and memory at 20%) with a zoom uac-2 audio interface.

 

rraud wrote on 8/9/2019, 10:19 AM

Strange that it happens on different PCs. I would look for something in-common to the machines For instance, the Zoom uac-2 audio interface. Try a different converter, even an integrated one would work for test purposes. I have not heard of of many issues with the Ozone Fx which runs ok on my PC as well/the SIR-1.

Otherwise are you using video plug-ins as well? Check for other apps or services running on your PCs. Anti-virus apps in particular have been known to cause problems with DAWs and NLEs. though I have not read of many lately.

Diego_C. wrote on 8/9/2019, 12:07 PM

same problem with different audio interfaces.
No antivirus or other services.
And the problem is there only if I use the effect on the bus or on the main out, non on the single (mono or stereo) track.

LanceMGY wrote on 8/13/2019, 7:11 PM

Oh dear this problem STILL exists in VP17? I saw in another post that VST effects were now working as expected when the interface was open. What you describe is the (not so) famous VST fx bug present in all 64 bit versions of Vegas, starting with 11. If you use the VST at the track level, it works decently well. But if you use it anywhere else like on a bus or master out, it will glitch pretty bad. It's much worse when the VST's interface is open.

I refuse to buy any more versions of Vegas until this is fixed. This, plus allowing more than one FX window open at a time... that would be tremendous. It's so stupid that only one FX window can be open at a time.

I had hopes this was fixed given another user's positive results. But if you're experiencing this issue in the version 17 now, I guess it will never be fixed. Sorry to say. If you want to use VST effects without the glitching, switch to version 10 32bit. Good luck finding new 32bit VSTs. 😡

garygiles63 wrote on 8/17/2019, 6:53 AM

The issue above is why I have moved over to Reaper. Sounds like its not been fixed in VP17 either 👿