The new Screen capture in VMS 16

j-v wrote on 7/22/2019, 11:41 AM

I tried some things with this new option in VMS 16 without being able to read something in the manual or helpfiles.
So now it looks to me an option that I cannot use because it worked with me with a 4x too big screen in which I could not see any changeable option.

When I tried to save a made file it turns out to become an unreadable small file.

So I'm forced to don't use this new option and stay with my beloved OBS for making screencaptures with and for Vegas Movie Studio and Vegas Pro.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Comments

Marco. wrote on 7/22/2019, 11:52 AM

The screenrecording will be stored at

C:\Users\"your name"\Captures\

It's an MP4 AVC coded video file.

j-v wrote on 7/22/2019, 12:09 PM

I don't see there a capture, but tonight later I'll try again (after my salmonfishing 😃😉)

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Marco. wrote on 7/22/2019, 12:17 PM

Before you hit the record button, did you select the display by clicking onto it within the screencapture tool?

Will-S wrote on 7/22/2019, 12:40 PM

Ive exactly the same problem.

Ive tried to both select (It puts a grey window around my screen capture display in VEGAS Capture) and recorded for 5 minutes. Ive also tried it without that selected and recorded for 5 minutes. (Also closed/reopened, rebooted, created a new Windows user and tried as them etc etc). Same result J-V the only thing I can get it to do is Export a 253 byte file (a FILENAME.vegcap file). Ive hunted through my user profile c:\users\username folders... no Capture folder. Ive hunted the disk for a Capture folder.. and all my users are Administrator accounts......

And yes, I cant find anything in either the manual (the online one isnt updated yet) and theres no help file that I can find for VEGAS Capture.

So Im stumped too!! But thought it worth sharing my experience.

Marco. wrote on 7/22/2019, 12:49 PM

Try creating that folder "Captures" manually (at C:\Users\"your name"\) before starting the screen recording.

Will-S wrote on 7/22/2019, 12:53 PM

Ive just tried that and YES that works...

I just used Microsoft Procmon and could see it was trying to create the file, but didnt create the folder called Captures. So I created it and Its off and working!

Thanks for your reply.

 

Marco. wrote on 7/22/2019, 1:00 PM

I just reported this as a bug.

Will-S wrote on 7/22/2019, 1:17 PM

Another quick note for anyone who looks. The Vegas Capture process is opening 3 x instances of the app, and only closing 1 of them... then when you re-open it, it opens another 3 x instances (so you now have 5 instances), then you close it and re open it.. you now have 8 x instances etc...

So a small bug I assume, which Ive reported, but I guess close down the dead instances with Task Manager when youve finished working (or reboot your machine). At least watch out for your RAM/memory being chewed up by them.

j-v wrote on 7/22/2019, 3:25 PM

This evening I tried many times but never a file has been captured.
Look after a capture, what is in my self made capture folder

and in my personal folder of me as user

And look how my taskbar is looking and what it is telling me after the 4 attempts and VMS 16 build 142 is closed

To me this new option looks a joke of the developpers and I stop trying to use it . I have a much, much better one and that one costs nothing.
Vegas 👎!

Last changed by j-v on 7/22/2019, 3:39 PM, changed a total of 1 times.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

j-v wrote on 7/22/2019, 3:41 PM

Who tested this piece of dirt?

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Marco. wrote on 7/22/2019, 3:49 PM

You used the wrong folder name. It needs to be "Captures", not "Capture".

vkmast wrote on 7/22/2019, 3:55 PM

@j-v Don't know about "who" or "dirt", but CR #9 states that "Publishing or mentioning the names of MAGIX employees in your [i.e. the members'] posts is not permitted". Please report the bug as you see it.

j-v wrote on 7/22/2019, 4:03 PM

@j-v Don't know about "who" or "dirt", but CR #9 states that "Publishing or mentioning the names of MAGIX employees in your [i.e. the members'] posts is not permitted". Please report the bug as you see it.

My question on this does not mean to ask for names, but to express my feeling IF this option is ever tested.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

j-v wrote on 7/22/2019, 4:14 PM

You used the wrong folder name. It needs to be "Captures", not "Capture".

Result after correction and 2 captures

and the taskbar

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Marco. wrote on 7/22/2019, 4:15 PM

@Chip-Shot Your question is not related to this topic which is about the new screen recording tool. Please open a new topic for yours.

j-v wrote on 7/22/2019, 4:28 PM

I'm not trying this anymore until there is a manual or helpfile that explains how to use this the right way and also the way it is intended to use it.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

FayFen wrote on 7/22/2019, 11:36 PM

Is this feature working at all? when I run it I get black empty rectangle and that's it.

Nothing to set, how to rec/stop? I see 2 process running

EricLNZ wrote on 7/23/2019, 4:42 AM

I'm not trying this anymore until there is a manual or helpfile that explains how to use this the right way and also the way it is intended to use it.

+1

EricLNZ wrote on 7/23/2019, 5:24 AM

Before you hit the record button, did you select the display by clicking onto it within the screencapture tool?

Interesting but I cannot find the screen capture tool. Where is it in what I'm presented with?

Also how do we select just one of the windows? Clicking, double clicking does nothing.

And how do we get it to save a proper file and not just a "cap" file of a few kilobytes?

 

Marco. wrote on 7/23/2019, 7:37 AM

The process for screen capturing is:

1. Due to a bug manually create a folder named "Captures" at C:\Users\"user name"\. This is were the recorded MP4 files are stored.

2. Open the screen capture tool via the menu "Project/Screen Capture".

3. Select the desired display and audio source by clicking once onto there frames. The selected sources then will have a grey border.

4. In the screen recorder window click the record button.

5. Hide the screen recorder window until you're done.

6. Unhide the screen recorder window.

7. Click the stop button.

Done. Your recorded MP4 file then is expected to be in the "Captures" folder you created in the first step. If it's not there, another bug seems to prevent recording.
No need to use the export button (to me it seems like it is not yet working).

For me this works fine except I cannot record microphone audio sources.

 

j-v wrote on 7/23/2019, 9:20 AM

While I was curious I used the manual given by @Marco.👍

Following that I was able to see 2 files in Captures
- videofile AVC FHD 30p
- audiofile wav with this MediaInfo

Video opened in VMS16 , but not the audio.
Audio plays nowhere except VLC player and than it is audio of my screencaptures sound of my speakers.
At one out of the two times I made such a screencapture after starting I could stop the capture again with the results above.
The other time after hiding the screencapture to the toolbar it was not there and the only way I could stop it was to end VMS16.
At all times the taskbar remains 2 screencapture tasks taking memory on the taskbar that can only be stopped by ending them one by one trough the "End" button on the taskbar.

To me it looks there are more than one bug in this option of VMS 16.

Last changed by j-v on 7/23/2019, 10:15 AM, changed a total of 1 times.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

EricLNZ wrote on 7/23/2019, 6:26 PM

Thanks @Marco. It worked following your instructions.

One additional comment - if you are using multiple monitors you can drag the screen recorder window off onto another monitor instead of having to hide it.

EricLNZ wrote on 7/23/2019, 10:22 PM

@j-v My wav audio plays in VMS16 but is horribly distorted. It sounds just the same in MPC-HC and VLC players. But it's not overloading. According to VMS's Master Bus the peak is just under zero.

I've tried turning my speaker volume down low but it makes no difference.

j-v wrote on 8/16/2019, 5:34 AM

@Marco.

Now I'm back home, I installed Vpro 17 on my desktop and updated VMS Pl 16.
No problems at all with all the things I was complaining about with the use on my laptop for both, especially the Screencapture option.
All went normal on desktop and also your advice to switch the "save" location to my normal used location on my SSD. Thanks again!

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!