john_dennis wrote on 10/24/2012, 6:52 PM
Shut the Vegas project and try it with the Windows Explorer. If a Vegas project is accessing the file you may be dealing with locks. It's probably easier to do it outside of Vegas than the struggle with it.
Kit wrote on 10/24/2012, 11:16 PM
I posted a query about this a few days ago. I think its a bug. Your suggestion to shut Vegas and retry with Explorer is a time killer. You can open the Explorer from Vegas and rename files but then Vegas will complain about offline files. It's a real nuisance. I hope they fix this in the next update.
john_dennis wrote on 10/25/2012, 12:58 AM
While it is common practice for other applications to make changes to files while Vegas references them and Vegas releases them (or the OS takes them away when focus is lost). I get the feeling that changing the file name while it is being used by multiple applications will get you in trouble with the OS. That may be a tougher nut for an application to crack. I could be wrong, given the magic that operating systems do these days, but I've been doing this stuff so long, I can certainly remember when you couldn't change a file name without exclusive control of a file.

I'd love for all the coders out there to chime in.
Kit wrote on 10/25/2012, 3:00 AM
Who said anything about multiple applications? Vegas 12 launches the trimmer if you try to type a space while changing a file name using F2 in Vegas Explorer. It's a bug. You can change the name as long as you don't use a space. Acid and Sound Forge and even old ThumbsPlus have no problem. I never noticed the problem using earlier versions.
john_dennis wrote on 10/25/2012, 9:26 AM
This morning, I tried changing the name of a file to include a space. I worked In Vegas Pro 12-367 with an empty project and no other applications running.

It appears to be a bug, or at a minimum, a different interpretation of the use of the spacebar.

It seems the spacebar is being interpreted as a transport control or something. When I touch the space bar, the picture is "played" in Preview rather than inserted into the file name.


With the file selected:

When the space is entered to change the file name.

I looked at switches for the space bar briefly but could not make a change to the behavior. I have to go earn a living.
john_dennis wrote on 10/25/2012, 6:04 PM
Has anyone filed a bug report on this?
Marco. wrote on 10/25/2012, 6:19 PM
Kit wrote on 10/26/2012, 12:24 AM
Thanks, Marco.

ECB wrote on 10/26/2012, 2:28 PM
You can enter a space in the file name by the key code. . Select Rename and move the cursor where you want the space in the file name hold down the alt key and enter 32 on the numeric key pad.

vkmast wrote on 10/26/2012, 2:45 PM
that works here too, thanks for the tip.
hollyviewvideo wrote on 10/27/2012, 2:51 PM
Good workaround... thanks.

Here is another.

Copy a space to the clip board.

Press F2 in the explorer to rename the video clip file.

Move your cursor to where you want the space.

Press CNTRL-V to paste the space in.

Of course this only works if you have not copied something else to the clipboard and the ALT 32 would work always.

I have dropped back to using Vegas 11 to rename clips in the explorer until they fix this bug.

I use the trimmer to quickly watch or "log" clips and then rename them in the explorer to something that tells me what the clip contains. Used to work great in version 11.

I also noticed that the space bar is being used differently in the Vegas 12 explorer to start and stop the clip play. This is not helpful.

If I want to start and stop a clip I will either drag it to the trimmer or the timeline.