Vegas 11 can't render to Mainconcept AVC MP4

VanLazarus wrote on 10/23/2011, 3:20 PM
Whenever I try to render in Vegas Pro 11 to Mainconcept AVC MP4, I get the following error:

An error occurred while creating the media file XXXX.
The reason for the error could not be determined.

Has anyone else had success in Vegas Pro 11 with this codec? I've tried using both built-in templates and ones I created in Vegas Pro 10. This is 100% re-creatable every time. How do bugs like this get through any QA department?

Comments

john_dennis wrote on 10/23/2011, 3:27 PM
Working here. Likely something in your installation.
Bob Decker wrote on 10/23/2011, 3:33 PM
I've been using this to render all my videos flawlessly. Upon reading your post I dropped a 1080p .MOV event on the timeline and rendered without any problems. I have been using the YouTube 720p setting for all my internet projects, since I have not been able to access Sony Avc in Vegas 11.
vkmast wrote on 10/23/2011, 3:37 PM
Hi.

Experiencing same as VanLazarus. I'm on VP11 trial with VP10e installed. SonyAVC working so far in VP11.
PeterDuke wrote on 10/23/2011, 5:07 PM
It seems to work for me. What are your source video and project properties, and what template are you using?
vkmast wrote on 10/23/2011, 6:00 PM
Hi.

Changing the encode mode to 'Render using CPU only' helped.
I found this mentioned in the recent thread http://www.sonycreativesoftware.com/forums/ShowMessage.asp?ForumID=4&MessageID=782239.
Think I need to remember to use 'Search' more.
Edit:
See also SCS Support Knowledgebase ref. no. 5068 GPU-accelerated rendering with the MainConcept AVC format
Former users wrote on 10/25/2011, 6:15 PM
You're not losing your mind VanLazarus. I had the same problem (i7 960 on an ASUS P6 motherboard, 12GB of RAM, ATI 4870).

Switching to CPU only fixed my issue as well.

Interestingly, the system detects open CL under "check for GPU," but I suspect it's sort of on the fence in terms of compatibility (re: close enough to be detected, but not close enough to actually work properly).
JasonATL wrote on 10/25/2011, 7:07 PM
When I tried "upgrading" to a AMD HD 6870 video card, I had this same issue. It would not render MainConcept mp4 using the GPU, but worked fine with the CPU-only mode checked. I think this is a bug in Vegas v11, especially since it seems that there are many of us who can replicate this issue.

I have sinced switched to an nVidia GTX 560 Ti and do not have this bug. I am able to render MainConcept .mp4 using the GPU.
eightyeightkeys wrote on 10/25/2011, 7:21 PM
Make sure you're not using an "old" preset from VP10 that was automatically imported into VP11. It won't work. At least it didn't for me.... I tried over and over with no luck and then it dawned on me to trash the old template
I had to re-create my old template settings but fresh from a VP11 default template.
Also, some VST plug-ins are causing havoc in VP11. I had fail after fail rendering with TC Electronic Powercore VST plug-ins to Denoise and Dethump a source audio track. No go. Trashed...never to be used again.
Gene Aum wrote on 10/25/2011, 11:00 PM
I was getting this error today on a project that was created with V11 (V10 was not used at all).

I then rendered a segment of the project, which worked, then tried again rendering the complete project - which then also worked. Go figure.

It would appear it's a definite bug. I won't hold my breath till it's fixed however.


Steve
kgilman wrote on 10/31/2011, 4:46 PM
"Changing the encode mode to 'Render using CPU only' helped."

I'm a new to Sony Vegas. I went into preferences to make sure GPU acceleration was turned off, and it is. Where do I go to change the encode mode? I went to customize in the render settings but still don't see anything...unless i'm blind and i wouldn't be surprised if i am.
Former users wrote on 10/31/2011, 5:04 PM
There's a setting at the bottom of the dialog box that probably says "Encode Mode." It's just below the bit rate settings.

I had a hard time finding it too (since I didn't know what I was looking for), but it's right there as plain as the nose on your face (apologies if you, like me, have a big nose).

vkmast wrote on 10/31/2011, 5:43 PM
Hi cwilcox.

you should find it in render as... MainConceptAVC MP4 templates / customise template...
rdolishny wrote on 11/19/2011, 1:37 PM
Thank you! You've saved my project.

Rick
Red Prince wrote on 11/19/2011, 5:16 PM
Edit:

@vkmast:

The link does not work... Can you post the actual link, please.

Adam

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

vkmast wrote on 11/20/2011, 4:51 AM
Adam,
try SCS Support / Knowledgebase and use Search: 5068.

GPU-accelerated rendering with the MainConcept AVC format
Published 10/15/2011 03:58 PM | Updated 11/01/2011 09:58 AM
GPU-accelerated rendering with the MainConcept AVC format

Update: The issue below has been fixed in Vegas Pro 11 build 424 (32-bit) and build 425 (64-bit).

GPU-accelerated rendering with the MainConcept AVC format can fail if your system has an NVIDIA CUDA driver but no NVIDIA CUDA-capable GPU is installed. This will result in an error dialog when as soon as you try to render with the MainConcept AVC format. To fix this, uninstall the NVIDIA CUDA driver, or Render using CPU Only in the Customize Render Dialogue.


...and the following Search options there may be of use too:
Vegas Pro 11 and OpenCL GPU-accelerated video processing
MainConcept AVC rendering with 32-bit floating point format projects
Red Prince wrote on 11/20/2011, 10:22 AM
OK, that got me to this link. though I see you have already copied its contents here.

He who knows does not speak; he who speaks does not know.
                    — Lao Tze in Tao Te Ching

Can you imagine the silence if everyone only said what he knows?
                    — Karel Čapek (The guy who gave us the word “robot” in R.U.R.)

Beatdemon wrote on 6/9/2012, 8:13 PM
So... here's one for ya, I DO have a CUDA-capable GPU: NVIDIA GForce 670 and cannot use the GPU to render. So how does that one get explained? I was only able to render using CPU.
John_Cline wrote on 6/9/2012, 8:58 PM
Seems that the Main Concept MP4 encoder has problems with certain resolutions, for example, I can't render 1920x1080 interlaced using the GPU, but I can render 1280x720 progressive. Maybe it's an interlaced vs. progressive issue, I haven't fully investigated what works and what doesn't.
Beatdemon wrote on 6/11/2012, 5:04 PM
Nope, the only option for me is CPU rendering. Which is OK, I would like to see the performance of the GPU but I will live. It doesn't matter what resolution I'm rendering to with my EVGA GTX 670. Sony should look into this.
Guy S. wrote on 6/12/2012, 2:41 PM
<<An error occurred while creating the media file XXXX.
The reason for the error could not be determined.>>

I get the same message every time, but ONLY after installing a new GTX680 graphics card. I've been using VP11 since it was released and I've had no problem rendering using Main Concept until the day I installed the new card.

Two easy workarounds that work fine for me:
Render using CPU Only, or
Render with Sony's AVC CODEC instead of Main Concept
Beatdemon wrote on 6/16/2012, 6:33 PM
Hi Guy,

Where on earth can Sony's AVC Codec be found... I've been looking everywhere for that one. I think the H.264 quality of that one is better anyway. So you got yourself the GTX 680, huh? That's a good card! I got the little brother to that one and it's also a good card! It's clear however that this is an issue with the 600 series... maybe the drivers? I see that Vegas is recognizing my "CUDA" cores at least.

ushere wrote on 6/16/2012, 7:31 PM
+1 - can't render to mc mp4.

i can render to any thing else, and i can render a single event to mc mp4, but NOT a mixed tl. always throws up the above mentioned error.
Guy S. wrote on 6/18/2012, 1:32 PM
<<Where on earth can Sony's AVC Codec be found...>>

In the Render As dialog, Sony AVC is seven down from Main Concept. Most of the presets are for Sony devices, but you can easily create a custom preset.

I have to say that I wouldn't recommend a 600 series card just yet. Our IT folks installed CS6 along with a Quadro 3800 in an HP Z420 workstation (quad core) to compare against my current workstation (HP Z400 6-core + GeForce 460 SE).

The results were disappointing: the newer quad core with a less powerful graphics card ran AfterEffects MUCH faster. We than installed the GeForce 680 in my workstation... And there was little, if any, improvement in Vegas or AfterEffects.

As a final test we replaced the Quadro 3800 (192 CUDA cores) with a GeForce 680 (1536 CUDA cores) in the Z420 workstation. We also added an Intel SSHD for temp files.

The result: When playing or scrubbing the timeline or creating a RAM preview, AfterEffects MAY have run a tiny bit faster - or maybe not. I didn't bother to do any benchmarks because that really wasn't the point for me - I was hoping for a substantially more fluid working experience and the 680 card simply didn't deliver that. What I DID notice was a vast improvement in AfterEffect's disk cache performance with the SSHD.

I took a very brief look at Prem Pro CS6 on both systems and it did well, playing back multiple streams in realtime at full quality. My Z400/680 was able to do play 4 layers, scaled down, moving across the frame, with CC on each clip, in realtime at full quality. I didn't test any more than that because I don't like editing with PP.

Although we did not load Vegas onto the Z420 test system my observations lead me to believe that the newer quad-core Sandy Bridge & Ivy Bridge CPUs and an SSHD for temp files will yield the largest performance gains for both CS6 and Vegas. And with a 400 or 500 series GPU we wouldn't get the Main Concept AVC rendering error.
DavidMcKnight wrote on 6/18/2012, 1:50 PM
I wanted a constant bitrate of 5,000,000 and the only way to get it without any errors was to choose Variable, not two-pass, and set max and average both to 5,000,000.