Vegas 13 won't load keeps redirecting me to purchase VP16

frederick-wise wrote on 6/23/2019, 3:41 PM

Help! Long-time Vegas user here. About a month ago my Vegas 13 wouldn't open, instead a little pop-up screen appears wanting me to purchase VP16 which I had tried about a year ago. So far I've done everything to delete all traces of Vegas in the registry, program files, etc. and even installed the latest build (545) but it just never opens and keeps sending me to the VP purchase page. I even tried installing the Vegas Movie Studio but it hangs on "loading plug-ins". Next I tried to find actual Vegas Pro support on the Magix site but they don't seem to offer ANY direct support for Vegas Pro. FYI - I visited the sites below and tried to do as suggested but no go. Any ideas? Looks like my only option at this point is a whole reinstall of windows 10 and about 50 some programs, plug-ins, etc, not what I want at all. Everything else seems to work fine on my up-to-date Windows 10 (from Windows 8) desktop.

Thanx, Frederick

http://www.vegascreativesoftware.com/us/downloads/

https://www.vegascreativesoftware.info/us/forum/faq-how-can-i-do-a-clean-uninstall-of-vegas-pro--111205/

Comments

j-v wrote on 6/23/2019, 4:00 PM

Something must have been changed on your computer, try to find out when it was starting well and try to reset your computer to before that date.

That Movie Studio hangs must have to do with installed 3th party plugins, maybe first deleting them can help and if yess install them again one by one to find out which one caused the fault.

met vriendelijke groet
Jan

Camera : Pan X900,GoPro Hero7 Hero Black
Desktop :AsRock Z270 Pro4, W10 , i7 7700K 4.2Ghz,16 DDR4 GB RAM, Gef. GTX 1050 Ti.
Laptop  :Asus ROG GL753VD, W10 home, version 1903 build 18.362, CPU i7 7700HQ, 16 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).
Both Nvidia GPU's have driver version 430.86 Studio Drivers
TV      :LG 4K 55EG960V

Dutch video tutorials for beginners

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

frederick-wise wrote on 6/23/2019, 5:32 PM

Thanx j-v, going thru that process can take longer than just a fresh reinstallation of Windows, I have a music DAW, CakeWalk/Sonar, with dozens of plug-ins plus lots of Photoshop and other multi-media plug-ins. I've already spent hours trying the registry edits (twice), etc. I'm hoping someone has experienced this same "redirection to purchase screen" and knows exactly how to easily fix it. I'll give it a few days to see if anyone has a fix.

Dr Zen wrote on 6/23/2019, 6:38 PM

Your problem sounds like you have 2x different License Keys that are in conflict with each other.
It has been discussed in the past on this forum, but I haven't been able to find that particular thread yet. As soon as I find it, I will share the link.

From what I can remember, there is a situation where a Trial License Key and bought License Key get stuck inside the same Windows Registry folder. Deleting the trial license key fixes the problem.

Open the Windows Registry and see if you have this folder:
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Sony Creative Software\VEGAS Pro\13.0\License

If you have newer versions of Vegas Pro also installed, you should see other folders as well, however you will probably find the other versions don't have license folders.

If you ever installed Vegas Pro 14, you should see this as well:
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Sony Creative Software\Vegas Pro - MAGIX\14.0\License

I wish I could be more specific, so will post again when I find that other thread.

frederick-wise wrote on 6/23/2019, 8:29 PM

Thanx for the suggestions Dr. Zen. I remember seeing VP13, 14, 15, and 16 here and there in the registry and deleted everything I could. I also have SONY ACID Pro that I never use in the Sony Creative Software folder which may be causing the problem. Should I try deleting all the Sony Creative Software folders/files?

Dr Zen wrote on 6/23/2019, 9:04 PM

Acid Pro has nothing to do with Vegas Pro - deleting Acid Pro entries will have no effect of Vegas Pro.

There is another question I need to ask.
Have you ever installed a pirated version of Vegas Pro on your computer ?
If you did do this in the past, that can also cause a MAJOR error which Vegas Pro.
Pirated versions of Vegas destroy the Magix/Vegas Windows Registry folders that contain license information. The only way to fix that problem is to do a complete Clean Re-install of Windows. I know this because one of my forum members installed a "cracked" version of Vegas, which screwed up all his other Vegas and Magix programs. A clean reinstall of Windows was the only thing that fixed it.

If I was you, I would definitely uninstall ALL Sony Creative Software programs and MAGIX programs, then delete every folder related to them.

I have an FAQ on my website that may help you in finding the folders you need to delete.
https://www.moviestudiozen.com/doctor-zen-faq/570-clean-install-sony-vegas-windows-10
https://www.moviestudiozen.com/doctor-zen-faq/602-how-to-clean-install-magix-vegas-pro-movie-studio

frederick-wise wrote on 6/23/2019, 9:49 PM

LOL I actually paid for every version and have the receipts somewhere to prove it. Started with Vegas 3 I think. Just got done trying to find every little Magix and Sony Creative Software file. Was even in the appdata for users and found a bunch of stuff and looked at certificates and such in local and roaming. Maybe I should try to get a cracked version since the real deal doesn't work and Magix doesn't seem to care.

 

Here's what keeps popping up:

 

Dr Zen wrote on 6/23/2019, 10:20 PM

I just thought of something else, that you should definitely check.
All VEGAS Licenses can be activated on up to 2x different computers.
If MAGIX/Vegas thinks you are trying to activate for a 3rd time, that may produce the error.

Login to your MAGIX account here:
https://www.magix.com/us/support/my-service-center/

Go to My Products
Find every version of VEGAS you have installed and check the license keys and which computer they are linked to.
Click Show more details under each version of Vegas
If you see 2x activations for Vegas, press the De-Activate link for both activations.
Logout of MAGIX
Re-boot your computer
Open Vegas
It should now ask you to re-enter your License Key

 

Dr Zen wrote on 6/23/2019, 10:22 PM

If you can't find a solution, make sure to contact Magix support and ask for assistance.

https://support2.magix.com/customer/vegas

frederick-wise wrote on 6/23/2019, 10:25 PM

I looked on the Magix site and found my VP13 credentials and serial number along with evidence I tried VP14, 15 and 16. Also there is a section of the "Account" window where I can create an "activation code" for VP13 but I don't seem to know what my ComputerID is. I searched how to find your ComputerID but none of the names I've tried work. I've tried Computer Description Name, Full Computer Name, and Windows Product ID number/name and none are acceptable. Maybe this will get me up and running if I can get it to accept a computer name.

EricLNZ wrote on 6/23/2019, 10:36 PM

My product details are shown as activated to "Device Name" which is identical to that shown in Win10 Settings\System\About - under Device Specifications.

frederick-wise wrote on 6/23/2019, 10:43 PM

Just sent a request for assistance and they claim they will respond within 2 days. We'll see.

frederick-wise wrote on 6/23/2019, 10:49 PM

My product details are shown as activated to "Device Name" which is identical to that shown in Win10 Settings\System\About - under Device Specifications.

Thanx Eric for that settings location where I did find a Device ID I hadn't seen before but it wasn't accepted either.

Dot wrote on 6/23/2019, 10:54 PM

I think the computer id is revealed when you install the product. Probably won't help unless you uninstall and then reinstall.

Dr Zen wrote on 6/23/2019, 10:59 PM

I do not think trying to create an "activation code" will help with your problem.
I am now 100% convinced that you have 2x activation codes stuck in your Windows Registry for the same version of Vegas. That's because I have seen the same pop-up window from another user. I remember they had to delete the "trial activation code". As soon as they did that, the pop-up window disappeared and the program started OK.

Did you try to DELETE the License folder for Vegas Pro 13 in the Windows Registry, as I suggested ?

HKEY_LOCAL_MACHINE > SOFTWARE > Wow6432Node > Sony Creative Software > VEGAS Pro > 13.0 > License

Right-click the License folder ONLY and select Delete. If prompted, confirm you wish to delete the folder.

 

You said you had installed Build Version #545 for Vegas Pro 13.
This is a MAGIX version of Vegas Pro.

Before that, you probably had Build Version #453, which was the final Sony version.

There is no advantage in installing the MAGIX version (545), if you already had the Sony version (453) installed.
The only difference was technical legal stuff - nothing to do with actual functionality.

 



 

Dexcon wrote on 6/24/2019, 6:29 AM

@frederick-wise … I am not sure that publishing your serial number is such a great idea. It is strongly suggested that you edit your post to remove the image with the s/n and repost it in with the s/n obscured via an image editor.

Dr Zen wrote on 6/24/2019, 7:04 AM

There have been plenty of times I have seen the Magix registration servers go down - often for many hours and often during the weekend. Once they are back up and running, hopefully the registration process will activate for you.

In the Windows Registry, where your screen shot says "keyTrial", on my computer it says key1.
I think the name should change for you and activate properly, once those servers are functioning correctly again.

frederick-wise wrote on 6/24/2019, 7:13 AM

OK deleted my SN stuff (thanx Dexcon) but new problem. When loading it crashes at "Initializing GPU-Accelerated Video Processing..." and gives the following reason. It looks like Unmanaged Exception (0xc0000005) is well known and I went into my NVIDIA settings and tried various power management settings but nothing works. Guess I'll reboot again and see if that fixes it.

 

Problem Description
   Application Name:    Vegas Pro
   Application Version: Version 13.0 (Build 453) 64-bit
   Problem:             Unmanaged Exception (0xc0000005)
   Fault Module:        C:\WINDOWS\System32\DriverStore\FileRepository\igdlh64.inf_amd64_250db833a1cd577e\igdrclneo64.dll
   Fault Address:       0x00007FFA90360819
   Fault Offset:        0x0000000000030819

Fault Process Details
   Process Path:        C:\Program Files\Sony\Vegas Pro 13.0\vegas130.exe
   Process Version:     Version 13.0 (Build 453) 64-bit
   Process Description: Vegas Pro
 

Dr Zen wrote on 6/25/2019, 3:33 AM

A simple question: Did you finally get the program to register correctly ?

frederick-wise wrote on 6/25/2019, 6:14 AM

Yes, due to your help it's registered but now when it tries to load it hangs on the "Initializing GPU-Accelerated Video Processing...". I think deleting the "License" folder in the registry was the final mod that got it to register.

Surprisingly, Magix support has responded fairly quickly and they are trying to figure out the loading problem. I sent them a few screenshots of the hung start-up window, the registry, and my device manager, etc. FYI - I have VP13 still installed and working perfectly on my laptop. Some article I read suggested maybe the problem has to do with 2 simultaneously working versions being enabled at the same time. And that the crashing is really a result of Magix not wanting 2 versions enabled but I think you can have 2 versions on 2 separate computers simultaneously. It's always worked well for me in that configuration.

 

FYI I don't see anywhere on the Magix site a location where it shows how many instances of VP13 have been registered and activated. It only shows that it is "activated".

 

Here's where it hangs:

vkmast wrote on 6/25/2019, 6:25 AM

I think you can have 2 versions on 2 separate computers simultaneously. It's always worked well for me in that configuration.

From the FAQ section 9: "You can use VEGAS Pro (14.0 and later) simultaneously on 2 devices. To deactivate a device so you can activate a different one, go to your MAGIX account > My Products > Show More Details > Deactivate. Older versions of Vegas Pro are licensed under a system (as previously used by Sony) which permits use on multiple computers by one user; after an unspecified number of installations on different or updated PCs you may need to contact support to reset your "installation count"."

If you mean/need several versions such as 13, 14, 15, 16 you can have those installed simultaneously.

 

 

frederick-wise wrote on 6/25/2019, 4:07 PM

Magix support just helped me fix it! They said "The crash is occurring within the igdrclneo64.dll. This is the OpenCL component of the NVidia driver." SO I downloaded the DDU and ran it twice. The first time I ran it I had it remove the NVIDIA drivers and then it reboots but I still couldn't get VP13 to open. So I ran it again selecting all INTEL drivers to be removed. After the 2nd process, VP13 opened in about 4 seconds!

NOTE: The DDU strongly suggest you run it in safe mode but I didn't as I read a readme.tx that said you may have a problem getting out of Safe Mode which has happened to me in the past so I just crossed my fingers and it worked. Below is where you can get the DDU.

https://www.guru3d.com/files-details/display-driver-uninstaller-download.html

 

 

vkmast wrote on 6/25/2019, 4:20 PM

@frederick-wise Thanks for confirming the solution. A previous thread related to the similar igdrclneo64.dll problem is here https://www.vegascreativesoftware.info/us/forum/vegas-startup-crash--111263/

frederick-wise wrote on 6/25/2019, 5:09 PM

Thanx to everyone who helped me, especially Dr. Zen who quickly got me out of that loop where it kept redirecting me to buy VP16 - that was maddening. As I had hoped, a few days on the forums worked out way better than reinstalling Windows 10 and hundreds of programs/plugins which would take weeks and may not have fixed the problems. My computer seems to work better now than it did the last few months - things are loading much faster. Till the next crisis, have a nice day, FW.

 

PS I want to try VP17, when is that coming out? Any clues other than August? I may finally upgrade but VP13 is pretty good for the simple things I do.