Comments

Henri-Thebault wrote on 4/27/2020, 11:17 AM

Hi,

I just bought Movie Studio 16 ... this week on 25th. Did not see anything about the 17. Will there be any update?

 

FayFen wrote on 4/27/2020, 11:26 AM

Hi,

I just bought Movie Studio 16 ... this week on 25th. Did not see anything about the 17. Will there be any update?

 

If indeed you just bought it, hurry and ask for refund and get 17 if you thing it's better for you.

rjshama56 wrote on 4/27/2020, 12:09 PM

I upgraded to version 16 on April 20th. Is there a free upgrade to version 17?

j-v wrote on 4/27/2020, 12:16 PM

I upgraded to version 16 on April 20th. Is there a free upgrade to version 17?

Only if you bought 16 it with a free upgrade, if not you get the normal upgrade price.

 

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 452.06 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

vkmast wrote on 4/27/2020, 12:37 PM

https://www.magix.com/int/terms-and-conditions/ § 3.

rjshama56 wrote on 4/27/2020, 1:26 PM

I bought an upgrade from the Magix site. I didn't see anything other than the price of the upgrade.

I'm trying to figure out what the terms and conditions mean. I need to cancel my purchase from the 20th and then purchase the version 17 upgrade? Thanks

vkmast wrote on 4/27/2020, 1:39 PM

I think it's an option for a recent purchase.

JohnStabler wrote on 4/27/2020, 2:30 PM

Just upgraded to 17 Platinum for the color grading workflow.

Can't see any color scopes / waveforms. Please tell me that I just can't see the button / option to show them.

vkmast wrote on 4/27/2020, 2:43 PM

Search "color grading" in online Help (F1).

JohnStabler wrote on 4/27/2020, 3:00 PM

There's no mention of scopes or waveforms in the help, which is incredibly disappointing. I swore I'd never spend money upgrading Movie Studio again (had it since v13) after comparing it to DaVinci Resolve.

I stuck with Movie Studio because I had a good working knowledge of the product, but I'm just going to have to bite the bullet and learn Resolve now.

JohnM wrote on 4/27/2020, 4:26 PM

I have Vegas Movie Studio Platinum 16. To upgrade to version 17 I am offered an insulting 5% discount compared to buying it new.

Australian upgrade pricing: A$94.99 Regularly A$99.99

vkmast wrote on 4/27/2020, 4:53 PM

@JohnM 

Australian pricing discussed here.

Johannes-Loots wrote on 4/27/2020, 5:37 PM

Hey there, so I've just bought the Movie Studio Suite 17 edition, and it's running great, though a plugin that I received with Suite 15, the Boris Continuum Film Style Unit, fails to load. It worked fine in ver.16 which was also Suite.

Anyone else having similar issues? A way to resolve it perhaps?

Thanks in advance.

VEGASDerek wrote on 4/28/2020, 8:15 AM

Similar to the situation with VEGAS Pro 17 when it was released, you will need to get an updated plugin from Boris.

Johannes-Loots wrote on 4/29/2020, 5:19 AM

Similar to the situation with VEGAS Pro 17 when it was released, you will need to get an updated plugin from Boris.

Tried that. Still no luck. I've reached out to BorisFX also, so will see what they say. I have a possible workaround though. Running v.16 for those specific purposes. Thanks though!

robbif2 wrote on 4/30/2020, 9:48 PM

One question: As with previous versions of VMS Platinum, will it co-reside with the previous version 16 on Windoze 10?

EricLNZ wrote on 5/1/2020, 6:16 AM

Just an observation but we no longer have a 'Media Pool Thumbnails' folder in users AppData\Local\Movie Studio Platinum\17.0. Device Explorer Thumbnails and File Explorer Thumbnails are still there. I wonder where or how Media thumbs are now being handled?

mark-h33 wrote on 5/1/2020, 1:30 PM

I just downloaded MS17 Platinum and I'm off to a bad start. :( I really hope it's not my computer, but I can no longer drag and drop files on to my editor directly from a folder on my computer. It just crashes. Any ideas?

And I guess you need a super high tech computer for the preview window, because even though it bragged about a better preview display with its GPU, mine is still slow and choppy when I blend two clips together.

And lastly (third edit) I can't use mp4 files for some reason. Program crashes when I try.

j-v wrote on 5/1/2020, 1:45 PM

I just downloaded MS17 Platinum and I'm off to a bad start. :( I really hope it's not my computer, but I can no longer drag and drop files on to my editor directly from a folder on my computer. It just crashes. Any ideas?

That is not the way to add files. You have to drag them from the Vegas explorer that gives you the same files as directly from a computer folder.

 

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 452.06 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

j-v wrote on 5/1/2020, 2:12 PM

Here it becomes a little off-topic on this post about an upgrade.
Should it be possible to make your own post in this VMS forumpart?

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 452.06 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

robbif2 wrote on 5/1/2020, 4:45 PM

In some cases, I've been able to drag files from Windows 10 File Explorer to VMS16P. I did it today. I'm not sure, but maybe if the File Explorer is in Administrator mode.

Paul-Hikari wrote on 6/14/2020, 6:33 PM

Movie Studio 17 appears to ignore my project settings when rendering videos, specifically the frame rate I set. I have a video running at 12 frames per second, bu when I try to render it using the Make Movie easy option, it defaults to 30 frames per second. Furthermore, all rendered video files below 23 frames per second render with desynched sound.

j-v wrote on 6/15/2020, 3:30 AM

Movie Studio 17 appears to ignore my project settings when rendering videos,

Therefore you need the Platinum version. There you have to customize the desired rendertemplate to output 12 fps

 

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 452.06 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!