Vegas Pro 12 "not responding"

PowerVine wrote on 2/4/2013, 10:41 AM
I am running the latest build of Vegas Pro 12 and have the latest video drivers installed. If I start a new project and import video (mov, mpg2, or mpg4) or stills (jpg) the program hangs and gives me the message "not responding." I have to restart and the same thing happens again. I can import audio (wav) files and drop them into the timeline and Vegas seems to be OK with that. However, I need to do video editing. This just started happening 3 days ago. I tried uninstalling and reinstalling but no improvement. Any suggestons?


Tech Diver wrote on 2/4/2013, 10:56 AM
Have you tried rolling back your registry to an earlier restore point?

ForumAdmin wrote on 2/4/2013, 11:01 AM
Powervine, can you tell me what your Project Media window's View setting is? (e.g. Thumbnails?) If it is set to Thumbnails view, please set it to Details or List and try again, then let me know the results.

PowerVine wrote on 2/4/2013, 11:38 AM
Thanks for the suggestion. Tried it. Didn't work.
PowerVine wrote on 2/4/2013, 11:42 AM
The view setting was Thumbnails. I changed it to List and then to Details and the problem was solved. However, as soon as I put it back to Thumbnails the program quit responding and I had to close it. Thanks for pointing me to where the problem is coming from. However, Is there anyway I can fix this so that I can go back to Thumbnails which I prefer and have been using in the past?
ForumAdmin wrote on 2/4/2013, 11:48 AM
PowerVine, thanks for confirming the problem. Please navigate to the following folder (make sure hidden files and folders are being shown):

C:\Users\[your user name]\AppData\Local\Sony\Vegas Pro\12.0\Media Pool Thumbnails

Select all of the contents of this folder, and delete them. Then launch Vegas again, and you should be back in business. Please let me know if the problem persists.

PowerVine wrote on 2/4/2013, 12:04 PM
Thank you, ForumAdmin. That fixed the problem. I had a power glitch a few days ago when the program was running and I suppose that caused those thumbnails to get stuck in the folder. After the power glitch I did use the program to finish editing an older project that I had created before the glitch. I didn't have a problem editing that video. It was when i tried to import videos into a new project that it started locking. I hope that never happens again, but I am keeping notes on this so that I will know what to do next time.
PhillB wrote on 2/12/2013, 11:37 AM
Just had exactly the same problem and clearing out the thumbs folder seems to have fixed the issue. The folder was full of thumbs from same project, which had a "vegas has stopped working" crash earlier.
VanLazarus wrote on 2/13/2013, 6:41 PM
Hi Paddy, Is there any way that Vegas code could be changed so that it handles this problem more elegantly instead of becoming unresponsive?
MUTTLEY wrote on 2/13/2013, 9:19 PM
Was hoping that this might fix the similar problem I had in another thread Thread : Opening Project Takes Hours) but apparently not, only option for me still is just not having the Project Media tab open at all.

- Ray
Underground Planet
Laurence wrote on 2/14/2013, 6:55 AM
Projects are opening fine for the vast majority of users. Don't let a couple of bad apples put this incredibly wonderful software down. All projects are opening perfectly for me.
Laurence wrote on 2/14/2013, 6:56 AM
By the way, the previous post was a joke.
ForumAdmin wrote on 2/14/2013, 9:51 AM
VanLazarus said: Hi Paddy, Is there any way that Vegas code could be changed so that it handles this problem more elegantly instead of becoming unresponsive?

Yes, we are currently investigating this issue and will address it ASAP.

JBird wrote on 2/14/2013, 9:52 AM
I don't have a AppData folder at all. I looked because although my computer is happy with build 394 of Vegas 12, when I load version 486 it crashes every time I attaempt to scroll thru my media in the media bin. I re-loaded 394 and everything works fine. I would put 486 back on, but I just can't seem to use it without Vegas 12 crashing.
When I download the 486 file the file size is 231,029kb. Someone on the Linked in Vegas user forum thought it should be 236,573,696 bytes. Am I not getting the entire file? I have tried downloading it 3 times and got the same file size every time.
vkmast wrote on 2/14/2013, 10:10 AM
AppData or Application data is a hidden folder in Windows 7. To access this folder you have to select “Show hidden files and folders” in the folder options.
JBird wrote on 2/14/2013, 7:40 PM
I found the folder and deleted the files. Then I reloadewd the 486 update. It still doesn't work at all. If I load an mxf project it crashes before it finishes loading. If I load an HDV project it loads, I can scrub the timeline (or play it), but when I attempt to scroll down my files in the media bin Vegas crashes again (white screen). Build 486 is absolutely useless on my computer. By the way - build 394 works nearly flawlessly on my computer. Sony - what did you do and when will you fix it?
Barry W. Hull wrote on 2/15/2013, 6:11 AM
JBird, your experience is my experience. Vegas had worked for years with essentially no issues, Vegas 12 v486 included. Then something happened, not sure what, and now v486 will not function, at all, period, (not responding), white screens, frozen screens.

I rolled back to v394 and that is working, but with regular crashes, I save often. I purchased a session with tech support, however they could not find the answer, suggested it was something with my system, and it might be, but all other software continues to work, and I am unable to discover the system issue.

I've become so frustrated, paranoid about the next crash, I'm buying a computer for nothing except Vegas. An expensive proposition, but something you might want to consider as well. I've spent two weeks trying to solve this with no luck, and I remember how nice Vegas worked on my machine, makes it all the more frustrating. Time is money, this just needs to work.
MUTTLEY wrote on 2/15/2013, 9:53 PM

If ya haven't read my similar thread that I mentioned above, what was suggested and worked for me is to close the project media tab before opening the actual project and leave it closed. I only had one project that had this issue but leaving it off for now just to be on the safe side.

- Ray
Underground Planet
Albert Barbieux wrote on 4/29/2013, 2:37 AM
I have the same problem too, and I don't see solution.

I don't like close de project media windows because I use often the search in project media for find an element from the timeline.

It is perharps already said, but I see that the response time increase when the number of media bin decrease. But it is not a solution.

Sony don't give an answer for the moment.
larry-peter wrote on 4/29/2013, 8:38 AM
@Barry and others who find Vegas' behavior suddenly changed. Check this thread:

Mike's response to me about a recent Win7 update that was hosing things was spot on, in my case. Uninstalling this update brought Vegas' performance back to normal on my system.
Albert Barbieux wrote on 4/29/2013, 9:35 AM

I have uninstalled th update of microsoft that you said but, unfortunately this is not the good solution. The loading of my project is always very long.


Weldon wrote on 4/30/2013, 5:14 AM
I have tried both sets of suggestions posted on this thread and am still having serious "not responding" issues. I have had no trouble with VP12 since the beta version... If it is a windows update, how do you know which one or how to remove it?
Barry W. Hull wrote on 4/30/2013, 7:30 PM
atom12, thanks for those suggestions. I have a brand new box with nothing on it except Vegas and Vegas related software. For the most part it is stable.

There are however the occasional completely random crashes, such as about 75% of the time I use stabalization, sometimes it works, sometimes not. VASST Ultimate S Pro seems buggier than I remember in the past, can only render two files in a row before it crashes, etc.

I've learned to "save" often, muddle through.
stanleyc wrote on 7/6/2013, 3:58 PM
Dear ForumAdmin,
This issue continues for me even after doing all you recommended on this tread. I am beyond frustrated as I bought a brand new computer with the latest GPU support and latest Intel processor. I did that because my older computer did not have GPU acceleration support and was having the very same issues with VP 11 and VP 10. I was told by technical support that my system was the issue. SO, I bought the new computer just to find out that this is actually a known issue by Sony.
Since this tread is old (April 2013) compared to my post date, I want to believe that Sony has found the solution. Please check my system configuration and let me know your recommendation. This is the only hobby I have and I have been frustrated for a long time, even to the point of considering to move to a different software manufacturer.... But I keep remembering the good old days when I had NO problem with Vegas. Please help...
ForumAdmin wrote on 7/6/2013, 5:52 PM
Hello stanleyc, I can't see your system specs, most likely because they're not enabled in your forum profile. Can you enable them so they'll be visible? Thanks.

Also, please let us know what build of Vegas you are running. The latest one, build 563, includes a fix for the problem described above.