Sony AVC Codec Missing

Beatdemon wrote on 6/16/2012, 7:49 PM
Can anyone tell me why the Sony AVC codec cannot be found in the export options? Only MainConcept's codec is there. I've had nothing but trouble trying to export with the MainConcept codec using "GPU" and want to try Sony's. It's there in Vegas 10, but no longer in 11? Am I missing something?

Thanks in advance for any help you can offer.


Tom Pauncz wrote on 6/16/2012, 8:07 PM
First, your terminology - EXPORT. I trust you mean RENDER AS.. Right?

Depending on your project setting, in the RENDER AS.. dialog if you have 'Match project settings' checked, it may not show up.

I have no problem seeing the SONY AVC option in that dialog - running VP11-64bit.

Beatdemon wrote on 6/16/2012, 8:30 PM
Hi Tom,

Yes, I mean "RENDER AS" in all caps. ;)

I've indeed tried everything: making sure "match project settings" is unchecked, "view all options" is checked, tried 'more filter options" to no avail. I've re-installed Vegas Pro 11 64bit, no go. My only options for "Sony" are "Sony Perfect Clarity Audio' and 'Sony Wave64". Should the "Sony AVC" codec option be listed with the aforementioned?

I just uninstalled Vegas 10, so maybe I need to now try re-installing 11?

Tom Pauncz wrote on 6/16/2012, 8:48 PM
That says to me that you are trying to render out AUDIO ONLY or that Vegas thinks there is no VIDEO attached to that audio.

Make sure that the audio track is not 'Solo' - exclamation mark in the audio track header is off and that the video track is not muted.

Can you post a screenshot of your Vegas workspace?


CAPS for emphasis/clarity - not shout. :-)
Beatdemon wrote on 6/16/2012, 10:20 PM
To be clear: I am seeing other video codecs as well, including the MainConcept codec. Nothing is muted or solo'ed (I'm a pro audio guy by trade and have been working in computer DAWs for over 15 years now).

Here is a screenshot:

Thanks for your help, BTW... I was just playin' RE: CAPS ;)
Tom Pauncz wrote on 6/17/2012, 12:01 AM
This is weird to be sure.

Thanks for the w/space post, but I wanted to see your timelines. In any event, if other video codecs are showing up, I am sort of at a loss....

Grazie wrote on 6/17/2012, 1:42 AM
What BUILD of VP11 are you running? The last, most recent was 682(32bit) and 683(64bit). Reading the WHITE Papers on this again, there was much activity by the SCS Engineers on AVC, SONY and MC and GPU and so on.

I can't repro your issues. I've just done renders using the CODECs.



PLS wrote on 6/17/2012, 3:42 AM
There is an old, known issue with the Sony AVC codec dissapearing when using Vegas Pro 11 if the early version of NewBlue Titler Pro was installed. NewBlue Titler Pro version 111013 infact. We were told to update to the newer version to resolve the issue.
Beatdemon wrote on 6/18/2012, 4:49 PM
OK, thanks for the replies everyone. I have checked the build and it is 683 (64bit) and I do have the NewBlue Titler Pro installed, but it's version 120528.

I wish Vegas had a "repair" feature since I've had to uninstall/reinstall twice already. I wonder if it's a VST plug-in that might be causing it... time to disable that folder and see, I suppose.

UPDATE: Nope, disabling the VST plug-in folder didn't change anything. I'm at a loss here as to what to do. Does anyone know the name of the plug-in and the folder location so I can see if it was even installed?
PeterWright wrote on 6/19/2012, 12:16 AM
If you have New Blue Titler installed, I would definitely try removing it - it's been associated with many problems ....
Wovian wrote on 6/19/2012, 3:51 AM

I hope you can get to render using the Sony AVC codec because your render may be successful given my experience.

I have Pro 11 and the New Blu Titler and could not render using the Main Concept codec but could with the Sony AVC version.

Sorry I can't help you find it on Pro 11 but the guys on this forum are hot so if anybody can help you they certainly can.
cohibaman#1 wrote on 6/19/2012, 5:42 AM
I would check the NewBlue Pro Titler you have installed, as the version I was told should be 120402:

"Subject: RE: Confused on which NewBlue Pro Titler to install

Reply by: jetdv

Date: 6/13/2012 6:21:22 AM

The correct version is build 120402 and can be found here:"
Beatdemon wrote on 6/19/2012, 12:40 PM
I did a "Check for updates" from within NewBlue Pro Titler and it prompted me to download the version I just installed. Prior to the update I had 120402 installed and was still not seeing the Sony AVC Codec. So I don't know what is going on. I will try uninstalling/reinstalling again now that I no longer have Vegas Pro 10 installed and see if that solves the issue. I am just worried that doing this nearly 3 times in a row is going to throw up red flags at Sony.
vkmast wrote on 6/19/2012, 12:57 PM
the Check for updates info window seems to indeed have changed in the last few days.Among other things, it now states
Latest available version 1.1 Build 120528.
Maybe this has been updated after jetdv posted his info... I'm waiting for further confirmation before downloading and installing this build.
Beatdemon wrote on 6/19/2012, 1:03 PM
Yes, this is the version I currently have installed. Still no Sony AVC Codec.
cohibaman#1 wrote on 6/19/2012, 4:45 PM
Thanks for the info about NB Pro Titler update change...sorry if if I was derailing thread.
Beatdemon wrote on 6/20/2012, 5:17 PM
I fixed it!

What I had to do was:

1. Locate the following folder: /Program Files/Sony/Vegas Pro 11.0/FileIO Plug-Ins/mp4plug3
2. Move mp4plug3 (Sony's AVC Codec) to a different location, temporarily
3. Start Vegas Pro 11 and then quit out of it
4. Move mp4plug3 folder back
5. Restart Vegas Pro 11 which then re-scans the folder and miraculously adds it.

Weird. Well, now if anyone else has this problem they can try this. ;)


Steve Mann wrote on 8/3/2012, 5:05 PM
I also lost the Sony AVC codec, tried this trick, no joy.
Chaborel wrote on 8/3/2012, 8:24 PM
It doesn't work for me either. I still missing Sony AVC Codec.
Woodenmike wrote on 8/4/2012, 9:20 AM
Nope...I've been missing it too on a fresh installl on a new machine...was going to post the question but you beat me to it. tried the trick, but without results.
john_dennis wrote on 8/7/2012, 1:32 AM
Just built a new machine and I'm missing the Sony AVC/MVC codec, too. Quite disconcerting as I have rendered 100s of hours with the old machine.
kplo wrote on 8/7/2012, 12:11 PM
In a previous thread, I posted about the Sony AVC plug causing an "unknown error" pop up when trying to render (Vegas 7.0d).
I tried the 'remove and restart" trick and now it doesn't even show up as a render choice any more!
Go figure.
john_dennis wrote on 8/15/2012, 12:28 AM

I just solved this problem on my i7-3770K machine by installing the latest Windows 8 driver for the HD 4000 video adapter in the 3770k.

When I built the machine, I dutifully downloaded the most current video driver from the motherboard mfr, ASUS.

When that didn't work with Vegas Pro 11-64 bit, I took the driver update offered on Windows Update. (I rarely do such a thing but I had nothing to lose.)

When that didn't work, I went to Intel's site and downloaded the Windows 7 driver that was offered. It failed to fix the problem.

Since I reasoned that OpenCL would be the only means of video acceleration for Vegas Pro with the Intel HD 4000 video adapter, I searched for information on OpenCL. While reading about OpenCL, someone mentioned that the Windows 8 video driver from Intel was backward compatible to Windows 7 so I tried it and it worked.

The 64 bit driver (version is here.
Beatdemon wrote on 8/15/2012, 9:18 PM
John, you are a rockstah! Installing the OpenGL version of that package from Intel fixed my problem. I'm scratching my head as to why Sony hasn't figured this out. Hopefully they are reading this.

The "trick" I posted earlier only worked a couple of times. I'm at a loss as to why it worked, and why it stopped working... but whatever, your fix is the one!


john_dennis wrote on 8/15/2012, 9:39 PM
Good that you are running as expected!

I could speculate as to why the video driver should have such an effect but it would be futile since I'm not a programmer or video hardware designer. Besides that, I haven't been a rock star for more than 30 years.

My SWAG is that the code in the context sensitive "Render As" dialog is too complicated and/or broken. It would seem to me that if the program was checking for video card capabilities in order to present codecs and it didn't find CUDA, OpenCL or the flavor of the month, it should still present Sony AVC since it can be rendered with the 4 CPU cores that my system has. But that's just me... and I'm not a programmer or video hardware engineer.