How to remove gaps when adding multiple clips at once

nateconlon wrote on 1/23/2021, 10:21 AM

I'm often dealing with uncompressed videos which have been broken down into lots of smaller clips - usually 70+ clips. When I import them into vegas and place them on the timeline, there's always a 1 frame gap between each clip. I was wondering if there is some kind of option/preference I can change which will prevent this or if there's a way to remove these gaps en masse.

Comments

Jack S wrote on 1/23/2021, 10:34 AM

@nateconlon There's an option in the event context menu called 'Close gaps'. You need to select your first event (clip) on the timeline, right-click it and select 'Select events to end' (or Ctrl+A) which will highlight them all. Then right-click on any one of them and select 'Close gaps'. See if this does it for you.

My system
Genshin Infinity Gaming PC
Motherboard Gigabyte H610M H: m-ATX w/, USB 3.2, 1 x M.2
Power Supply Corsair RM750X
Intel Core i7-13700K - 16-Core [8P @ 3.4GHz-5.4GHz / 8E @ 2.50GHz-4.20GHz]
30MB Cache + UHD Graphics, Ultimate OC Compatible
Case Fan 4 x CyberPowerPC Hyperloop 120mm ARGB & PWM Fan Kit
CPU Fan CyberPowerPC Master Liquid LITE 360 ARGB AIO Liquid Cooler, Ultimate OC Compatible
Memory 32GB (2 x 16GB) DDR5/5200MHz Corsair Vengeance RGB
MSI GeForce RTX 4060 Ti 8GB - Ray Tracing Technology, DX12, VR Ready, HDMI, DP
System drive 1TB WD Black SN770 M.2 NVMe PCIe SSD - 5150MB/s Read & 4900MB/s Write
Storage 2 x 2TB Seagate BarraCuda SATA-III 6.0Gb/s 7200RPM
Windows 11 Home (x64)
Monitors
Generic Monitor (PHL 222V8) connected to GeForce RTX 4060 Ti
Generic Monitor (SAMSUNG) connected to iGPU

Camcorder
SONY Handycam HDR-XR550VE

Former user wrote on 1/23/2021, 11:15 AM

And make sure you have Quantize to Frame enabled.

Not sure why there is a gap unless your source frame rate does not match your project frame rate.

nateconlon wrote on 1/23/2021, 1:21 PM

Thanks for the help guys! Although the gaps appearing is a lot less consistent than I may have indicated. After looking through the timeline a few times, I've noticed that sometimes there aren't any gaps between clips. I think this might have to do with the clips I'm using being 59.293fps as I've noticed that gaps are occurring between frames. Is there anyway I can avoid this? I've tried setting my project frame rate to an integer but that doesn't seem to help, I'm guessing I may have to change the fps of the clips themselves

Former user wrote on 1/23/2021, 4:28 PM

You can't and don't want to change the frame rate of the clips. 59.293 is normal for NTSC HD video. Use the Match Source option in Vegas to match the timeline to your source and that should be fine. I don't know if that will fix your gaps, but it might.

nateconlon wrote on 1/23/2021, 5:00 PM

Ah I see, that's good to know, thank you! Although I'm afraid matching my project settings to the source doesn't help with the gaps. The "Close Gaps" option is also greyed out when I tried what Jack suggested. I'm starting to think I may have to fix this issue manually haha.

Kinvermark wrote on 1/23/2021, 5:09 PM

Uhh que? Double NTSC is 59.94 NOT 59.293 That is a very strange number and indeed likely to be causing problems.

wwaag wrote on 1/23/2021, 6:24 PM

Most likely you are using footage that is variable frame rate which is causing the problem of the footage not ending on frame boundaries. In order to check, open internal preferences and search for "quan" and set “Show Unquantized event end” to TRUE as shown here.

If there are unquantized events, they will look like this on the timeline with a red bar.

If you have Vegasaur, there is a tool for quantizing events. If not, there is a free tool in the HappyOtterScripts Free Tool Library, Quantize to Frames, that can help. Here's the link. https://tools4vegas.com/quantize-to-frames/ and a screen grab of the UI.

AKA the HappyOtter at https://tools4vegas.com/. System 1: Intel i7-8700k with HD 630 graphics plus an Nvidia RTX4070 graphics card. System 2: Intel i7-3770k with HD 4000 graphics plus an AMD RX550 graphics card. System 3: Laptop. Dell Inspiron Plus 16. Intel i7-11800H, Intel Graphics. Current cameras include Panasonic FZ2500, GoPro Hero11 and Hero8 Black plus a myriad of smartPhone, pocket cameras, video cameras and film cameras going back to the original Nikon S.

nateconlon wrote on 1/30/2021, 1:20 PM

Apologies for the slow response, life has been busy. Unfortunately, the "Show Unquantized Event End" option yielded no results. I appreciate all the help so far though. Please let me know if there is any kind of information I can supply that might be helpful.

PeterDuke wrote on 4/22/2023, 1:41 AM

Thanks for the responses in this thread which led me to the solution to my problem.

I have been a long-time user of Vegas but recently started getting problems of gaps of about 1 frame between many but not all clips when I dragged them to the timeline. I spent hours looking for the cause.

It turned out to be due to the default project properties of Vegas being set to an NTSC template (29.970 or 59.940 fps) when the source clips were to a PAL template (25 or 50 fps). Vegas asked me if I wanted to match the project properties to my source, which it did, but apparently after it had put them on the timeline. A PAL clip will almost never be a multiple of an NTSC frame in length, hence the gap at the end.

The solution is to not rely solely on Vegas to set the project properties to match the source for you, but to first make sure that the default project properties use the same video standard as your clips, before you drag them to the timeline.

vkmast wrote on 4/22/2023, 3:13 AM

@PeterDuke glad to see you're still around and posting again.

PeterDuke wrote on 4/22/2023, 5:04 AM

Thanks VK

In retrospect, I think I should have recommended:

Do not rely on Vegas to set the project properties to match the source for you, but first make sure that the default project frame rate is the same as your clips (use say Mediainfo if you are not sure of the source frame rate) before you drag them to the timeline. It is OK to accept Vegas's offer to do the matching if only the frame sizes are different.

Another strategy may be to drag the first clip to the timeline, let Vegas set the frame size and frame rate, and then drag the remaining clips to the timeline, being sure not to leave a gap at the end of the first clip.