Comments

RogerS wrote on 9/16/2020, 5:34 AM

Do you have both installed at the same time? I would just put in one at a time. For NVIDIA, you can add VP 18 in the NVIDIA Control Panel. Try the latest NVIDIA Studio Driver.

KZNM wrote on 9/16/2020, 6:05 AM

Do you have both installed at the same time? I would just put in one at a time. For NVIDIA, you can add VP 18 in the NVIDIA Control Panel. Try the latest NVIDIA Studio Driver.

I remember that VP17 shows both graphic card.
I think I should touch some settings. Thank u!

j-v wrote on 9/16/2020, 6:27 AM

I remember that VP17 shows both graphic card.
I think I should touch some settings. Thank u!

No, since VPro 18 there is a big difference for that option compared to the former version.
Set this option to default because the program chooses itself the best settings for this option.

 

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 2004 build 19041.264, i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti.
Laptop  :Asus ROG GL753VD, W10 home version 2004 build 19041.264, CPU i7 7700HQ, 8 GB RAM, GeF. GTX 1050 (2 GB) + Int. HD Graphics 630(2GB).VP 17,18 and VMS PL 16,17 are installed, all latest builds
Both Nvidia GPU's have driver version 456.71 Studio Driver.
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Illusion wrote on 9/16/2020, 6:42 AM

There is only Off and Auto(Off) option in the list.

I have Geforce GTX 1070Ti, and RX560 and both doesnt work it.

I already Delete driver with DDU, and re-install it.

My version is Pro 18 284 build.

How can I fix it?

(sorry for my weak english writing)

I had the same thing when I selected "Enable Legacy AVC/HEVC decoding" under File I/O. After unchecking them and restarting Vegas, I was able to choose NVDEC.

KZNM wrote on 9/16/2020, 6:44 AM

There is only Off and Auto(Off) option in the list.

I have Geforce GTX 1070Ti, and RX560 and both doesnt work it.

I already Delete driver with DDU, and re-install it.

My version is Pro 18 284 build.

How can I fix it?

(sorry for my weak english writing)

I had the same thing when I selected "Enable Legacy AVC/HEVC decoding" under File I/O. After unchecking them and restarting Vegas, I was able to choose NVDEC.

I can now select both my graphic cards!

Thank you very much!!

Howard-Vigorita wrote on 9/16/2020, 4:24 PM

That's an interesting idea. I have systems with amd gpu's but no igpu and have been waiting for Intel to release it's pcie xe-board so I could dedicate it to decoding. I wonder if dropping in an nvidia board would work just as well. Or better. If Vegas buys it, I think the only downside might be knocking pcie lanes available to each board down from 16 to 8.

Cameras: Z-Cam E2 classic, Canon XF305, JVC GV-LS2, Canon 6D w/L-glass line.
Laptop: Dell XPS15-9570; i7-8750h 32gb (integrated Intel UHD-630 & Nvidia GTX-1050Ti)
Road: Intel NUC i7 8809g 32gb (integrated AMD VegaM 4gb graphics and Intel HD630)
Workstation: i9 9900k 32 gb (Sapphire AMD Radeon VII 16gb graphics and integrated Intel UHD630)
Workstation2: e5 1650v4 128 gb (Sapphire Nitro+ RX5700xt Navi 8gb graphics)
Workstation3: i7-980X 24gb (Sapphire Nitro+ Vega64 8gb graphics)
currently Vegas 17.452 (testing Vegas 18.284)

PhilippZ wrote on 9/29/2020, 2:29 AM

Hi, unfortunately I have the same issue, but the Fix doesnt helped. Maybe you know a other fix?

KZNM wrote on 9/29/2020, 6:10 AM

Hi, unfortunately I have the same issue, but the Fix doesnt helped. Maybe you know a other fix?

Options -> File I/O -> Disable 'Enable legacy AVC decoding' and reboot Vegas

I fix by this way, but when this doesnt work just reset it.

You can press Ctrl+Shift and double click Vegas then it will reset

andyrpsmith wrote on 9/29/2020, 6:24 AM

You can easily check if Vegas is using the GPU (NVIDIA) by running Task Manager and selecting the GPU. It will show % use for both encode and decode. If 0% when playing the timeline (need to be using the So4compoundplug) then you have no video acceleration and if 0% for encode when rendering with a NVDEC template V18 is not using your card. (I'm not sure how AMD Cards show as I don't have one).

vkmast wrote on 9/29/2020, 6:37 AM

The full resetting instructions. You need to clear the cached data as well.

PhilippZ wrote on 9/30/2020, 12:12 AM

Unfortunately, all attempts and solutions so far have been unsuccessful. Reinstalling Windows and Vegas was unsuccessful. Another graphics card + reinstallation of all drivers (clean uninstallation) did not bring any success.

I'm in close contact with Vegas Support, but we're now at a loss.

A BIOS reset and chipset update were also unsuccessful.

Maybe someone (hopefully me) will find a solution one day, then it will be posted here!

My system: AMD Ryzen 7 1800x / Nvidea GTX 1080 8GB / 32 GB RAM

RogerS wrote on 9/30/2020, 1:12 AM

Dumb question but it seems some people using non-English localized versions of Vegas are having issues. Any way to give it a try with the stock English version (is that just setting language to Eng?) Do other apps that use the graphics card (like a benchmark) work right?

VEGASPascal wrote on 9/30/2020, 3:17 AM

 

Unfortunately, all attempts and solutions so far have been unsuccessful. Reinstalling Windows and Vegas was unsuccessful. Another graphics card + reinstallation of all drivers (clean uninstallation) did not bring any success.

I'm in close contact with Vegas Support, but we're now at a loss.

A BIOS reset and chipset update were also unsuccessful.

Maybe someone (hopefully me) will find a solution one day, then it will be posted here!

My system: AMD Ryzen 7 1800x / Nvidea GTX 1080 8GB / 32 GB RAM

@VEGASHeman Could you jump in? A clean system with VP18 and the latest NVIDIA driver for the 1080 GTX. @PhilippZ is not able to use NVDEC. The File I/O interface is reacting like "Enable Legacy AVC/HEVC decoding" is selected but unselecting is not returning the normal behaviour.

KZNM wrote on 9/30/2020, 5:09 AM

멍청한 질문이지만 영어가 아닌 지역화 된 Vegas 버전을 사용하는 일부 사람들이 문제가있는 것입니다. 기본 영어 버전으로 시도해 볼 수있는 방법이 있습니까? (그냥 언어를 영어로 설정하는 것입니까?) 그래픽 카드를 사용하는 다른 앱 (예 : 벤치 마크)이 제대로 작동하고 있습니까?

im using VP18 English version but i have same problem

I think its not the main problem

VEGASHeman wrote on 9/30/2020, 3:15 PM

@VEGASPascal: Thanks for alerting me to this thread. I will be contacting @PhilippZ and any one else who has similar problems (related to either hardware decode options not being available, or issues starting up VEGAS) directly to both understand their specific problem, and provide updated builds of VEGAS to help fix it. I may not be able to reach out to every one who has this issue right away, but will try to do so over the next day or so.

JN- wrote on 10/2/2020, 6:00 PM

I finally got around to this, both laptop and desktop had only 2 options, off and Auto off. Fixed on both machines by holding down shift/Ctrl while double clicking the shortcut on the desktop. @andyrpsmith Thanks, Taskmanager is a great way to confirm and see the change take place. Preview playback in best/full went from a few fps to full, nice.

---------------------------------------------

VFR2CFR, Variable frame rate to Constant frame rate etc

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

JN- wrote on 10/2/2020, 7:16 PM

@VEGASHeman

All this now on laptop.

This is a real mess. I thought I was there, it comes and goes. I don't know what causes, i.e. is it because sometimes I run VP18 from the taskbar icon, or right click an .mp4 file and load vegas that way.

To clarify, the decoding can be obviously working, or not, by viewing GPU decoding in task manager and watching the preview playback speed.

What's happening is that after doing the reset, clearing cache, I thought that this was fixed.

Now I see that the I/O state doesn't always reflect the reality of whether decoding is/is not available.

So, decoding can actually be available, really working, when the I/O "Hardware decoder to use" value is Off or Auto Off. I don't set it to Off or Auto Off, it sometimes automatically goes off/toggles itself from say the previous session where it was last set as "Nvidia Nvdec"

Decoding can actually NOT be available when the I/O "Hardware decoder to use" value shows Nvidia Nvdec.

The values in the list change, disappear sometimes on next launch of VP. They can be only 2, Off and Auto Off, or 3 Off, Auto Off and Nvidia Nvdec. But which item that appears doesn't necessarily match the reality, though it mostly does, it can say off when you have Decoding availibility, and it can show Nvdec when decoding availibility is not obviously available, easy to see via Task Manager and Preview playback window fps.

Simply put, changing the values, if 3 are available, and hitting apply, is not guaranteed to last. Reminds me a little bit of the way the favourites in the VFX wouldn't stay when you closed VP and then launched again, in the previous build.

Last changed by JN- on 10/2/2020, 7:28 PM, changed a total of 4 times.

---------------------------------------------

VFR2CFR, Variable frame rate to Constant frame rate etc

Benchmarking thread

Codec Render Quality tables

---------------------------------------------

PC ... Corsair case, own build ...

CPU .. i9 9900K, iGpu UHD 630

Memory .. 32GB DDR4

Graphics card .. MSI RTX 2080 ti

Graphics driver .. latest studio

PSU .. Corsair 850i

Mboard .. Asus Z390 Code

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..32 GB DDR4, was previously 16 GB

Graphics card .. Nvidia GTX 1070

Graphics driver .. latest studio

lenard-p wrote on 10/2/2020, 8:51 PM

I also get Auto Off, or Nvdec , seemingly randomly . I only notice the lack of decoder due to lagginess or excess cpu use , then check decoder setting, then check gpu decoding graph. I've restarted vegas and then the decoder came back and was operational.