Comments

Mike_Byrd wrote on 5/13/2022, 9:23 PM

I am seeing this exact thing currently with latest studio drivers from NVIDIA and latest VP19 550. After a number of BRAW files added ~20 in my case, things go black and Vegas stops working correctly for video (preview, timeline, trimmer, scrubbing thumbnails all black).

What appears to be happening is that when opening BRAW (6k, 24p) files, the GPU (NVIDIA RTX laptop 3070) memory is loaded up incrementally with each one - GPU has 8GB RAM and once that fills up (monitoring memory used with GPU-Z app) any additional added BRAW are black. The larger problem is that the memory never seems to release/clear, so once I open about 20 BRAW files, my 8GB is maxed and everything else after is black. Then also the trimmer, timeline, preview etc. also all go black because, I assume, the GPU can't function properly since its memory is full.

Even if I remove all the clips from the timeline and from the project, the GPU memory load never decreases until I quit VP19. I don't expect this is the preferred behavior.

In further testing, I changed 'GPU acceleration of video processing' to the Intel UHD and there is no black frames - but GPU-Z does show large amounts of system memory being used by the Intel GPU.

I'd be happy to provide any additional detail.

john_dennis wrote on 5/13/2022, 9:42 PM

@Mike_Byrd

Perhaps you would like to upload a sample file to a cloud drive and post the link here so people could test on their systems?

My main system:
Motherboard: Asus X99-AII
CPU: Intel i7-6850K
GPU: Sapphire Radeon RX480-8GB
RAM: Corsair Dominator (4 x 4 GB) DDR4 2400
Disk O/S & Programs: Intel SSD 750 (400 GB)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: Corsair Hydro series H115i
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Crystal Sound 3 on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 190943
Camera: Sony RX10 Model IV

https://www.youtube.com/user/thedennischannel

Mike_Byrd wrote on 5/13/2022, 11:05 PM

@Mike_Byrd

Perhaps you would like to upload a sample file to a cloud drive and post the link here so people could test on their systems?

Happy to. Any old BRAW file should do the trick though if you just duplicate it and keep loading copies until your GPU fills up.

Mike_Byrd wrote on 5/14/2022, 12:51 PM

@Mike_Byrd

Perhaps you would like to upload a sample file to a cloud drive and post the link here so people could test on their systems?

https://we.tl/t-5Egh7SXiNH

Two BRAW files for your testing enjoyment.

john_dennis wrote on 5/14/2022, 1:38 PM

@Mike_Byrd

I used four files from the Black Magic web site to create this epic. Perhaps, it will illuminate your experience.

I'll try your files, too. Maybe they will be even more illuminating.

My main system:
Motherboard: Asus X99-AII
CPU: Intel i7-6850K
GPU: Sapphire Radeon RX480-8GB
RAM: Corsair Dominator (4 x 4 GB) DDR4 2400
Disk O/S & Programs: Intel SSD 750 (400 GB)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: Corsair Hydro series H115i
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Crystal Sound 3 on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 190943
Camera: Sony RX10 Model IV

https://www.youtube.com/user/thedennischannel

john_dennis wrote on 5/14/2022, 2:09 PM

@Mike_Byrd

Tell me when to stop.

My main system:
Motherboard: Asus X99-AII
CPU: Intel i7-6850K
GPU: Sapphire Radeon RX480-8GB
RAM: Corsair Dominator (4 x 4 GB) DDR4 2400
Disk O/S & Programs: Intel SSD 750 (400 GB)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: Corsair Hydro series H115i
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Crystal Sound 3 on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 190943
Camera: Sony RX10 Model IV

https://www.youtube.com/user/thedennischannel

Mike_Byrd wrote on 5/14/2022, 4:28 PM

@Mike_Byrd

Tell me when to stop.

My issue is 100% reproducible. It could well be related to the NVIDIA as I mentioned. I see you have an AMD GPU. Also, as I mentioned above, when I changed 'GPU acceleration of video processing' to the Intel UHD vice the NVIDIA, the issue went away. I've been editing that way to get the project done. However, there is clearly still an issue with the NVIDIA GPU memory full causing this error.

I appreciate you checking it as well with the AMD GPU which seems to be working fine per your posts. (Unless you have your GPU acceleration of video processing set not to use your AMD GPU.)

My hope is that since this is an error and is reproducible that the memory management issue can be isolated and addressed for a future release. I would like the option to use my NVIDIA GPU.

john_dennis wrote on 5/14/2022, 8:03 PM

@Mike_Byrd @VEGASHeman

My settings:

Have you filed a trouble report with Magix?

My main system:
Motherboard: Asus X99-AII
CPU: Intel i7-6850K
GPU: Sapphire Radeon RX480-8GB
RAM: Corsair Dominator (4 x 4 GB) DDR4 2400
Disk O/S & Programs: Intel SSD 750 (400 GB)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: Corsair Hydro series H115i
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Crystal Sound 3 on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 190943
Camera: Sony RX10 Model IV

https://www.youtube.com/user/thedennischannel

Mike_Byrd wrote on 5/14/2022, 8:55 PM

@Mike_Byrd @VEGASHeman

My settings:

Have you filed a trouble report with Magix?

After searching and finding the below instruction on how to actually file a ticket I now have!

Link to instructions: https://www.magix.info/us/forum/unable-to-record--1272206/#ca1661047

 

john_dennis wrote on 5/14/2022, 11:47 PM

@Mike_Byrd

I tried the files on my laptop which has an Intel and AMD video adapter. Both work (poorly).

My main system:
Motherboard: Asus X99-AII
CPU: Intel i7-6850K
GPU: Sapphire Radeon RX480-8GB
RAM: Corsair Dominator (4 x 4 GB) DDR4 2400
Disk O/S & Programs: Intel SSD 750 (400 GB)
Disk Active Projects: 1TB & 2TB WD BLACK SN750 NVMe Internal PCI Express 3.0 x4 Solid State Drives
Disk Other: WD Ultrastar/Hitachi Hard Drives: WDBBUR0080BNC-WRSN, HGST HUH728080ALE600, 724040ALE640, HDS3020BLA642
Case: LIAN LI PC-90 Black Aluminum ATX Full Tower Case
CPU cooling: Corsair Hydro series H115i
Power supply: SeaSonic SS-750KM3 750W 80 PLUS GOLD Certified Full Modular Active PFC Power Supply
Drive Bay: Kingwin KF-256-BK 2.5" and 3.5" Trayless Hot Swap Rack with USB 3
Sound card: Crystal Sound 3 on motherboard. Recording done on another system.
Primary Monitor: Asus ProArt PA248q (24" 1920 x 1200)
O/S: Windows 10 Pro 190943
Camera: Sony RX10 Model IV

https://www.youtube.com/user/thedennischannel

vkmast wrote on 5/15/2022, 3:49 AM

@Mike_Byrd the advice on how to contact VEGAS Support is here https://www.vegascreativesoftware.info/us/forum/customer-support--132075/#ca823263

Other links in this post https://www.vegascreativesoftware.info/us/forum/ask-support-advice--120281/ incl. also a visual tutorial from @john_dennis

The magix.info link is for MAGIX products. The procedure is basically the same though.

Gid wrote on 5/15/2022, 5:50 AM

@Mike_Byrd Hi, i had a play with your files, prob no use to you but thought i'd share how it went 👍🤷‍♂️

Dedicated memory filled up when play was started

but got to 16GB & the events needed to play through once before reaching full fps but all could still be played

closing the project Dedicated memory stayed high tho 🤔

Until Vegas was closed,

I tried filling up the GPU but it wouldn't, see count in project top left, all still playable.

I put a video on YT as to how it went, this was only 2 files replicated so i would prob need Lots of different files to try to get close replicating your issue, like i say just sharing

 

Last changed by Gid on 5/15/2022, 5:52 AM, changed a total of 1 times.

Vegas Pro 19 (Latest build), HitFilm Pro,  
Boris Continuum, Sapphire, Silhouette Standalone + Plugin, 
Mocha Pro Standalone + Plugin, Optics,
TurboCAD Platinum 2021
Desktop PC Microsoft Windows 10 Pro - 64-Bit
ASUS PRO WS WRX80E-SAGE SE WIFI AMD Motherboard
AMD Ryzen Threadripper PRO 3975WX 3.5GHz 32 Core
Corsair iCUE H150i RGB PRO XT 360mm All-in-One Liquid CPU Cooler
RAM 256GB ( 8x Micron 32GB (1x 32GB) 2666MHz DDR4 RAM )
2x Western Digital Black SN850 2TB M.2-2280 SSD, 7000MB/s Read, 5100MB/s Write
(Windows & programs on one, temp project files on the other)
Graphics MSI GeForce RTX 3090 SUPRIM X 24GB OC GPU
ASUS ROG Thor 1200W Semi-Modular 80+ Platinum PSU 
Fractal Design Define 7 XL Dark TG Case with 3 mounted Fans
2 x Seagate IronWolf 12TB NAS Hard Drives for file storage.

I'm 53, I've been a UK joiner for 37yrs, apprentice trained & time served, I make videos about my work & post them on Youtube so that i can share what I've learnt over the yrs,
https://www.youtube.com/c/Gidjoiner

At the moment my filming is done with a Samsung Galaxy S21 Ultra 5G
 

Yelandkeil wrote on 5/15/2022, 9:41 AM

Did test for HDR10 and SDR, both led VEGAS go crash or just vanish several times by synchro (audio) previewing. Rendering no problem.

Hier the SDR exercise, enjoy it, thanks.

 


Adrenalin 22.5.1 (WHQL) + 2xDP: Samsung (LU28R55x) 4k60Hz 300cd/m²HDR10 
Realtek 6.0.9239.1 (ALC1200 Backplate): ROCCAT Kave Solid 5.1Surround Headset/Mic 
USB Imput: iRig midi24Keys 
USB Device: Card Reader/Writer 

Vegaspro19 + DVDArchi7 + XMediaRecode 
Acidpro10 + SoundForgpro14.0.0.65 + SpectraLayers7 
K-LitecodecPack1662 (MPC Video Renderer for HDR10-Videoplayback)