VEGAS Movie Studio 17 Update 2 (Builds 159 & 204) - General Discussion

Bri-Hageman wrote on 10/30/2020, 10:49 AM

Dear Community,

We have just released the second update for VEGAS Movie Studio 17 (build 159)  and VEGAS Movie Studio 17 Platinum (build 204). Please give us your feedback in this thread.

If you already have an earlier build of VEGAS Movie Studio 17 or VEGAS Movie Studio 17 Platinum,  there is no need to uninstall it. These builds will overwrite your installation and retain your settings. Keep in mind that your computer will need to be online for activation after the update.

For more information, please refer to our official announcement with patch notes.

I hope you have a great rest of your week.

Sincerely,

Bri

Comments

Anna-Schaldenbrand wrote on 10/30/2020, 12:02 PM

Nothing happens when you go to the pages in the "Offical announcement" page so what are we suppose to do to get the 204 build?

pius-h wrote on 10/30/2020, 12:06 PM

strange thing: you want to do the update - the download takes a long time - then you do the installation - and the update says you have to close the program VMS (wich was closed) - there is no path for the download - the download has disappeared - so the whole thing again - can't you make it work properly?

j-v wrote on 10/30/2020, 12:07 PM

Maybe you had the internet problem I also had.
You can go to your Magix Account and download it under your products Movie Studio 17: https://www.magix.com/us/support/my-service-center/

BTW you have to be patient because their server is very busy with a lot more updates today.

Last changed by j-v on 10/30/2020, 12:09 PM, changed a total of 1 times.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 20H2 , i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti, Intel HD graphics 630
Laptop  :Asus EVO37T, W10 home version 20H2, CPU i7-10875H, 16 GB RAM, GeF.RTX2070 + Intel HD Graphics 630,NVIDIA GeForce RTX 2070
.VP 17,18 and VMS PL 17 are installed, all latest builds, both Nvidia GPU's have driver version 460.89 Studio Driver.both Intel GPU's have driver: 27.20.100.9126, DHC driver
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Anna-Schaldenbrand wrote on 10/30/2020, 12:31 PM

But under the Magix Account there isn't the build 204 so what now do we do?

 

vkmast wrote on 10/30/2020, 12:48 PM

Try https://www.magix.com/us/support/my-service-center/product-downloads/

Note also @j-v's "BTW".

VEGASDerek wrote on 10/30/2020, 12:56 PM

The link in the official announcement page should be working now.

BCBob wrote on 10/30/2020, 2:50 PM

I just installed Build 204. If I have Windows Media Player (WMP) playing some tunes, I'm finding loading Movie Studio 17 now interrupts WMP. Prior build didn't do that. Error message below pops up. Maybe I have a file association set incorrectly in Windows 10?? But I can't find anything.....

 

j-v wrote on 10/30/2020, 3:13 PM

To me that looks a Windows problem, not Vegas.
But you can try in Vegas to use another audio device.

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 20H2 , i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti, Intel HD graphics 630
Laptop  :Asus EVO37T, W10 home version 20H2, CPU i7-10875H, 16 GB RAM, GeF.RTX2070 + Intel HD Graphics 630,NVIDIA GeForce RTX 2070
.VP 17,18 and VMS PL 17 are installed, all latest builds, both Nvidia GPU's have driver version 460.89 Studio Driver.both Intel GPU's have driver: 27.20.100.9126, DHC driver
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

Dr Zen wrote on 10/31/2020, 7:58 PM

*UPDATE POSTED IN NEW MESSAGE BELOW*
Ignore everything I said in this message!

Just in case anyone is having the same problem, please be aware of this.
I posted the same message in the Vegas Pro update thread.

There appears to be a Magix Server problem at this very moment.
All download links for every version of Vegas Pro and Vegas Movie Studio ever published on this forum, are not working right now.
However, program update IS working through update windows inside of Vegas Pro and Vegas Movie Studio.

vkmast wrote on 10/31/2020, 8:05 PM

@Dr Zen Derek, I just tested the MAGIX Account, Download Center and Direct Links d/l options and all seem to be working here on the other side of the globe.

The only issue has been and was again that with at least Direct Links Chrome does not download, but Edge does (for me).

robbif2 wrote on 10/31/2020, 8:34 PM

The (seemingly) consistent annoyments in VMS are:
1. No way to "permanently" turn off a Major Update Window
2. No option to "download only" for later installation
3. Have the unchecked Options/Preferences/General/"Use Newsfeed..." box actually obey.

 

Dr Zen wrote on 10/31/2020, 9:47 PM

@Dr Zen Derek, I just tested the MAGIX Account, Download Center and Direct Links d/l options and all seem to be working here on the other side of the globe.

The only issue has been and was again that with at least Direct Links Chrome does not download, but Edge does (for me).

Now I get it. I wonder when that change was made to Google Chrome???
It must have been very recent!
I just tested Chrome, Firefox, new Microsoft Edge and Opera web browsers.
@Bri-Hageman needs to add a notation to the official download links, so that Chrome users know it won't work.

Google Chrome is now blocking any download links that are .exe files and is not issuing any warnings, which is bound to create a lot of confusion, considering Chrome is the No.1 most used browser.

Firefox downloads OK with now warnings.

new Microsoft Edge downloads after you approve a warning message.

Opera downloads OK with no warnings.

vkmast wrote on 11/1/2020, 5:39 AM

Copying the download link and pasting it seems to work in Chrome. See here https://www.vegascreativesoftware.info/us/forum/vegas-pro-18-update-2-build-373-general-discussion--124911/?page=2#ca777565

robbif2 wrote on 11/1/2020, 9:06 AM

@EricLNZ, Yes...slow, but working via Firefox.
Edit a few minutes later: About 3-4 minutes into two tries, Firefox just said "Failed..."

Julie-Jean-Janson wrote on 11/1/2020, 4:07 PM

After the update on 31 Oct 2020, Movie Studio says that it no longer supports MP4s. I have been using only MP4s since I bought the software not long ago. Please assist.. I don't want to buy another type of software that will support MP4s. Also, I have a deadline and this is really halting my work

Dr Zen wrote on 11/1/2020, 5:37 PM

I just installed Build 204. If I have Windows Media Player (WMP) playing some tunes, I'm finding loading Movie Studio 17 now interrupts WMP. Prior build didn't do that. Error message below pops up. Maybe I have a file association set incorrectly in Windows 10?? But I can't find anything.....

 

I'm fairly certain this is a Windows problem.
For the last 2 years, I also experienced the same problem and just learned to live with it.
I would stop any Media Player from playing while loading any version of Vegas, then re-start my Media Player.
This problem use to affect other programs as well - not just Vegas!

However, a few months ago I had to re-install Windows 10.
I did a full clean install of Windows 10.
After doing this, the problem with any Media Player crashing while Vegas loads, has completely disappeared!
My guess is that Microsoft has cleaned up some Audio Driver problems that have been there for a long time.
Of course, I can't guarantee if you did the same thing as me, you would get the same result.
What I would say though, is that re-installing Windows 10 has made my computer a lot faster now.
 

rafal-zazuniuk wrote on 11/1/2020, 5:59 PM

Hi.

After updating to build 204 my preview window became very choppy. Actually so choppy that editing is impossible. I never had this kind of of problem before this build. I have 24GB of ram and an I5 7200U @2.5ghz Intel CPU.

Janet-Shapan wrote on 11/1/2020, 6:50 PM

I had this same issue and now it is downloading on Edge. There have been lots of issues with Chrome lately loading general sites, so I am heading over to edge for a while. Not what I want to do, but maybe the best solution.

BCBob wrote on 11/2/2020, 9:07 AM

re: loading Movie Studio 17 interrupting Windows Media Player

j-v and Dr Zen, thanks for the replies. It does look like a Windows 10 issue, especially with no one else reporting the problem. I tried removing and reinstalling Windows Media Player but that didn't fix it. I don't want to do a Windows 10 reinstall so will live with the problem for now or perhaps try other media players.

robbif2 wrote on 11/2/2020, 1:59 PM

I just remembered having the problem with VLC doing the same thing on Windoze 10 with VMSP179.
I don't believe I've seen it for a while now. Of course it's now several Windoze Updates later.

rcflyer wrote on 11/7/2020, 8:34 AM

Hello , i'm new to movie studio and i just bought MS17 suite and i want to retain a copy of the program i downloaded but i don't know where the main program downloaded to. it looked to be about 500 megs and it's not in any of my folders etc. thanks

  • Desktop
  • ASUS z390-E gaming strix ROG motherboard
  • 32 GIG 3000mHz ram
  • I9-9900k Processor
  • MSI GTX1660 super gaming-X GPU
  • NVMe m.2 500 gig WD HD
  • 600W EVGA power supply
  • windows 10 pro
  • Camera : Canon VIXIA HF-G50 - Canon EOS Rebel T5i
j-v wrote on 11/7/2020, 8:44 AM

@rcflyer Look in your Documents/Magiix Downloads

met vriendelijke groet
Marten

Camera : Pan X900, GoPro Hero7 Hero Black, DJI Osmo Pocket, Samsung Galaxy A8
Desktop :MB Gigabyte Z390M, W10 home version 20H2 , i7 9700 4.7Ghz,16 DDR4 GB RAM, Gef. GTX 1660 Ti, Intel HD graphics 630
Laptop  :Asus EVO37T, W10 home version 20H2, CPU i7-10875H, 16 GB RAM, GeF.RTX2070 + Intel HD Graphics 630,NVIDIA GeForce RTX 2070
.VP 17,18 and VMS PL 17 are installed, all latest builds, both Nvidia GPU's have driver version 460.89 Studio Driver.both Intel GPU's have driver: 27.20.100.9126, DHC driver
TV      :LG 4K 55EG960V

My slogan is: BE OR BECOME A STEMCELL DONOR !!!

SantomPhith17 wrote on 11/7/2020, 2:11 PM

strange thing: you want to do the update - the download takes a long time - then you do the installation - and the update says you have to close the program VMS (wich was closed) - there is no path for the download - the download has disappeared - so the whole thing again - can't you make it work properly?