VEGAS Pro 21 Build 314 and 315 General Thread

Comments

Dexcon wrote on 5/22/2024, 8:47 PM

@iEmby  ... As per usual, there's a link to the full ,exe file at the bottom of the forum's NEWS section.

Cameras: Sony FDR-AX100E; GoPro Hero 11 Black Creator Edition

Installed: Vegas Pro 16, 17, 18, 19, 20 & 21, HitFilm Pro 2021.3, DaVinci Resolve Studio 18.5, BCC 2023.5, Mocha Pro 2023, Ignite Pro, NBFX TotalFX 7, Neat NR, DVD Architect 6.0, MAGIX Travel Maps, Sound Forge Pro 16, SpectraLayers Pro 11, iZotope RX10 Advanced and many other iZ plugins, Vegasaur 4.0

Windows 11

Dell Alienware Aurora 11

10th Gen Intel i9 10900KF - 10 cores (20 threads) - 3.7 to 5.3 GHz

NVIDIA GeForce RTX 2080 SUPER 8GB GDDR6 - liquid cooled

64GB RAM - Dual Channel HyperX FURY DDR4 XMP at 3200MHz

C drive: 2TB Samsung 990 PCIe 4.0 NVMe M.2 PCIe SSD

D: drive: 4TB Samsung 870 SATA SSD (used for media for editing current projects)

E: drive: 2TB Samsung 870 SATA SSD

F: drive: 6TB WD 7200 rpm Black HDD 3.5"

Dell Ultrasharp 32" 4K Color Calibrated Monitor

RogerS wrote on 5/22/2024, 8:52 PM

@iEmby There's a download link at the bottom here: https://www.vegascreativesoftware.info/us/forum/update-vegas-pro-21-build-315-patch-for-314--145714/

Nick usually adds new versions to this page within a day or two. I suggest bookmarking it. https://www.vegascreativesoftware.info/us/forum/faq-where-can-i-download-vegas-pro-and-other-vegas-software--104782/

Custom PC (2022) Intel i5-13600K with UHD 770 iGPU with latest driver, MSI z690 Tomahawk motherboard, 64GB Corsair DDR5 5200 ram, NVIDIA 2080 Super (8GB) with latest studio driver, 2TB Hynix P41 SSD, Windows 11 Pro 64 bit

Dell XPS 15 laptop (2017) 32GB ram, NVIDIA 1050 (4GB) with latest studio driver, Intel i7-7700HQ with Intel 630 iGPU (latest available driver), dual internal SSD (1TB; 1TB), Windows 10 64 bit

VEGAS Pro 19.651
VEGAS Pro 20.411
VEGAS Pro 21.208

Try the
VEGAS 4K "sample project" benchmark: https://forms.gle/ypyrrbUghEiaf2aC7
VEGAS Pro 20 "Ad" benchmark: https://forms.gle/eErJTR87K2bbJc4Q7

iEmby wrote on 5/22/2024, 9:46 PM

All Good Now.. All AMD Decoding & FX & PAN CROP Buttons Errors Gone.
Thanks Guys For Working So Fast On This Patch.

Keep It Up.

Last changed by iEmby on 5/22/2024, 9:46 PM, changed a total of 1 times.

PROCESSOR
     

Operating System: Windows 11 Pro 64-bit (Always Updated)
System Manufacturer: ASUS
12th Gen Intel(R) Core(TM) i7-12700 (20 CPUs), ~2.1GHz - 4.90GHz
Memory: 32GB RAM
Page File: 11134MB used, 7934MB Available
DirectX Version: DirectX 12

-----------------------------------------------

MOTHERBOARD

 

ASUS PRIME H610-CS D4
Intel® H610 (LGA 1700)
Ready for 12th Gen Intel® Processors
Micro-ATX Motherboard with DDR4
Realtek 1 Gb Ethernet
PCH Heatsink
PCIe 4.0 | M.2 slot (32Gbps) 
HDMI® | D-Sub | USB 3.2 Gen 1 ports
SATA 6 Gbps | COM header
LPT header | TPM header
Luminous Anti-Moisture Coating
5X Protection III
(Multiple Hardware Safeguards
For all-round protection)

-----------------------------------------------
EXTERNAL GRAPHIC CARD

-----------------------------------------------

INTERNAL GRAPHIC CARD (iGPU)

------------------------------------------------

LED - MONITOR

Monitor Name: Generic PnP Monitor
Monitor Model: HP 22es
Monitor Id: HWP331B
Native Mode: 1920 x 1080(p) (60.000Hz)
Output Type: HDMI

-----------------------------------------------

STORAGE DRIVE

Drive: C:
Free Space: 182.3 GB
Total Space: 253.9 GB
File System: NTFS
Model: WD Blue SN570 1TB (NVMe)

---------------O----------------

My System Info (PDF File).

https://drive.google.com/open?id=1-eoLmuXzshTRH_8RunAYAuNocKpiLoiV&usp=drive_fs

 

Also Check

VEGAS Scripts Collection By Me

https://www.vegascreativesoftware.info/us/forum/vegas-pro-scripts-collections-share-your-script-here--145667/

VEGAS Pro Vault Blogger Created By Me.

https://vegasprofreetools.blogspot.com

My YouTube Channel Dedicated to Only VEGAS Pro Tutorials

http://www.youtube.com/@editroom1580

Wolfgang S. wrote on 5/23/2024, 1:13 AM

Make a reset of Vegas - including the cache cleaning. Then it works again.

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti (12 GB)* Blackmagic Extreme 4K 12G * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K/6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram). Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor. Blackmagic Ultrastudio 4K mini

HDR monitor: ProArt Monitor PA32 UCG, Atomos Sumo

Others: Edius NX (Canopus NX)-card in an old XP-System. Edius X. Resolve Studio 18

Reyfox wrote on 5/23/2024, 3:38 AM

@Marcio-VonKruger wrote:

Please clarify if the tool "speech to text" is available ,without restrictions. in this new update.

There are restrictions as always, depending on if your license is perpetual or subscription and what "model" you are using.

GerY wrote on 5/23/2024, 5:38 AM

After updating from 314 to 315....No VEGAS Hub anymore ??????? VEGAS Hub online 3 dots😬. But it still works in VP20 ????

A total reset was the solution to my problem.

john_dennis wrote on 5/23/2024, 6:48 AM

I was prompted to run my generated media Audio Sync Test using Vegas Pro 21-314 and observed the following audio decode differences from compoundplug.dll to mxcompoundplug.dll.

compoundplug.dll

mxcompoundplug.dll

Notes:

  1. Used the default Magix AVC/AAC render template and placed the file back on the Vegas Pro timeline.
  2. Since I hear sound transmitted through air, I'm not particularly offended by "lagging audio".
Shaun_K wrote on 5/24/2024, 6:05 AM

@Wolfgang S. in regards to your comment on the other thread....I appreciate that there is a thread for the new update/patch....but that doesn't change the fact I did not get support, or even a response in the previous thread after providing what was requested by Magix staff, after months. If there was some other reasonable way to get support, I would do so. The issue is still the same as I mentioned in the previous thread...yet I now have to start the whole request for support from the beginning once again, and once again repeat myself with regards to the issue.

Shaun_K wrote on 5/24/2024, 6:11 AM

Timecodes are still not working. Below is the mediainfo export for a sample file
 

General
Complete name                            : F:\DCIM\102__GH6\PGH63064.MOV
Format                                   : MPEG-4
Format profile                           : QuickTime
Codec ID                                 : qt   2011.07 (qt  /pana)
File size                                : 145 MiB
Duration                                 : 7 s 200 ms
Overall bit rate mode                    : Variable
Overall bit rate                         : 169 Mb/s
Frame rate                               : 25.000 FPS
Encoded date                             : 2024-05-24 09:20:41 UTC
Tagged date                              : 2024-05-24 09:20:41 UTC
com.panasonic.Semi-Pro.metadata.xml      : <?xml version="1.0" encoding="UTF-8" standalone="no" ?> / <ClipMain xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="urn:schemas-Professional-Plug-in:Semi-Pro:ClipMetadata:v1.0"> /   <ClipContent> /     <GlobalClipID>060A2B340101010501010D21130000001F77429C0A00000455F60E9110880050</GlobalClipID> /     <Duration>180</Duration> /     <EditUnit>1/25</EditUnit> /     <EssenceList> /       <Video> /         <Codec BitRate="150">H264_422_LongGOP</Codec> /         <ActiveLine>2160</ActiveLine> /         <ActivePixel>3840</ActivePixel> /         <BitDepth>10</BitDepth> /         <FrameRate>25p</FrameRate> /         <TimecodeType>NonDrop</TimecodeType> /         <StartTimecode>10:17:58:20</StartTimecode> /       </Video> /       <Audio> /         <Channel>4</Channel> /         <SamplingRate>48000</SamplingRate> /         <BitsPerSample>24</BitsPerSample> /       </Audio> /     </EssenceList> /     <ClipMetadata> /       <Rating>0</Rating> /       <Access> /         <CreationDate>2024-05-24T09:20:41+00:00</CreationDate> /         <LastUpdateDate>2024-05-24T09:20:41+00:00</LastUpdateDate> /       </Access> /       <Device> /         <Manufacturer>Panasonic</Manufacturer> /         <ModelName>DC-GH6</ModelName> /       </Device> /       <Shoot> /         <StartDate>2024-05-24T09:20:41+00:00</StartDate> /       </Shoot> /     </ClipMetadata> /   </ClipContent> /   <UserArea> /     <AcquisitionMetadata xmlns="urn:schemas-Professional-Plug-in:P2:CameraMetadata:v1.2"> /       <CameraUnitMetadata> /         <ISOSensitivity>250</ISOSensitivity> /         <Gamma> /           <CaptureGamma>V-Log</CaptureGamma> /         </Gamma> /         <Gamut> /           <CaptureGamut>V-Gamut</CaptureGamut> /         </Gamut> /       </CameraUnitMetadata> /     </AcquisitionMetadata> /   </UserArea> / </ClipMain>

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High 4:2:2@L5.1
Format settings                          : CABAC / 1 Ref Frames
Format settings, CABAC                   : Yes
Format settings, Reference frames        : 1 frame
Format settings, GOP                     : M=1, N=12
Format settings, Slice count             : 16 slices per frame
Codec ID                                 : avc1
Codec ID/Info                            : Advanced Video Coding
Duration                                 : 7 s 200 ms
Bit rate mode                            : Variable
Bit rate                                 : 150 Mb/s
Maximum bit rate                         : 180 Mb/s
Width                                    : 3 840 pixels
Height                                   : 2 160 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 25.000 FPS
Standard                                 : Component
Color space                              : YUV
Chroma subsampling                       : 4:2:2
Bit depth                                : 10 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.724
Stream size                              : 129 MiB (89%)
Encoded date                             : 2024-05-24 09:20:41 UTC
Tagged date                              : 2024-05-24 09:20:41 UTC
Color range                              : Full
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709
Codec configuration box                  : avcC

Audio #1
ID                                       : 2
Format                                   : PCM
Format settings                          : Big / Signed
Codec ID                                 : lpcm
Duration                                 : 7 s 200 ms
Bit rate mode                            : Constant
Bit rate                                 : 1 152 kb/s
Channel(s)                               : 1 channel
Sampling rate                            : 48.0 kHz
Bit depth                                : 24 bits
Stream size                              : 1 012 KiB (1%)
Encoded date                             : 2024-05-24 09:20:41 UTC
Tagged date                              : 2024-05-24 09:20:41 UTC

Audio #2
ID                                       : 3
Format                                   : PCM
Format settings                          : Big / Signed
Codec ID                                 : lpcm
Duration                                 : 7 s 200 ms
Bit rate mode                            : Constant
Bit rate                                 : 1 152 kb/s
Channel(s)                               : 1 channel
Sampling rate                            : 48.0 kHz
Bit depth                                : 24 bits
Stream size                              : 1 012 KiB (1%)
Encoded date                             : 2024-05-24 09:20:41 UTC
Tagged date                              : 2024-05-24 09:20:41 UTC

Audio #3
ID                                       : 4
Format                                   : PCM
Format settings                          : Big / Signed
Codec ID                                 : lpcm
Duration                                 : 7 s 200 ms
Bit rate mode                            : Constant
Bit rate                                 : 1 152 kb/s
Channel(s)                               : 1 channel
Sampling rate                            : 48.0 kHz
Bit depth                                : 24 bits
Stream size                              : 1 012 KiB (1%)
Encoded date                             : 2024-05-24 09:20:41 UTC
Tagged date                              : 2024-05-24 09:20:41 UTC

Audio #4
ID                                       : 5
Format                                   : PCM
Format settings                          : Big / Signed
Codec ID                                 : lpcm
Duration                                 : 7 s 200 ms
Bit rate mode                            : Constant
Bit rate                                 : 1 152 kb/s
Channel(s)                               : 1 channel
Sampling rate                            : 48.0 kHz
Bit depth                                : 24 bits
Stream size                              : 1 012 KiB (1%)
Encoded date                             : 2024-05-24 09:20:41 UTC
Tagged date                              : 2024-05-24 09:20:41 UTC

Other
ID                                       : 6
Type                                     : Time code
Format                                   : QuickTime TC
Duration                                 : 7 s 200 ms
Bit rate mode                            : Constant
Frame rate                               : 25.000 FPS
Time code of first frame                 : 10:17:58:20
Time code of last frame                  : 10:18:05:24
Time code, stripped                      : No
Encoded date                             : 2024-05-24 09:20:41 UTC
Tagged date                              : 2024-05-24 09:20:41 UTC

 

This is the view in Vegas Pro (timecode shows the same for all files):

Wolfgang S. wrote on 5/24/2024, 6:14 AM

@Wolfgang S. in regards to your comment on the other thread....I appreciate that there is a thread for the new update/patch....but that doesn't change the fact I did not get support, or even a response in the previous thread after providing what was requested by Magix staff, after months. If there was some other reasonable way to get support, I would do so. The issue is still the same as I mentioned in the previous thread...yet I now have to start the whole request for support from the beginning once again, and once again repeat myself with regards to the issue.

Since your point does not show up in the new feature list, I would say that it was not solved.

I assume that you are talking about the timecode issue posted from your side here?

I have no information if and when it will be corrected. That is up to the development team.

Have you posted an example file, as it was requested some time ago? That would help the team.

Last changed by Wolfgang S. on 5/24/2024, 6:15 AM, changed a total of 1 times.

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti (12 GB)* Blackmagic Extreme 4K 12G * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K/6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram). Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor. Blackmagic Ultrastudio 4K mini

HDR monitor: ProArt Monitor PA32 UCG, Atomos Sumo

Others: Edius NX (Canopus NX)-card in an old XP-System. Edius X. Resolve Studio 18

Shaun_K wrote on 5/24/2024, 6:17 AM

@Wolfgang S. in regards to your comment on the other thread....I appreciate that there is a thread for the new update/patch....but that doesn't change the fact I did not get support, or even a response in the previous thread after providing what was requested by Magix staff, after months. If there was some other reasonable way to get support, I would do so. The issue is still the same as I mentioned in the previous thread...yet I now have to start the whole request for support from the beginning once again, and once again repeat myself with regards to the issue.

Since your point does not show up in the new feature list, I would say that it was not solved.

I assume that you are talking about the timecode issue posted from your side here?

I have no information if and when it will be corrected. That is up to the development team.

Have you posted an example file, as it was requested some time ago? That would help the team.

I posted what was asked of me...the mediainfo extract. Exactly as I have done above. And yes, its the same issue that you link to. But I realised that I wasn't getting support from the devs on that thread.
I can't believe this issue isn't being experienced by others.

Wolfgang S. wrote on 5/24/2024, 7:07 AM

No, typically they need a sample of the original footage. To be able to repro and test that.

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti (12 GB)* Blackmagic Extreme 4K 12G * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K/6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram). Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor. Blackmagic Ultrastudio 4K mini

HDR monitor: ProArt Monitor PA32 UCG, Atomos Sumo

Others: Edius NX (Canopus NX)-card in an old XP-System. Edius X. Resolve Studio 18

VEGASDerek wrote on 5/24/2024, 7:34 AM

@Shaun_K: For this particular case, yes...some sample footage would be beneficial for us to reproduce the issue and to use in our automated testing to ensure, once this is fixed, it does not get broken with changes we make in the future.

Shaun_K wrote on 5/24/2024, 8:33 AM

@Shaun_K: For this particular case, yes...some sample footage would be beneficial for us to reproduce the issue and to use in our automated testing to ensure, once this is fixed, it does not get broken with changes we make in the future.

Where do you want me to send it?

Wolfgang S. wrote on 5/24/2024, 8:35 AM

Please, upload it to a webspace. And place the download link your thread.

Desktop: PC AMD 3960X, 24x3,8 Mhz * GTX 3080 Ti (12 GB)* Blackmagic Extreme 4K 12G * QNAP Max8 10 Gb Lan * Blackmagic Pocket 6K/6K Pro, EVA1, FS7

Laptop: ProArt Studiobook 16 OLED (ProArt Studiobook 16 OLED (i9 12900H with i-GPU Iris XE, 32 GB Ram). Geforce RTX 3070 TI 8GB) with internal HDR preview on the laptop monitor. Blackmagic Ultrastudio 4K mini

HDR monitor: ProArt Monitor PA32 UCG, Atomos Sumo

Others: Edius NX (Canopus NX)-card in an old XP-System. Edius X. Resolve Studio 18

Shaun_K wrote on 5/24/2024, 9:07 AM

I have put it in the other thread....and here as well: https://we.tl/t-hdzXDhxS5a

ccscotty wrote on 5/24/2024, 12:23 PM

Debugging scripts in Visual Studio still appears to be broken. I even tried the 2022 preview build and no change. It attempts to start up Vegas, but then within a second the IDE gets a return code from the application.

Also, It would be nice if when there is an update and the re-registration thing automatically pops up that the serial number and email address are obscured by default. Have a check box where the user can see that information if they want. This bit me today when I was streaming. I don't have much of an audience on twitch, so I'm probably fine, but in my case not great to showing that information automatically and updates happen infrequently enough it's easy to forget private information is show upon startup.

After installing Visual Studio 2017 and rebuilding my project for that IDE, the same issue happens with Vegas Pro 21 build 315 upon trying to debug/run and that IDE. I'm not sure if any of the previous builds of Vegas Pro 21 have worked with debugging as I started using it somewhat recently.

eg: "The program '[12768] vegas210.exe' has exited with code 0 (0x0)."

Vegas Pro 19 works fine with debugging, so it appears to be Vegas 21.

DB777 wrote on 5/24/2024, 12:45 PM

I'm having a weird issue where the rotating update window and the completed window are showing the upper-left quadrant only. See image. The first time I tried to update it just went round and round and I finally reset it and the second time it ran and seems to have updated. Haven't tested the program beyond this point yet.

Jos-DeRoeck wrote on 5/24/2024, 1:21 PM

I wan't to change my Licence to the abonnement version. Wath shall I do to activate it?

vkmast wrote on 5/27/2024, 2:42 AM

@Jos-DeRoeck try contacting shop@magix.net by email if you want to cancel the (perpetual) license that you have purchased and get one of the two currently available 365 subscription versions instead (VEGAS Pro Edit 365 or VEGAS Pro Suite 365).

You activate your VP 365 with its own specific serial number. Note that " VEGAS Pro 365 can be used on 1 device only at a time. To deactivate a device, so you can activate a different one, visit your MAGIX account > My Products > Show More Details > Deactivate. This option can be used only once a month. You Ican also choose Deactivate the Software on this PC from the Help menu This option can be used as often as you wish. An internet connection is required.

Rony-Alfandary wrote on 5/29/2024, 7:48 AM

Hello all,

 

I have two issues\questions.

1. Since the new update a couple of days ago, each time I make a cut on my time line (s), it only applies to the video or audio track I am on, though both tracks are of the same footage. What can be done?

2. This is an old issue - I need Right-to-Left script (Hebrew) in text (subtitles, etc) and punctuation marks do not appear where they should be. For instance, brackets appear inside out, )etc(.

 

Can any of you help me out?

 

Thanks,

 

Rony

NickHope wrote on 5/29/2024, 8:27 AM
1. Since the new update a couple of days ago, each time I make a cut on my time line (s), it only applies to the video or audio track I am on, though both tracks are of the same footage. What can be done?

@Rony-Alfandary It sounds like your video and audio streams became ungrouped somehow. Make sure they are lined up, then select both (hold CTRL when you click the 2nd one), then press 'G' for 'group' on your keyboard. This is also on the context menu if you right-click on an event.

Might be best to make a new post on the forum about your 2nd issue.

Dexcon wrote on 5/29/2024, 8:32 AM

1. Since the new update a couple of days ago, each time I make a cut on my time line (s), it only applies to the video or audio track I am on, though both tracks are of the same footage. What can be done?

This is what should happen:

  • If no video or audio event is highlighted on the timeline, then a split will affect all video and audio events on the timeline at the split point.
  • If the video and audio event are grouped, then if only one of the events is highlighted (i.e. video or audio), then both video and audio will be split.
  • If the video and audio events are ungrouped, then only the highlighted event will be split.
  • If you have a number of video or audio events stacked on the timeline (i.e. multiple tracks one above the other), only the highlighted events will be split - though grouped events will also be included in the split even if not highlighted.

Cameras: Sony FDR-AX100E; GoPro Hero 11 Black Creator Edition

Installed: Vegas Pro 16, 17, 18, 19, 20 & 21, HitFilm Pro 2021.3, DaVinci Resolve Studio 18.5, BCC 2023.5, Mocha Pro 2023, Ignite Pro, NBFX TotalFX 7, Neat NR, DVD Architect 6.0, MAGIX Travel Maps, Sound Forge Pro 16, SpectraLayers Pro 11, iZotope RX10 Advanced and many other iZ plugins, Vegasaur 4.0

Windows 11

Dell Alienware Aurora 11

10th Gen Intel i9 10900KF - 10 cores (20 threads) - 3.7 to 5.3 GHz

NVIDIA GeForce RTX 2080 SUPER 8GB GDDR6 - liquid cooled

64GB RAM - Dual Channel HyperX FURY DDR4 XMP at 3200MHz

C drive: 2TB Samsung 990 PCIe 4.0 NVMe M.2 PCIe SSD

D: drive: 4TB Samsung 870 SATA SSD (used for media for editing current projects)

E: drive: 2TB Samsung 870 SATA SSD

F: drive: 6TB WD 7200 rpm Black HDD 3.5"

Dell Ultrasharp 32" 4K Color Calibrated Monitor