Vegas Pro 17 De-synching Audio from Video

Joseph-Boone wrote on 5/3/2020, 12:42 AM

I just recently upgraded to Vegas Pro 17 (was using 13) and am experiencing a strange intermittent problem. When importing video files created with Nvidia Shadowplay, some of them are coming in with the audio at a shorter duration than the video portion. I have recorded hundreds of videos using Shadowplay and have never had an issue with any other program including Vegas 13. In fact, I can import these same files into 13 and they are perfect. I can play the videos and the audio is in synch perfectly. But in Vegas 17, a 30 minute video will have something like 29:50 in the audio track.

I found a couple of tips online to stretch the audio and bring the two back into alignment but they didn't work. It seems as though the desynch is not happening in a linear fashion and the only way I've found to fix it is to spend an insane amount of time chopping the audio into small pieces and lining it up. I did that once, I'll stop using the software before I do it again. Anyone have any ideas to try and fix this? I'm completely baffled and this is happening with about 25% of the video files I'm importing.

Comments

Mohammed_Anis wrote on 5/3/2020, 2:35 AM

I just recently upgraded to Vegas Pro 17 (was using 13) and am experiencing a strange intermittent problem. When importing video files created with Nvidia Shadowplay, some of them are coming in with the audio at a shorter duration than the video portion. I have recorded hundreds of videos using Shadowplay and have never had an issue with any other program including Vegas 13. In fact, I can import these same files into 13 and they are perfect. I can play the videos and the audio is in synch perfectly. But in Vegas 17, a 30 minute video will have something like 29:50 in the audio track.

I found a couple of tips online to stretch the audio and bring the two back into alignment but they didn't work. It seems as though the desynch is not happening in a linear fashion and the only way I've found to fix it is to spend an insane amount of time chopping the audio into small pieces and lining it up. I did that once, I'll stop using the software before I do it again. Anyone have any ideas to try and fix this? I'm completely baffled and this is happening with about 25% of the video files I'm importing..

I would wager it has something to do with project settings or the codec coming out of Shadowplay that doesn't play nice with a Constant Frame Rate timeline.

Chopping the audio is a beat zealous.

I"m not sure if this is agreeable Forum decorum, but I'm happy to meet you on Zoom if you provide me your email.

You can share your screen and I can try to guide you.





 

vkmast wrote on 5/3/2020, 4:05 AM

@Mohammed_Anis et al. please use the "Write a message" option. No private email addresses (or other personal information) on the forum.

Mohammed_Anis wrote on 5/3/2020, 4:18 AM

Understood!

Thank you

Joseph-Boone wrote on 5/3/2020, 10:07 AM

I would wager it has something to do with project settings or the codec coming out of Shadowplay that doesn't play nice with a Constant Frame Rate timeline.

Chopping the audio is a beat zealous.

I"m not sure if this is agreeable Forum decorum, but I'm happy to meet you on Zoom if you provide me your email.

You can share your screen and I can try to guide you.
 

There are only a few setting in ShadowPlay that I can alter:

Resolution is set at 1440p

Frame Rate is 60 FPS (30 is the only other option)

Bit Rate is 40 Mbps

That's literally the entire list of what I can change. I have wondered if 60fps is the problem given that my Vegas Pro projects are set at 59.94 but I've tried changing the project in Vegas to an even 60 and that had no effect.

Musicvid wrote on 5/3/2020, 10:36 AM

Shadowplay never played nice with Vegas, sorry.

Many of us use OBS Studio.