At Wits End - Audio driver & settings changed without doing anything

mike-oOtto wrote on 7/18/2020, 3:58 PM

Please bare with me, i'm in full-on rage mode at the moment...

I've been using Vegas Pro since version 4, and even had a mid-level studio at one point (Using Vegas for multi-tracking). I've never run into this before. I am currently on VP10, Win7 NT 64bt, 8core AMD, tons or ram & HD/SD room. Three days ago while recording, all was well. I turned off my Mackie ProFX8v2 (USB Mixer) and left the PC on. Two hours later i turned it on to start recording & nothing worked correctly. Sound was only coming through my PC speakers (Not my powered monitors through the board, as it always does). I checked the settings & it appeared correct, but i was unsure. To be safe i rebooted, same thing happened. I did nothing differently than i have for years. As a last resort i fidgeted with the settings, i tried various configurations with ASIO4all, MS sound mapper, windows classic, and Direct mapper, and finally got something to work. However, now i had track bleed-through that i never had before, a recording volume that was incredibly low, and whenever a track was armed...the meter is already bouncing as if there's a hot mic on it (Producing almost a white noise). Oh, AND...now all of the new recordings are a split second off from the other tracks (Latency, i'm guessing). I unplugged everything & started over (Even though nothing had ever changed), still the same thing. I truly feel that this is a driver issue, but i can't figure it out.

 

Since then, i have tried (Literally) every configuration of Playback & Recording Device imaginable in settings. Each time i find something that "Kinda" works...but when i save & re-enter any projects, it all goes out the window! Back to square one, nothing working again except for playback through my pc speakers with no working "Input" device. What concerns me, is that i never touched or changed anything...gremlins?

Thanks in advance for ANY help.

Comments

diverG wrote on 7/18/2020, 4:28 PM

Maybe restart holding down ctrl+shift key. If that does not work start a new project and see if that is stable. Might also try emptying vegas folder found in hidden temp folder.

Until sure vegas & system is OK leave your major project shut.

Wait for advice from more experienced users who will help.

Sys 1 Gig Z370-HD3, i7 8086K @ 5.0 Ghz 16gb ram, 250gb SSD, 2x2Tb hd,  GTX 1060 6Gb Vegas 14 & 17 plus Edius 8WG Win 10pro (1909) BMIP4k video out. (PS 650W)

Sys 2 Gig Z170-HD3, i7 6700K @ 3.8Ghz 16gb ram, 250gb SSD, 2x2Tb, hdd GTX 750ti,  Vegas 15 & 16 plus Edius 8WG Win 10pro (1909) BMIP4k video out. (PS 650W)

Sys 3 Laptop 'Clevo' i7 6700K @ 3.0ghz, 16gb ram, 250gb SSd + 2Tb hdd,   nvidia 940 M graphics. VP14 & 17 via humble bundle. Plus Edius 8WG Win 10pro (1909)

 

mike-oOtto wrote on 7/18/2020, 4:57 PM

Thanks diverG. I tried all of that already, and just tried it again to make sure. No luck! Still have the same four issues (latency, bleed, low record volume, and white noise on armed track(s)). I did however, just notice that it happened around the same day/time as my anti-virus updated to a newer version (ESET). I'm grasping at straws here, but makes me wonder. I've had ESET for over 10 years without issues, but who knows? Thx

john_dennis wrote on 7/18/2020, 5:19 PM

Every time I mention this concept, no one wants to hear it, but that's not going to stop me from bringing it up. When these things happen to me, I whip out a standalone USB boot disc and restore a system image from a time when all worked. That 5 minute activity keeps me from ever getting into "full on rage".  I'm too old to spend my last few hours on the earth shooting bugs on my systems.

Keep that in mind when you settle down.

mike-oOtto wrote on 7/18/2020, 5:38 PM

Thanks John, i actually agree with that concept. It's a great habit that i got away from several years ago when i "Confidently" thought my system was stable...yeah right! Going forward, you are correct. Thx

Musicvid wrote on 7/19/2020, 2:29 PM

Any time another program is opened or closed, the current application hijacks the Windows Mapper Drivers for its own use. It has nothing to to with Vegas, and everything to do with outdated WDM (Windows Driver Module).

Probable solution: Switch Vegas Audio Drivers to ASIO, Direct Sound Surround, or HD Audio, whatever it's called for your audio interface. Mapper does not have low-latency duplex support, so it is like shooting yourself in the foot to leave it on.

mike-oOtto wrote on 7/19/2020, 3:22 PM

Musicvid - i have 2 questions for you. 1) Are saying that i should "uninstall" WDM, or simply choose one of the other options? I've already tried every combination of the other 3 (DSS, HD, and ASIO4all). and 2) Why would it have previously worked for 3 straight years, then all of a sudden crap out on me like this? I have always had it set on the ASIO4all option, but now it works one time, but not the next, then again it works (Maybe), then not at all. I feel like there's a deeper issue here (Besides the user ;-)

Musicvid wrote on 7/19/2020, 5:07 PM

WDM is as entrenched in Windows as DOS. You cannot get rid of it. Simply choose one of the other working options in Vegas, and Vegas should "stick" with it, instead of letting whatever app happens to be open hijack your audio settings whenever you open them or minimize Vegas.

As far as the change in behavior, I'm sorry I don't have a good answer for you. You could:

  • Try resetting Vegas. https://www.vegascreativesoftware.info/us/forum/faq-how-can-i-reset-vegas-pro-to-default-settings--104646/
  • Upgrade your audio device drivers.
  • Not use ASIO4All, but your dedicated device Direct or HD drivers
  • There are internet reports of botched Windows updates messing with everything from audio to internet. It doesn't put you at risk too much to uninstall the last update and let Windows find you again and reinstall. If the latest update won't uninstall, you've got a problem that needs a saved system image to restore.
  • As a very last resort, you can uninstall Vegas with Revo and re-install, but be sure and have your serial # at hand.
  • I assume your Mackie has its own drivers. You can try uninstall them temporarily and reinstall the default device drivers. Maybe the mixer is affecting the same libraries that Vegas needs.

Good luck, I hope some little bit of my speculation can be helpful, because I know how frustrating these little surprises can be.

 

vkmast wrote on 7/19/2020, 5:12 PM

While resetting be sure to be able to clear the cache.

mike-oOtto wrote on 7/19/2020, 5:32 PM

First off, i can't thank you all enough for all of your input! Question, i keep hearing about this "Hidden cache" folder that needs to be cleared out. I can't find it anywhere. I know where the windows Temp/cache is, but i'm assuming this one is different? Do i perhaps need to un-hide it (In folder view) while searching? Thanks again all.

vkmast wrote on 7/19/2020, 5:40 PM

Did you read the instructions link in @Musicvid's latest comment (first point there)?

mike-oOtto wrote on 7/20/2020, 9:50 AM

I GOT IT!!!! Thank you all so much for your input, it is/was truly appreciated. Hopefully this will help others as well.

It ended up being my ASIO driver (ASIO4ALL v2.14). I uninstalled it, reinstalled it, rebooted, and reconfigured not only my settings in Vegas, but also in the GUI that comes with ASIO4ALL. No more track bleed, no more In/Out routing issues, no more meters going haywire, no more rec. volume issues. The only issue i'm having now is most likely a mild latency issue. My new tracks are a split second off, i can "Budge" in the meantime...but it'll definitely need fixing. Thank you all so very much!

Oh...and i learned to turn off all Windows "System sounds" - as this simple sound can trigger other audio drivers inadvertently (Kinda like what @Musicvid was stating previously) makes total sense now.