New Canon 5D Mark IV camera files - limit on how many will open?

peter-pappas wrote on 10/1/2016, 3:02 PM

Have a new camera. The Canon 5D Mark IV. The container for the 4K files are MOV and the codec is MJPEG.

The camera divides up the files to the max of 4GB on the FAT32 system. I did a 55 minute 4K video, giving me 55 4GB files. I add them all to the timeline to color grade and or edit them.

When all 55 files are added they will go onto the timeline and some of the clips show a thumb and some don't. It's random. What is not random is there is no video either in the preview window or in a trial rendering of a couple of minutes. Sound yes, video no. This is using Edit Pro 13 AND also in a trial of Edit Pro 14.

If I add a few files at a time to the timeline, I can get up to about 27 before the video is no longer being viewed.
I am using Win 10, 64 bit, 64GB ram, RX 480 8GB video card and 1TB SSD drive. The Vegas Pro 14 is set to 8 bit mode (not 32bit floating).

What limitation am I hitting, and can I get past it? Premiere Pro will open and read the files and give me video viewing and rendering (exporting). It gets more bogged down as I add color grading.

Thanks,
Peter

Comments

john_dennis wrote on 10/1/2016, 5:28 PM

"What limitation am I hitting..."

You're possibly running into a 32 bit Quicktime limitation. Is Quicktime used to decode the files.

"...and can I get past it?"

Transcode to some other wrapper?

Post a short sample of one of the files and someone will help you. Use dropbox or other cloud sharing service so the files will not be re-encoded. Post the link here.

NormanPCN wrote on 10/1/2016, 5:48 PM

Vegas bypasses Quicktime for DSLR MOV files. (AVC video and PCM audio)

JN_ wrote on 10/2/2016, 5:39 AM

I know this doesn't directly solve your issue.  With the software included, and the mk. iv connected to the PC you can import all 55 small files as 1 file.  Of course you can also shoot in future with exFat cards, they'll save as 1 file, cutting out the hassle of using the Canon utility software.

 

EOS MOVIE Utility, page 601 in the user manual.

Last changed by JN_ on 10/2/2016, 11:13 AM, changed a total of 2 times.

 

Desktop and Laptop basic specs ...

Both run Win 10 ...

Running latest ver. of Vegas Pro with latest updates.

VP13 B453 also.

Vegaseur and Pluraleyes installed on both ...

Quicktime 7.79.80.95

PC ...

i9 9900K, Intel Graphics 630. Nov 2018.

Mem. 32gb DDR4 Nov. '18.

Graphics card .. Nvidia Rtx 2080 Ti

Nvidia Graphics driver .. latest Studio driver.

Latest Intel Graphics driver

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..16GB DDR4 

Graphics card .. Nvidia GTX 1070, latest Studio driver.

Musicvid wrote on 10/2/2016, 10:05 PM

See if GoPro Studio Cineform solves your problem. It's free.

peter-pappas wrote on 10/2/2016, 10:25 PM

JN_  Thanks. I took the 55 files and the utility merged them into 4 files (why 4, I have no clue). Sony Vegas Pro 13 took them and played them like a champ. I then was able to grade them, edit them and it didn't crash! I Rendered the whole thing out as 4K to 1080 and it took about 4 hours. No crashes and without a hiccup.

I did send the camera back, but if I decide to buy it again at least it will be on my own terms and i will be able to pump out videos with it. If you format any card IN the camera that is smaller than 256GB it will format in FAT32. i can format in the computer, but my workflow habit is to format a card right before the start of the job, so if forget and format the card on the job site, it is back to FAT32.

Vegas Pro 13 will not work with 55 4GB files, but it will take the same length of time and work with no problems if they are merged into 4 files. Can't figure that one out - but, I am thankful :)

Peter

Musicvid wrote on 10/3/2016, 6:01 AM

Backing up a step, did you import the files from the card using normal Windows Explorer? Don't.

Try Vegas' Device Explorer instead to import the files from the card. May save you a step.

JN_ wrote on 10/3/2016, 6:21 AM

I'm glad that worked out Peter.  I got 2 cards for this camera, both 128gb. It's better anyway to format in camera.  The sdxc 128 formats in camera to exFat, the CF 128 formats in camera to Fat32.  I tested the sdxc for full 29m 59s and no problem.  If I was doing something important I'd use the CF, I feel there's a bit of security/safety with a lot of smaller files rather than 1 big one, in case of corruption, might be harder to get back 1 big file.  For messing around I just use the sdxc card.

 

Desktop and Laptop basic specs ...

Both run Win 10 ...

Running latest ver. of Vegas Pro with latest updates.

VP13 B453 also.

Vegaseur and Pluraleyes installed on both ...

Quicktime 7.79.80.95

PC ...

i9 9900K, Intel Graphics 630. Nov 2018.

Mem. 32gb DDR4 Nov. '18.

Graphics card .. Nvidia Rtx 2080 Ti

Nvidia Graphics driver .. latest Studio driver.

Latest Intel Graphics driver

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..16GB DDR4 

Graphics card .. Nvidia GTX 1070, latest Studio driver.

peter-pappas wrote on 10/3/2016, 5:51 PM

Here is an added FYI. I was able to (accidentally) recreate the original problem. The original problem was, when I add 55 4GB 4K files from the newly released Canon 5D Mark IV camera to the timeline the video disappears. It disappears in the Preview window (I call it the preview window, the working window on the upper right side of the screen), and it disappears in any Rendering I do. I only tried the rendering to see if the video was really gone. it was.

The solution was to merge the files down from 55 of them, to 4 of them in the Canon Movie Utility as suggested here on this forum by Ron, and in the future to format the cards as exFat. At that point I was able to grade/edit and so on and then Render out with no problems on those files. Happy camper.

However, I was able to make the video disappear with only 1 of the merged files on the timeline (about 7 minutes) and make it reappear again. I brought one file in to toy around with the "graded look" and in the process I remembered researching to "fix" this problem to make proxy files as a possible solution.

As I am working on this 1 seven minute file, it stutters because of the MJPEG format. I thought maybe a proxy file would stop the stuttering. I selected the file in the Project Media and then selected Make Proxy File.

When I did the video image disappeared. The file would play, the sound would play but there was no video. I though I broke it again - crap. But this time (and NOT before) I saw the "building video proxy for . . ." on the bottom left of the screen along with a cancel button. That info never was there before (I would have dived in after it) so I of course HIT CANCEL. The video instantly came back. I tried it again, and as soon as I went to make a proxy file the video died again, and clicking "cancel" allowed me to see, or reconnect with the video.

So, in my dangerous position of knowing very little about this whole process, I am making the assumption that at some point, my adding the 55 files to the time line caused whatever is making the video to disappear to be similar in nature to what happens when I just tried to make a proxy file.

I can replicate this all day and night, make the video "turn off" and come back again by manually creating a proxy file of a pretty big file, and then canceling the process. I know there is a setting in the program to turn on/off auto-making proxy files, but it didn't do anything to help fix my problem.

Does any of this matter? I have no clue if this helps anyone, or if the techs even will see what I have written, but really did want to share what I just discovered.

Peter

NormanPCN wrote on 10/3/2016, 6:25 PM

On the video tab in the Preferences dialog, is the automatically create proxies for Ultra HD media files option checked. 

When checked, Vegas will auto start creating proxies for your media when you import media. There could be some sketchy issue with proxy creation of your media files.

--A wrote on 2/12/2019, 4:08 PM

THE same problem here. Problem is EXCATLY the same in my case. I have Canon 5D Mark IV - there is no problems working with FullHD. But when I switched to 4K, I can import only 40 files.

How can I solve it? I NEED MORE of 40 files in my project. I won't be transcoding etc. I WILL NOT BE MERGE FILES! It should work.

This is hilarious buf of Magix Vegas!

Musicvid wrote on 2/12/2019, 4:29 PM

Did you read the post directly above yours, made in 2016?

--A wrote on 2/13/2019, 10:42 AM

Did you read the post directly above yours, made in 2016?

Yes. And....? Why do you ask?

How to solve that problem? I work in video company and I HAVE TO have 100% working montage software. Vegas should keep over 40 files in 4K also. This issue I can see ONLY when I import media clips from Canon 5d Mark IV camera. Any others works perfectly always.

 


Any OFFICIAL support here?

vkmast wrote on 2/13/2019, 10:55 AM

Any OFFICIAL support here?

See Community rule #2, points 3 and 4.

--A wrote on 2/13/2019, 3:47 PM

I show you and describe my bug.

Marco. wrote on 2/13/2019, 4:41 PM

These are Quicktime Photo-JPEG files which are decoded by Quicktime not by a Vegas Pro native decoder. So it might be the trouble is caused by the Quicktime version you use.
And even if you refuse to, transcoding the files to a proper editing standard which does not need a Quicktime decoding probably would be the best solution (and this way it would also correct false header flags of these Quicktime files which use the wrong color matrix coefficent and wrong bit rate modes).

 

fr0sty wrote on 2/13/2019, 4:48 PM

and unfortunately, quicktime is no longer supporting windows, so you can't get a newer version, most likely. Your best bet is to transcode to an intermediate codec like Magic YUV (there's others some here can recommend as well, Cineform is one as musicvid suggested).

Musicvid wrote on 2/13/2019, 11:05 PM

Please do not ignore the advice above yours and learn the word "proxy."

Your video "company" should be able to tell you about this if searching is beneath your entitlement.

JN_ wrote on 2/14/2019, 5:50 AM

 

I created 50 Canon 5D MK. IV clips, C4K 25fps (the same 12 sec. clip renamed x 50) using .mov wrapper with the PCM audio codec. This used the Qt7plug.dll. Win 10 latest updates for VP, proxies disabled to speed things up. I attempted to load all clips using my laptop and PC, see my profile.

Theres a limit around clip 38 on PC, loading clip 39 and all clips then don’t display in preview window. Load another one and it crashes.

On laptop I could load 36 clips, none showed in Preview window. If I attempted to drag no. 37 from project properties to the timeline it simply won’t go.

If I use ffmpeg to convert to mp4 by simply muxing both streams VP won’t load one clip, reports clip as corrupt, plays in VLC.

If I use ffmpeg to convert to mp4 by copying the video stream and converting the PCM audio to aac you get the same result, won’t load, plays in VLC.

My previous post in 2016 is a solution that requires the camera attached to use the EOS utility. This may not be an option for - -A.

Maybe they could be concated, I’ll try that later today. Best solution going forward would be for - -A to request the files in future are shot in camera as mp4, but this may not be possible.

 

Desktop and Laptop basic specs ...

Both run Win 10 ...

Running latest ver. of Vegas Pro with latest updates.

VP13 B453 also.

Vegaseur and Pluraleyes installed on both ...

Quicktime 7.79.80.95

PC ...

i9 9900K, Intel Graphics 630. Nov 2018.

Mem. 32gb DDR4 Nov. '18.

Graphics card .. Nvidia Rtx 2080 Ti

Nvidia Graphics driver .. latest Studio driver.

Latest Intel Graphics driver

 

Laptop ... (Acer Predator G9-793-77AC)

CPU .. i7-6700HQ Skylake-H

Memory ..16GB DDR4 

Graphics card .. Nvidia GTX 1070, latest Studio driver.

--A wrote on 2/14/2019, 6:07 AM

1. I can Import all the files in ADOBE Premiere Pro, there is no troubles. Only Vegas Pro can't import them. So? Still is a QuickTIme codec fault?

2. Absolutely there is no "solution" for transcode that files before import Vegas. Do you want me to converta 256 GB 4k 500 MB/s files? Seriously? Over 200/300 separate clips? No way. And look above to point 1 - In Adobe Premiere ewerything works fine.

3. User musicvid, please stop talking about "a proxy". That not help.


JN_ I can't have merged clips to use. I have to have all clips imported to my Vegas Pro.
NO JOKE, this should be working!

Marco. wrote on 2/14/2019, 6:47 AM

"Still is a QuickTIme codec fault?"

Yes. Transcoding is the way to go, like it or not.

"If I use ffmpeg to convert to mp4 by simply muxing both streams VP won’t load one clip, reports clip as corrupt"

MP4 is no valid wrapper for Photo-JPEG encoded files.

--A wrote on 2/14/2019, 7:02 AM

Transcoding in GoPro Studio mentioned above doesn't import that files either.
What is an good alternative for that?

Marco. wrote on 2/14/2019, 7:13 AM

I'd use FFmpeg as it offers easy batch encoding.

--A wrote on 2/14/2019, 7:17 AM

I'd use FFmpeg as it offers easy batch encoding.

Any other, better software that looks like not a MS DOS, awful and complicated menu?

klt wrote on 2/14/2019, 7:38 AM

Commandline != MSDOS

There are countless GUIs for ffmpeg, google for one.

But none of them can cover the full capabilities of ffmpeg.

Yet, if there were any, that would be more complicated than the command line.