Known Issues in the Latest Version of VEGAS Pro

Nick Hope wrote on 10/5/2017, 12:58 AM

This is an unofficial list of known issues in the latest version & build of VEGAS Pro.

To be listed below, an issue preferably has to either be acknowledged by MAGIX or verified by a number of users. It is by no means a comprehensive list.

Note that many bugs that are marked [...,VP13] also affect earlier versions.

For issues that are not listed, please comment on a relevant existing post, or the pinned "General Discussion" post for the latest version, or start a new post.

Please message me or another moderator if you believe an issue has been fixed or incorrectly listed.

The Release History post lists issues that have been fixed and new features.

UNOFFICIAL KNOWN ISSUES

 

OFFICIAL KNOWN ISSUES

Below are the official known issues listed in the Release Notes at C:/Program Files/VEGAS/VEGAS Pro 16.0/readme/Vegas_readme.htm

  • If you are printing a rendered file to HDV tape, the file must precisely conform to the target HDV device and file type requirements, or the print-to-tape operation will fail. Rendering using the provided HDV MPEG-2 render templates—unmodified in any way—is required to successfully print to HDV tape.
  • VEGAS Pro templates for rendering multichannel audio in .wav/.wav64, .avi, and .mxf formats may be visible in other VEGAS applications that do not support multichannel audio. Using these templates in other applications will not produce the desired result and should be avoided.
  • Under some uncommon conditions on multiprocessor machines, you may encounter stability problems when using some Waves 5.2 plug-ins. In most cases, the stability issues can be resolved by clearing the Enable track buffering check box in VEGAS Pro (Options > Preferences > Audio Device).
  • You may not be able to render files larger than 4 GB using some combinations of settings in the Sony AVC encoder.
  • If you have multiple VEGAS or MAGIX applications (such as ACID, Sound Forge, CD Architect, etc.) installed, uninstalling other applications may cause your audio plug-ins to be removed from VEGAS Pro. To restore your audio plug-ins, uninstall and reinstall VEGAS Pro.
  • When the Show Video Monitor button in the Trimmer window is selected, video that you preview from the VEGAS Explorer and Media Manager windows is played back in the Trimmer. Because the Trimmer is placed in the same window dock as the Explorer and Media Manager, you will not see your video preview. To preview Explorer and Media Manager video, you can drag the Trimmer to a new dock group, or you can turn off the Show Video Monitor button to preview in the Video Preview window.
  • The Step Forward and Step Backward buttons in the Capture window are not supported by all HDV devices.
  • If your project contains still-image sequences, segmented .r3d files, or P2 MXF files, do not select the Copy media with project check box in the Save As dialog. Some frames or segments may not be saved when this check box is selected.
  • Installing driver 2.21 for the PDW-UI XDCAM drive can prevent VEGAS from starting. Uninstalling the driver or upgrading to version 2.3 will resolve the issue.
  • If you're running two instances of VEGAS Pro, external control devices are available only to the first instance of the software.
  • When using the Stereoscopic 3D Graphic Card as your preview device with an nVidia 3D Vision for Quadro or 3D Vision Pro setup on a Windows Vista machine, the 3D output may stop when opening another window (such as a video FX property page). If this occurs, please make sure you have the latest graphic card driver and 3D Vision USB driver installed. If installing the latest drivers does not fix the problem, try switching the primary and secondary monitors. There is also a known issue where content on the main window will flicker. This can be fixed by moving another window over the portions of the window that are flickering and then closing the overlapping window.
  • We recommend Windows 7 for nVidia 3D Vision for Quadro setups.
  • Rendering CineForm Neo3D files requires CineForm NeoHD, Neo4K, or Neo3D 5.1 (or newer) or GoPro-CineForm Studio, Studio Premium or Studio Professional. The CineForm Neo Player is not compatible with other CineForm products. Do not install Neo Player if you have another CineForm product installed.
  • CEA608 and CEA708 closed captions are supported over HD-SDI on AJA cards only. Line 21 captions are supported on AJA and DeckLink cards.
  • Right-clicking a media file and choosing Edit Source Project fails to load the project path saved in the media file for media rendered using the following settings: MainConcept AVC/AAC and Sony AVC (Memory Stick templates only).
  • In order for some devices to appear in the Device Explorer window, you may need to change the device’s USB Connect setting from Automatic or MTP to Mass Storage.
  • The Tools > Burn Disc > DVD with Menus and Tools > Burn Disc > Blu-ray Disc with Menus commands are unavailable if DVD Architect Pro is not installed.
  • If you want to use RAW camera files in your project, the Microsoft Camera Codec Pack will allow you to view RAW camera files and add them to the timeline.
  • When previewing through an SDI video preview device, audio and video quality issues may occur when previewing 720p video.
  • When using an AJA SDI device, AJA driver version 10.1 is required for audio and video preview. Do not use driver version 10.3.
  • For best results when previewing audio through an SDI video preview device, please turn off Video Preview on External Monitor before loading a project or changing project formats.
  • 24p pulldown removal is not currently available for Panasonic P2 files.
  • Some MOV files recorded by devices running Apple iOS 6 may fail to read correctly when using QuickTime 7.7.2. Updating to QuickTime 7.7.3 resolves the issue.
  • When using some source files with highly saturated colors, you may notice color variations after rendering when the Project Properties > Video > Pixel Format is set to 8-bit. Change the setting to 32-bit floating point (video levels) to prevent IRE levels from clipping.
  • When using AMD Catalyst 13.4, Video Preview on External Monitor does not work correctly when using a display that is rotated into portrait mode.
  • Shot marks are not read correctly when copying DVCAM clips directly from an XDCAM Station. The shot marks are displayed correctly when you use the VEGAS XDCAM Explorer to import clips.
  • Only 4:2:0 10-bit HEVC rendering is supported.
  • Storyboards do not handle multiple instances of the same media.
  • Replacing a piece of media in a storyboard does not replace it on the timeline.
  • Using import media function to import media directly main timeline storyboard does not update the main timeline.
  • Auto-scrolling does not work within the storyboard.
  • Reordering media in the storyboard resets the in/out points to beginning/end.
  • Checkerboard artifacts may be visible in HDR external preview when preview quality is set to "Best" with certain kinds of footage; please switch to "Good" quality in such scenarios; this does not affect the actual rendered output

Comments

Nick Hope wrote on 10/5/2017, 1:35 AM

The above list should be up to date for VEGAS Pro 15.0 (Build 216).

malowz wrote on 10/7/2017, 9:58 AM

how about the old script icons disappearing?

since 2005 i believe.

there are a few post, latest one i believe:

https://www.vegascreativesoftware.info/us/forum/disappearing-icons-in-toolbar--104674/

to me, a simple way to reproduce is disconnect the video cable from a second monitor.

 

Nick Hope wrote on 10/7/2017, 11:32 AM

how about the old script icons disappearing?...

Thanks @malowz. I had omitted it because I got it confused with the issue whereby installing plugins or scripts causes buttons on a customized toolbar to get replaced. Now both issues are listed and I have updated the thread you link to.

Kit-As-Was wrote on 10/8/2017, 7:36 PM

An issue I have is that the search filter doesn't work when opening files. In File explorer typing *13 or 13 into the search box will give me all files containing 13 in the title. With the Vegas 15 open dialogue I get no results.

mark-woollard wrote on 10/10/2017, 2:49 PM

Vegas Pro 14 is working fine. 15 however will never complete the launch sequence. It hangs at "initializing GPU-accelerated video processing". Went back and forth with a support ticket -- Ticket#2017091117010103 and followed all of their suggestions. That did not solve the problem, yet support closed the ticket. Nobody answers the phone in customer service. How do I get a refund? I'm content to stick with version 14 which works fine.

Nick Hope wrote on 10/10/2017, 11:19 PM

Vegas Pro 14 is working fine. 15 however will never complete the launch sequence...

Work through this if you haven't already: https://www.vegascreativesoftware.info/us/forum/faq-vegas-pro-won-t-start-what-can-i-do--104784/

redpaw wrote on 10/11/2017, 2:15 PM

the multiscreen multicamera editing issue with AMD GPU has also been confirmed by the support [v13,14,15]
https://www.vegascreativesoftware.info/us/forum/multi-camera-editing-with-amd-gpu-vegas-15-14-13--108823/

Nick Hope wrote on 10/14/2017, 3:27 AM

Added to OP:

  • [VP15] The audio time-stretch percentage (shown if Active Take Information is on) is obscured the "hamburger" and Event FX button when Event Headers are off.
Nick Hope wrote on 10/20/2017, 10:10 PM

Added to OP:

PhilD wrote on 10/30/2017, 1:13 AM

AUDIO CLICKS - Vegas Pro 15 (latest build) Windows 10 Getting an unusual high number of "clicks" appearing on audio time line when editing ... Original audio clean during edit then later an audio clip will get an electronic "click" ... it did use to happen now and then on older versions but seems to happen a lot more frequently in v15, last 3 min edit I did had 4 clicks appear on different clips

david-oneal wrote on 11/4/2017, 12:55 PM

I'm fighting with very bothersome UI lag. Vegas Pro 14 runs much more smoothly than 15. What can I change to make the user interface run faster? I'm finding myself going back to 14 for most projects. It's really disappointing to have a degraded experience after spending the money on the upgrade.

joseph-w wrote on 11/5/2017, 2:09 AM

I'm fighting with very bothersome UI lag. Vegas Pro 14 runs much more smoothly than 15. What can I change to make the user interface run faster? I'm finding myself going back to 14 for most projects. It's really disappointing to have a degraded experience after spending the money on the upgrade.

I am finding the same thing unfortunately :( V15 seems to build up lag the more steps you do in a project. It also seems like the UI redraws it self way too often. Maybe the new icons and look aren't optimized like the old? Like you I'm disappointed. I think the FX windows in general were much easier on the eyes than V15 (where I often miss that a bolded txt option can be expanded for options). Overall the UI just feels "heavier" in that I know after I click something I'm going to have to wait a split second and the screen may flicker/refresh before my intended click is properly registered. I'm still hoping for a "legacy UI" option in internals. It was smooth as butter.

david-oneal wrote on 11/6/2017, 7:36 PM

I'm just getting the very irritating sluggishness. I haven't had a problem with crashing. I'm in agreement with the comment before yours. Just give us the legacy UI option. I don't need bells, whistles and pretty colors. I need performance and reliability. The advertised enhanced rendering speeds is what attracted me (of which I've seen very little improvement). By the way, I had just done a complete OS wipe and reload (Windows 10 Home) a few weeks before loading Vegas Pro 15. So, I know the OS is clean. I also do have Vegas Pro 14 loaded (which I'm very thankful for at this point), but don't think that would cause a problem.

I've faithfully been upgrading for several years now. But, I'm thinking 15 might have been a mistake. The only big thing I know that's changed is the move to Magix. I honestly was not expecting that.

I know the developers worked very long and hard to give us this new version. But just because a lot of effort was put into a project doesn't make the end result better. I really don't think they performance tested the user interface prior to release. It seems as if the main focus was on utilizing Intel's QSV feature, which took the attention away from other areas. It's disheartening to realize that a product I would frequently champion to others is something I can not longer do. I'm very disappointed. I'm really just asking and hoping for one thing. Make the product run at least as well as it predecessor, Vegas Pro 14. In other words, do no harm.

Nick Hope wrote on 11/8/2017, 4:51 AM

Added to OP:

Closing this thread to keep it tidy. For issues that are not listed, please comment on a relevant existing post, or the pinned "General Discussion" post for the latest version, or start a new post. Please message me or another moderator if you believe an issue has been fixed or incorrectly listed.

The VP15 performance issue is continued here: https://www.vegascreativesoftware.info/us/forum/general-performance-issues-with-vegas-pro-15-216--109355/

Nick Hope wrote on 11/30/2017, 9:25 AM

Removed from OP (fixed in VP 15 build 261):

Changed: